Number Lock Won't Stay Locked after Shutdown

Discussion in 'Computer Support' started by Sens Fan Happy In Ohio, Oct 22, 2004.

  1. One of our computers at work is running Windows XP Pro SP2, P4 3GHz,
    256 RAM. It uses a Microsoft MultiMedia Keyboard 1.0a with a F Lock
    (Function Lock) and Num Lock (Number Lock) keys that refuse to stay in
    their locked position after a reboot or shutdown. I've updated the
    drivers and still have this issue. It's not a problem to hit them
    each time at start-up ... but it is kind of annoying if you forget to
    do this each time. Any ideas how to make XP keep these settings?

    Thanks :)
     
    Sens Fan Happy In Ohio, Oct 22, 2004
    #1
    1. Advertising

  2. Sens Fan Happy In Ohio wrote:
    > One of our computers at work is running Windows XP Pro SP2, P4 3GHz,
    > 256 RAM. It uses a Microsoft MultiMedia Keyboard 1.0a with a F Lock
    > (Function Lock) and Num Lock (Number Lock) keys that refuse to stay in
    > their locked position after a reboot or shutdown. I've updated the
    > drivers and still have this issue. It's not a problem to hit them
    > each time at start-up ... but it is kind of annoying if you forget to
    > do this each time. Any ideas how to make XP keep these settings?


    http://www.kellys-korner-xp.com/xp_tweaks.htm
    and click on
    Set Numlock State On or Off at Startup
    and also
    Control the F Lock Key Functionality State/Status

    regards
    Thorkild Dalsgaard
     
    Thorkild Dalsgaard, Oct 22, 2004
    #2
    1. Advertising

  3. Sens Fan Happy In Ohio

    Barry OGrady Guest

    On 22 Oct 2004 08:39:52 -0700, (Sens Fan Happy In Ohio) wrote:

    >One of our computers at work is running Windows XP Pro SP2, P4 3GHz,
    >256 RAM. It uses a Microsoft MultiMedia Keyboard 1.0a with a F Lock
    >(Function Lock) and Num Lock (Number Lock) keys that refuse to stay in
    >their locked position after a reboot or shutdown. I've updated the
    >drivers and still have this issue. It's not a problem to hit them
    >each time at start-up ... but it is kind of annoying if you forget to
    >do this each time. Any ideas how to make XP keep these settings?


    Change the setting in the bios.


    >
    >Thanks :)



    -Barry
    ========
    Web page: http://members.iinet.net.au/~barry.og
    Atheist, radio scanner, LIPD information.
     
    Barry OGrady, Oct 23, 2004
    #3
  4. Well I tried first to check the BIOS and it is listed there as having
    the Number Lock maintained. This didn't solve it, as Windows XP turns
    it off during boot-up. So then I went to the website below and used
    the file that was there. I tried it both as "enabled" and as
    "disabled" and both ways still did not good. Windows XP somehow
    overrides the BIOS setting at boot-up. And I watched carefully at
    shutdown and the Caps Lock, Number Lock and Function Lock keys all are
    deactivated at shutdown.

    So ... Windows XP is certainly the culprit here. But where/how can I
    access these setting to stop it from overriding the BIOS ... since
    BIOS clearly shows it is turned on and stays on just until about the
    first 5 seconds of Win XPs initial loading.

    "Thorkild Dalsgaard" <> wrote in message news:<>...
    >
    >
    > http://www.kellys-korner-xp.com/xp_tweaks.htm
    > and click on
    > Set Numlock State On or Off at Startup
    > and also
    > Control the F Lock Key Functionality State/Status
    >
    > regards
    > Thorkild Dalsgaard
     
    Sens Fan Happy In Ohio, Oct 25, 2004
    #4
  5. Sens Fan Happy In Ohio

    thephilster

    Joined:
    Jul 12, 2007
    Messages:
    1
    Still an issue here, too

    I've just run into the same problem. Thought it was our GPO, but no dice. The VBS script provided might work, if our infosec team didn't find it necessary to lock our vbs scripts!

    I noticed, in the registry, you can turn on num lock by changing "HKEY_CURRENT_USER, Control Panel, Keyboard, InitialKeyboardIndicators" to "2", but, alas, when I reboot, mine resets back to "0" (all off).

    Still a problem for me, too! If anyone has an idea!

    ---




     
    thephilster, Jul 12, 2007
    #5
  6. Sens Fan Happy In Ohio

    beille

    Joined:
    Oct 9, 2008
    Messages:
    1
    num lock wont stay on

    i am having the same problem, the bios has the num lock as on but once windows start to load the login screen it turns off the num lock. how do i get it to stay on????

    Beille
     
    beille, Oct 9, 2008
    #6
  7. Sens Fan Happy In Ohio

    Gosh

    Joined:
    Nov 7, 2008
    Messages:
    1
    There are 2 registry settings - if you have tried HKEY_CURRENT_USER\Control Panel\Keyboard\InitialKeyBoardIndicators and it doesn't solve your problem then try HKEY_USERS\.DEFAULT\Control Panel\Keyboard\InitialKeyBoardIndicators

    It wasn't until I changed the latter that the key states behaved the way I wanted them.
     
    Gosh, Nov 7, 2008
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?SmltIENsYXJr?=

    Setting Won't Stay Set

    =?Utf-8?B?SmltIENsYXJr?=, Jan 25, 2005, in forum: Wireless Networking
    Replies:
    1
    Views:
    763
    Mungo Bulge
    Jan 26, 2005
  2. Frisbee®
    Replies:
    37
    Views:
    1,176
  3. Brian Keys

    number lock on keyboard

    Brian Keys, Sep 23, 2007, in forum: Computer Information
    Replies:
    2
    Views:
    719
    Jeff Strickland
    Sep 24, 2007
  4. Joy

    XP and number lock

    Joy, Jun 6, 2004, in forum: NZ Computing
    Replies:
    3
    Views:
    434
    Mr Bond
    Jun 8, 2004
  5. rynes01
    Replies:
    3
    Views:
    572
    Bobby Johnson
    Jun 24, 2009
Loading...

Share This Page