NTP on Polycom Soundpoint IP-331

Discussion in 'UK VOIP' started by davehigton14@gmail.com, Aug 19, 2013.

  1. Guest

    I've got a Polycom Soundpoint IP-331 phone on my LAN. I've
    configured its NTP setting to uk.pool.ntp.org but it
    obstinately refuses to synchronise its time and date.

    I'm on BT Infinity. I don't have any firewall settings for
    any services at all. I have computers on the LAN that sync
    with uk.pool.ntp.org. The phone registers with Sipgate and
    can make and receive external calls.

    Google search hasn't found any solution, though I haven't
    been able to formulate a search that really expresses the
    problem I want solving (I'm getting lots of hits for sales
    brochures and standard instruction manuals, for example).

    Can anyone offer any solution or insight?

    Dave
     
    , Aug 19, 2013
    #1
    1. Advertising

  2. On 2013-08-19, wrote:
    >Can anyone offer any solution or insight?


    Gather a packet trace?
     
    Roger Bell_West, Aug 19, 2013
    #2
    1. Advertising

  3. Roger Guest

    On 19/08/2013 13:58, Roger Bell_West wrote:
    > On 2013-08-19, wrote:
    >> Can anyone offer any solution or insight?

    >
    > Gather a packet trace?
    >

    Try the ip address instead of the url. if that works try a different dns
    server in the polycom settings - some of my gear on the network wont
    resolve domain names unless I use the router as a dsn server e.g. if I
    configure the item with google's dns server address it wont resolve names.
     
    Roger, Aug 19, 2013
    #3
  4. Woody Guest

    "Roger" <> wrote in message
    news:OOqQt.38128$4...
    > On 19/08/2013 13:58, Roger Bell_West wrote:
    >> On 2013-08-19, wrote:
    >>> Can anyone offer any solution or insight?

    >>
    >> Gather a packet trace?
    >>

    > Try the ip address instead of the url. if that works try a
    > different dns server in the polycom settings - some of my gear
    > on the network wont resolve domain names unless I use the
    > router as a dsn server e.g. if I configure the item with
    > google's dns server address it wont resolve names.




    Agreed. I use Atomic Clock Sync to set my PC clock. It uses
    128.138.140.44. Worth a try?



    --
    Woody

    harrogate three at ntlworld dot com
     
    Woody, Aug 19, 2013
    #4
  5. Dave Higton Guest

    In message <kutupp$r3$>
    "Woody" <> wrote:

    > "Roger" <> wrote in message
    > news:OOqQt.38128$4...
    > > On 19/08/2013 13:58, Roger Bell_West wrote:
    > > > On 2013-08-19, wrote:
    > > > > Can anyone offer any solution or insight?
    > > >
    > > > Gather a packet trace?
    > > >

    > > Try the ip address instead of the url. if that works try a different dns
    > > server in the polycom settings - some of my gear on the network wont
    > > resolve domain names unless I use the router as a dsn server e.g. if I
    > > configure the item with google's dns server address it wont resolve
    > > names.

    >
    > Agreed. I use Atomic Clock Sync to set my PC clock. It uses
    > 128.138.140.44. Worth a try?


    I tried 128.138.140.44 and one of the resolved addresses of
    uk.pool.ntp.org. I also reduced the resync time to 60 s, the minimum
    setting. No success.

    I'm going to try a packet trace, but I need to add a hub so the
    Wireshark computer can see the packets between the IP331 and the
    rest of the LAN. Tomorrow, all being well.

    Dave
     
    Dave Higton, Aug 19, 2013
    #5
  6. Dave Higton Guest

    In message <>
    Dave Higton <> wrote:

    > In message <kutupp$r3$>
    > "Woody" <> wrote:
    >
    > > "Roger" <> wrote in message
    > > news:OOqQt.38128$4...
    > > > On 19/08/2013 13:58, Roger Bell_West wrote:
    > > > > On 2013-08-19, wrote:
    > > > > > Can anyone offer any solution or insight?
    > > > >
    > > > > Gather a packet trace?
    > > > >
    > > > Try the ip address instead of the url. if that works try a different
    > > > dns server in the polycom settings - some of my gear on the network
    > > > wont resolve domain names unless I use the router as a dsn server e.g.
    > > > if I configure the item with google's dns server address it wont
    > > > resolve names.

    > >
    > > Agreed. I use Atomic Clock Sync to set my PC clock. It uses
    > > 128.138.140.44. Worth a try?

    >
    > I tried 128.138.140.44 and one of the resolved addresses of
    > uk.pool.ntp.org. I also reduced the resync time to 60 s, the minimum
    > setting. No success.
    >
    > I'm going to try a packet trace, but I need to add a hub so the Wireshark
    > computer can see the packets between the IP331 and the rest of the LAN.
    > Tomorrow, all being well.


    It was configured to 128.138.140.44 but no packets went to or from
    that address. When I power cycled it, something bizarre happened:
    there were two DNS requests, one for "_ntp._udp.clock" and one for
    "clock". Not surprisingly, neither was resolved.

    I changed the configuration to "pool.ntp.org", which is one of the
    choices from the standard list. Saving the choices did not result
    in any DNS requests. Power cycling it a second time produced the
    same two DNS requests again.

    At no time was there any NTP or SNTP traffic.

    It appears to be completely ignoring its NTP configuration setting.

    Dave
     
    Dave Higton, Aug 20, 2013
    #6
  7. ßodincus Guest

    | · : · : · : · : · : · : · Original Message · : · : ·: · : · : · : ·
    | From: Dave Higton
    | Date: 20/08/13 21:04

    > In message <>
    > Dave Higton <> wrote:
    >
    >> In message <kutupp$r3$>
    >> "Woody" <> wrote:
    >>
    >>> "Roger" <> wrote in message
    >>> news:OOqQt.38128$4...
    >>>> On 19/08/2013 13:58, Roger Bell_West wrote:
    >>>>> On 2013-08-19, wrote:
    >>>>>> Can anyone offer any solution or insight?
    >>>>>
    >>>>> Gather a packet trace?
    >>>>>
    >>>> Try the ip address instead of the url. if that works try a different
    >>>> dns server in the polycom settings - some of my gear on the network
    >>>> wont resolve domain names unless I use the router as a dsn server e.g.
    >>>> if I configure the item with google's dns server address it wont
    >>>> resolve names.
    >>>
    >>> Agreed. I use Atomic Clock Sync to set my PC clock. It uses
    >>> 128.138.140.44. Worth a try?

    >>
    >> I tried 128.138.140.44 and one of the resolved addresses of
    >> uk.pool.ntp.org. I also reduced the resync time to 60 s, the minimum
    >> setting. No success.
    >>
    >> I'm going to try a packet trace, but I need to add a hub so the Wireshark
    >> computer can see the packets between the IP331 and the rest of the LAN.
    >> Tomorrow, all being well.

    >
    > It was configured to 128.138.140.44 but no packets went to or from
    > that address. When I power cycled it, something bizarre happened:
    > there were two DNS requests, one for "_ntp._udp.clock" and one for
    > "clock". Not surprisingly, neither was resolved.
    >
    > I changed the configuration to "pool.ntp.org", which is one of the
    > choices from the standard list. Saving the choices did not result
    > in any DNS requests. Power cycling it a second time produced the
    > same two DNS requests again.
    >
    > At no time was there any NTP or SNTP traffic.
    >
    > It appears to be completely ignoring its NTP configuration setting.
    >
    > Dave
    >

    The _ntp._udp.X requests are for SRV records. Odd.

    FW version bug? Check on
    http://support.polycom.com/PolycomS...voice/soundpoint_ip/soundpoint_ip321_331.html
    for the latest version.

    Try resetting it to factory settings.

    If the phone is getting the IP from a DHCP server, ensure it's not the
    DHCP server to override the NTP server with some options.
    Easy to check: give it a static address.

    Let us know how it goes.
    --
    ßodincus - The Y2K Druid
     
    ßodincus, Aug 20, 2013
    #7
  8. Guest

    On Tuesday, August 20, 2013 10:41:25 PM UTC+1, ßodincus wrote:
    > | · : · : · : · : · : · : · Original Message · : · : · : · : · : · : ·
    > | From: Dave Higton
    > | Date: 20/08/13 21:04
    >
    > > In message <>
    > > Dave Higton wrote:

    >
    > >> In message <kutupp$r3$>
    > >> "Woody" wrote:

    >
    > >>> "Roger" wrote in message
    > >>> news:OOqQt.38128$4...
    > >>>> On 19/08/2013 13:58, Roger Bell_West wrote:
    > >>>>> On 2013-08-19, wrote:
    > >>>>>> Can anyone offer any solution or insight?

    >
    > >>>>> Gather a packet trace?

    >
    > >>>> Try the ip address instead of the url. if that works try a different
    > >>>> dns server in the polycom settings - some of my gear on the network
    > >>>> wont resolve domain names unless I use the router as a dsn server e..g.
    > >>>> if I configure the item with google's dns server address it wont
    > >>>> resolve names.

    >
    > >>> Agreed. I use Atomic Clock Sync to set my PC clock. It uses
    > >>> 128.138.140.44. Worth a try?

    >
    > >> I tried 128.138.140.44 and one of the resolved addresses of
    > >> uk.pool.ntp.org. I also reduced the resync time to 60 s, the minimum
    > >> setting. No success.

    >
    > >> I'm going to try a packet trace, but I need to add a hub so the Wireshark
    > >> computer can see the packets between the IP331 and the rest of the LAN..
    > >> Tomorrow, all being well.

    >
    > > It was configured to 128.138.140.44 but no packets went to or from
    > > that address. When I power cycled it, something bizarre happened:
    > > there were two DNS requests, one for "_ntp._udp.clock" and one for
    > > "clock". Not surprisingly, neither was resolved

    >
    > > I changed the configuration to "pool.ntp.org", which is one of the
    > > choices from the standard list. Saving the choices did not result
    > > in any DNS requests. Power cycling it a second time produced the
    > > same two DNS requests again.

    >
    > > At no time was there any NTP or SNTP traffic.

    >
    > > It appears to be completely ignoring its NTP configuration setting.

    >
    > > Dave

    >
    > The _ntp._udp.X requests are for SRV records. Odd.
    >
    > FW version bug? Check on
    > http://support.polycom.com/PolycomS...voice/soundpoint_ip/soundpoint_ip321_331.html
    > for the latest version.
    >
    > Try resetting it to factory settings.
    >
    > If the phone is getting the IP from a DHCP server, ensure it's not the
    > DHCP server to override the NTP server with some options.
    > Easy to check: give it a static address.


    It has a static IP address, as do all the entities on my cabled
    LAN.

    When I get it to check for new firmware, the version offered by
    Polycom's site has a lower version number (4.0.1.xxxx) than that
    on the phone (4.0.3.xxxx). I think I'm going to up/down/sidegrade
    it tonight.

    Dave

    (My apologies if the formatting/quoting aren't right. This is
    posted from Google Groups, which makes a right mess of quoting,
    including double spacing everything. I've attempted a manual
    clean-up, but it may not be completely right.)
     
    , Aug 21, 2013
    #8
  9. Dave Higton Guest

    In message <kv2qop$41a$>
    Andrew Benham <> wrote:

    >Polycom look to have a poor record with NTP, see the end of the page
    >http://wiki.aa.org.uk/VoIP_Phones_-_Polycom


    Well, I got the clock working. Not by the route I expected...

    I downgraded the firmware to 4.0.1.(whatever) and noticed that the
    clock was showing 6 hours slow but the right date, so something
    had changed. I saw in the log that the GMT offset was -21600
    seconds, which certainly didn't fit the time zone setting.

    I exported the configuration and examined the file. You'd think
    it was impossible for a simple (-ish) thing like a VoIP phone to
    have so many configuration lines in the file. And then I saw
    some really good ones: there is an explicit GMT offset that is
    not connected to the time zone. I set that to 0, uploaded the
    configuration to the phone, and now the time was correct but
    still flashing.

    Then I saw that there are two NTP server configuration lines.
    One was correctly set from the web settings, the other was just
    "clock". Making that the "uk.pool.ntp.org" rewarded me with
    a correct, non-flashing, time and date.

    It looks like some of their programmers have a gift for over-
    complicating things.

    Dave
     
    Dave Higton, Aug 21, 2013
    #9
  10. ßodincus Guest

    | · : · : · : · : · : · : · Original Message · : · : ·: · : · : · : ·
    | From: Dave Higton
    | Date: 21/08/13 22:03

    > In message <kv2qop$41a$>
    > Andrew Benham <> wrote:
    >
    >> Polycom look to have a poor record with NTP, see the end of the page
    >> http://wiki.aa.org.uk/VoIP_Phones_-_Polycom

    >
    > Well, I got the clock working. Not by the route I expected...
    >
    > I downgraded the firmware to 4.0.1.(whatever) and noticed that the
    > clock was showing 6 hours slow but the right date, so something
    > had changed. I saw in the log that the GMT offset was -21600
    > seconds, which certainly didn't fit the time zone setting.
    >
    > I exported the configuration and examined the file. You'd think
    > it was impossible for a simple (-ish) thing like a VoIP phone to
    > have so many configuration lines in the file. And then I saw
    > some really good ones: there is an explicit GMT offset that is
    > not connected to the time zone. I set that to 0, uploaded the
    > configuration to the phone, and now the time was correct but
    > still flashing.
    >
    > Then I saw that there are two NTP server configuration lines.
    > One was correctly set from the web settings, the other was just
    > "clock". Making that the "uk.pool.ntp.org" rewarded me with
    > a correct, non-flashing, time and date.
    >
    > It looks like some of their programmers have a gift for over-
    > complicating things.
    >
    > Dave
    >

    Now I remember why I don't use Polycoms.
    And I don't like to configure phones via their web interface but prefer
    the automated provisioning.
    Given it's implemented correctly, it usually gives you a finer
    granularity and works every time.
    snom (and recently Yealink) have been a breeze to work with.

    --
    ßodincus - The Y2K Druid
     
    ßodincus, Aug 22, 2013
    #10
  11. Roger <> wrote in <OOqQt.38128$4>:
    > On 19/08/2013 13:58, Roger Bell_West wrote:
    >> On 2013-08-19, wrote:
    >>> Can anyone offer any solution or insight?

    >>
    >> Gather a packet trace?
    >>

    > Try the ip address instead of the url.


    *cringe* uk.pool.ntp.org is a hostname, not a url.

    Having that out of the way: the ntp pool constantly checks all its ntp
    servers for accuracy and only returns working and accurate IP addresses for
    pool.ntp.org names. So using the name is preferred strongly over using a
    fixed IP.

    Unless you know the fixed IP is of a very reliable and robust ntp server
    and you keep an eye for news of the maintainer of that ntp server.

    Koos

    --
    Koos van den Hout, PGP keyid DSS/1024 0xF0D7C263 via keyservers
    4all.nl IPv6: Think ::/0, act ::1.
    http://idefix.net/ Are you ready to start supporting IPv6?
     
    Koos van den Hout, Aug 25, 2013
    #11
  12. Roger Guest

    On 25/08/2013 15:37, Koos van den Hout wrote:
    > Roger <> wrote in <OOqQt.38128$4>:
    >> On 19/08/2013 13:58, Roger Bell_West wrote:
    >>> On 2013-08-19, wrote:
    >>>> Can anyone offer any solution or insight?
    >>>
    >>> Gather a packet trace?
    >>>

    >> Try the ip address instead of the url.

    >
    > *cringe* uk.pool.ntp.org is a hostname, not a url.
    >
    > Having that out of the way: the ntp pool constantly checks all its ntp
    > servers for accuracy and only returns working and accurate IP addresses for
    > pool.ntp.org names. So using the name is preferred strongly over using a
    > fixed IP.
    >
    > Unless you know the fixed IP is of a very reliable and robust ntp server
    > and you keep an eye for news of the maintainer of that ntp server.
    >
    > Koos
    >

    If you had read the post properly you would have seen that the
    suggestion of using the ip address was ONLY to test if the DNS server on
    the phone was working correctly and then move on. Why bother not reading
    the original posts correctly and then posting after the problem has been
    solved?
     
    Roger, Aug 25, 2013
    #12
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Scott Crabb

    ntp from ntp.org

    Scott Crabb, Aug 5, 2004, in forum: Cisco
    Replies:
    5
    Views:
    3,735
  2. Patrick

    AVG Update 331 3/11/03

    Patrick, Nov 3, 2003, in forum: Computer Support
    Replies:
    0
    Views:
    425
    Patrick
    Nov 3, 2003
  3. SPD
    Replies:
    2
    Views:
    1,439
    -=-peas-=-
    Aug 19, 2004
  4. Hui
    Replies:
    0
    Views:
    697
  5. DarkStar
    Replies:
    13
    Views:
    684
    thanatoid
    Aug 17, 2006
Loading...

Share This Page