Novice needs help with Client VPN

Discussion in 'Cisco' started by Shane, Feb 22, 2006.

  1. Shane

    Shane Guest

    I'm trying to setup my client vpn on a PIX 515e. I can get connected
    just fine, but I can not see anything on the inside network. I've
    attached my running config here. I thought I'd set everything up
    correctly and have NAT right but I still cannot see anything on the
    inside network. Can anyone give me any assistance?

    Here is my config

    PIX Version 6.3(3)
    interface ethernet0 auto
    interface ethernet1 auto
    interface ethernet2 auto shutdown
    nameif ethernet0 outside security0
    nameif ethernet1 inside security100
    nameif ethernet2 dmz security50
    enable password Hvup11B1njUIaHN3 encrypted
    passwd Hvup11B1njUIaHN3 encrypted
    hostname cerberus
    domain-name mycompany.com
    clock timezone EST -5
    no fixup protocol dns
    fixup protocol ftp 21
    fixup protocol h323 h225 1720
    fixup protocol h323 ras 1718-1719
    fixup protocol http 80
    fixup protocol rsh 514
    fixup protocol rtsp 554
    fixup protocol sip 5060
    fixup protocol sip udp 5060
    fixup protocol skinny 2000
    no fixup protocol smtp 25
    fixup protocol sqlnet 1521
    fixup protocol tftp 69
    names
    name 192.43.244.18 time.nist.gov
    access-list acl-out permit tcp any any eq ftp-data
    access-list acl-out permit tcp any any eq ftp
    access-list acl-out permit icmp any 1x.x.x.0 255.255.255.0
    access-list acl-out permit tcp any eq ssh interface inside
    access-list acl-out permit tcp interface outside eq ssh any eq ssh
    access-list acl-out permit tcp any host 1x.x.x.20 eq www
    access-list acl-out permit tcp any host 1x.x.x.x eq 3389
    access-list acl-out permit tcp any host 1x.x.x.x eq www
    access-list acl-out permit tcp any host 1x.x.x.x eq smtp
    access-list acl-out permit tcp any host 1x.x.x.x eq 3389
    access-list acl-out permit tcp any host 1x.x.x.x eq pop3
    access-list acl-out permit tcp any host 1x.x.x.x eq imap4
    access-list acl-out permit icmp any 1x.x.x.0 255.255.255.0 echo-reply
    access-list acl-out permit udp host 1x.x.x.x host 1x.x.x.x eq snmp
    access-list acl-out permit tcp any host 1x.x.x.x eq www
    access-list acl-in permit ip host 192.168.128.2 any
    access-list acl-in permit ip host 192.168.128.3 any
    access-list acl-in permit ip host 192.168.128.10 any
    access-list acl-in permit ip host 192.168.128.16 any
    access-list acl-in permit ip host 192.168.128.25 any
    access-list acl-in permit ip host 192.168.128.27 any
    access-list acl-in permit ip host 192.168.128.36 any
    access-list acl-in permit ip host 192.168.128.74 any
    access-list 101 permit ip 192.168.128.0 255.255.255.0 10.99.99.0
    255.255.255.0
    pager lines 24
    logging on
    logging trap debugging
    logging host inside 192.168.128.16
    icmp deny any outside
    mtu outside 1500
    mtu inside 1500
    mtu dmz 1500
    ip address outside 1x.x.x.x 255.255.255.0
    ip address inside 192.168.128.22 255.255.255.0
    ip address dmz 172.16.10.1 255.255.255.0
    ip audit info action alarm
    ip audit attack action alarm
    ip local pool vpnpool 10.99.99.1-10.99.99.254
    pdm location 192.168.128.3 255.255.255.255 inside
    pdm location 192.168.128.11 255.255.255.255 inside
    pdm location 192.168.128.15 255.255.255.255 inside
    pdm location 192.168.128.20 255.255.255.255 inside
    pdm location 192.168.128.25 255.255.255.255 inside
    pdm history enable
    arp timeout 14400
    global (outside) 1 1x.x.x.x
    nat (inside) 0 access-list 101
    nat (inside) 1 192.168.128.0 255.255.255.0 0 0
    static (inside,outside) 1x.x.x.x 192.168.128.20 netmask 255.255.255.255
    0 0
    static (inside,outside) 1x.x.x.x 192.168.128.11 netmask 255.255.255.255
    0 0
    static (inside,outside) 1x.x.x.x 192.168.128.3 netmask 255.255.255.255
    0 0
    static (inside,outside) 1x.x.x.x 192.168.128.25 netmask 255.255.255.255
    0 0
    static (inside,outside) 1x.x.x.x 192.168.128.11 netmask 255.255.255.255
    0 0
    static (inside,outside) 1x.x.x.x 192.168.128.31 netmask 255.255.255.255
    0 0
    access-group acl-out in interface outside
    access-group acl-in in interface inside
    route outside 0.0.0.0 0.0.0.0 1x.x.x.x 1
    timeout xlate 3:00:00
    timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225
    1:00:00
    timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
    timeout uauth 0:05:00 absolute
    aaa-server TACACS+ protocol tacacs+
    aaa-server RADIUS protocol radius
    aaa-server LOCAL protocol local
    ntp authentication-key 1 md5 ********
    ntp authenticate
    ntp trusted-key 1
    ntp server time.nist.gov source outside prefer
    http server enable
    http 192.168.128.0 255.255.255.0 inside
    no snmp-server location
    no snmp-server contact
    snmp-server community public
    no snmp-server enable traps
    floodguard enable
    sysopt connection permit-ipsec
    sysopt connection permit-pptp
    crypto ipsec transform-set myset esp-des esp-md5-hmac
    crypto dynamic-map dynmap 10 set transform-set myset
    crypto map mymap 10 ipsec-isakmp dynamic dynmap
    crypto map mymap client configuration address initiate
    crypto map mymap client configuration address respond
    crypto map mymap interface outside
    isakmp enable outside
    isakmp key ******** address 0.0.0.0 netmask 0.0.0.0
    isakmp identity address
    isakmp client configuration address-pool local vpnpool outside
    isakmp policy 10 authentication pre-share
    isakmp policy 10 encryption des
    isakmp policy 10 hash md5
    isakmp policy 10 group 1
    isakmp policy 10 lifetime 86400
    isakmp policy 20 authentication pre-share
    isakmp policy 20 encryption des
    isakmp policy 20 hash md5
    isakmp policy 20 group 2
    isakmp policy 20 lifetime 86400
    vpngroup hsvpn address-pool vpnpool
    vpngroup hsvpn dns-server 192.168.128.3
    vpngroup hsvpn wins-server 192.168.128.1
    vpngroup hsvpn default-domain mycompany.com
    vpngroup hsvpn idle-time 1800
    vpngroup hsvpn password ********
    telnet 192.168.128.0 255.255.255.0 inside
    telnet timeout 5
    ssh 192.168.128.0 255.255.255.0 inside
    ssh timeout 5
    console timeout 0
    vpdn group 1 accept dialin pptp
    vpdn group 1 ppp authentication pap
    vpdn group 1 ppp authentication chap
    vpdn group 1 ppp authentication mschap
    vpdn group 1 ppp encryption mppe 40
    vpdn group 1 client configuration address local vpnpool
    vpdn group 1 pptp echo 60
    vpdn group 1 client authentication local
    vpdn username hsvpn password *********
    vpdn enable outside
    terminal width 80
    Cryptochecksum:18674da1476e626ff236c501d1d3f7ca
    : end
     
    Shane, Feb 22, 2006
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. MAG7577

    Novice needs help! Connection Problem

    MAG7577, Dec 30, 2004, in forum: Wireless Networking
    Replies:
    1
    Views:
    466
    mikeFNB
    Jan 7, 2005
  2. MAG7577

    Novice needs help! Connection Problem

    MAG7577, Dec 30, 2004, in forum: Wireless Networking
    Replies:
    2
    Views:
    459
    mikeFNB
    Jan 7, 2005
  3. john
    Replies:
    2
    Views:
    689
  4. Novice needs help

    , May 24, 2006, in forum: Cisco
    Replies:
    0
    Views:
    460
  5. John

    Novice needs Help!

    John, Jul 30, 2006, in forum: Digital Photography
    Replies:
    3
    Views:
    327
    m Ransley
    Jul 30, 2006
Loading...

Share This Page