no Portfast in cisco 85x?

Discussion in 'Cisco' started by Nicolai, Jul 27, 2008.

  1. Nicolai

    Nicolai Guest

    After every boot I have to wait for 10-30 seconds before I can ping the
    cisco 85x router and the internet. My port is spanning-tree portfast
    enabled.

    Any suggestions?
     
    Nicolai, Jul 27, 2008
    #1
    1. Advertising

  2. Nicolai

    News Reader Guest

    Nicolai wrote:
    > After every boot I have to wait for 10-30 seconds before I can ping the
    > cisco 85x router and the internet. My port is spanning-tree portfast
    > enabled.
    >
    > Any suggestions?
    >
    >


    It takes time to decompress and load the software image.

    Connect your host to the console port and watch the boot process.

    Best Regards,
    News Reader
     
    News Reader, Jul 28, 2008
    #2
    1. Advertising

  3. Nicolai

    Merv Guest


    > After every boot I have to wait for 10-30 seconds before I can ping the
    > cisco 85x router and the internet.



    reboot of what - the router or a PC connected to the router ?
     
    Merv, Jul 28, 2008
    #3
  4. Nicolai

    Nicolai Guest

    > It takes time to decompress and load the software image.

    Sorry, after my PC boot. Router has been up for weeks
     
    Nicolai, Jul 28, 2008
    #4
  5. Nicolai

    Merv Guest


    > Sorry, after my PC boot. Router has been up for weeks



    How does the PC acquire it's IP address - is it hard coded or is it
    assigned via DHCP by router ?

    with PC power on and able to ping Internet site, start a long running
    ping on your PC in a command window (ping -t x.x.x.x) , then
    disconnect the cable to router, should be loss of ping, reconnect,
    note whether ping start again immediately - if it does then portfast
    is functioning properly
     
    Merv, Jul 28, 2008
    #5
  6. Nicolai

    bobby84

    Joined:
    Jul 28, 2008
    Messages:
    9
    just to add to the last comment, when you are trying this again you should connect to the router via console or via another PC and continuously run the following command:-

    sh spanning-tree interface <int x>

    You should see the interface go straight into a designated forwarding status, if it's going through listening/learning phases then portfast isn't working as expected.
     
    bobby84, Jul 28, 2008
    #6
  7. Nicolai

    Nicolai Guest

    > How does the PC acquire it's IP address - is it hard coded or is it
    > assigned via DHCP by router ?


    Hard coded.

    > with PC power on and able to ping Internet site, start a long running
    > ping on your PC in a command window (ping -t x.x.x.x) , then
    > disconnect the cable to router, should be loss of ping, reconnect,
    > note whether ping start again immediately - if it does then portfast
    > is functioning properly


    Of course. Will try that.

    And if it is - then what is next suggestion? :)
     
    Nicolai, Jul 28, 2008
    #7
  8. Nicolai

    Merv Guest

    On Jul 28, 5:01 pm, "Nicolai" <> wrote:
    > > How does the PC acquire it's IP address - is it hard coded or is it
    > > assigned via DHCP by router ?

    >
    > Hard coded.
    >
    > > with PC power on and able to ping Internet site, start a long running
    > > ping on your PC in a command window (ping -t x.x.x.x) , then
    > > disconnect the cable to router, should be loss of ping, reconnect,
    > > note whether ping start again immediately - if it does then portfast
    > > is functioning properly

    >
    > Of course. Will try that.
    >
    > And if it is - then what is next suggestion? :)


    then you would need to also connect your PC serial port to the router
    console
    and perform some debugging - spanning-tree debugging

    you would post the output of show version and the output
    of show run removing of course all passwords and external IP addresses
     
    Merv, Jul 28, 2008
    #8
  9. Nicolai

    Merv Guest

    On Jul 28, 5:01 pm, "Nicolai" <> wrote:
    > > How does the PC acquire it's IP address - is it hard coded or is it
    > > assigned via DHCP by router ?

    >
    > Hard coded.
    >
    > > with PC power on and able to ping Internet site, start a long running
    > > ping on your PC in a command window (ping -t x.x.x.x) , then
    > > disconnect the cable to router, should be loss of ping, reconnect,
    > > note whether ping start again immediately - if it does then portfast
    > > is functioning properly

    >
    > Of course. Will try that.
    >
    > And if it is - then what is next suggestion? :)


    THe other thing that it might be is that the WAN side of the
    connection is down and the router is spending that time bring it up

    What is the WAN connection type - cable modem or DSL ?
     
    Merv, Jul 28, 2008
    #9
  10. Nicolai

    Nicolai Guest

    > THe other thing that it might be is that the WAN side of the
    > connection is down and the router is spending that time bring it up
    >
    > What is the WAN connection type - cable modem or DSL ?


    Its DSL and up 24/7

    I try to ping the router during boot - after login it takes about 10 secs
    before I get a respond
     
    Nicolai, Jul 29, 2008
    #10
  11. Nicolai

    Merv Guest

    On Jul 29, 2:46 pm, "Nicolai" <> wrote:
    > > THe other thing that it might be is that the WAN side of the
    > > connection is down and the router is spending that time bring it up

    >
    > > What is the WAN connection type - cable modem or DSL ?

    >
    > Its DSL and up 24/7



    and what is the evidence of it being up 24/7 ?

    post output of show interface
     
    Merv, Jul 29, 2008
    #11
  12. Nicolai

    Nicolai Guest

    >> Its DSL and up 24/7
    >
    >
    > and what is the evidence of it being up 24/7 ?


    Trust me ;)

    Anyway, I should be able to ping the routers internal IP even though the WAN
    is down...

    > post output of show interface


    FastEthernet4 is up, line protocol is up
    Hardware is PQUICC_FEC, address is x
    Description: WAN$FW_OUTSIDE$
    Internet address is x
    MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    reliability 255/255, txload 1/255, rxload 1/255
    Encapsulation ARPA, loopback not set
    Keepalive set (10 sec)
    Full-duplex, 100Mb/s, 100BaseTX/FX
    ARP type: ARPA, ARP Timeout 04:00:00
    Last input 00:00:11, output 00:00:10, output hang never
    Last clearing of "show interface" counters never
    Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    Queueing strategy: fifo
    Output queue: 0/40 (size/max)
    5 minute input rate 165000 bits/sec, 4 packets/sec
    5 minute output rate 0 bits/sec, 2 packets/sec
    1309255 packets input, 1243940840 bytes
    Received 3 broadcasts, 0 runts, 0 giants, 0 throttles
    0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    0 watchdog
    0 input packets with dribble condition detected
    977740 packets output, 107940049 bytes, 0 underruns
    0 output errors, 0 collisions, 2 interface resets
    0 babbles, 0 late collision, 0 deferred
    0 lost carrier, 0 no carrier
    0 output buffer failures, 0 output buffers swapped out
     
    Nicolai, Jul 30, 2008
    #12
  13. Nicolai

    Nicolai Guest

    >> Of course. Will try that.
    >>
    >> And if it is - then what is next suggestion? :)

    >
    > then you would need to also connect your PC serial port to the router
    > console
    > and perform some debugging - spanning-tree debugging


    Unplugged and plugged the cable:

    065884: Jul 30 08:18:14.603 CEST: %LINEPROTO-5-UPDOWN: Line protocol on
    Interfac
    e FastEthernet3, changed state to down
    065885: Jul 30 08:18:14.603 CEST: %LINEPROTO-5-UPDOWN: Line protocol on
    Interfac
    e Vlan1, changed state to down
    065886: Jul 30 08:18:15.607 CEST: %LINK-3-UPDOWN: Interface FastEthernet3,
    chang
    ed state to down
    065887: Jul 30 08:18:18.247 CEST: %LINEPROTO-5-UPDOWN: Line protocol on
    Interfac
    e Vlan1, changed state to up
    065888: Jul 30 08:18:19.239 CEST: %LINK-3-UPDOWN: Interface FastEthernet3,
    chang
    ed state to up
    065889: Jul 30 08:18:20.239 CEST: %LINEPROTO-5-UPDOWN: Line protocol on
    Interfac
    e FastEthernet3

    After line protocol came up it Believe it took about 15 seconds before the
    vlan1 up responded to ping
     
    Nicolai, Jul 30, 2008
    #13
  14. Nicolai

    Nicolai Guest

    > you would post the output of show version and the output
    > of show run removing of course all passwords and external IP addresses


    Cisco#sh ver
    Cisco IOS Software, C850 Software (C850-ADVSECURITYK9-M), Version
    12.4(15)T5, RE
    LEASE SOFTWARE (fc4)
    Technical Support: http://www.cisco.com/techsupport
    Copyright (c) 1986-2008 by Cisco Systems, Inc.
    Compiled Thu 01-May-08 02:07 by prod_rel_team

    ROM: System Bootstrap, Version 12.3(8r)YI2, RELEASE SOFTWARE

    Cisco uptime is 1 week, 20 hours, 19 minutes
    System returned to ROM by power-on
    System restarted at 12:00:44 CEST Tue Jul 22 2008
    System image file is "flash:c850-advsecurityk9-mz.124-15.T5.bin"

    Cisco 851W (MPC8272) processor (revision 0x200) with 59392K/6144K bytes of
    memory.
    Processor board ID FCZ102421AK
    MPC8272 CPU Rev: Part Number 0xC, Mask Number 0x10
    5 FastEthernet interfaces
    1 802.11 Radio
    128K bytes of non-volatile configuration memory.
    20480K bytes of processor board System flash (Intel Strataflash)


    KONF:
    ----------

    Cisco#sh run
    Building configuration...

    Current configuration : 6083 bytes
    !
    ! Last configuration change at 23:16:21 CEST Mon Jul 28 2008 by nifo
    ! NVRAM config last updated at 23:17:49 CEST Mon Jul 28 2008 by nifo
    !
    version 12.4
    no service pad
    service tcp-keepalives-in
    service tcp-keepalives-out
    service timestamps debug datetime msec localtime show-timezone
    service timestamps log datetime msec localtime show-timezone
    service password-encryption
    service compress-config
    service sequence-numbers
    !
    hostname Cisco
    !
    boot-start-marker
    boot system flash c850-advsecurityk9-mz.124-15.T5.bin
    boot-end-marker
    !
    logging buffered 8192
    no logging rate-limit
    !
    no aaa new-model
    clock timezone CET 1
    clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
    !
    dot11 syslog
    !
    dot11 ssid 12
    vlan 1
    authentication open
    authentication key-management wpa
    guest-mode
    wpa-psk ascii 7 xxx
    !
    no ip source-route
    no ip dhcp use vrf connected
    ip dhcp excluded-address 10.10.10.1 10.10.10.10
    !
    ip dhcp pool sdm-pool1
    import all
    network 10.10.10.0 255.255.255.0
    default-router 10.10.10.1
    !
    !
    ip cef
    ip inspect tcp max-incomplete host 50 block-time 120
    ip inspect name INSPECT tcp
    ip inspect name INSPECT udp
    ip inspect name INSPECT icmp
    ip inspect name INSPECT ftp
    ip auth-proxy max-nodata-conns 3
    ip admission max-nodata-conns 3
    no ip bootp server
    no ip domain lookup
    !
    !
    !
    username x
    !
    !
    archive
    log config
    hidekeys
    !
    !
    !
    bridge irb
    !
    !
    interface Null0
    no ip unreachables
    !
    interface FastEthernet0
    spanning-tree portfast
    !
    interface FastEthernet1
    spanning-tree portfast
    !
    interface FastEthernet2
    spanning-tree portfast
    !
    interface FastEthernet3
    spanning-tree portfast
    !
    interface FastEthernet4
    description WAN$FW_OUTSIDE$
    ip address dhcp client-id FastEthernet4
    ip access-group 101 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip inspect INSPECT out
    ip nat outside
    ip virtual-reassembly
    ip route-cache flow
    duplex auto
    speed auto
    !
    interface Dot11Radio0
    no ip address
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip route-cache flow
    !
    encryption vlan 1 mode ciphers tkip
    !
    ssid 12
    !
    speed basic-1.0 basic-2.0 basic-5.5 basic-6.0 basic-9.0 basic-11.0
    basic-12.0 b
    asic-18.0 basic-24.0 basic-36.0 basic-48.0 basic-54.0
    channel 2412
    station-role root
    no cdp enable
    !
    interface Dot11Radio0.1
    encapsulation dot1Q 1 native
    no cdp enable
    bridge-group 1
    bridge-group 1 subscriber-loop-control
    bridge-group 1 spanning-disabled
    bridge-group 1 block-unknown-source
    no bridge-group 1 source-learning
    no bridge-group 1 unicast-flooding
    !
    interface Vlan1
    description VLAN1-INSIDE-VLAN1
    no ip address
    ip tcp adjust-mss 1450
    bridge-group 1
    !
    interface BVI1
    description VLAN1-INSIDE-BVI$FW_INSIDE$
    ip address 10.10.10.1 255.255.255.0
    ip access-group 100 in
    no ip redirects
    no ip unreachables
    no ip proxy-arp
    ip nat inside
    ip virtual-reassembly
    ip route-cache flow
    ip tcp adjust-mss 1450
    !
    ip forward-protocol nd
    !
    no ip http server
    no ip http secure-server
    ip nat inside source list 1 interface FastEthernet4 overload
    ip nat inside source static tcp 10.10.10.10 3389 interface FastEthernet4
    3389
    !
    no logging trap
    access-list 1 remark INSIDE_IF=BVI1
    access-list 1 remark SDM_ACL Category=2
    access-list 1 permit 10.10.10.0 0.0.0.255
    access-list 2 remark HTTP Access-class list
    access-list 2 remark SDM_ACL Category=1
    access-list 2 permit 10.10.10.0 0.0.0.255
    access-list 2 deny any
    access-list 100 remark auto generated by Cisco SDM Express firewall
    configuratio
    n
    access-list 100 remark SDM_ACL Category=1
    access-list 100 deny ip host 255.255.255.255 any
    access-list 100 deny ip 127.0.0.0 0.255.255.255 any
    access-list 100 permit ip any any
    access-list 101 permit udp host x host x eq snmp
    access-list 101 permit udp any eq bootps any eq bootpc
    access-list 101 permit tcp any any eq 3389 log
    access-list 101 permit icmp any any
    access-list 101 deny ip any any
    snmp-server community soldug RO
    no cdp run
    !
    control-plane
    !
    bridge 1 protocol ieee
    bridge 1 route ip
    banner login ^CWelcome^C
    !
    line con 0
    login local
    no modem enable
    transport output telnet
    line aux 0
    login local
    transport output telnet
    line vty 0 4
    privilege level 15
    login local
    transport input telnet ssh
    !
    scheduler max-task-time 5000
    scheduler allocate 4000 1000
    scheduler interval 500
    end

    Cisco#
     
    Nicolai, Jul 30, 2008
    #14
  15. Nicolai

    Merv Guest

    do you have another PC that you can connect to one of the 851's
    Ethernet hub other ports and to see if you can ping it as soon as you
    reconnect the PC attached to port FA 3

    ie. is the Ethernet hub working properly - respecting the portfast
    config

    the objective is to determine if the BVI interface / vlan 1 interface
    handling is the issue
     
    Merv, Jul 30, 2008
    #15
  16. Nicolai

    Nicolai Guest

    > ie. is the Ethernet hub working properly - respecting the portfast
    > config
    >
    > the objective is to determine if the BVI interface / vlan 1 interface
    > handling is the issue


    Youre good - good idear!

    Will try this soon.
     
    Nicolai, Jul 30, 2008
    #16
  17. Nicolai

    Guest

    On Jul 30, 7:15 am, "Nicolai" <> wrote:
    > >> Its DSL and up 24/7

    >
    > > and what is the evidence of it being up 24/7 ?

    >
    > Trust me ;)
    >
    > Anyway, I should be able to ping the routers internal IP even though the WAN
    > is down...
    >
    > > post output of show interface

    >
    > FastEthernet4 is up, line protocol is up
    >   Hardware is PQUICC_FEC, address is x
    >   Description: WAN$FW_OUTSIDE$
    >   Internet address is x
    >   MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
    >      reliability 255/255, txload 1/255, rxload 1/255
    >   Encapsulation ARPA, loopback not set
    >   Keepalive set (10 sec)
    >   Full-duplex, 100Mb/s, 100BaseTX/FX
    >   ARP type: ARPA, ARP Timeout 04:00:00
    >   Last input 00:00:11, output 00:00:10, output hang never
    >   Last clearing of "show interface" counters never
    >   Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
    >   Queueing strategy: fifo
    >   Output queue: 0/40 (size/max)
    >   5 minute input rate 165000 bits/sec, 4 packets/sec
    >   5 minute output rate 0 bits/sec, 2 packets/sec
    >      1309255 packets input, 1243940840 bytes
    >      Received 3 broadcasts, 0 runts, 0 giants, 0 throttles
    >      0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
    >      0 watchdog
    >      0 input packets with dribble condition detected
    >      977740 packets output, 107940049 bytes, 0 underruns
    >      0 output errors, 0 collisions, 2 interface resets
    >      0 babbles, 0 late collision, 0 deferred
    >      0 lost carrier, 0 no carrier
    >      0 output buffer failures, 0 output buffers swapped out


    I notice that you have DHCP configured.
    How long does it take for DHCP to do its thing?
    You might try using a static address to test what happens.

    I think that the DHCP client waits for a while to see if there
    are other replies before continuing.

    You will be able to see what STP is doing with

    sh spanning-tree
    Port 3 (FastEthernet2) of VLAN2 is forwarding

    You will I guess be able to debug STP.
    debug spanning-tree events ! at a guess

    debug spanning-tree all

    deb ip dhcp serv events

    I wont describe how to view the debug output
    in full but this might get you going.

    conf t
    logg buff deb
    logg buff 50000
    end

    sh log

    Good luck.
     
    , Jul 31, 2008
    #17
  18. Nicolai

    Nicolai Guest

    006856: Aug 10 12:29:01.582 CEST: %LINEPROTO-5-UPDOWN: Line protocol on
    Interface Vlan1, changed state to up
    006857: Aug 10 12:29:02.574 CEST: %LINK-3-UPDOWN: Interface FastEthernet3,
    changed state to up
    006858: Aug 10 12:29:03.573 CEST: %LINEPROTO-5-UPDOWN: Line protocol on
    Interface FastEthernet3, changed state to up
    006859: Aug 10 12:29:21.683 CEST: %LINEPROTO-5-UPDOWN: Line protocol on
    Interface FastEthernet3, changed state to down
    006860: Aug 10 12:29:21.683 CEST: %LINEPROTO-5-UPDOWN: Line protocol on
    Interface Vlan1, changed state to down
    006861: Aug 10 12:29:22.687 CEST: %LINK-3-UPDOWN: Interface FastEthernet3,
    changed state to up
    006862: Aug 10 12:29:23.435 CEST: %LINEPROTO-5-UPDOWN: Line protocol on
    Interface Vlan1, changed state to up
    006863: Aug 10 12:29:23.687 CEST: %LINEPROTO-5-UPDOWN: Line protocol on
    Interface FastEthernet3, changed state to up

    Maybe I should try to connect another PC to keep vlan1 up?
     
    Nicolai, Aug 10, 2008
    #18
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Geert
    Replies:
    1
    Views:
    490
    Diesel
    Feb 2, 2004
  2. Gary
    Replies:
    3
    Views:
    2,159
    Kevin Widner
    Jul 16, 2004
  3. ants

    spanning tree portfast

    ants, Mar 9, 2005, in forum: Cisco
    Replies:
    2
    Views:
    35,861
  4. HPauly

    portfast bpduguard..

    HPauly, Sep 8, 2005, in forum: Cisco
    Replies:
    1
    Views:
    4,602
  5. tony

    portfast

    tony, Sep 7, 2006, in forum: Cisco
    Replies:
    5
    Views:
    4,838
    BernieM
    Sep 8, 2006
Loading...

Share This Page