'no ip classless' not working?

Discussion in 'Cisco' started by tom, Jul 22, 2009.

  1. tom

    tom Guest

    I am playing with some routers in a lab and just to say that I've seen
    it break things I set 'no ip classless'. However, I am not getting the
    result I expected and I was hoping someone could tell me what I'm
    missing.

    My lab topology is set up like so:

    RouterA---10.32.20.0/24---RouterB---10.32.10.0/24---
    RouterC---10.32.32.0/24---RouterD---10.35.35.0/24--->

    RouterB is set with 'no ip classless' and its routing table is below:

    RouterB#show ip route
    Gateway of last resort is 10.32.10.254 to network 0.0.0.0

    172.16.0.0/24 is subnetted, 1 subnets
    C 172.16.30.0 is directly connected, FastEthernet0/1.30
    10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
    C 10.32.10.0/24 is directly connected, FastEthernet0/0.10
    C 10.32.20.0/24 is directly connected, FastEthernet0/1.20
    S 10.100.0.0/14 [1/0] via 10.32.10.254
    S* 0.0.0.0/0 [1/0] via 10.32.10.254

    If I understand how classful routing works, I should not be able to
    ping 10.35.35.1 from RouterA; the reason being that RouterB is
    configured for classful routing and has routes to other networks in
    10.0.0.0/8 (but not 10.35.35.0/24). Therefore, RouterB discards the
    packet.

    However, when I try to ping 10.35.35.1, it works fine:

    RouterA#ping 10.35.35.1

    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 10.35.35.1, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
    RouterA#traceroute 10.35.35.1

    Type escape sequence to abort.
    Tracing the route to 10.35.35.1

    1 10.32.20.253 0 msec 0 msec 0 msec
    2 10.32.10.254 4 msec 4 msec 0 msec
    3 10.35.35.1 4 msec 8 msec 0 msec
     
    tom, Jul 22, 2009
    #1
    1. Advertising

  2. tom

    alexd Guest

    tom wrote:

    > I am playing with some routers in a lab and just to say that I've seen
    > it break things I set 'no ip classless'.


    What IOS are you using? I'm sure I heard that classful support has been
    dropped from recent IOS, but I can't find a reference to it at the moment.

    --
    <http://ale.cx/> (AIM:troffasky) ()
    14:26:06 up 77 days, 2:34, 2 users, load average: 0.16, 0.12, 0.09
    A few flakes working together can unleash an avalanche of destruction
     
    alexd, Jul 22, 2009
    #2
    1. Advertising

  3. tom

    Morph Guest

    In the message
    <> tom
    wrote:

    | I am playing with some routers in a lab and just to say that I've seen
    | it break things I set 'no ip classless'. However, I am not getting the
    | result I expected and I was hoping someone could tell me what I'm
    | missing.
    |
    | My lab topology is set up like so:
    |
    | RouterA---10.32.20.0/24---RouterB---10.32.10.0/24---
    | RouterC---10.32.32.0/24---RouterD---10.35.35.0/24--->
    |
    | RouterB is set with 'no ip classless' and its routing table is below:
    |
    | RouterB#show ip route
    | Gateway of last resort is 10.32.10.254 to network 0.0.0.0
    |
    | 172.16.0.0/24 is subnetted, 1 subnets
    | C 172.16.30.0 is directly connected, FastEthernet0/1.30
    | 10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
    | C 10.32.10.0/24 is directly connected, FastEthernet0/0.10
    | C 10.32.20.0/24 is directly connected, FastEthernet0/1.20
    | S 10.100.0.0/14 [1/0] via 10.32.10.254
    | S* 0.0.0.0/0 [1/0] via 10.32.10.254
    |
    | If I understand how classful routing works, I should not be able to
    | ping 10.35.35.1 from RouterA; the reason being that RouterB is
    | configured for classful routing and has routes to other networks in
    | 10.0.0.0/8 (but not 10.35.35.0/24). Therefore, RouterB discards the
    | packet.
    |
    | However, when I try to ping 10.35.35.1, it works fine:
    |
    | RouterA#ping 10.35.35.1
    |
    | Type escape sequence to abort.
    | Sending 5, 100-byte ICMP Echos to 10.35.35.1, timeout is 2 seconds:
    | !!!!!
    | Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
    | RouterA#traceroute 10.35.35.1
    |
    | Type escape sequence to abort.
    | Tracing the route to 10.35.35.1
    |
    | 1 10.32.20.253 0 msec 0 msec 0 msec
    | 2 10.32.10.254 4 msec 4 msec 0 msec
    | 3 10.35.35.1 4 msec 8 msec 0 msec

    Is it possible that a router on 10.32.20.X is doing proxy ARP?
     
    Morph, Jul 22, 2009
    #3
  4. tom

    Guest

    On Jul 22, 8:58 am, Morph <> wrote:
    > In the message
    > <> tom
    > wrote:
    >
    > | I am playing with some routers in a lab and just to say that I've seen
    > | it break things I set 'no ip classless'. However, I am not getting the
    > | result I expected and I was hoping someone could tell me what I'm
    > | missing.
    > |
    > | My lab topology is set up like so:
    > |
    > | RouterA---10.32.20.0/24---RouterB---10.32.10.0/24---
    > | RouterC---10.32.32.0/24---RouterD---10.35.35.0/24--->
    > |
    > | RouterB is set with 'no ip classless' and its routing table is below:
    > |
    > | RouterB#show ip route
    > | Gateway of last resort is 10.32.10.254 to network 0.0.0.0
    > |
    > |      172.16.0.0/24 is subnetted, 1 subnets
    > | C       172.16.30.0 is directly connected, FastEthernet0/1.30
    > |      10.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
    > | C       10.32.10.0/24 is directly connected, FastEthernet0/0.10
    > | C       10.32.20.0/24 is directly connected, FastEthernet0/1.20
    > | S       10.100.0.0/14 [1/0] via 10.32.10.254
    > | S*   0.0.0.0/0 [1/0] via 10.32.10.254
    > |
    > | If I understand how classful routing works, I should not be able to
    > | ping 10.35.35.1 from RouterA; the reason being that RouterB is
    > | configured for classful routing and has routes to other networks in
    > | 10.0.0.0/8 (but not 10.35.35.0/24). Therefore, RouterB discards the
    > | packet.
    > |
    > | However, when I try to ping 10.35.35.1, it works fine:
    > |
    > | RouterA#ping 10.35.35.1
    > |
    > | Type escape sequence to abort.
    > | Sending 5, 100-byte ICMP Echos to 10.35.35.1, timeout is 2 seconds:
    > | !!!!!
    > | Success rate is 100 percent (5/5), round-trip min/avg/max = 1/3/4 ms
    > | RouterA#traceroute 10.35.35.1
    > |
    > | Type escape sequence to abort.
    > | Tracing the route to 10.35.35.1
    > |
    > |   1 10.32.20.253 0 msec 0 msec 0 msec
    > |   2 10.32.10.254 4 msec 4 msec 0 msec
    > |   3 10.35.35.1 4 msec 8 msec 0 msec
    >
    > Is it possible that a router on 10.32.20.X is doing proxy ARP?

    With no ip classless in the configuration you have enabled classful
    routing.. You will notice that if any part of the destination IP
    addresses classful network is in the routing table, the router will
    not use the default route to forward the packet. I would suggest
    trying this with dynamic routing protocols (RIPv2, EIGRP, etc..) to
    test behavior also.
     
    , Jul 22, 2009
    #4
  5. tom

    tom Guest

    On Jul 22, 8:32 am, alexd <> wrote:
    >
    > What IOS are you using? I'm sure I heard that classful support has been
    > dropped from recent IOS, but I can't find a reference to it at the moment..


    The routers are all running 12.3 or 12.4 (details below). Regarding
    Proxy ARP, I don't think it is configured, I certainly didn't
    configure it explicitly. The A-C configs are below. Thanks for the
    suggestions.

    RouterA is a 1720 running 12.3(23)
    RouterB is a 1841 running IP Base 12.3(8)T5
    RouterC is a 3640 running IP Plus 12.4(16)
    RouterD is actually a Pix501 running 6.3.5

    ==RouterA config==
    version 12.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname c1700
    !
    boot-start-marker
    boot-end-marker
    !
    no logging buffered
    enable secret 5 $1$aGun$pr7FjqTJLRWJr7IK7ZybZ/
    !
    memory-size iomem 25
    no aaa new-model
    ip subnet-zero
    !
    no ip domain lookup
    !
    ip cef
    !
    interface FastEthernet0
    ip address 10.32.20.20 255.255.255.0
    speed auto
    !
    interface Serial0
    no ip address
    shutdown
    !
    ip classless
    ip default-network 10.0.0.0
    ip route 0.0.0.0 0.0.0.0 172.16.30.253
    ip route 0.0.0.0 0.0.0.0 10.32.20.253
    ip route 10.32.10.0 255.255.255.0 10.32.20.253
    ip route 10.32.10.0 255.255.255.0 172.16.30.253
    no ip http server
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    password cisco
    logging synchronous
    login


    ==RouterB config==
    version 12.3
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname 1841
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$hiFe$mTnPJtBBtct5FO6c8D/Dp0
    !
    username cisco secret 5 $1$f6gj$PjxDNivBCz/JtXQZbi7w3.
    mmi polling-interval 60
    no mmi auto-configure
    no mmi pvc
    mmi snmp-timeout 180
    no aaa new-model
    ip subnet-zero
    ip cef
    !
    !
    !
    !
    no ip domain lookup
    no ftp-server write-enable
    !
    !
    !
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.10
    encapsulation dot1Q 10
    ip address 10.32.10.253 255.255.255.0
    no cdp enable
    !
    interface FastEthernet0/0.20
    !
    interface FastEthernet0/1
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/1.20
    encapsulation dot1Q 20
    ip address 10.32.20.253 255.255.255.0
    !
    interface FastEthernet0/1.30
    encapsulation dot1Q 30 native
    ip address 172.16.30.253 255.255.255.0
    !
    interface Serial0/0/0
    no ip address
    shutdown
    !
    no ip classless
    ip route 0.0.0.0 0.0.0.0 10.32.10.254
    ip route 10.100.0.0 255.252.0.0 10.32.10.254
    no ip http server
    !
    !
    !
    control-plane
    !
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    history size 15
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    logging synchronous
    login local
    history size 15
    line vty 5 15
    exec-timeout 0 0
    logging synchronous
    login local
    history size 15



    ==RouterC config==
    !
    version 12.4
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname r2
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$Z7iL$d6iyr1T0G5GGJIBeEB5IX1
    !
    no aaa new-model
    !
    ip cef
    no ip domain lookup
    !
    username cisco secret 5 $1$xFnX$32qbiWsFGoGCIWrmPURPO.
    !
    interface FastEthernet0/0
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet0/0.1
    encapsulation isl 1
    ip address 10.32.32.254 255.255.255.0
    no ip redirects
    !
    interface FastEthernet0/0.10
    encapsulation isl 10
    ip address 10.32.10.254 255.255.255.0
    no ip redirects
    !
    interface Serial0/0
    no ip address
    shutdown
    !
    interface Serial0/1
    no ip address
    shutdown
    clock rate 2000000
    !
    interface Serial0/2
    no ip address
    shutdown
    !
    ip http server
    !
    no ip classless
    ip route 0.0.0.0 0.0.0.0 10.32.32.1
    ip route 10.32.20.0 255.255.255.0 10.32.10.253
    ip route 172.16.30.0 255.255.255.0 10.32.10.253
    !
    control-plane
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    exec-timeout 0 0
    logging synchronous
    login local
    line vty 5 15
    exec-timeout 0 0
    logging synchronous
    login local
     
    tom, Jul 22, 2009
    #5
  6. tom

    Thrill5 Guest

    I'm pretty sure classfull routing is no longer supported as well, either
    that or its broken. I do know that classless routing is now the default in
    the newer versions of IOS, I'm not sure what version this changed. If it
    were broken, I doubt that Cisco would fix it because the entire concept of
    classfull routing was itself sent to the bit bucket more than 15 years ago.
    A workaround is to add a static route for 10/8 to null0. This is exactly
    what "no ip classless" would do anyway.

    ip route 10.0.0.0 255.0.0.0 null0


    "alexd" <> wrote in message
    news:...
    > tom wrote:
    >
    >> I am playing with some routers in a lab and just to say that I've seen
    >> it break things I set 'no ip classless'.

    >
    > What IOS are you using? I'm sure I heard that classful support has been
    > dropped from recent IOS, but I can't find a reference to it at the moment.
    >
    > --
    > <http://ale.cx/> (AIM:troffasky) ()
    > 14:26:06 up 77 days, 2:34, 2 users, load average: 0.16, 0.12, 0.09
    > A few flakes working together can unleash an avalanche of destruction
    >
    >
     
    Thrill5, Jul 23, 2009
    #6
  7. tom

    tom Guest

    On Jul 22, 7:39 pm, "Thrill5" <> wrote:
    > I'm pretty sure classfull routing is no longer supported as well, either
    > that or its broken. I do know that classless routing is now the default in
    > the newer versions of IOS, I'm not sure what version this changed.  If it
    > were broken, I doubt that Cisco would fix it because the entire concept of
    > classfull routing was itself sent to the bit bucket more than 15 years ago.
    > A workaround is to add a static route for 10/8 to null0.  This is exactly
    > what "no ip classless" would do anyway.


    I don't doubt that the functionality was eliminated; it seems
    prehistoric, and I've been trying to think of a situation in which it
    would be useful. But if it is indeed depreciated, i wonder why it
    would even still be a configuration option. Furthermore, I wonder why
    it would still be included in the CCNA material, other than as a "this
    is how things were in the bad old days" aside.
     
    tom, Jul 23, 2009
    #7
  8. tom

    alexd Guest

    tom wrote:

    > But if it is indeed depreciated, i wonder why it
    > would even still be a configuration option.


    You'd hope the CLI would warn you if you tried to configure it, if it is
    indeed now non-functional. It could of course just be a bug.

    > Furthermore, I wonder why it would still be included in the CCNA material,
    > other than as a "this is how things were in the bad old days" aside.


    Indeed. My CCNA tutor seemed to think that serial interfaces were what made
    the world go round.

    --
    <http://ale.cx/> (AIM:troffasky) ()
    12:46:16 up 79 days, 1:14, 2 users, load average: 0.15, 0.15, 0.10
    A few flakes working together can unleash an avalanche of destruction
     
    alexd, Jul 24, 2009
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?RHJhZ29ueA==?=

    wifi not working on new hp, or not working after live update

    =?Utf-8?B?RHJhZ29ueA==?=, Oct 2, 2005, in forum: Wireless Networking
    Replies:
    1
    Views:
    1,138
    =?Utf-8?B?RHJhZ29ueA==?=
    Oct 2, 2005
  2. Replies:
    0
    Views:
    907
  3. jh3ang

    ip classless and auto-summary

    jh3ang, Aug 4, 2006, in forum: Cisco
    Replies:
    3
    Views:
    72,757
    Barry Margolin
    Aug 5, 2006
  4. Max

    IP CLASSLESS not working

    Max, May 6, 2008, in forum: Cisco
    Replies:
    13
    Views:
    3,827
  5. Pawe³ Damian

    "no ip classless" and "ip cef"

    Pawe³ Damian, May 4, 2009, in forum: Cisco
    Replies:
    8
    Views:
    5,126
    Sam Wilson
    May 25, 2009
Loading...

Share This Page