No incoming call, CSipSimple on Android 2.2

Discussion in 'UK VOIP' started by divoch, Feb 23, 2011.

  1. divoch

    divoch Guest

    LG Optimus One, Android 2.2, successfully registered (to FAYN.CZ) using
    CSipSimple VOIP software for Android, while connected over home Wi-Fi
    network.
    Set to "Always available".
    Outgoing call rings in the destination fixed phone OK but Incoming call does
    not ring and, after 2 or 3 rings, call goes to the FAYN answerphone
    CSipSimple version 0.01-01 r615
    Skype works both ways on the mobile using Wi-Fi. Also connection works fine
    both ways using X-Lite by Counterpath on the desktop PC.

    Any advice will be appreciated

    divoch
     
    divoch, Feb 23, 2011
    #1
    1. Advertising

  2. divoch <> wrote:
    > LG Optimus One, Android 2.2, successfully registered (to FAYN.CZ) using
    > CSipSimple VOIP software for Android, while connected over home Wi-Fi
    > network.
    > Set to "Always available".


    There are various things that affect this:

    The wifi goes to sleep, or doesn't wake from sleep (Android settings)
    The softphone doesn't stay registered
    The softphone is set not to register on wifi/3G/2G/whatever.
    (I can't remember the precise menu options)

    When I had this problem with CSipSimple, it was because the wifi goes to
    sleep when the phone is idle.

    Theo
     
    Theo Markettos, Feb 24, 2011
    #2
    1. Advertising

  3. divoch

    divoch Guest

    "Theo Markettos" <> wrote in message
    news:ejz*...
    > divoch <> wrote:
    >> LG Optimus One, Android 2.2, successfully registered (to FAYN.CZ) using
    >> CSipSimple VOIP software for Android, while connected over home Wi-Fi
    >> network.
    >> Set to "Always available".

    >
    > There are various things that affect this:
    >
    > The wifi goes to sleep, or doesn't wake from sleep (Android settings)
    > The softphone doesn't stay registered
    > The softphone is set not to register on wifi/3G/2G/whatever.
    > (I can't remember the precise menu options)
    >
    > When I had this problem with CSipSimple, it was because the wifi goes to
    > sleep when the phone is idle.
    >

    I may have found something: When both softphones were active, call always
    came through to the X-lite on my desktop PC but not to the mobile. When I
    turned off X-lite softphone , which was registered to the same account, a
    call suddenly came through to the mobile. (This is different with Skype,
    where it rings on both desktop and PC).
    When I turned then X-lite On and then Off again, calls did not come to the
    mobile for some time. I looked also on the status of "channels" and "lines"
    in my VOIP account. There are colour indicators for the channel (I have only
    one) and the lines in that channel ( two lines, one geographic number and
    one not). When I run mouse over the green indicator it shows my IP address,
    but when it goes to Red it does not.
    When only X-lite is connected, geographic number line goes green, but the
    channel colour indicator [and the other line] stays red (or maybe channel is
    orange in this case). It took some time after I turned off X-lite before
    mobile accepted VOIP calls again. I do not think I did anything specific,
    it just took some time. I noted the state of the indicators in my VOIP
    provider's account when my mobile accepted calls again : Channel is Green
    (IP address shown) but both lines are Red.
    I read somewhere that this state means, that the device (mobile in this
    case) is registered to the "channel" rather than individual "line.

    So I am not sure if it will now continue to work reliably with X-lite turned
    Off or not. I have disabled voicemail associated with the account because I
    do not know how to access it through the CSipSimple.

    divoch
     
    divoch, Feb 24, 2011
    #3
  4. divoch

    divoch Guest

    "divoch" <> wrote in message
    news:ket9p.39907$2...
    >
    > "Theo Markettos" <> wrote in message
    > news:ejz*...
    >> divoch <> wrote:
    >>> LG Optimus One, Android 2.2, successfully registered (to FAYN.CZ) using
    >>> CSipSimple VOIP software for Android, while connected over home Wi-Fi
    >>> network.
    >>> Set to "Always available".

    >>
    >> There are various things that affect this:
    >>
    >> The wifi goes to sleep, or doesn't wake from sleep (Android settings)
    >> The softphone doesn't stay registered
    >> The softphone is set not to register on wifi/3G/2G/whatever.
    >> (I can't remember the precise menu options)
    >>
    >> When I had this problem with CSipSimple, it was because the wifi goes to
    >> sleep when the phone is idle.
    >>

    > I may have found something: When both softphones were active, call always
    > came through to the X-lite on my desktop PC but not to the mobile. When I
    > turned off X-lite softphone , which was registered to the same account, a
    > call suddenly came through to the mobile. (This is different with Skype,
    > where it rings on both desktop and PC).
    > When I turned then X-lite On and then Off again, calls did not come to
    > the mobile for some time. I looked also on the status of "channels" and
    > "lines" in my VOIP account. There are colour indicators for the channel (I
    > have only one) and the lines in that channel ( two lines, one geographic
    > number and one not). When I run mouse over the green indicator it shows my
    > IP address, but when it goes to Red it does not.
    > When only X-lite is connected, geographic number line goes green, but the
    > channel colour indicator [and the other line] stays red (or maybe channel
    > is orange in this case). It took some time after I turned off X-lite
    > before mobile accepted VOIP calls again. I do not think I did anything
    > specific, it just took some time. I noted the state of the indicators in
    > my VOIP provider's account when my mobile accepted calls again : Channel
    > is Green (IP address shown) but both lines are Red.
    > I read somewhere that this state means, that the device (mobile in this
    > case) is registered to the "channel" rather than individual "line.
    >
    > So I am not sure if it will now continue to work reliably with X-lite
    > turned Off or not. I have disabled voicemail associated with the account
    > because I do not know how to access it through the CSipSimple.
    >
    > divoch


    It is not that simple. After rebooting PC, whatever I do, I cannot get the
    mobile to respond to incoming calls . Wi-Fi is active and registered, the
    latter is visible also in the VOIP account , where it is showing active
    status and the IP
    address of my PC. Outgoing calls ring the destination number, but incoming
    do not get through. I suspect it is something to do with the router settings
    rather
    than the phone settings but I cannot find any CSipSimple support information
    that may shed some light on this.

    divoch
     
    divoch, Feb 24, 2011
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Michael Bower
    Replies:
    3
    Views:
    4,716
    beenthere
    Oct 1, 2006
  2. zlajavi
    Replies:
    0
    Views:
    440
    zlajavi
    Apr 19, 2008
  3. divoch
    Replies:
    1
    Views:
    1,231
    divoch
    Feb 26, 2011
  4. Lawrence D'Oliveiro

    Android, Android, Android

    Lawrence D'Oliveiro, May 21, 2011, in forum: NZ Computing
    Replies:
    2
    Views:
    768
    Boots
    May 21, 2011
  5. Allan
    Replies:
    6
    Views:
    566
    ├čodincus
    Jan 28, 2014
Loading...

Share This Page