No DVD Sound on Vista 64

Discussion in 'Windows 64bit' started by Ken Triebold, Jan 31, 2008.

  1. Ken Triebold

    Ken Triebold Guest

    I have just built a new computer, and it seems to be running pretty well. I
    have Vista Home Premium 64 bit. One thing I noticed is that I have picture
    but no sound when playing a movie DVD. When I play a music CD sound works
    normally. Someone advised me that this is because I need a codec for DVD
    sound. I then downloaded and installed a couple of free codecs, but that did
    not improve the situation. I read on Windows Help that my operating system
    requires a codec that is written in 64 bit, so that could be the problem
    since the codecs that I downloaded were probably 32 bit. I imagine finding a
    64 bit codec will be pretty hard to find. Am I on the right track in solving
    this problem? Does anyone know if a 64 bit codec will be included with SP1?
     
    Ken Triebold, Jan 31, 2008
    #1
    1. Advertising

  2. Ken Triebold

    Carlos Guest

    Ken,
    Here you have a freeware multiformat x64 audio/video decoder.
    This is the direct download link:
    http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    This is the web page you can check for updates.
    http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    The decoder is labeled as "64-bit builds (experimental)" but I works
    flawlessly for me.
    The other decoders in that page are 32-bit.
    I also use them and they coexist pacefully in Vista x64.

    as a bonus, you might also want to try the lightweight x64 "Media Player
    Classic"
    http://sourceforge.net/project/showfiles.php?group_id=170561

    Carlos

    "Ken Triebold" wrote:

    > I have just built a new computer, and it seems to be running pretty well. I
    > have Vista Home Premium 64 bit. One thing I noticed is that I have picture
    > but no sound when playing a movie DVD. When I play a music CD sound works
    > normally. Someone advised me that this is because I need a codec for DVD
    > sound. I then downloaded and installed a couple of free codecs, but that did
    > not improve the situation. I read on Windows Help that my operating system
    > requires a codec that is written in 64 bit, so that could be the problem
    > since the codecs that I downloaded were probably 32 bit. I imagine finding a
    > 64 bit codec will be pretty hard to find. Am I on the right track in solving
    > this problem? Does anyone know if a 64 bit codec will be included with SP1?
    >
    >
     
    Carlos, Jan 31, 2008
    #2
    1. Advertising

  3. Ken Triebold

    Ken Triebold Guest

    Thanks for the info. I downloaded and installed the x64 codec that you
    mentioned but it didn't seem to make any difference. There are some guys on
    the Media Center forum that think my problem is more related to settings,
    but I haven't made any real progress with that either. Thanks for the help
    though.


    "Carlos" <> wrote in message
    news:...
    > Ken,
    > Here you have a freeware multiformat x64 audio/video decoder.
    > This is the direct download link:
    > http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    > This is the web page you can check for updates.
    > http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    > The decoder is labeled as "64-bit builds (experimental)" but I works
    > flawlessly for me.
    > The other decoders in that page are 32-bit.
    > I also use them and they coexist pacefully in Vista x64.
    >
    > as a bonus, you might also want to try the lightweight x64 "Media Player
    > Classic"
    > http://sourceforge.net/project/showfiles.php?group_id=170561
    >
    > Carlos
    >
    > "Ken Triebold" wrote:
    >
    >> I have just built a new computer, and it seems to be running pretty well.
    >> I
    >> have Vista Home Premium 64 bit. One thing I noticed is that I have
    >> picture
    >> but no sound when playing a movie DVD. When I play a music CD sound works
    >> normally. Someone advised me that this is because I need a codec for DVD
    >> sound. I then downloaded and installed a couple of free codecs, but that
    >> did
    >> not improve the situation. I read on Windows Help that my operating
    >> system
    >> requires a codec that is written in 64 bit, so that could be the problem
    >> since the codecs that I downloaded were probably 32 bit. I imagine
    >> finding a
    >> 64 bit codec will be pretty hard to find. Am I on the right track in
    >> solving
    >> this problem? Does anyone know if a 64 bit codec will be included with
    >> SP1?
    >>
    >>
     
    Ken Triebold, Feb 1, 2008
    #3
  4. Ken Triebold

    Carlos Guest

    Ken,
    If you try Media Player Classic x64 and you have sound, then you will be
    sure it is a Media Center settings issue.
    If you don't have sound, then you will have to look elsewhere.
    Carlos

    "Ken Triebold" wrote:

    > Thanks for the info. I downloaded and installed the x64 codec that you
    > mentioned but it didn't seem to make any difference. There are some guys on
    > the Media Center forum that think my problem is more related to settings,
    > but I haven't made any real progress with that either. Thanks for the help
    > though.
    >
    >
    > "Carlos" <> wrote in message
    > news:...
    > > Ken,
    > > Here you have a freeware multiformat x64 audio/video decoder.
    > > This is the direct download link:
    > > http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    > > This is the web page you can check for updates.
    > > http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    > > The decoder is labeled as "64-bit builds (experimental)" but I works
    > > flawlessly for me.
    > > The other decoders in that page are 32-bit.
    > > I also use them and they coexist pacefully in Vista x64.
    > >
    > > as a bonus, you might also want to try the lightweight x64 "Media Player
    > > Classic"
    > > http://sourceforge.net/project/showfiles.php?group_id=170561
    > >
    > > Carlos
    > >
    > > "Ken Triebold" wrote:
    > >
    > >> I have just built a new computer, and it seems to be running pretty well.
    > >> I
    > >> have Vista Home Premium 64 bit. One thing I noticed is that I have
    > >> picture
    > >> but no sound when playing a movie DVD. When I play a music CD sound works
    > >> normally. Someone advised me that this is because I need a codec for DVD
    > >> sound. I then downloaded and installed a couple of free codecs, but that
    > >> did
    > >> not improve the situation. I read on Windows Help that my operating
    > >> system
    > >> requires a codec that is written in 64 bit, so that could be the problem
    > >> since the codecs that I downloaded were probably 32 bit. I imagine
    > >> finding a
    > >> 64 bit codec will be pretty hard to find. Am I on the right track in
    > >> solving
    > >> this problem? Does anyone know if a 64 bit codec will be included with
    > >> SP1?
    > >>
    > >>

    >
    >
     
    Carlos, Feb 1, 2008
    #4
  5. See
    http://forms.analog.com/Form_Pages/soundMax/soundMaxSupportFAQ.html#question25
    There are other answers on the same page which might be relevant.



    "Ken Triebold" <> wrote in message
    news:...
    > Thanks for the info. I downloaded and installed the x64 codec that you
    > mentioned but it didn't seem to make any difference. There are some guys
    > on the Media Center forum that think my problem is more related to
    > settings, but I haven't made any real progress with that either. Thanks
    > for the help though.
    >
    >
    > "Carlos" <> wrote in message
    > news:...
    >> Ken,
    >> Here you have a freeware multiformat x64 audio/video decoder.
    >> This is the direct download link:
    >> http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    >> This is the web page you can check for updates.
    >> http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    >> The decoder is labeled as "64-bit builds (experimental)" but I works
    >> flawlessly for me.
    >> The other decoders in that page are 32-bit.
    >> I also use them and they coexist pacefully in Vista x64.
    >>
    >> as a bonus, you might also want to try the lightweight x64 "Media Player
    >> Classic"
    >> http://sourceforge.net/project/showfiles.php?group_id=170561
    >>
    >> Carlos
    >>
    >> "Ken Triebold" wrote:
    >>
    >>> I have just built a new computer, and it seems to be running pretty
    >>> well. I
    >>> have Vista Home Premium 64 bit. One thing I noticed is that I have
    >>> picture
    >>> but no sound when playing a movie DVD. When I play a music CD sound
    >>> works
    >>> normally. Someone advised me that this is because I need a codec for DVD
    >>> sound. I then downloaded and installed a couple of free codecs, but that
    >>> did
    >>> not improve the situation. I read on Windows Help that my operating
    >>> system
    >>> requires a codec that is written in 64 bit, so that could be the problem
    >>> since the codecs that I downloaded were probably 32 bit. I imagine
    >>> finding a
    >>> 64 bit codec will be pretty hard to find. Am I on the right track in
    >>> solving
    >>> this problem? Does anyone know if a 64 bit codec will be included with
    >>> SP1?
    >>>
    >>>

    >
     
    Dominic Payer, Feb 1, 2008
    #5
  6. Ken Triebold

    Ken Triebold Guest

    Carlos, I searched on "Media Player Classic x64" and found this link:
    http://www.start64.com/index.php?option=com_content&task=view&id=1376&Itemid=72

    That link allowed me to download a 64 bit version of Media Player Classic
    HomeCinema. I was shocked to find that my DVD's played correctly (with
    sound) using that player. I then checked once again on Windows Media Player
    and Windows Media Center and the DVD did not produce sound on either of
    those. As you said in your last post, I now know that this is a Media Center
    settings issue so I will pursue that further. Maybe the link that Dominic
    Payer provided in his message will help me out. At least now I have a way to
    play DVD's even though I really want to get Windows Media Center working as
    it should. Thanks for all your help.

    -Ken


    "Carlos" <> wrote in message
    news:...
    > Ken,
    > If you try Media Player Classic x64 and you have sound, then you will be
    > sure it is a Media Center settings issue.
    > If you don't have sound, then you will have to look elsewhere.
    > Carlos
    >
    > "Ken Triebold" wrote:
    >
    >> Thanks for the info. I downloaded and installed the x64 codec that you
    >> mentioned but it didn't seem to make any difference. There are some guys
    >> on
    >> the Media Center forum that think my problem is more related to settings,
    >> but I haven't made any real progress with that either. Thanks for the
    >> help
    >> though.
    >>
    >>
    >> "Carlos" <> wrote in message
    >> news:...
    >> > Ken,
    >> > Here you have a freeware multiformat x64 audio/video decoder.
    >> > This is the direct download link:
    >> > http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    >> > This is the web page you can check for updates.
    >> > http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    >> > The decoder is labeled as "64-bit builds (experimental)" but I works
    >> > flawlessly for me.
    >> > The other decoders in that page are 32-bit.
    >> > I also use them and they coexist pacefully in Vista x64.
    >> >
    >> > as a bonus, you might also want to try the lightweight x64 "Media
    >> > Player
    >> > Classic"
    >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    >> >
    >> > Carlos
    >> >
    >> > "Ken Triebold" wrote:
    >> >
    >> >> I have just built a new computer, and it seems to be running pretty
    >> >> well.
    >> >> I
    >> >> have Vista Home Premium 64 bit. One thing I noticed is that I have
    >> >> picture
    >> >> but no sound when playing a movie DVD. When I play a music CD sound
    >> >> works
    >> >> normally. Someone advised me that this is because I need a codec for
    >> >> DVD
    >> >> sound. I then downloaded and installed a couple of free codecs, but
    >> >> that
    >> >> did
    >> >> not improve the situation. I read on Windows Help that my operating
    >> >> system
    >> >> requires a codec that is written in 64 bit, so that could be the
    >> >> problem
    >> >> since the codecs that I downloaded were probably 32 bit. I imagine
    >> >> finding a
    >> >> 64 bit codec will be pretty hard to find. Am I on the right track in
    >> >> solving
    >> >> this problem? Does anyone know if a 64 bit codec will be included with
    >> >> SP1?
    >> >>
    >> >>

    >>
    >>
     
    Ken Triebold, Feb 1, 2008
    #6
  7. Ken Triebold

    Carlos Guest

    Ken,
    That is good news.
    You have a working x64 Player now because it has its own AC3/DTS audio
    decoder (the 5.1 sound of DVD's) and your audio setup is fine.
    Always check here:
    http://sourceforge.net/project/showfiles.php?group_id=170561
    for updates, it is the MPC Home Cinema project page.

    Now, getting back to your issue with Media Center...
    I assume you have already installed ffdshow x64.
    Let's see its Audio Configuration.
    Start, Programs, ffdshow, Audio Decoder Configuration.
    Click on "Codecs" o the left pane.
    Choose AC3 on the "Format" column, right pane.
    What do you have in the AC3 row, Decoder column?
    Make sure it is not "Disabled" or "S/PDIF".
    Disabled is... well... disabled, and you surely don't want that.
    S/PDIF means that your sound goes to the optical connection and from there
    to an external decoder.
    Choose the "other" option (I am not at my Vista x64 PC now but it shoudl be
    something like "liba52")
    Maybe you can find something there.

    Also click on Mixer (left pane) and take look at the Output speakers
    configuration.
    Does it match your system?

    Carlos

    "Ken Triebold" wrote:

    > Carlos, I searched on "Media Player Classic x64" and found this link:
    > http://www.start64.com/index.php?option=com_content&task=view&id=1376&Itemid=72
    >
    > That link allowed me to download a 64 bit version of Media Player Classic
    > HomeCinema. I was shocked to find that my DVD's played correctly (with
    > sound) using that player. I then checked once again on Windows Media Player
    > and Windows Media Center and the DVD did not produce sound on either of
    > those. As you said in your last post, I now know that this is a Media Center
    > settings issue so I will pursue that further. Maybe the link that Dominic
    > Payer provided in his message will help me out. At least now I have a way to
    > play DVD's even though I really want to get Windows Media Center working as
    > it should. Thanks for all your help.
    >
    > -Ken
    >
    >
    > "Carlos" <> wrote in message
    > news:...
    > > Ken,
    > > If you try Media Player Classic x64 and you have sound, then you will be
    > > sure it is a Media Center settings issue.
    > > If you don't have sound, then you will have to look elsewhere.
    > > Carlos
    > >
    > > "Ken Triebold" wrote:
    > >
    > >> Thanks for the info. I downloaded and installed the x64 codec that you
    > >> mentioned but it didn't seem to make any difference. There are some guys
    > >> on
    > >> the Media Center forum that think my problem is more related to settings,
    > >> but I haven't made any real progress with that either. Thanks for the
    > >> help
    > >> though.
    > >>
    > >>
    > >> "Carlos" <> wrote in message
    > >> news:...
    > >> > Ken,
    > >> > Here you have a freeware multiformat x64 audio/video decoder.
    > >> > This is the direct download link:
    > >> > http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    > >> > This is the web page you can check for updates.
    > >> > http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    > >> > The decoder is labeled as "64-bit builds (experimental)" but I works
    > >> > flawlessly for me.
    > >> > The other decoders in that page are 32-bit.
    > >> > I also use them and they coexist pacefully in Vista x64.
    > >> >
    > >> > as a bonus, you might also want to try the lightweight x64 "Media
    > >> > Player
    > >> > Classic"
    > >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    > >> >
    > >> > Carlos
    > >> >
    > >> > "Ken Triebold" wrote:
    > >> >
    > >> >> I have just built a new computer, and it seems to be running pretty
    > >> >> well.
    > >> >> I
    > >> >> have Vista Home Premium 64 bit. One thing I noticed is that I have
    > >> >> picture
    > >> >> but no sound when playing a movie DVD. When I play a music CD sound
    > >> >> works
    > >> >> normally. Someone advised me that this is because I need a codec for
    > >> >> DVD
    > >> >> sound. I then downloaded and installed a couple of free codecs, but
    > >> >> that
    > >> >> did
    > >> >> not improve the situation. I read on Windows Help that my operating
    > >> >> system
    > >> >> requires a codec that is written in 64 bit, so that could be the
    > >> >> problem
    > >> >> since the codecs that I downloaded were probably 32 bit. I imagine
    > >> >> finding a
    > >> >> 64 bit codec will be pretty hard to find. Am I on the right track in
    > >> >> solving
    > >> >> this problem? Does anyone know if a 64 bit codec will be included with
    > >> >> SP1?
    > >> >>
    > >> >>
    > >>
    > >>

    >
    >
     
    Carlos, Feb 1, 2008
    #7
  8. Ken Triebold

    Ken Triebold Guest

    OK Carlos, I looked at ffdshow x64 and here is what I found:
    1. The AC3 Decoder was set to liba52 so I left it alone.
    2. The output speaker configuration shown in Mixer was set to 3/0/2 - 5
    channels so I left that alone too but I am not entirely sure this is
    correct. My speaker system is 5.1 surround sound with two front speakers,
    one center speaker, one woofer, and two rear speakers.

    -Ken


    "Carlos" <> wrote in message
    news:...
    > Ken,
    > That is good news.
    > You have a working x64 Player now because it has its own AC3/DTS audio
    > decoder (the 5.1 sound of DVD's) and your audio setup is fine.
    > Always check here:
    > http://sourceforge.net/project/showfiles.php?group_id=170561
    > for updates, it is the MPC Home Cinema project page.
    >
    > Now, getting back to your issue with Media Center...
    > I assume you have already installed ffdshow x64.
    > Let's see its Audio Configuration.
    > Start, Programs, ffdshow, Audio Decoder Configuration.
    > Click on "Codecs" o the left pane.
    > Choose AC3 on the "Format" column, right pane.
    > What do you have in the AC3 row, Decoder column?
    > Make sure it is not "Disabled" or "S/PDIF".
    > Disabled is... well... disabled, and you surely don't want that.
    > S/PDIF means that your sound goes to the optical connection and from there
    > to an external decoder.
    > Choose the "other" option (I am not at my Vista x64 PC now but it shoudl
    > be
    > something like "liba52")
    > Maybe you can find something there.
    >
    > Also click on Mixer (left pane) and take look at the Output speakers
    > configuration.
    > Does it match your system?
    >
    > Carlos
    >
    > "Ken Triebold" wrote:
    >
    >> Carlos, I searched on "Media Player Classic x64" and found this link:
    >> http://www.start64.com/index.php?option=com_content&task=view&id=1376&Itemid=72
    >>
    >> That link allowed me to download a 64 bit version of Media Player Classic
    >> HomeCinema. I was shocked to find that my DVD's played correctly (with
    >> sound) using that player. I then checked once again on Windows Media
    >> Player
    >> and Windows Media Center and the DVD did not produce sound on either of
    >> those. As you said in your last post, I now know that this is a Media
    >> Center
    >> settings issue so I will pursue that further. Maybe the link that Dominic
    >> Payer provided in his message will help me out. At least now I have a way
    >> to
    >> play DVD's even though I really want to get Windows Media Center working
    >> as
    >> it should. Thanks for all your help.
    >>
    >> -Ken
    >>
    >>
    >> "Carlos" <> wrote in message
    >> news:...
    >> > Ken,
    >> > If you try Media Player Classic x64 and you have sound, then you will
    >> > be
    >> > sure it is a Media Center settings issue.
    >> > If you don't have sound, then you will have to look elsewhere.
    >> > Carlos
    >> >
    >> > "Ken Triebold" wrote:
    >> >
    >> >> Thanks for the info. I downloaded and installed the x64 codec that you
    >> >> mentioned but it didn't seem to make any difference. There are some
    >> >> guys
    >> >> on
    >> >> the Media Center forum that think my problem is more related to
    >> >> settings,
    >> >> but I haven't made any real progress with that either. Thanks for the
    >> >> help
    >> >> though.
    >> >>
    >> >>
    >> >> "Carlos" <> wrote in message
    >> >> news:...
    >> >> > Ken,
    >> >> > Here you have a freeware multiformat x64 audio/video decoder.
    >> >> > This is the direct download link:
    >> >> > http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    >> >> > This is the web page you can check for updates.
    >> >> > http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    >> >> > The decoder is labeled as "64-bit builds (experimental)" but I works
    >> >> > flawlessly for me.
    >> >> > The other decoders in that page are 32-bit.
    >> >> > I also use them and they coexist pacefully in Vista x64.
    >> >> >
    >> >> > as a bonus, you might also want to try the lightweight x64 "Media
    >> >> > Player
    >> >> > Classic"
    >> >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    >> >> >
    >> >> > Carlos
    >> >> >
    >> >> > "Ken Triebold" wrote:
    >> >> >
    >> >> >> I have just built a new computer, and it seems to be running pretty
    >> >> >> well.
    >> >> >> I
    >> >> >> have Vista Home Premium 64 bit. One thing I noticed is that I have
    >> >> >> picture
    >> >> >> but no sound when playing a movie DVD. When I play a music CD sound
    >> >> >> works
    >> >> >> normally. Someone advised me that this is because I need a codec
    >> >> >> for
    >> >> >> DVD
    >> >> >> sound. I then downloaded and installed a couple of free codecs, but
    >> >> >> that
    >> >> >> did
    >> >> >> not improve the situation. I read on Windows Help that my operating
    >> >> >> system
    >> >> >> requires a codec that is written in 64 bit, so that could be the
    >> >> >> problem
    >> >> >> since the codecs that I downloaded were probably 32 bit. I imagine
    >> >> >> finding a
    >> >> >> 64 bit codec will be pretty hard to find. Am I on the right track
    >> >> >> in
    >> >> >> solving
    >> >> >> this problem? Does anyone know if a 64 bit codec will be included
    >> >> >> with
    >> >> >> SP1?
    >> >> >>
    >> >> >>
    >> >>
    >> >>

    >>
    >>
     
    Ken Triebold, Feb 1, 2008
    #8
  9. Ken Triebold

    Carlos Guest

    It should be 3/2/1 - 6 channels, but I don't think it will make any
    difference because you have no sound at all.
    There is something else you might try.
    Open Media Player Home Cinema x64, and click on View, Options.
    On the left pane click on "Output" in the Playback section.
    Take note of the device in "DirectShow Audio" on the right pane.
    It is a dropdown list with options like System Default, DirectSound, etc.
    Just take note of what it is there right now that ensures that the 5.1
    audio, when directed to that device, gives you speaker sound.
    Now go again to the Audio Decoder Configuration in ffdshow x64 and click on
    Output in the Mixer Section (left pane).
    Check the selection (right pane) of "Connect to:" and make it equal to the
    one in Media Player Home Cinema (same output device).
    Click Ok and try again with Media Center.

    You could also try playing your DVD with Windows Media Player 11 x64.
    Its executable is in the C:\Program Files\Windows Media Player folder.
    Note that the default WMP11 in Vista x64 is the 32-bit one and we want to
    run the 64-bit version in order to test x64 audio decoding.
    So try using WMP11 x64 and check if you have audio.
    If you have audio then the problem is Media Center specific and we will have
    narrowed it there.
    If you don't have audio then we are not decoding properly it, 64-bit wise.

    Last but not least, what audio are you choosing: AC3 (a.k.a. "Dolby 5.1) or
    DTS?
    If it is DTS we have not done any check so far.
    DTS is the following format (next row) after AC3 in ffdshow x64.

    Carlos

    "Ken Triebold" wrote:

    > OK Carlos, I looked at ffdshow x64 and here is what I found:
    > 1. The AC3 Decoder was set to liba52 so I left it alone.
    > 2. The output speaker configuration shown in Mixer was set to 3/0/2 - 5
    > channels so I left that alone too but I am not entirely sure this is
    > correct. My speaker system is 5.1 surround sound with two front speakers,
    > one center speaker, one woofer, and two rear speakers.
    >
    > -Ken
    >
    >
    > "Carlos" <> wrote in message
    > news:...
    > > Ken,
    > > That is good news.
    > > You have a working x64 Player now because it has its own AC3/DTS audio
    > > decoder (the 5.1 sound of DVD's) and your audio setup is fine.
    > > Always check here:
    > > http://sourceforge.net/project/showfiles.php?group_id=170561
    > > for updates, it is the MPC Home Cinema project page.
    > >
    > > Now, getting back to your issue with Media Center...
    > > I assume you have already installed ffdshow x64.
    > > Let's see its Audio Configuration.
    > > Start, Programs, ffdshow, Audio Decoder Configuration.
    > > Click on "Codecs" o the left pane.
    > > Choose AC3 on the "Format" column, right pane.
    > > What do you have in the AC3 row, Decoder column?
    > > Make sure it is not "Disabled" or "S/PDIF".
    > > Disabled is... well... disabled, and you surely don't want that.
    > > S/PDIF means that your sound goes to the optical connection and from there
    > > to an external decoder.
    > > Choose the "other" option (I am not at my Vista x64 PC now but it shoudl
    > > be
    > > something like "liba52")
    > > Maybe you can find something there.
    > >
    > > Also click on Mixer (left pane) and take look at the Output speakers
    > > configuration.
    > > Does it match your system?
    > >
    > > Carlos
    > >
    > > "Ken Triebold" wrote:
    > >
    > >> Carlos, I searched on "Media Player Classic x64" and found this link:
    > >> http://www.start64.com/index.php?option=com_content&task=view&id=1376&Itemid=72
    > >>
    > >> That link allowed me to download a 64 bit version of Media Player Classic
    > >> HomeCinema. I was shocked to find that my DVD's played correctly (with
    > >> sound) using that player. I then checked once again on Windows Media
    > >> Player
    > >> and Windows Media Center and the DVD did not produce sound on either of
    > >> those. As you said in your last post, I now know that this is a Media
    > >> Center
    > >> settings issue so I will pursue that further. Maybe the link that Dominic
    > >> Payer provided in his message will help me out. At least now I have a way
    > >> to
    > >> play DVD's even though I really want to get Windows Media Center working
    > >> as
    > >> it should. Thanks for all your help.
    > >>
    > >> -Ken
    > >>
    > >>
    > >> "Carlos" <> wrote in message
    > >> news:...
    > >> > Ken,
    > >> > If you try Media Player Classic x64 and you have sound, then you will
    > >> > be
    > >> > sure it is a Media Center settings issue.
    > >> > If you don't have sound, then you will have to look elsewhere.
    > >> > Carlos
    > >> >
    > >> > "Ken Triebold" wrote:
    > >> >
    > >> >> Thanks for the info. I downloaded and installed the x64 codec that you
    > >> >> mentioned but it didn't seem to make any difference. There are some
    > >> >> guys
    > >> >> on
    > >> >> the Media Center forum that think my problem is more related to
    > >> >> settings,
    > >> >> but I haven't made any real progress with that either. Thanks for the
    > >> >> help
    > >> >> though.
    > >> >>
    > >> >>
    > >> >> "Carlos" <> wrote in message
    > >> >> news:...
    > >> >> > Ken,
    > >> >> > Here you have a freeware multiformat x64 audio/video decoder.
    > >> >> > This is the direct download link:
    > >> >> > http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    > >> >> > This is the web page you can check for updates.
    > >> >> > http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    > >> >> > The decoder is labeled as "64-bit builds (experimental)" but I works
    > >> >> > flawlessly for me.
    > >> >> > The other decoders in that page are 32-bit.
    > >> >> > I also use them and they coexist pacefully in Vista x64.
    > >> >> >
    > >> >> > as a bonus, you might also want to try the lightweight x64 "Media
    > >> >> > Player
    > >> >> > Classic"
    > >> >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    > >> >> >
    > >> >> > Carlos
    > >> >> >
    > >> >> > "Ken Triebold" wrote:
    > >> >> >
    > >> >> >> I have just built a new computer, and it seems to be running pretty
    > >> >> >> well.
    > >> >> >> I
    > >> >> >> have Vista Home Premium 64 bit. One thing I noticed is that I have
    > >> >> >> picture
    > >> >> >> but no sound when playing a movie DVD. When I play a music CD sound
    > >> >> >> works
    > >> >> >> normally. Someone advised me that this is because I need a codec
    > >> >> >> for
    > >> >> >> DVD
    > >> >> >> sound. I then downloaded and installed a couple of free codecs, but
    > >> >> >> that
    > >> >> >> did
    > >> >> >> not improve the situation. I read on Windows Help that my operating
    > >> >> >> system
    > >> >> >> requires a codec that is written in 64 bit, so that could be the
    > >> >> >> problem
    > >> >> >> since the codecs that I downloaded were probably 32 bit. I imagine
    > >> >> >> finding a
    > >> >> >> 64 bit codec will be pretty hard to find. Am I on the right track
    > >> >> >> in
    > >> >> >> solving
    > >> >> >> this problem? Does anyone know if a 64 bit codec will be included
    > >> >> >> with
    > >> >> >> SP1?
    > >> >> >>
    > >> >> >>
    > >> >>
    > >> >>
    > >>
    > >>

    >
    >
     
    Carlos, Feb 1, 2008
    #9
  10. Ken Triebold

    Ken Triebold Guest

    Carlos, here is what I found:
    1. In Media Player Home Cinema, View, Options, Output, the device in
    DirectShow Audio is "System Default". In ffdshow x64, Audio Decoder
    Configuration, Mixer, Output, Connect to is shown as "Any Filter". There
    were two other options: "DirectSound" and "WaveOut". I left it at "Any
    Filter" since none of the three options matched "System Default".

    2. I tried Windows Media Player 11 x64 and it worked fine (got sound). The
    filename is wmplayer.exe but I am sure it is the 64 bit version because it
    was located under Program Files (not Program Files x86). Then I tried Media
    Center and the default Media Player (32 bit) and they both still did not
    have sound. So Media Player x64 gives sound but Media Center and Media
    Player 32 do not give sound.

    3. Sorry, but I don't know which audio I am choosing nor do I know how to
    determine that. Maybe it is not relevant now based on what I found out in
    item 2 above.

    -Ken



    "Carlos" <> wrote in message
    news:...
    > It should be 3/2/1 - 6 channels, but I don't think it will make any
    > difference because you have no sound at all.
    > There is something else you might try.
    > Open Media Player Home Cinema x64, and click on View, Options.
    > On the left pane click on "Output" in the Playback section.
    > Take note of the device in "DirectShow Audio" on the right pane.
    > It is a dropdown list with options like System Default, DirectSound, etc.
    > Just take note of what it is there right now that ensures that the 5.1
    > audio, when directed to that device, gives you speaker sound.
    > Now go again to the Audio Decoder Configuration in ffdshow x64 and click
    > on
    > Output in the Mixer Section (left pane).
    > Check the selection (right pane) of "Connect to:" and make it equal to the
    > one in Media Player Home Cinema (same output device).
    > Click Ok and try again with Media Center.
    >
    > You could also try playing your DVD with Windows Media Player 11 x64.
    > Its executable is in the C:\Program Files\Windows Media Player folder.
    > Note that the default WMP11 in Vista x64 is the 32-bit one and we want to
    > run the 64-bit version in order to test x64 audio decoding.
    > So try using WMP11 x64 and check if you have audio.
    > If you have audio then the problem is Media Center specific and we will
    > have
    > narrowed it there.
    > If you don't have audio then we are not decoding properly it, 64-bit wise.
    >
    > Last but not least, what audio are you choosing: AC3 (a.k.a. "Dolby 5.1)
    > or
    > DTS?
    > If it is DTS we have not done any check so far.
    > DTS is the following format (next row) after AC3 in ffdshow x64.
    >
    > Carlos
    >
    > "Ken Triebold" wrote:
    >
    >> OK Carlos, I looked at ffdshow x64 and here is what I found:
    >> 1. The AC3 Decoder was set to liba52 so I left it alone.
    >> 2. The output speaker configuration shown in Mixer was set to 3/0/2 - 5
    >> channels so I left that alone too but I am not entirely sure this is
    >> correct. My speaker system is 5.1 surround sound with two front speakers,
    >> one center speaker, one woofer, and two rear speakers.
    >>
    >> -Ken
    >>
    >>
    >> "Carlos" <> wrote in message
    >> news:...
    >> > Ken,
    >> > That is good news.
    >> > You have a working x64 Player now because it has its own AC3/DTS audio
    >> > decoder (the 5.1 sound of DVD's) and your audio setup is fine.
    >> > Always check here:
    >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    >> > for updates, it is the MPC Home Cinema project page.
    >> >
    >> > Now, getting back to your issue with Media Center...
    >> > I assume you have already installed ffdshow x64.
    >> > Let's see its Audio Configuration.
    >> > Start, Programs, ffdshow, Audio Decoder Configuration.
    >> > Click on "Codecs" o the left pane.
    >> > Choose AC3 on the "Format" column, right pane.
    >> > What do you have in the AC3 row, Decoder column?
    >> > Make sure it is not "Disabled" or "S/PDIF".
    >> > Disabled is... well... disabled, and you surely don't want that.
    >> > S/PDIF means that your sound goes to the optical connection and from
    >> > there
    >> > to an external decoder.
    >> > Choose the "other" option (I am not at my Vista x64 PC now but it
    >> > shoudl
    >> > be
    >> > something like "liba52")
    >> > Maybe you can find something there.
    >> >
    >> > Also click on Mixer (left pane) and take look at the Output speakers
    >> > configuration.
    >> > Does it match your system?
    >> >
    >> > Carlos
    >> >
    >> > "Ken Triebold" wrote:
    >> >
    >> >> Carlos, I searched on "Media Player Classic x64" and found this link:
    >> >> http://www.start64.com/index.php?option=com_content&task=view&id=1376&Itemid=72
    >> >>
    >> >> That link allowed me to download a 64 bit version of Media Player
    >> >> Classic
    >> >> HomeCinema. I was shocked to find that my DVD's played correctly (with
    >> >> sound) using that player. I then checked once again on Windows Media
    >> >> Player
    >> >> and Windows Media Center and the DVD did not produce sound on either
    >> >> of
    >> >> those. As you said in your last post, I now know that this is a Media
    >> >> Center
    >> >> settings issue so I will pursue that further. Maybe the link that
    >> >> Dominic
    >> >> Payer provided in his message will help me out. At least now I have a
    >> >> way
    >> >> to
    >> >> play DVD's even though I really want to get Windows Media Center
    >> >> working
    >> >> as
    >> >> it should. Thanks for all your help.
    >> >>
    >> >> -Ken
    >> >>
    >> >>
    >> >> "Carlos" <> wrote in message
    >> >> news:...
    >> >> > Ken,
    >> >> > If you try Media Player Classic x64 and you have sound, then you
    >> >> > will
    >> >> > be
    >> >> > sure it is a Media Center settings issue.
    >> >> > If you don't have sound, then you will have to look elsewhere.
    >> >> > Carlos
    >> >> >
    >> >> > "Ken Triebold" wrote:
    >> >> >
    >> >> >> Thanks for the info. I downloaded and installed the x64 codec that
    >> >> >> you
    >> >> >> mentioned but it didn't seem to make any difference. There are some
    >> >> >> guys
    >> >> >> on
    >> >> >> the Media Center forum that think my problem is more related to
    >> >> >> settings,
    >> >> >> but I haven't made any real progress with that either. Thanks for
    >> >> >> the
    >> >> >> help
    >> >> >> though.
    >> >> >>
    >> >> >>
    >> >> >> "Carlos" <> wrote in message
    >> >> >> news:...
    >> >> >> > Ken,
    >> >> >> > Here you have a freeware multiformat x64 audio/video decoder.
    >> >> >> > This is the direct download link:
    >> >> >> > http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    >> >> >> > This is the web page you can check for updates.
    >> >> >> > http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    >> >> >> > The decoder is labeled as "64-bit builds (experimental)" but I
    >> >> >> > works
    >> >> >> > flawlessly for me.
    >> >> >> > The other decoders in that page are 32-bit.
    >> >> >> > I also use them and they coexist pacefully in Vista x64.
    >> >> >> >
    >> >> >> > as a bonus, you might also want to try the lightweight x64 "Media
    >> >> >> > Player
    >> >> >> > Classic"
    >> >> >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    >> >> >> >
    >> >> >> > Carlos
    >> >> >> >
    >> >> >> > "Ken Triebold" wrote:
    >> >> >> >
    >> >> >> >> I have just built a new computer, and it seems to be running
    >> >> >> >> pretty
    >> >> >> >> well.
    >> >> >> >> I
    >> >> >> >> have Vista Home Premium 64 bit. One thing I noticed is that I
    >> >> >> >> have
    >> >> >> >> picture
    >> >> >> >> but no sound when playing a movie DVD. When I play a music CD
    >> >> >> >> sound
    >> >> >> >> works
    >> >> >> >> normally. Someone advised me that this is because I need a codec
    >> >> >> >> for
    >> >> >> >> DVD
    >> >> >> >> sound. I then downloaded and installed a couple of free codecs,
    >> >> >> >> but
    >> >> >> >> that
    >> >> >> >> did
    >> >> >> >> not improve the situation. I read on Windows Help that my
    >> >> >> >> operating
    >> >> >> >> system
    >> >> >> >> requires a codec that is written in 64 bit, so that could be the
    >> >> >> >> problem
    >> >> >> >> since the codecs that I downloaded were probably 32 bit. I
    >> >> >> >> imagine
    >> >> >> >> finding a
    >> >> >> >> 64 bit codec will be pretty hard to find. Am I on the right
    >> >> >> >> track
    >> >> >> >> in
    >> >> >> >> solving
    >> >> >> >> this problem? Does anyone know if a 64 bit codec will be
    >> >> >> >> included
    >> >> >> >> with
    >> >> >> >> SP1?
    >> >> >> >>
    >> >> >> >>
    >> >> >>
    >> >> >>
    >> >>
    >> >>

    >>
    >>
     
    Ken Triebold, Feb 1, 2008
    #10
  11. Ken Triebold

    Carlos Guest

    Ken,
    In order to give sound to the default Windows Media Player 11, which is
    32-bit, you need the 32-bit version of ffdshow.
    http://www.free-codecs.com/download/FFDShow.htm
    Download it and install it.
    Please note that during the install you will have to choose a different
    Program group (the one that shows in the Start, Programs, menu) in order not
    to overwrite the one created by ffdshow x64.
    Both tend to create a Program group named "ffdshow".
    There is no conflict with their installations in the Program Files section.
    ffdshow x86 goes to C:\Program Files (x86)
    and coexists peacefully with its x64 partner.
    Check now if WMP11 32-bit has sound.
    I believe that Media Center is 64-bit, but it doesn't hurt to try again
    after installing ffdshow x86.
    Best of luck!
    Carlos

    "Ken Triebold" wrote:

    > Carlos, here is what I found:
    > 1. In Media Player Home Cinema, View, Options, Output, the device in
    > DirectShow Audio is "System Default". In ffdshow x64, Audio Decoder
    > Configuration, Mixer, Output, Connect to is shown as "Any Filter". There
    > were two other options: "DirectSound" and "WaveOut". I left it at "Any
    > Filter" since none of the three options matched "System Default".
    >
    > 2. I tried Windows Media Player 11 x64 and it worked fine (got sound). The
    > filename is wmplayer.exe but I am sure it is the 64 bit version because it
    > was located under Program Files (not Program Files x86). Then I tried Media
    > Center and the default Media Player (32 bit) and they both still did not
    > have sound. So Media Player x64 gives sound but Media Center and Media
    > Player 32 do not give sound.
    >
    > 3. Sorry, but I don't know which audio I am choosing nor do I know how to
    > determine that. Maybe it is not relevant now based on what I found out in
    > item 2 above.
    >
    > -Ken
    >
    >
    >
    > "Carlos" <> wrote in message
    > news:...
    > > It should be 3/2/1 - 6 channels, but I don't think it will make any
    > > difference because you have no sound at all.
    > > There is something else you might try.
    > > Open Media Player Home Cinema x64, and click on View, Options.
    > > On the left pane click on "Output" in the Playback section.
    > > Take note of the device in "DirectShow Audio" on the right pane.
    > > It is a dropdown list with options like System Default, DirectSound, etc.
    > > Just take note of what it is there right now that ensures that the 5.1
    > > audio, when directed to that device, gives you speaker sound.
    > > Now go again to the Audio Decoder Configuration in ffdshow x64 and click
    > > on
    > > Output in the Mixer Section (left pane).
    > > Check the selection (right pane) of "Connect to:" and make it equal to the
    > > one in Media Player Home Cinema (same output device).
    > > Click Ok and try again with Media Center.
    > >
    > > You could also try playing your DVD with Windows Media Player 11 x64.
    > > Its executable is in the C:\Program Files\Windows Media Player folder.
    > > Note that the default WMP11 in Vista x64 is the 32-bit one and we want to
    > > run the 64-bit version in order to test x64 audio decoding.
    > > So try using WMP11 x64 and check if you have audio.
    > > If you have audio then the problem is Media Center specific and we will
    > > have
    > > narrowed it there.
    > > If you don't have audio then we are not decoding properly it, 64-bit wise.
    > >
    > > Last but not least, what audio are you choosing: AC3 (a.k.a. "Dolby 5.1)
    > > or
    > > DTS?
    > > If it is DTS we have not done any check so far.
    > > DTS is the following format (next row) after AC3 in ffdshow x64.
    > >
    > > Carlos
    > >
    > > "Ken Triebold" wrote:
    > >
    > >> OK Carlos, I looked at ffdshow x64 and here is what I found:
    > >> 1. The AC3 Decoder was set to liba52 so I left it alone.
    > >> 2. The output speaker configuration shown in Mixer was set to 3/0/2 - 5
    > >> channels so I left that alone too but I am not entirely sure this is
    > >> correct. My speaker system is 5.1 surround sound with two front speakers,
    > >> one center speaker, one woofer, and two rear speakers.
    > >>
    > >> -Ken
    > >>
    > >>
    > >> "Carlos" <> wrote in message
    > >> news:...
    > >> > Ken,
    > >> > That is good news.
    > >> > You have a working x64 Player now because it has its own AC3/DTS audio
    > >> > decoder (the 5.1 sound of DVD's) and your audio setup is fine.
    > >> > Always check here:
    > >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    > >> > for updates, it is the MPC Home Cinema project page.
    > >> >
    > >> > Now, getting back to your issue with Media Center...
    > >> > I assume you have already installed ffdshow x64.
    > >> > Let's see its Audio Configuration.
    > >> > Start, Programs, ffdshow, Audio Decoder Configuration.
    > >> > Click on "Codecs" o the left pane.
    > >> > Choose AC3 on the "Format" column, right pane.
    > >> > What do you have in the AC3 row, Decoder column?
    > >> > Make sure it is not "Disabled" or "S/PDIF".
    > >> > Disabled is... well... disabled, and you surely don't want that.
    > >> > S/PDIF means that your sound goes to the optical connection and from
    > >> > there
    > >> > to an external decoder.
    > >> > Choose the "other" option (I am not at my Vista x64 PC now but it
    > >> > shoudl
    > >> > be
    > >> > something like "liba52")
    > >> > Maybe you can find something there.
    > >> >
    > >> > Also click on Mixer (left pane) and take look at the Output speakers
    > >> > configuration.
    > >> > Does it match your system?
    > >> >
    > >> > Carlos
    > >> >
    > >> > "Ken Triebold" wrote:
    > >> >
    > >> >> Carlos, I searched on "Media Player Classic x64" and found this link:
    > >> >> http://www.start64.com/index.php?option=com_content&task=view&id=1376&Itemid=72
    > >> >>
    > >> >> That link allowed me to download a 64 bit version of Media Player
    > >> >> Classic
    > >> >> HomeCinema. I was shocked to find that my DVD's played correctly (with
    > >> >> sound) using that player. I then checked once again on Windows Media
    > >> >> Player
    > >> >> and Windows Media Center and the DVD did not produce sound on either
    > >> >> of
    > >> >> those. As you said in your last post, I now know that this is a Media
    > >> >> Center
    > >> >> settings issue so I will pursue that further. Maybe the link that
    > >> >> Dominic
    > >> >> Payer provided in his message will help me out. At least now I have a
    > >> >> way
    > >> >> to
    > >> >> play DVD's even though I really want to get Windows Media Center
    > >> >> working
    > >> >> as
    > >> >> it should. Thanks for all your help.
    > >> >>
    > >> >> -Ken
    > >> >>
    > >> >>
    > >> >> "Carlos" <> wrote in message
    > >> >> news:...
    > >> >> > Ken,
    > >> >> > If you try Media Player Classic x64 and you have sound, then you
    > >> >> > will
    > >> >> > be
    > >> >> > sure it is a Media Center settings issue.
    > >> >> > If you don't have sound, then you will have to look elsewhere.
    > >> >> > Carlos
    > >> >> >
    > >> >> > "Ken Triebold" wrote:
    > >> >> >
    > >> >> >> Thanks for the info. I downloaded and installed the x64 codec that
    > >> >> >> you
    > >> >> >> mentioned but it didn't seem to make any difference. There are some
    > >> >> >> guys
    > >> >> >> on
    > >> >> >> the Media Center forum that think my problem is more related to
    > >> >> >> settings,
    > >> >> >> but I haven't made any real progress with that either. Thanks for
    > >> >> >> the
    > >> >> >> help
    > >> >> >> though.
    > >> >> >>
    > >> >> >>
    > >> >> >> "Carlos" <> wrote in message
    > >> >> >> news:...
    > >> >> >> > Ken,
    > >> >> >> > Here you have a freeware multiformat x64 audio/video decoder.
    > >> >> >> > This is the direct download link:
    > >> >> >> > http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    > >> >> >> > This is the web page you can check for updates.
    > >> >> >> > http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    > >> >> >> > The decoder is labeled as "64-bit builds (experimental)" but I
    > >> >> >> > works
    > >> >> >> > flawlessly for me.
    > >> >> >> > The other decoders in that page are 32-bit.
    > >> >> >> > I also use them and they coexist pacefully in Vista x64.
    > >> >> >> >
    > >> >> >> > as a bonus, you might also want to try the lightweight x64 "Media
    > >> >> >> > Player
    > >> >> >> > Classic"
    > >> >> >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    > >> >> >> >
    > >> >> >> > Carlos
    > >> >> >> >
    > >> >> >> > "Ken Triebold" wrote:
    > >> >> >> >
    > >> >> >> >> I have just built a new computer, and it seems to be running
    > >> >> >> >> pretty
    > >> >> >> >> well.
    > >> >> >> >> I
    > >> >> >> >> have Vista Home Premium 64 bit. One thing I noticed is that I
    > >> >> >> >> have
    > >> >> >> >> picture
    > >> >> >> >> but no sound when playing a movie DVD. When I play a music CD
    > >> >> >> >> sound
    > >> >> >> >> works
    > >> >> >> >> normally. Someone advised me that this is because I need a codec
    > >> >> >> >> for
    > >> >> >> >> DVD
    > >> >> >> >> sound. I then downloaded and installed a couple of free codecs,
    > >> >> >> >> but
    > >> >> >> >> that
    > >> >> >> >> did
    > >> >> >> >> not improve the situation. I read on Windows Help that my
    > >> >> >> >> operating
    > >> >> >> >> system
    > >> >> >> >> requires a codec that is written in 64 bit, so that could be the
    > >> >> >> >> problem
    > >> >> >> >> since the codecs that I downloaded were probably 32 bit. I
    > >> >> >> >> imagine
    > >> >> >> >> finding a
    > >> >> >> >> 64 bit codec will be pretty hard to find. Am I on the right
    > >> >> >> >> track
    > >> >> >> >> in
    > >> >> >> >> solving
    > >> >> >> >> this problem? Does anyone know if a 64 bit codec will be
    > >> >> >> >> included
    > >> >> >> >> with
    > >> >> >> >> SP1?
    > >> >> >> >>
    > >> >> >> >>
    > >> >> >>
    > >> >> >>
    > >> >>
    > >> >>
    > >>
    > >>

    >
    >
     
    Carlos, Feb 1, 2008
    #11
  12. Ken Triebold

    Ken Triebold Guest

    Carlos, I downloaded and installed the 32 bit version of ffdshow. I then
    tried Windows Media Player 32 bit and Windows Media Center and they both did
    not have sound. I tried Windows Media Player 64 bit again and it still does
    have sound.

    -Ken


    "Carlos" <> wrote in message
    news:...
    > Ken,
    > In order to give sound to the default Windows Media Player 11, which is
    > 32-bit, you need the 32-bit version of ffdshow.
    > http://www.free-codecs.com/download/FFDShow.htm
    > Download it and install it.
    > Please note that during the install you will have to choose a different
    > Program group (the one that shows in the Start, Programs, menu) in order
    > not
    > to overwrite the one created by ffdshow x64.
    > Both tend to create a Program group named "ffdshow".
    > There is no conflict with their installations in the Program Files
    > section.
    > ffdshow x86 goes to C:\Program Files (x86)
    > and coexists peacefully with its x64 partner.
    > Check now if WMP11 32-bit has sound.
    > I believe that Media Center is 64-bit, but it doesn't hurt to try again
    > after installing ffdshow x86.
    > Best of luck!
    > Carlos
    >
    > "Ken Triebold" wrote:
    >
    >> Carlos, here is what I found:
    >> 1. In Media Player Home Cinema, View, Options, Output, the device in
    >> DirectShow Audio is "System Default". In ffdshow x64, Audio Decoder
    >> Configuration, Mixer, Output, Connect to is shown as "Any Filter". There
    >> were two other options: "DirectSound" and "WaveOut". I left it at "Any
    >> Filter" since none of the three options matched "System Default".
    >>
    >> 2. I tried Windows Media Player 11 x64 and it worked fine (got sound).
    >> The
    >> filename is wmplayer.exe but I am sure it is the 64 bit version because
    >> it
    >> was located under Program Files (not Program Files x86). Then I tried
    >> Media
    >> Center and the default Media Player (32 bit) and they both still did not
    >> have sound. So Media Player x64 gives sound but Media Center and Media
    >> Player 32 do not give sound.
    >>
    >> 3. Sorry, but I don't know which audio I am choosing nor do I know how to
    >> determine that. Maybe it is not relevant now based on what I found out in
    >> item 2 above.
    >>
    >> -Ken
    >>
    >>
    >>
    >> "Carlos" <> wrote in message
    >> news:...
    >> > It should be 3/2/1 - 6 channels, but I don't think it will make any
    >> > difference because you have no sound at all.
    >> > There is something else you might try.
    >> > Open Media Player Home Cinema x64, and click on View, Options.
    >> > On the left pane click on "Output" in the Playback section.
    >> > Take note of the device in "DirectShow Audio" on the right pane.
    >> > It is a dropdown list with options like System Default, DirectSound,
    >> > etc.
    >> > Just take note of what it is there right now that ensures that the 5.1
    >> > audio, when directed to that device, gives you speaker sound.
    >> > Now go again to the Audio Decoder Configuration in ffdshow x64 and
    >> > click
    >> > on
    >> > Output in the Mixer Section (left pane).
    >> > Check the selection (right pane) of "Connect to:" and make it equal to
    >> > the
    >> > one in Media Player Home Cinema (same output device).
    >> > Click Ok and try again with Media Center.
    >> >
    >> > You could also try playing your DVD with Windows Media Player 11 x64.
    >> > Its executable is in the C:\Program Files\Windows Media Player folder.
    >> > Note that the default WMP11 in Vista x64 is the 32-bit one and we want
    >> > to
    >> > run the 64-bit version in order to test x64 audio decoding.
    >> > So try using WMP11 x64 and check if you have audio.
    >> > If you have audio then the problem is Media Center specific and we will
    >> > have
    >> > narrowed it there.
    >> > If you don't have audio then we are not decoding properly it, 64-bit
    >> > wise.
    >> >
    >> > Last but not least, what audio are you choosing: AC3 (a.k.a. "Dolby
    >> > 5.1)
    >> > or
    >> > DTS?
    >> > If it is DTS we have not done any check so far.
    >> > DTS is the following format (next row) after AC3 in ffdshow x64.
    >> >
    >> > Carlos
    >> >
    >> > "Ken Triebold" wrote:
    >> >
    >> >> OK Carlos, I looked at ffdshow x64 and here is what I found:
    >> >> 1. The AC3 Decoder was set to liba52 so I left it alone.
    >> >> 2. The output speaker configuration shown in Mixer was set to 3/0/2 -
    >> >> 5
    >> >> channels so I left that alone too but I am not entirely sure this is
    >> >> correct. My speaker system is 5.1 surround sound with two front
    >> >> speakers,
    >> >> one center speaker, one woofer, and two rear speakers.
    >> >>
    >> >> -Ken
    >> >>
    >> >>
    >> >> "Carlos" <> wrote in message
    >> >> news:...
    >> >> > Ken,
    >> >> > That is good news.
    >> >> > You have a working x64 Player now because it has its own AC3/DTS
    >> >> > audio
    >> >> > decoder (the 5.1 sound of DVD's) and your audio setup is fine.
    >> >> > Always check here:
    >> >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    >> >> > for updates, it is the MPC Home Cinema project page.
    >> >> >
    >> >> > Now, getting back to your issue with Media Center...
    >> >> > I assume you have already installed ffdshow x64.
    >> >> > Let's see its Audio Configuration.
    >> >> > Start, Programs, ffdshow, Audio Decoder Configuration.
    >> >> > Click on "Codecs" o the left pane.
    >> >> > Choose AC3 on the "Format" column, right pane.
    >> >> > What do you have in the AC3 row, Decoder column?
    >> >> > Make sure it is not "Disabled" or "S/PDIF".
    >> >> > Disabled is... well... disabled, and you surely don't want that.
    >> >> > S/PDIF means that your sound goes to the optical connection and from
    >> >> > there
    >> >> > to an external decoder.
    >> >> > Choose the "other" option (I am not at my Vista x64 PC now but it
    >> >> > shoudl
    >> >> > be
    >> >> > something like "liba52")
    >> >> > Maybe you can find something there.
    >> >> >
    >> >> > Also click on Mixer (left pane) and take look at the Output speakers
    >> >> > configuration.
    >> >> > Does it match your system?
    >> >> >
    >> >> > Carlos
    >> >> >
    >> >> > "Ken Triebold" wrote:
    >> >> >
    >> >> >> Carlos, I searched on "Media Player Classic x64" and found this
    >> >> >> link:
    >> >> >> http://www.start64.com/index.php?option=com_content&task=view&id=1376&Itemid=72
    >> >> >>
    >> >> >> That link allowed me to download a 64 bit version of Media Player
    >> >> >> Classic
    >> >> >> HomeCinema. I was shocked to find that my DVD's played correctly
    >> >> >> (with
    >> >> >> sound) using that player. I then checked once again on Windows
    >> >> >> Media
    >> >> >> Player
    >> >> >> and Windows Media Center and the DVD did not produce sound on
    >> >> >> either
    >> >> >> of
    >> >> >> those. As you said in your last post, I now know that this is a
    >> >> >> Media
    >> >> >> Center
    >> >> >> settings issue so I will pursue that further. Maybe the link that
    >> >> >> Dominic
    >> >> >> Payer provided in his message will help me out. At least now I have
    >> >> >> a
    >> >> >> way
    >> >> >> to
    >> >> >> play DVD's even though I really want to get Windows Media Center
    >> >> >> working
    >> >> >> as
    >> >> >> it should. Thanks for all your help.
    >> >> >>
    >> >> >> -Ken
    >> >> >>
    >> >> >>
    >> >> >> "Carlos" <> wrote in message
    >> >> >> news:...
    >> >> >> > Ken,
    >> >> >> > If you try Media Player Classic x64 and you have sound, then you
    >> >> >> > will
    >> >> >> > be
    >> >> >> > sure it is a Media Center settings issue.
    >> >> >> > If you don't have sound, then you will have to look elsewhere.
    >> >> >> > Carlos
    >> >> >> >
    >> >> >> > "Ken Triebold" wrote:
    >> >> >> >
    >> >> >> >> Thanks for the info. I downloaded and installed the x64 codec
    >> >> >> >> that
    >> >> >> >> you
    >> >> >> >> mentioned but it didn't seem to make any difference. There are
    >> >> >> >> some
    >> >> >> >> guys
    >> >> >> >> on
    >> >> >> >> the Media Center forum that think my problem is more related to
    >> >> >> >> settings,
    >> >> >> >> but I haven't made any real progress with that either. Thanks
    >> >> >> >> for
    >> >> >> >> the
    >> >> >> >> help
    >> >> >> >> though.
    >> >> >> >>
    >> >> >> >>
    >> >> >> >> "Carlos" <> wrote in message
    >> >> >> >> news:...
    >> >> >> >> > Ken,
    >> >> >> >> > Here you have a freeware multiformat x64 audio/video decoder.
    >> >> >> >> > This is the direct download link:
    >> >> >> >> > http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    >> >> >> >> > This is the web page you can check for updates.
    >> >> >> >> > http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    >> >> >> >> > The decoder is labeled as "64-bit builds (experimental)" but I
    >> >> >> >> > works
    >> >> >> >> > flawlessly for me.
    >> >> >> >> > The other decoders in that page are 32-bit.
    >> >> >> >> > I also use them and they coexist pacefully in Vista x64.
    >> >> >> >> >
    >> >> >> >> > as a bonus, you might also want to try the lightweight x64
    >> >> >> >> > "Media
    >> >> >> >> > Player
    >> >> >> >> > Classic"
    >> >> >> >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    >> >> >> >> >
    >> >> >> >> > Carlos
    >> >> >> >> >
    >> >> >> >> > "Ken Triebold" wrote:
    >> >> >> >> >
    >> >> >> >> >> I have just built a new computer, and it seems to be running
    >> >> >> >> >> pretty
    >> >> >> >> >> well.
    >> >> >> >> >> I
    >> >> >> >> >> have Vista Home Premium 64 bit. One thing I noticed is that I
    >> >> >> >> >> have
    >> >> >> >> >> picture
    >> >> >> >> >> but no sound when playing a movie DVD. When I play a music CD
    >> >> >> >> >> sound
    >> >> >> >> >> works
    >> >> >> >> >> normally. Someone advised me that this is because I need a
    >> >> >> >> >> codec
    >> >> >> >> >> for
    >> >> >> >> >> DVD
    >> >> >> >> >> sound. I then downloaded and installed a couple of free
    >> >> >> >> >> codecs,
    >> >> >> >> >> but
    >> >> >> >> >> that
    >> >> >> >> >> did
    >> >> >> >> >> not improve the situation. I read on Windows Help that my
    >> >> >> >> >> operating
    >> >> >> >> >> system
    >> >> >> >> >> requires a codec that is written in 64 bit, so that could be
    >> >> >> >> >> the
    >> >> >> >> >> problem
    >> >> >> >> >> since the codecs that I downloaded were probably 32 bit. I
    >> >> >> >> >> imagine
    >> >> >> >> >> finding a
    >> >> >> >> >> 64 bit codec will be pretty hard to find. Am I on the right
    >> >> >> >> >> track
    >> >> >> >> >> in
    >> >> >> >> >> solving
    >> >> >> >> >> this problem? Does anyone know if a 64 bit codec will be
    >> >> >> >> >> included
    >> >> >> >> >> with
    >> >> >> >> >> SP1?
    >> >> >> >> >>
    >> >> >> >> >>
    >> >> >> >>
    >> >> >> >>
    >> >> >>
    >> >> >>
    >> >>
    >> >>

    >>
    >>
     
    Ken Triebold, Feb 1, 2008
    #12
  13. Ken Triebold

    Carlos Guest

    Ken,
    I am now at my Vista x64 machine.

    Output Speaker Configuration in Mixer menu is 3/0/2 - 5 channels and the
    "LFE" checkbox is checked.
    That is the working configuration for my 5.1 speaker system.
    Carlos

    "Ken Triebold" wrote:

    > OK Carlos, I looked at ffdshow x64 and here is what I found:
    > 1. The AC3 Decoder was set to liba52 so I left it alone.
    > 2. The output speaker configuration shown in Mixer was set to 3/0/2 - 5
    > channels so I left that alone too but I am not entirely sure this is
    > correct. My speaker system is 5.1 surround sound with two front speakers,
    > one center speaker, one woofer, and two rear speakers.
    >
    > -Ken
    >
    >
    > "Carlos" <> wrote in message
    > news:...
    > > Ken,
    > > That is good news.
    > > You have a working x64 Player now because it has its own AC3/DTS audio
    > > decoder (the 5.1 sound of DVD's) and your audio setup is fine.
    > > Always check here:
    > > http://sourceforge.net/project/showfiles.php?group_id=170561
    > > for updates, it is the MPC Home Cinema project page.
    > >
    > > Now, getting back to your issue with Media Center...
    > > I assume you have already installed ffdshow x64.
    > > Let's see its Audio Configuration.
    > > Start, Programs, ffdshow, Audio Decoder Configuration.
    > > Click on "Codecs" o the left pane.
    > > Choose AC3 on the "Format" column, right pane.
    > > What do you have in the AC3 row, Decoder column?
    > > Make sure it is not "Disabled" or "S/PDIF".
    > > Disabled is... well... disabled, and you surely don't want that.
    > > S/PDIF means that your sound goes to the optical connection and from there
    > > to an external decoder.
    > > Choose the "other" option (I am not at my Vista x64 PC now but it shoudl
    > > be
    > > something like "liba52")
    > > Maybe you can find something there.
    > >
    > > Also click on Mixer (left pane) and take look at the Output speakers
    > > configuration.
    > > Does it match your system?
    > >
    > > Carlos
    > >
    > > "Ken Triebold" wrote:
    > >
    > >> Carlos, I searched on "Media Player Classic x64" and found this link:
    > >> http://www.start64.com/index.php?option=com_content&task=view&id=1376&Itemid=72
    > >>
    > >> That link allowed me to download a 64 bit version of Media Player Classic
    > >> HomeCinema. I was shocked to find that my DVD's played correctly (with
    > >> sound) using that player. I then checked once again on Windows Media
    > >> Player
    > >> and Windows Media Center and the DVD did not produce sound on either of
    > >> those. As you said in your last post, I now know that this is a Media
    > >> Center
    > >> settings issue so I will pursue that further. Maybe the link that Dominic
    > >> Payer provided in his message will help me out. At least now I have a way
    > >> to
    > >> play DVD's even though I really want to get Windows Media Center working
    > >> as
    > >> it should. Thanks for all your help.
    > >>
    > >> -Ken
    > >>
    > >>
    > >> "Carlos" <> wrote in message
    > >> news:...
    > >> > Ken,
    > >> > If you try Media Player Classic x64 and you have sound, then you will
    > >> > be
    > >> > sure it is a Media Center settings issue.
    > >> > If you don't have sound, then you will have to look elsewhere.
    > >> > Carlos
    > >> >
    > >> > "Ken Triebold" wrote:
    > >> >
    > >> >> Thanks for the info. I downloaded and installed the x64 codec that you
    > >> >> mentioned but it didn't seem to make any difference. There are some
    > >> >> guys
    > >> >> on
    > >> >> the Media Center forum that think my problem is more related to
    > >> >> settings,
    > >> >> but I haven't made any real progress with that either. Thanks for the
    > >> >> help
    > >> >> though.
    > >> >>
    > >> >>
    > >> >> "Carlos" <> wrote in message
    > >> >> news:...
    > >> >> > Ken,
    > >> >> > Here you have a freeware multiformat x64 audio/video decoder.
    > >> >> > This is the direct download link:
    > >> >> > http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    > >> >> > This is the web page you can check for updates.
    > >> >> > http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    > >> >> > The decoder is labeled as "64-bit builds (experimental)" but I works
    > >> >> > flawlessly for me.
    > >> >> > The other decoders in that page are 32-bit.
    > >> >> > I also use them and they coexist pacefully in Vista x64.
    > >> >> >
    > >> >> > as a bonus, you might also want to try the lightweight x64 "Media
    > >> >> > Player
    > >> >> > Classic"
    > >> >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    > >> >> >
    > >> >> > Carlos
    > >> >> >
    > >> >> > "Ken Triebold" wrote:
    > >> >> >
    > >> >> >> I have just built a new computer, and it seems to be running pretty
    > >> >> >> well.
    > >> >> >> I
    > >> >> >> have Vista Home Premium 64 bit. One thing I noticed is that I have
    > >> >> >> picture
    > >> >> >> but no sound when playing a movie DVD. When I play a music CD sound
    > >> >> >> works
    > >> >> >> normally. Someone advised me that this is because I need a codec
    > >> >> >> for
    > >> >> >> DVD
    > >> >> >> sound. I then downloaded and installed a couple of free codecs, but
    > >> >> >> that
    > >> >> >> did
    > >> >> >> not improve the situation. I read on Windows Help that my operating
    > >> >> >> system
    > >> >> >> requires a codec that is written in 64 bit, so that could be the
    > >> >> >> problem
    > >> >> >> since the codecs that I downloaded were probably 32 bit. I imagine
    > >> >> >> finding a
    > >> >> >> 64 bit codec will be pretty hard to find. Am I on the right track
    > >> >> >> in
    > >> >> >> solving
    > >> >> >> this problem? Does anyone know if a 64 bit codec will be included
    > >> >> >> with
    > >> >> >> SP1?
    > >> >> >>
    > >> >> >>
    > >> >>
    > >> >>
    > >>
    > >>

    >
    >
     
    Carlos, Feb 1, 2008
    #13
  14. Ken Triebold

    Carlos Guest

    Ken,
    This is as far as I can get.
    At least you have found some workarounds to watch and listen your movies.
    Come back to us if you figure out the rest of the issues.
    Have a nice week end!
    Carlos

    "Ken Triebold" wrote:

    > Carlos, I downloaded and installed the 32 bit version of ffdshow. I then
    > tried Windows Media Player 32 bit and Windows Media Center and they both did
    > not have sound. I tried Windows Media Player 64 bit again and it still does
    > have sound.
    >
    > -Ken
    >
    >
    > "Carlos" <> wrote in message
    > news:...
    > > Ken,
    > > In order to give sound to the default Windows Media Player 11, which is
    > > 32-bit, you need the 32-bit version of ffdshow.
    > > http://www.free-codecs.com/download/FFDShow.htm
    > > Download it and install it.
    > > Please note that during the install you will have to choose a different
    > > Program group (the one that shows in the Start, Programs, menu) in order
    > > not
    > > to overwrite the one created by ffdshow x64.
    > > Both tend to create a Program group named "ffdshow".
    > > There is no conflict with their installations in the Program Files
    > > section.
    > > ffdshow x86 goes to C:\Program Files (x86)
    > > and coexists peacefully with its x64 partner.
    > > Check now if WMP11 32-bit has sound.
    > > I believe that Media Center is 64-bit, but it doesn't hurt to try again
    > > after installing ffdshow x86.
    > > Best of luck!
    > > Carlos
    > >
    > > "Ken Triebold" wrote:
    > >
    > >> Carlos, here is what I found:
    > >> 1. In Media Player Home Cinema, View, Options, Output, the device in
    > >> DirectShow Audio is "System Default". In ffdshow x64, Audio Decoder
    > >> Configuration, Mixer, Output, Connect to is shown as "Any Filter". There
    > >> were two other options: "DirectSound" and "WaveOut". I left it at "Any
    > >> Filter" since none of the three options matched "System Default".
    > >>
    > >> 2. I tried Windows Media Player 11 x64 and it worked fine (got sound).
    > >> The
    > >> filename is wmplayer.exe but I am sure it is the 64 bit version because
    > >> it
    > >> was located under Program Files (not Program Files x86). Then I tried
    > >> Media
    > >> Center and the default Media Player (32 bit) and they both still did not
    > >> have sound. So Media Player x64 gives sound but Media Center and Media
    > >> Player 32 do not give sound.
    > >>
    > >> 3. Sorry, but I don't know which audio I am choosing nor do I know how to
    > >> determine that. Maybe it is not relevant now based on what I found out in
    > >> item 2 above.
    > >>
    > >> -Ken
    > >>
    > >>
    > >>
    > >> "Carlos" <> wrote in message
    > >> news:...
    > >> > It should be 3/2/1 - 6 channels, but I don't think it will make any
    > >> > difference because you have no sound at all.
    > >> > There is something else you might try.
    > >> > Open Media Player Home Cinema x64, and click on View, Options.
    > >> > On the left pane click on "Output" in the Playback section.
    > >> > Take note of the device in "DirectShow Audio" on the right pane.
    > >> > It is a dropdown list with options like System Default, DirectSound,
    > >> > etc.
    > >> > Just take note of what it is there right now that ensures that the 5.1
    > >> > audio, when directed to that device, gives you speaker sound.
    > >> > Now go again to the Audio Decoder Configuration in ffdshow x64 and
    > >> > click
    > >> > on
    > >> > Output in the Mixer Section (left pane).
    > >> > Check the selection (right pane) of "Connect to:" and make it equal to
    > >> > the
    > >> > one in Media Player Home Cinema (same output device).
    > >> > Click Ok and try again with Media Center.
    > >> >
    > >> > You could also try playing your DVD with Windows Media Player 11 x64.
    > >> > Its executable is in the C:\Program Files\Windows Media Player folder.
    > >> > Note that the default WMP11 in Vista x64 is the 32-bit one and we want
    > >> > to
    > >> > run the 64-bit version in order to test x64 audio decoding.
    > >> > So try using WMP11 x64 and check if you have audio.
    > >> > If you have audio then the problem is Media Center specific and we will
    > >> > have
    > >> > narrowed it there.
    > >> > If you don't have audio then we are not decoding properly it, 64-bit
    > >> > wise.
    > >> >
    > >> > Last but not least, what audio are you choosing: AC3 (a.k.a. "Dolby
    > >> > 5.1)
    > >> > or
    > >> > DTS?
    > >> > If it is DTS we have not done any check so far.
    > >> > DTS is the following format (next row) after AC3 in ffdshow x64.
    > >> >
    > >> > Carlos
    > >> >
    > >> > "Ken Triebold" wrote:
    > >> >
    > >> >> OK Carlos, I looked at ffdshow x64 and here is what I found:
    > >> >> 1. The AC3 Decoder was set to liba52 so I left it alone.
    > >> >> 2. The output speaker configuration shown in Mixer was set to 3/0/2 -
    > >> >> 5
    > >> >> channels so I left that alone too but I am not entirely sure this is
    > >> >> correct. My speaker system is 5.1 surround sound with two front
    > >> >> speakers,
    > >> >> one center speaker, one woofer, and two rear speakers.
    > >> >>
    > >> >> -Ken
    > >> >>
    > >> >>
    > >> >> "Carlos" <> wrote in message
    > >> >> news:...
    > >> >> > Ken,
    > >> >> > That is good news.
    > >> >> > You have a working x64 Player now because it has its own AC3/DTS
    > >> >> > audio
    > >> >> > decoder (the 5.1 sound of DVD's) and your audio setup is fine.
    > >> >> > Always check here:
    > >> >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    > >> >> > for updates, it is the MPC Home Cinema project page.
    > >> >> >
    > >> >> > Now, getting back to your issue with Media Center...
    > >> >> > I assume you have already installed ffdshow x64.
    > >> >> > Let's see its Audio Configuration.
    > >> >> > Start, Programs, ffdshow, Audio Decoder Configuration.
    > >> >> > Click on "Codecs" o the left pane.
    > >> >> > Choose AC3 on the "Format" column, right pane.
    > >> >> > What do you have in the AC3 row, Decoder column?
    > >> >> > Make sure it is not "Disabled" or "S/PDIF".
    > >> >> > Disabled is... well... disabled, and you surely don't want that.
    > >> >> > S/PDIF means that your sound goes to the optical connection and from
    > >> >> > there
    > >> >> > to an external decoder.
    > >> >> > Choose the "other" option (I am not at my Vista x64 PC now but it
    > >> >> > shoudl
    > >> >> > be
    > >> >> > something like "liba52")
    > >> >> > Maybe you can find something there.
    > >> >> >
    > >> >> > Also click on Mixer (left pane) and take look at the Output speakers
    > >> >> > configuration.
    > >> >> > Does it match your system?
    > >> >> >
    > >> >> > Carlos
    > >> >> >
    > >> >> > "Ken Triebold" wrote:
    > >> >> >
    > >> >> >> Carlos, I searched on "Media Player Classic x64" and found this
    > >> >> >> link:
    > >> >> >> http://www.start64.com/index.php?option=com_content&task=view&id=1376&Itemid=72
    > >> >> >>
    > >> >> >> That link allowed me to download a 64 bit version of Media Player
    > >> >> >> Classic
    > >> >> >> HomeCinema. I was shocked to find that my DVD's played correctly
    > >> >> >> (with
    > >> >> >> sound) using that player. I then checked once again on Windows
    > >> >> >> Media
    > >> >> >> Player
    > >> >> >> and Windows Media Center and the DVD did not produce sound on
    > >> >> >> either
    > >> >> >> of
    > >> >> >> those. As you said in your last post, I now know that this is a
    > >> >> >> Media
    > >> >> >> Center
    > >> >> >> settings issue so I will pursue that further. Maybe the link that
    > >> >> >> Dominic
    > >> >> >> Payer provided in his message will help me out. At least now I have
    > >> >> >> a
    > >> >> >> way
    > >> >> >> to
    > >> >> >> play DVD's even though I really want to get Windows Media Center
    > >> >> >> working
    > >> >> >> as
    > >> >> >> it should. Thanks for all your help.
    > >> >> >>
    > >> >> >> -Ken
    > >> >> >>
    > >> >> >>
    > >> >> >> "Carlos" <> wrote in message
    > >> >> >> news:...
    > >> >> >> > Ken,
    > >> >> >> > If you try Media Player Classic x64 and you have sound, then you
    > >> >> >> > will
    > >> >> >> > be
    > >> >> >> > sure it is a Media Center settings issue.
    > >> >> >> > If you don't have sound, then you will have to look elsewhere.
    > >> >> >> > Carlos
    > >> >> >> >
    > >> >> >> > "Ken Triebold" wrote:
    > >> >> >> >
    > >> >> >> >> Thanks for the info. I downloaded and installed the x64 codec
    > >> >> >> >> that
    > >> >> >> >> you
    > >> >> >> >> mentioned but it didn't seem to make any difference. There are
    > >> >> >> >> some
    > >> >> >> >> guys
    > >> >> >> >> on
    > >> >> >> >> the Media Center forum that think my problem is more related to
    > >> >> >> >> settings,
    > >> >> >> >> but I haven't made any real progress with that either. Thanks
    > >> >> >> >> for
    > >> >> >> >> the
    > >> >> >> >> help
    > >> >> >> >> though.
    > >> >> >> >>
    > >> >> >> >>
    > >> >> >> >> "Carlos" <> wrote in message
    > >> >> >> >> news:...
    > >> >> >> >> > Ken,
    > >> >> >> >> > Here you have a freeware multiformat x64 audio/video decoder.
    > >> >> >> >> > This is the direct download link:
    > >> >> >> >> > http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    > >> >> >> >> > This is the web page you can check for updates.
    > >> >> >> >> > http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    > >> >> >> >> > The decoder is labeled as "64-bit builds (experimental)" but I
    > >> >> >> >> > works
    > >> >> >> >> > flawlessly for me.
    > >> >> >> >> > The other decoders in that page are 32-bit.
    > >> >> >> >> > I also use them and they coexist pacefully in Vista x64.
    > >> >> >> >> >
    > >> >> >> >> > as a bonus, you might also want to try the lightweight x64
    > >> >> >> >> > "Media
    > >> >> >> >> > Player
    > >> >> >> >> > Classic"
    > >> >> >> >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    > >> >> >> >> >
    > >> >> >> >> > Carlos
    > >> >> >> >> >
    > >> >> >> >> > "Ken Triebold" wrote:
    > >> >> >> >> >
    > >> >> >> >> >> I have just built a new computer, and it seems to be running
    > >> >> >> >> >> pretty
    > >> >> >> >> >> well.
    > >> >> >> >> >> I
    > >> >> >> >> >> have Vista Home Premium 64 bit. One thing I noticed is that I
    > >> >> >> >> >> have
    > >> >> >> >> >> picture
    > >> >> >> >> >> but no sound when playing a movie DVD. When I play a music CD
    > >> >> >> >> >> sound
    > >> >> >> >> >> works
    > >> >> >> >> >> normally. Someone advised me that this is because I need a
    > >> >> >> >> >> codec
    > >> >> >> >> >> for
    > >> >> >> >> >> DVD
    > >> >> >> >> >> sound. I then downloaded and installed a couple of free
    > >> >> >> >> >> codecs,
    > >> >> >> >> >> but
    > >> >> >> >> >> that
    > >> >> >> >> >> did
    > >> >> >> >> >> not improve the situation. I read on Windows Help that my
    > >> >> >> >> >> operating
    > >> >> >> >> >> system
    > >> >> >> >> >> requires a codec that is written in 64 bit, so that could be
    > >> >> >> >> >> the
    > >> >> >> >> >> problem
    > >> >> >> >> >> since the codecs that I downloaded were probably 32 bit. I
    > >> >> >> >> >> imagine
    > >> >> >> >> >> finding a
    > >> >> >> >> >> 64 bit codec will be pretty hard to find. Am I on the right
    > >> >> >> >> >> track
    > >> >> >> >> >> in
    > >> >> >> >> >> solving
    > >> >> >> >> >> this problem? Does anyone know if a 64 bit codec will be
    > >> >> >> >> >> included
    > >> >> >> >> >> with
    > >> >> >> >> >> SP1?
    > >> >> >> >> >>
    > >> >> >> >> >>
    > >> >> >> >>
    > >> >> >> >>
    > >> >> >>
    > >> >> >>
    > >> >>
    > >> >>
    > >>
    > >>

    >
    >
     
    Carlos, Feb 1, 2008
    #14
  15. Ken Triebold

    Ken Triebold Guest

    Thanks, Carlos, for all the help. My "LFE" box is checked too. Like you said
    at least now I can watch DVD's normally which is something I couldn't do
    before. Cheers!

    -Ken


    "Carlos" <> wrote in message
    news:D...
    > Ken,
    > I am now at my Vista x64 machine.
    >
    > Output Speaker Configuration in Mixer menu is 3/0/2 - 5 channels and the
    > "LFE" checkbox is checked.
    > That is the working configuration for my 5.1 speaker system.
    > Carlos
    >
    > "Ken Triebold" wrote:
    >
    >> OK Carlos, I looked at ffdshow x64 and here is what I found:
    >> 1. The AC3 Decoder was set to liba52 so I left it alone.
    >> 2. The output speaker configuration shown in Mixer was set to 3/0/2 - 5
    >> channels so I left that alone too but I am not entirely sure this is
    >> correct. My speaker system is 5.1 surround sound with two front speakers,
    >> one center speaker, one woofer, and two rear speakers.
    >>
    >> -Ken
    >>
    >>
    >> "Carlos" <> wrote in message
    >> news:...
    >> > Ken,
    >> > That is good news.
    >> > You have a working x64 Player now because it has its own AC3/DTS audio
    >> > decoder (the 5.1 sound of DVD's) and your audio setup is fine.
    >> > Always check here:
    >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    >> > for updates, it is the MPC Home Cinema project page.
    >> >
    >> > Now, getting back to your issue with Media Center...
    >> > I assume you have already installed ffdshow x64.
    >> > Let's see its Audio Configuration.
    >> > Start, Programs, ffdshow, Audio Decoder Configuration.
    >> > Click on "Codecs" o the left pane.
    >> > Choose AC3 on the "Format" column, right pane.
    >> > What do you have in the AC3 row, Decoder column?
    >> > Make sure it is not "Disabled" or "S/PDIF".
    >> > Disabled is... well... disabled, and you surely don't want that.
    >> > S/PDIF means that your sound goes to the optical connection and from
    >> > there
    >> > to an external decoder.
    >> > Choose the "other" option (I am not at my Vista x64 PC now but it
    >> > shoudl
    >> > be
    >> > something like "liba52")
    >> > Maybe you can find something there.
    >> >
    >> > Also click on Mixer (left pane) and take look at the Output speakers
    >> > configuration.
    >> > Does it match your system?
    >> >
    >> > Carlos
    >> >
    >> > "Ken Triebold" wrote:
    >> >
    >> >> Carlos, I searched on "Media Player Classic x64" and found this link:
    >> >> http://www.start64.com/index.php?option=com_content&task=view&id=1376&Itemid=72
    >> >>
    >> >> That link allowed me to download a 64 bit version of Media Player
    >> >> Classic
    >> >> HomeCinema. I was shocked to find that my DVD's played correctly (with
    >> >> sound) using that player. I then checked once again on Windows Media
    >> >> Player
    >> >> and Windows Media Center and the DVD did not produce sound on either
    >> >> of
    >> >> those. As you said in your last post, I now know that this is a Media
    >> >> Center
    >> >> settings issue so I will pursue that further. Maybe the link that
    >> >> Dominic
    >> >> Payer provided in his message will help me out. At least now I have a
    >> >> way
    >> >> to
    >> >> play DVD's even though I really want to get Windows Media Center
    >> >> working
    >> >> as
    >> >> it should. Thanks for all your help.
    >> >>
    >> >> -Ken
    >> >>
    >> >>
    >> >> "Carlos" <> wrote in message
    >> >> news:...
    >> >> > Ken,
    >> >> > If you try Media Player Classic x64 and you have sound, then you
    >> >> > will
    >> >> > be
    >> >> > sure it is a Media Center settings issue.
    >> >> > If you don't have sound, then you will have to look elsewhere.
    >> >> > Carlos
    >> >> >
    >> >> > "Ken Triebold" wrote:
    >> >> >
    >> >> >> Thanks for the info. I downloaded and installed the x64 codec that
    >> >> >> you
    >> >> >> mentioned but it didn't seem to make any difference. There are some
    >> >> >> guys
    >> >> >> on
    >> >> >> the Media Center forum that think my problem is more related to
    >> >> >> settings,
    >> >> >> but I haven't made any real progress with that either. Thanks for
    >> >> >> the
    >> >> >> help
    >> >> >> though.
    >> >> >>
    >> >> >>
    >> >> >> "Carlos" <> wrote in message
    >> >> >> news:...
    >> >> >> > Ken,
    >> >> >> > Here you have a freeware multiformat x64 audio/video decoder.
    >> >> >> > This is the direct download link:
    >> >> >> > http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    >> >> >> > This is the web page you can check for updates.
    >> >> >> > http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    >> >> >> > The decoder is labeled as "64-bit builds (experimental)" but I
    >> >> >> > works
    >> >> >> > flawlessly for me.
    >> >> >> > The other decoders in that page are 32-bit.
    >> >> >> > I also use them and they coexist pacefully in Vista x64.
    >> >> >> >
    >> >> >> > as a bonus, you might also want to try the lightweight x64 "Media
    >> >> >> > Player
    >> >> >> > Classic"
    >> >> >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    >> >> >> >
    >> >> >> > Carlos
    >> >> >> >
    >> >> >> > "Ken Triebold" wrote:
    >> >> >> >
    >> >> >> >> I have just built a new computer, and it seems to be running
    >> >> >> >> pretty
    >> >> >> >> well.
    >> >> >> >> I
    >> >> >> >> have Vista Home Premium 64 bit. One thing I noticed is that I
    >> >> >> >> have
    >> >> >> >> picture
    >> >> >> >> but no sound when playing a movie DVD. When I play a music CD
    >> >> >> >> sound
    >> >> >> >> works
    >> >> >> >> normally. Someone advised me that this is because I need a codec
    >> >> >> >> for
    >> >> >> >> DVD
    >> >> >> >> sound. I then downloaded and installed a couple of free codecs,
    >> >> >> >> but
    >> >> >> >> that
    >> >> >> >> did
    >> >> >> >> not improve the situation. I read on Windows Help that my
    >> >> >> >> operating
    >> >> >> >> system
    >> >> >> >> requires a codec that is written in 64 bit, so that could be the
    >> >> >> >> problem
    >> >> >> >> since the codecs that I downloaded were probably 32 bit. I
    >> >> >> >> imagine
    >> >> >> >> finding a
    >> >> >> >> 64 bit codec will be pretty hard to find. Am I on the right
    >> >> >> >> track
    >> >> >> >> in
    >> >> >> >> solving
    >> >> >> >> this problem? Does anyone know if a 64 bit codec will be
    >> >> >> >> included
    >> >> >> >> with
    >> >> >> >> SP1?
    >> >> >> >>
    >> >> >> >>
    >> >> >>
    >> >> >>
    >> >>
    >> >>

    >>
    >>
     
    Ken Triebold, Feb 1, 2008
    #15
  16. Ken Triebold

    Carlos Guest

    Ken,
    Glad to hear that.
    It is 3:00 AM down here. I guess I'll hit the sack.
    Have a nice weekend.
    Carlos

    "Ken Triebold" wrote:

    > Thanks, Carlos, for all the help. My "LFE" box is checked too. Like you said
    > at least now I can watch DVD's normally which is something I couldn't do
    > before. Cheers!
    >
    > -Ken
    >
    >
    > "Carlos" <> wrote in message
    > news:D...
    > > Ken,
    > > I am now at my Vista x64 machine.
    > >
    > > Output Speaker Configuration in Mixer menu is 3/0/2 - 5 channels and the
    > > "LFE" checkbox is checked.
    > > That is the working configuration for my 5.1 speaker system.
    > > Carlos
    > >
    > > "Ken Triebold" wrote:
    > >
    > >> OK Carlos, I looked at ffdshow x64 and here is what I found:
    > >> 1. The AC3 Decoder was set to liba52 so I left it alone.
    > >> 2. The output speaker configuration shown in Mixer was set to 3/0/2 - 5
    > >> channels so I left that alone too but I am not entirely sure this is
    > >> correct. My speaker system is 5.1 surround sound with two front speakers,
    > >> one center speaker, one woofer, and two rear speakers.
    > >>
    > >> -Ken
    > >>
    > >>
    > >> "Carlos" <> wrote in message
    > >> news:...
    > >> > Ken,
    > >> > That is good news.
    > >> > You have a working x64 Player now because it has its own AC3/DTS audio
    > >> > decoder (the 5.1 sound of DVD's) and your audio setup is fine.
    > >> > Always check here:
    > >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    > >> > for updates, it is the MPC Home Cinema project page.
    > >> >
    > >> > Now, getting back to your issue with Media Center...
    > >> > I assume you have already installed ffdshow x64.
    > >> > Let's see its Audio Configuration.
    > >> > Start, Programs, ffdshow, Audio Decoder Configuration.
    > >> > Click on "Codecs" o the left pane.
    > >> > Choose AC3 on the "Format" column, right pane.
    > >> > What do you have in the AC3 row, Decoder column?
    > >> > Make sure it is not "Disabled" or "S/PDIF".
    > >> > Disabled is... well... disabled, and you surely don't want that.
    > >> > S/PDIF means that your sound goes to the optical connection and from
    > >> > there
    > >> > to an external decoder.
    > >> > Choose the "other" option (I am not at my Vista x64 PC now but it
    > >> > shoudl
    > >> > be
    > >> > something like "liba52")
    > >> > Maybe you can find something there.
    > >> >
    > >> > Also click on Mixer (left pane) and take look at the Output speakers
    > >> > configuration.
    > >> > Does it match your system?
    > >> >
    > >> > Carlos
    > >> >
    > >> > "Ken Triebold" wrote:
    > >> >
    > >> >> Carlos, I searched on "Media Player Classic x64" and found this link:
    > >> >> http://www.start64.com/index.php?option=com_content&task=view&id=1376&Itemid=72
    > >> >>
    > >> >> That link allowed me to download a 64 bit version of Media Player
    > >> >> Classic
    > >> >> HomeCinema. I was shocked to find that my DVD's played correctly (with
    > >> >> sound) using that player. I then checked once again on Windows Media
    > >> >> Player
    > >> >> and Windows Media Center and the DVD did not produce sound on either
    > >> >> of
    > >> >> those. As you said in your last post, I now know that this is a Media
    > >> >> Center
    > >> >> settings issue so I will pursue that further. Maybe the link that
    > >> >> Dominic
    > >> >> Payer provided in his message will help me out. At least now I have a
    > >> >> way
    > >> >> to
    > >> >> play DVD's even though I really want to get Windows Media Center
    > >> >> working
    > >> >> as
    > >> >> it should. Thanks for all your help.
    > >> >>
    > >> >> -Ken
    > >> >>
    > >> >>
    > >> >> "Carlos" <> wrote in message
    > >> >> news:...
    > >> >> > Ken,
    > >> >> > If you try Media Player Classic x64 and you have sound, then you
    > >> >> > will
    > >> >> > be
    > >> >> > sure it is a Media Center settings issue.
    > >> >> > If you don't have sound, then you will have to look elsewhere.
    > >> >> > Carlos
    > >> >> >
    > >> >> > "Ken Triebold" wrote:
    > >> >> >
    > >> >> >> Thanks for the info. I downloaded and installed the x64 codec that
    > >> >> >> you
    > >> >> >> mentioned but it didn't seem to make any difference. There are some
    > >> >> >> guys
    > >> >> >> on
    > >> >> >> the Media Center forum that think my problem is more related to
    > >> >> >> settings,
    > >> >> >> but I haven't made any real progress with that either. Thanks for
    > >> >> >> the
    > >> >> >> help
    > >> >> >> though.
    > >> >> >>
    > >> >> >>
    > >> >> >> "Carlos" <> wrote in message
    > >> >> >> news:...
    > >> >> >> > Ken,
    > >> >> >> > Here you have a freeware multiformat x64 audio/video decoder.
    > >> >> >> > This is the direct download link:
    > >> >> >> > http://downloads.sourceforge.net/ff...clsid_x64.exe?modtime=1201633141&big_mirror=0
    > >> >> >> > This is the web page you can check for updates.
    > >> >> >> > http://sourceforge.net/project/showfiles.php?group_id=173941&package_id=199416
    > >> >> >> > The decoder is labeled as "64-bit builds (experimental)" but I
    > >> >> >> > works
    > >> >> >> > flawlessly for me.
    > >> >> >> > The other decoders in that page are 32-bit.
    > >> >> >> > I also use them and they coexist pacefully in Vista x64.
    > >> >> >> >
    > >> >> >> > as a bonus, you might also want to try the lightweight x64 "Media
    > >> >> >> > Player
    > >> >> >> > Classic"
    > >> >> >> > http://sourceforge.net/project/showfiles.php?group_id=170561
    > >> >> >> >
    > >> >> >> > Carlos
    > >> >> >> >
    > >> >> >> > "Ken Triebold" wrote:
    > >> >> >> >
    > >> >> >> >> I have just built a new computer, and it seems to be running
    > >> >> >> >> pretty
    > >> >> >> >> well.
    > >> >> >> >> I
    > >> >> >> >> have Vista Home Premium 64 bit. One thing I noticed is that I
    > >> >> >> >> have
    > >> >> >> >> picture
    > >> >> >> >> but no sound when playing a movie DVD. When I play a music CD
    > >> >> >> >> sound
    > >> >> >> >> works
    > >> >> >> >> normally. Someone advised me that this is because I need a codec
    > >> >> >> >> for
    > >> >> >> >> DVD
    > >> >> >> >> sound. I then downloaded and installed a couple of free codecs,
    > >> >> >> >> but
    > >> >> >> >> that
    > >> >> >> >> did
    > >> >> >> >> not improve the situation. I read on Windows Help that my
    > >> >> >> >> operating
    > >> >> >> >> system
    > >> >> >> >> requires a codec that is written in 64 bit, so that could be the
    > >> >> >> >> problem
    > >> >> >> >> since the codecs that I downloaded were probably 32 bit. I
    > >> >> >> >> imagine
    > >> >> >> >> finding a
    > >> >> >> >> 64 bit codec will be pretty hard to find. Am I on the right
    > >> >> >> >> track
    > >> >> >> >> in
    > >> >> >> >> solving
    > >> >> >> >> this problem? Does anyone know if a 64 bit codec will be
    > >> >> >> >> included
    > >> >> >> >> with
    > >> >> >> >> SP1?
    > >> >> >> >>
    > >> >> >> >>
    > >> >> >>
    > >> >> >>
    > >> >>
    > >> >>
    > >>
    > >>

    >
    >
     
    Carlos, Feb 2, 2008
    #16
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?VGFueWE=?=
    Replies:
    2
    Views:
    1,012
    Yoshi
    Oct 26, 2003
  2. Matthew Morrison

    Geforce 4 MX 440 Sound Prob (thats right, sound)

    Matthew Morrison, Jul 27, 2003, in forum: Computer Support
    Replies:
    2
    Views:
    605
    JabberSmith
    Jul 29, 2003
  3. John E

    Mobo On-Board Sound + PCI Sound Card?

    John E, Nov 29, 2003, in forum: Computer Support
    Replies:
    24
    Views:
    7,042
    thesodakid
    Oct 1, 2007
  4. Nozza

    DVD-R & DVD-RW & DVD+R & DVD+RW DVD-WTF

    Nozza, Dec 1, 2004, in forum: Computer Support
    Replies:
    5
    Views:
    1,893
    Nozza
    Dec 2, 2004
  5. lbbss
    Replies:
    16
    Views:
    1,682
Loading...

Share This Page