No drivers are installed for this device.

Discussion in 'General Computer Support' started by wcwager, Jan 27, 2009.

  1. wcwager

    wcwager

    Joined:
    Jan 27, 2009
    Messages:
    1
    I have an Acer Aspire 5672WLMi with Windows XP, probably 2006 or so.
    I have about 8 different USB modules that are making my life difficult right now.

    None of the 8 will recieve a USB device, and one will accept the usb cable attached to my printer (the rest will not). By recieve, I mean when I stick the device in the module, there is a window that pops up saying Device Not Recognized. So I click on the bubble and check out the properties.

    Device status: "No drivers are installed for this device.

    If you are having problems with this device, click Troubleshoot to start the troubleshooter."

    Then I click the Driver tab:
    Driver provider: Microsoft
    Driver date: 01/07/2001
    Driver version: 5.1.2600.0
    Digital Signer: Microsoft Windows Component Publisher

    I can click on Driver Details, Update Driver, Roll Back Driver and Uninstall.

    Driver Details doesn't help, the Roll Back Driver button just informs me there were never any drivers backed up for the device. I have uninstalled one of the drivers, in one of the modules, and then restarted but it of course didn't do anything.

    When I click on Update Driver it brings me to this installation window and asks me to insert a CD or Floppy that supposedly came with either the computer or device. First of all, I moved and any software that came with my computer is at my parent's house an hour away. Secondly, this device came with nothing else, I got it at like a hockey game as a prize or something.

    I have tried two other devices too, which leads me to believe my USB modules are to blame. I have also scanned for and deleted any adware/spyware/malware, as I thought that might be the problem. No such luck.

    Can anyone help me? This is absurd, my USB ports have been working fine for three years, I've never had a problem. This just occurred within the past few days. I am in journalism and I have a recorder that plugs in via USB so I need this to be fixed. Any ideas at all?

    Thanks alot :).
     
    wcwager, Jan 27, 2009
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. reynaldo enriquez

    PCI Simple Communication Control Device Driver Not Installed

    reynaldo enriquez, Aug 2, 2004, in forum: Computer Support
    Replies:
    2
    Views:
    15,720
    seldogan
    Aug 7, 2008
  2. =?Utf-8?B?ZHV0Y2htYW5s?=

    No drivers are installed for this device.

    =?Utf-8?B?ZHV0Y2htYW5s?=, May 6, 2006, in forum: Microsoft Certification
    Replies:
    11
    Views:
    33,100
    stephanieleann
    Jul 17, 2007
  3. Giuen
    Replies:
    0
    Views:
    984
    Giuen
    Sep 12, 2008
  4. P. Qwan
    Replies:
    1
    Views:
    1,181
  5. s
    Replies:
    15
    Views:
    1,375
    PA Bear [MS MVP]
    Nov 19, 2009
Loading...

Share This Page