Nikon D100 and Phoenix RL59 RingFlash

Discussion in 'Digital Photography' started by mike14k, Sep 2, 2003.

  1. mike14k

    mike14k Guest

    Hi folks,

    Just found this newsgroup and seeking abit of info.

    I have a Nikon D-100 digital and use it mainly for macro photography.
    I recently purchased (on line) a Phoenix RL59 Ring Flash. I can't
    get the flash to work at all with the camera. It will not fire the
    ringflash and, in fact, locks up so that the shutter button cannot be
    pushed. I've tried any combination of settings, lenses, etc.....

    The RingFlash works just fine on my old FM2... and a standard SunPak
    Flash,(and others) works just fine on the D100. Just not the Phoenix
    RingFlash....

    I called Phoenix and they were not sure if they were compatable....
    sort of a vague answer on their part.

    Wondered if anyone on here had experience with this particular
    ringflash... or any ringflash on the D100.....

    Thanks in advance...

    Mike
     
    mike14k, Sep 2, 2003
    #1
    1. Advertising

  2. mike14k

    Chris Hoopes Guest

    "mike14k" <> wrote in message
    news:...
    > Hi folks,
    >
    > Just found this newsgroup and seeking abit of info.
    >
    > I have a Nikon D-100 digital and use it mainly for macro photography.
    > I recently purchased (on line) a Phoenix RL59 Ring Flash. I can't
    > get the flash to work at all with the camera. It will not fire the
    > ringflash and, in fact, locks up so that the shutter button cannot be
    > pushed. I've tried any combination of settings, lenses, etc.....
    >
    > The RingFlash works just fine on my old FM2... and a standard SunPak
    > Flash,(and others) works just fine on the D100. Just not the Phoenix
    > RingFlash....
    >
    > I called Phoenix and they were not sure if they were compatable....
    > sort of a vague answer on their part.
    >
    > Wondered if anyone on here had experience with this particular
    > ringflash... or any ringflash on the D100.....
    >
    > Thanks in advance...
    >
    > Mike


    Have you tried putting the camera's flash mode to Manual? If you are trying
    to shoot with it in D-TTL mode, it may be causing the problem. CSM Menu item
    #23. I haven't tried that specific flash, but I do use Metz flashes with my
    D100 all the time - just have to switch to Manual mode first.
     
    Chris Hoopes, Sep 3, 2003
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John and Madeleine McCormack

    Ringflash

    John and Madeleine McCormack, Oct 7, 2003, in forum: Digital Photography
    Replies:
    4
    Views:
    1,876
  2. Warren Jones

    10D with older Canon ringflash question

    Warren Jones, Dec 8, 2003, in forum: Digital Photography
    Replies:
    1
    Views:
    351
    Michael Quack
    Dec 8, 2003
  3. Onepercentf

    Canon 10D and ML3 ringflash

    Onepercentf, Jan 26, 2004, in forum: Digital Photography
    Replies:
    1
    Views:
    1,279
    Mark B.
    Jan 27, 2004
  4. Naima

    Dsrl body and ringflash running with any lens on

    Naima, May 15, 2004, in forum: Digital Photography
    Replies:
    3
    Views:
    341
    Dave Herzstein
    May 18, 2004
  5. john chapman

    Rechargeable AA Batteries in MB-D100 for Nikon D100

    john chapman, Aug 19, 2004, in forum: Digital Photography
    Replies:
    2
    Views:
    717
    Ed Ruf
    Aug 19, 2004
Loading...

Share This Page