Nikon Coolpix 950 Millenium

Discussion in 'Digital Photography' started by elasticgurl, Aug 21, 2007.

  1. elasticgurl

    elasticgurl Guest

    I've had this for about 7 years. It's worked fine until now. I've put
    in fresh batteries and nothing turns on. I don't have an AC adapter.
    I'm wondering if this is something I can fix or do I have to take it
    in. Any suggestions welcome.
     
    elasticgurl, Aug 21, 2007
    #1
    1. Advertising

  2. elasticgurl wrote:
    > I've had this for about 7 years. It's worked fine until now. I've put
    > in fresh batteries and nothing turns on. I don't have an AC adapter.
    > I'm wondering if this is something I can fix or do I have to take it
    > in. Any suggestions welcome.


    Corroded contacts?
    Did you put in the batteries in the correct orientation?

    jue
     
    Jürgen Exner, Aug 21, 2007
    #2
    1. Advertising

  3. elasticgurl

    elasticgurl Guest

    Yes, the contacts had corrosion. I wiped them off.
    And I did put them in the right way.

    On Aug 21, 10:08 am, "Jürgen Exner" <> wrote:
    > elasticgurl wrote:
    > > I've had this for about 7 years. It's worked fine until now. I've put
    > > in fresh batteries and nothing turns on. I don't have an AC adapter.
    > > I'm wondering if this is something I can fix or do I have to take it
    > > in. Any suggestions welcome.

    >
    > Corroded contacts?
    > Did you put in the batteries in the correct orientation?
    >
    > jue
     
    elasticgurl, Aug 21, 2007
    #3
  4. elasticgurl

    Yes Baby Guest

    "elasticgurl" <> wrote in message
    news:...
    > I've had this for about 7 years. It's worked fine until now. I've put
    > in fresh batteries and nothing turns on. I don't have an AC adapter.
    > I'm wondering if this is something I can fix or do I have to take it
    > in. Any suggestions welcome.
    >


    I did this and have had no problems since..........

    http://www.nightskyevents.com/Nikon950repair1.pdf
     
    Yes Baby, Aug 21, 2007
    #4
  5. elasticgurl

    Newbie Guest

    elasticgurl <> wrote:

    : I've had this for about 7 years. It's worked fine until now. I've put
    : in fresh batteries and nothing turns on. I don't have an AC adapter.
    : I'm wondering if this is something I can fix or do I have to take it
    : in. Any suggestions welcome.

    You mean, it used to work until you put in new fresh batteries?!?!

    Maybe the batteries are not that fresh, try another set before giving
    up. Check the orientation of all batteries.

    I wouldn't spend serious money on repair though. Maybe better to get a
    new camera.
     
    Newbie, Aug 21, 2007
    #5
  6. elasticgurl

    elasticgurl Guest

    Someone mentioned cleaning the contacts with vinegar. Has anyone tried
    this with any success?
     
    elasticgurl, Aug 21, 2007
    #6
  7. In article <>,
    elasticgurl <> wrote:

    > Someone mentioned cleaning the contacts with vinegar. Has anyone tried
    > this with any success?


    Vinegar will react with and help remove the deposits from alkaline
    batteries. You have to be sure to get the vinegar off the contacts
    afterwards, though.

    However, no amount of cleaning will help for long if the battery crud
    (or the users cleaning efforts) have removed the plating from the
    contacts. Once the base metal is exposed, it will keep oxidizing and
    you'll have problems forever after.

    I'd suspect that since the original poster said he had corrosion and
    "cleaned" it, that's the boat he's in now.
     
    Scott Schuckert, Aug 21, 2007
    #7
  8. elasticgurl

    Don Wiss Guest

    On Tue, 21 Aug 2007, Yes Baby <> wrote:

    >elasticgurl <> wrote:
    >> I've had this for about 7 years. It's worked fine until now. I've put
    >> in fresh batteries and nothing turns on. I don't have an AC adapter.
    >> I'm wondering if this is something I can fix or do I have to take it
    >> in. Any suggestions welcome.

    >
    >I did this and have had no problems since..........
    >
    >http://www.nightskyevents.com/Nikon950repair1.pdf


    Yes, that will work. But what I did was to buy the stuff recommended on
    that page, but I did not disassemble the camera. I simply squirted a lot
    under the rotating switch and rotated it. This worked.

    Don <www.donwiss.com/pictures/> (e-mail link at page bottoms).
     
    Don Wiss, Aug 22, 2007
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. algae

    Newbie question on Coolpix 950.

    algae, Jul 31, 2003, in forum: Digital Photography
    Replies:
    10
    Views:
    595
    Ed Ruf
    Aug 1, 2003
  2. Tobit

    Coolpix 950 infra red characteristics

    Tobit, Sep 26, 2003, in forum: Digital Photography
    Replies:
    5
    Views:
    771
    Ian Stirling
    Sep 30, 2003
  3. Melissa

    Looking at Coolpix 950 auction...??

    Melissa, Dec 2, 2003, in forum: Digital Photography
    Replies:
    8
    Views:
    342
    Melissa
    Dec 25, 2003
  4. wilmac

    Le Old CoolPix 950

    wilmac, Dec 3, 2003, in forum: Digital Photography
    Replies:
    10
    Views:
    866
    wilmac
    Dec 5, 2003
  5. Robert Green

    Nikon Coolpix 950 slideshow question

    Robert Green, Dec 30, 2005, in forum: Digital Photography
    Replies:
    26
    Views:
    783
    Robert Green
    Jan 2, 2006
Loading...

Share This Page