Newbie route redistribution eigrp into bgp question

Discussion in 'Cisco' started by Sean.Evershed@gmail.com, Aug 21, 2005.

  1. Guest

    I am attempting to redistribute EIGRP into BGP. I have 3 routers

    Router A
    router bgp 11
    no synchronization
    neighbor 150.10.10.2 remote-as 10
    neighbor 160.20.20.2 remote-as 10

    Router B
    interface Ethernet0
    ip address 192.168.1.2 255.255.255.0
    router eigrp 10
    network 192.168.1.0
    router bgp 10
    no synchronization
    network 10.0.0.0
    network 192.168.1.0
    neighbor 160.20.20.1 remote-as 11

    Router C
    interface Ethernet0
    ip address 192.168.1.1 255.255.255.0
    router eigrp 10
    network 192.168.1.0
    router bgp 10
    no synchronization
    redistribute eigrp 10
    neighbor 150.10.10.1 remote-as 11

    >From Router A I can ping 192.168.1.2 on Router B but not 192.168.1.1 on

    Router C. Any ideas? See below results of sh ip bgp from Router A
    Network Next Hop Metric LocPrf Weight Path
    * 192.168.1.0 150.10.10.2 0 0 10 ?
    *> 160.20.20.2 0 0 10 i
    , Aug 21, 2005
    #1
    1. Advertising

  2. Ahmed

    Joined:
    Sep 16, 2008
    Messages:
    1
    please post topology pic

    Hi, can u please send topology pic so that i could know how your routers are connected to eachother.

    Ahmed
    Ahmed, Sep 16, 2008
    #2
    1. Advertising

  3. theapplebee

    Joined:
    Jun 19, 2009
    Messages:
    67
    Location:
    USA
    On router C, you need to configure network 192.168.1.0 under BGP configuration. That's it.
    theapplebee, Jun 20, 2009
    #3
  4. zupa

    Joined:
    Mar 19, 2009
    Messages:
    8
    Location:
    Latvia
    Yes, the topology would be a great help. I think that next-hop-self would be a helpful command.
    zupa, Jun 25, 2009
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. slipstream_242

    route redistribution RIP and EIGRP

    slipstream_242, Jul 15, 2004, in forum: Cisco
    Replies:
    1
    Views:
    10,604
  2. ciscokid

    bgp redistribution into Eigrp

    ciscokid, Nov 22, 2004, in forum: Cisco
    Replies:
    2
    Views:
    25,661
    daricha74
    Jun 25, 2012
  3. Rob
    Replies:
    14
    Views:
    7,159
  4. ciscohelp
    Replies:
    0
    Views:
    631
    ciscohelp
    Sep 5, 2006
  5. Brian
    Replies:
    4
    Views:
    3,432
    dkdent
    Sep 3, 2013
Loading...

Share This Page