Newbie question - Read-Only Attribute Removal

Discussion in 'Windows 64bit' started by =?Utf-8?B?UGFwYSBTbXVyZg==?=, Nov 10, 2006.

  1. AMD 3800+
    XP64 Pro
    C/D/F Drives

    File folders under logical D-drive are always attributed with Read-Only
    (green box - not checked). If I click on the green box for any of the
    folders, I can click the box to get a check mark or a blank box. If I chose
    either the check mark or the blank box (blank box is the one I want), and
    propagate all the files and sub folders, The attributes do not change! If you
    go back into the properties of the folder, it has reverted back to the green
    box (or never changed in the first place). For the life of me, I cannot
    figure this out. The D-drive is shared via the "Sharing and Security" tab. I
    can open files on this drive, but if I wish to "Save As" I get the warning:
    "File cannot be opened. Check the read only attribute". Any suggestions would
    be greatly appreciated. Gary.
    =?Utf-8?B?UGFwYSBTbXVyZg==?=, Nov 10, 2006
    #1
    1. Advertising

  2. check the properties of the drive itself. And clear the inheritance check
    box as well. And if all else fails, take ownership of the drive and/or the
    folder.

    --
    Charlie.
    http://msmvps.com/xperts64


    "Papa Smurf" <> wrote in message
    news:...
    > AMD 3800+
    > XP64 Pro
    > C/D/F Drives
    >
    > File folders under logical D-drive are always attributed with Read-Only
    > (green box - not checked). If I click on the green box for any of the
    > folders, I can click the box to get a check mark or a blank box. If I
    > chose
    > either the check mark or the blank box (blank box is the one I want), and
    > propagate all the files and sub folders, The attributes do not change! If
    > you
    > go back into the properties of the folder, it has reverted back to the
    > green
    > box (or never changed in the first place). For the life of me, I cannot
    > figure this out. The D-drive is shared via the "Sharing and Security" tab.
    > I
    > can open files on this drive, but if I wish to "Save As" I get the
    > warning:
    > "File cannot be opened. Check the read only attribute". Any suggestions
    > would
    > be greatly appreciated. Gary.
    Charlie Russel - MVP, Nov 10, 2006
    #2
    1. Advertising

  3. Papa Smurf wrote:

    >AMD 3800+
    >XP64 Pro
    >C/D/F Drives
    >
    >File folders under logical D-drive are always attributed with Read-Only
    >(green box - not checked). If I click on the green box for any of the
    >folders, I can click the box to get a check mark or a blank box. If I chose
    >either the check mark or the blank box (blank box is the one I want), and
    >propagate all the files and sub folders, The attributes do not change! If
    >you
    >go back into the properties of the folder, it has reverted back to the
    >green
    >box (or never changed in the first place). For the life of me, I cannot
    >figure this out. The D-drive is shared via the "Sharing and Security" tab.
    >I
    >can open files on this drive, but if I wish to "Save As" I get the warning:
    >"File cannot be opened. Check the read only attribute". Any suggestions
    >would
    >be greatly appreciated. Gary.


    The Read-Only attribute is not relevant to folders, hence the "non-state"
    green mark.

    The default share permissions on new shares is Read-Only, so I'd check the
    share permissions.

    --
    Steve Foster [SBS MVP]
    ---------------------------------------
    MVPs do not work for Microsoft. Please reply only to the newsgroups.
    Steve Foster [SBS MVP], Nov 10, 2006
    #3
  4. Thanks Charlie, but I am still stumped. I remember seeing this stuff before
    when I first got my machine, but alas it seems lost. When I look up
    "ownership" in the help files, I get this:

    To take ownership of a file or folder
    Open Windows Explorer, and then locate the file or folder you want to take
    ownership of.
    Right-click the file or folder, click Properties, and then click the
    Security tab.
    Click Advanced, and then click the Owner tab.
    In the Change owner to box, click the new owner.
    (Optional) To change the owner of all subcontainers and objects within the
    tree, select the Replace owner on subcontainers and objects check box.
    Notes

    To open Windows Explorer, click Start, point to All Programs, point to
    Accessories, and then click Windows Explorer.
    If you are not joined to a domain and want to view the Security tab, see To
    display the Security tab.
    You can transfer ownership in two ways:
    The current owner can grant the Take ownership permission to others,
    allowing those users to take ownership at any time.
    An administrator can take ownership of any file on the computer. However,
    the administrator cannot transfer ownership to others. This restriction keeps
    the administrator accountable.
    In Windows XP Professional, the Everyone group no longer includes the
    Anonymous Logon group.

    Soooo, since I see a "Sharing and Security" tab and not see a "Security"
    tab, I figured I was on the right track. However, I do not have an "Advanced"
    button nor a "Owner" tab within this "sharing and Security" tab. Is something
    turned off perhaps? I am the admin. Also the folder options have "Simple File
    Sharing" checked on. Any thoughts? This is troublesome. P.S. I have read
    Steve's response, but the path kind of leads me back to this wall. Tia, Gary

    "Charlie Russel - MVP" wrote:

    > check the properties of the drive itself. And clear the inheritance check
    > box as well. And if all else fails, take ownership of the drive and/or the
    > folder.
    >
    > --
    > Charlie.
    > http://msmvps.com/xperts64
    >
    >
    > "Papa Smurf" <> wrote in message
    > news:...
    > > AMD 3800+
    > > XP64 Pro
    > > C/D/F Drives
    > >
    > > File folders under logical D-drive are always attributed with Read-Only
    > > (green box - not checked). If I click on the green box for any of the
    > > folders, I can click the box to get a check mark or a blank box. If I
    > > chose
    > > either the check mark or the blank box (blank box is the one I want), and
    > > propagate all the files and sub folders, The attributes do not change! If
    > > you
    > > go back into the properties of the folder, it has reverted back to the
    > > green
    > > box (or never changed in the first place). For the life of me, I cannot
    > > figure this out. The D-drive is shared via the "Sharing and Security" tab.
    > > I
    > > can open files on this drive, but if I wish to "Save As" I get the
    > > warning:
    > > "File cannot be opened. Check the read only attribute". Any suggestions
    > > would
    > > be greatly appreciated. Gary.

    >
    =?Utf-8?B?UGFwYSBTbXVyZg==?=, Nov 15, 2006
    #4
  5. Thanks Steve. Please read my reply to Charlie if you have time. Tia, Gary.

    "Steve Foster [SBS MVP]" wrote:

    > Papa Smurf wrote:
    >
    > >AMD 3800+
    > >XP64 Pro
    > >C/D/F Drives
    > >
    > >File folders under logical D-drive are always attributed with Read-Only
    > >(green box - not checked). If I click on the green box for any of the
    > >folders, I can click the box to get a check mark or a blank box. If I chose
    > >either the check mark or the blank box (blank box is the one I want), and
    > >propagate all the files and sub folders, The attributes do not change! If
    > >you
    > >go back into the properties of the folder, it has reverted back to the
    > >green
    > >box (or never changed in the first place). For the life of me, I cannot
    > >figure this out. The D-drive is shared via the "Sharing and Security" tab.
    > >I
    > >can open files on this drive, but if I wish to "Save As" I get the warning:
    > >"File cannot be opened. Check the read only attribute". Any suggestions
    > >would
    > >be greatly appreciated. Gary.

    >
    > The Read-Only attribute is not relevant to folders, hence the "non-state"
    > green mark.
    >
    > The default share permissions on new shares is Read-Only, so I'd check the
    > share permissions.
    >
    > --
    > Steve Foster [SBS MVP]
    > ---------------------------------------
    > MVPs do not work for Microsoft. Please reply only to the newsgroups.
    >
    =?Utf-8?B?UGFwYSBTbXVyZg==?=, Nov 15, 2006
    #5
  6. Answered in the newer thread. Kill Simple file sharing

    --
    Charlie.
    http://msmvps.com/xperts64


    "Papa Smurf" <> wrote in message
    news:...
    > Thanks Charlie, but I am still stumped. I remember seeing this stuff
    > before
    > when I first got my machine, but alas it seems lost. When I look up
    > "ownership" in the help files, I get this:
    >
    > To take ownership of a file or folder
    > Open Windows Explorer, and then locate the file or folder you want to take
    > ownership of.
    > Right-click the file or folder, click Properties, and then click the
    > Security tab.
    > Click Advanced, and then click the Owner tab.
    > In the Change owner to box, click the new owner.
    > (Optional) To change the owner of all subcontainers and objects within the
    > tree, select the Replace owner on subcontainers and objects check box.
    > Notes
    >
    > To open Windows Explorer, click Start, point to All Programs, point to
    > Accessories, and then click Windows Explorer.
    > If you are not joined to a domain and want to view the Security tab, see
    > To
    > display the Security tab.
    > You can transfer ownership in two ways:
    > The current owner can grant the Take ownership permission to others,
    > allowing those users to take ownership at any time.
    > An administrator can take ownership of any file on the computer. However,
    > the administrator cannot transfer ownership to others. This restriction
    > keeps
    > the administrator accountable.
    > In Windows XP Professional, the Everyone group no longer includes the
    > Anonymous Logon group.
    >
    > Soooo, since I see a "Sharing and Security" tab and not see a "Security"
    > tab, I figured I was on the right track. However, I do not have an
    > "Advanced"
    > button nor a "Owner" tab within this "sharing and Security" tab. Is
    > something
    > turned off perhaps? I am the admin. Also the folder options have "Simple
    > File
    > Sharing" checked on. Any thoughts? This is troublesome. P.S. I have read
    > Steve's response, but the path kind of leads me back to this wall. Tia,
    > Gary
    >
    > "Charlie Russel - MVP" wrote:
    >
    >> check the properties of the drive itself. And clear the inheritance check
    >> box as well. And if all else fails, take ownership of the drive and/or
    >> the
    >> folder.
    >>
    >> --
    >> Charlie.
    >> http://msmvps.com/xperts64
    >>
    >>
    >> "Papa Smurf" <> wrote in message
    >> news:...
    >> > AMD 3800+
    >> > XP64 Pro
    >> > C/D/F Drives
    >> >
    >> > File folders under logical D-drive are always attributed with Read-Only
    >> > (green box - not checked). If I click on the green box for any of the
    >> > folders, I can click the box to get a check mark or a blank box. If I
    >> > chose
    >> > either the check mark or the blank box (blank box is the one I want),
    >> > and
    >> > propagate all the files and sub folders, The attributes do not change!
    >> > If
    >> > you
    >> > go back into the properties of the folder, it has reverted back to the
    >> > green
    >> > box (or never changed in the first place). For the life of me, I cannot
    >> > figure this out. The D-drive is shared via the "Sharing and Security"
    >> > tab.
    >> > I
    >> > can open files on this drive, but if I wish to "Save As" I get the
    >> > warning:
    >> > "File cannot be opened. Check the read only attribute". Any suggestions
    >> > would
    >> > be greatly appreciated. Gary.

    >>
    Charlie Russel - MVP, Nov 16, 2006
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Add Subtract

    Remove "Read Only" Attribute?

    Add Subtract, Jul 15, 2003, in forum: Computer Support
    Replies:
    6
    Views:
    35,479
    Shep©
    Jul 15, 2003
  2. Add Subtract

    Re: Remove "Read Only" Attribute?

    Add Subtract, Jul 18, 2003, in forum: Computer Support
    Replies:
    0
    Views:
    781
    Add Subtract
    Jul 18, 2003
  3. anthonyberet

    changing read-only file attribute in batch

    anthonyberet, Feb 21, 2004, in forum: Computer Support
    Replies:
    9
    Views:
    20,986
    nospam
    Feb 25, 2004
  4. ashjas
    Replies:
    8
    Views:
    1,264
  5. =?Utf-8?B?UGFwYSBTbXVyZg==?=

    Newbie question - Read-Only Attribute Removal - Re-visited

    =?Utf-8?B?UGFwYSBTbXVyZg==?=, Nov 16, 2006, in forum: Windows 64bit
    Replies:
    5
    Views:
    384
    Charlie Russel - MVP
    Nov 16, 2006
Loading...

Share This Page