Newbie Question: 802.1q and VLAN interfaces on 877w

Discussion in 'Cisco' started by James.Brown, Jul 21, 2007.

  1. James.Brown

    James.Brown Guest

    All,

    I'm planning to buy my first Cisco router, an 877w. Could anyone take
    a quick look at my ideas below and let me know if this can be achieved
    with an Advanced IP Services image please?

    I have 2x Cisco 7941 phones (old phones from work), a static /29 block
    from my ISP (PPPoA connection) and a few PCs on the local network.

    I would like to give the 7941's an address from the static ISP-
    allocated range. Any traffic from the phones should be routed without
    NAT, directly to the ISP's gateway. PCs plugged into the spare port on
    the back of the phones should receive a 192.168.0.x address and be
    NAT'ed on their way to the internet. PCs attached to wireless would
    act in the same way as the PC's hooked up to the back of the phones.

    I think this can be achieved using 802.1Q VLAN trunking and layer 3
    VLAN interfaces on the router, but I'm only a newbie. Could anyone
    confirm please?

    * There would be two VLANS trunked through fa0/0-3. The PCs would be
    in the Native VLAN, the phones in a trunked VLAN .

    * The Wireless interface would have only the Native VLAN, since there
    is no possibility to attach phones.

    * Each VLAN would have it's own VLAN interface with a seperate DHCP
    pool.

    * One DHCP pool would contain the /29 from the ISP (minus one address,
    used by the ATM0 interface) to be allocated to the phones, the other
    DHCP pool would contain the 192.168.0.x/24 range, for allocation to
    the PCs.

    * The VLAN interface for the PCs would have an "IP nat inside source"
    statement

    * The VLAN interface for the Phones would not require this statement

    * The ATM0 interface would have an "IP nat outside" statement and an
    associated dialer interface.

    Does the above sound plausible on this entry-level router?

    One question I don't know the answer to is, how will the phones know
    to use the trunked VLAN rather than the native? Do they need some kind
    of special setting to ask them to only send traffic along the trunk,
    while leaving the native for an attached PC?

    Sorry this has been such a long explanation and thank you to anyone
    who responds.

    All the best

    James.
     
    James.Brown, Jul 21, 2007
    #1
    1. Advertising

  2. James.Brown

    Arthur Brain Guest

    A few random toughts

    > * There would be two VLANS trunked through fa0/0-3. The PCs would be
    > in the Native VLAN, the phones in a trunked VLAN .


    OK.
    Each interface is configured as a dot1q trunk with a sub-interface
    configured as dot1q in VLAN 20 (for example)

    Check that your router supports dot1q trunking, and check its Config
    Guide for the exact format for creating a dot1q trunk.

    > * The Wireless interface would have only the Native VLAN, since there
    > is no possibility to attach phones.


    Just use a normal interface config for it in the same VLAN as the
    above native VLAN

    > * Each VLAN would have it's own VLAN interface with a seperate DHCP
    > pool.


    Make sure your router supports VLAN interfaces and check config guide
    for how to configure them.

    > * One DHCP pool would contain the /29 from the ISP (minus one address,
    > used by the ATM0 interface) to be allocated to the phones, the other
    > DHCP pool would contain the 192.168.0.x/24 range, for allocation to
    > the PCs.


    Don't forget the IP-HELPER address on the VLAN 20 interface.

    > One question I don't know the answer to is, how will the phones know
    > to use the trunked VLAN rather than the native? Do they need some kind
    > of special setting to ask them to only send traffic along the trunk,
    > while leaving the native for an attached PC?


    The phones have a trunked interface in them, and a normal switched
    interface to the PC.

    For an all-cisco environment, you configure the trunk for example:

    interface FastEthernet1/0/31
    switchport access vlan 10
    switchport voice vlan 20

    Otherwise:

    interface GigabitEthernet1/0/4
    switchport trunk encapsulation dot1q
    switchport trunk native vlan 10
    switchport mode trunk
    switchport trunk allowed vlan 10,20

    But check your router Config Guide for the exact commands you need to
    achieve something similar.
     
    Arthur Brain, Jul 23, 2007
    #2
    1. Advertising

  3. James.Brown

    Arthur Brain Guest

    Arthur Brain wrote:
    ...
    > The phones have a trunked interface in them, and a normal switched
    > interface to the PC.
    >
    > For an all-cisco environment, you configure the trunk for example:
    >
    > interface FastEthernet1/0/31
    > switchport access vlan 10
    > switchport voice vlan 20
    >
    > Otherwise:
    >
    > interface GigabitEthernet1/0/4
    > switchport trunk encapsulation dot1q
    > switchport trunk native vlan 10
    > switchport mode trunk
    > switchport trunk allowed vlan 10,20
    >
    > But check your router Config Guide for the exact commands you need to
    > achieve something similar.


    I forgot the most important question your question was begging....

    What are you going to do with your phones?
    They won't be any use unless they can register with a GK to set calls
    up to/from them, ie, Cisco Call Manager needs to admin them.

    You'd have to be pretty whiz-bang to write your own app to do call
    setup & signalling, etc..
    Better start reading the Encyclopaedia of H.323/Q.931.....

    Maybe there is an open-source app for doing it?
     
    Arthur Brain, Jul 23, 2007
    #3
  4. James.Brown

    James.Brown Guest

    On 23 Jul, 05:59, Arthur Brain <> wrote:
    > Arthur Brain wrote:
    >
    > ...
    >
    >
    >
    > > The phones have a trunked interface in them, and a normal switched
    > > interface to the PC.

    >
    > > For an all-cisco environment, you configure the trunk for example:

    >
    > > interface FastEthernet1/0/31
    > > switchport access vlan 10
    > > switchport voice vlan 20

    >
    > > Otherwise:

    >
    > > interface GigabitEthernet1/0/4
    > > switchport trunk encapsulation dot1q
    > > switchport trunk native vlan 10
    > > switchport mode trunk
    > > switchport trunk allowed vlan 10,20

    >
    > > But check your router Config Guide for the exact commands you need to
    > > achieve something similar.

    >
    > I forgot the most important question your question was begging....
    >
    > What are you going to do with your phones?
    > They won't be any use unless they can register with a GK to set calls
    > up to/from them, ie, Cisco Call Manager needs to admin them.
    >
    > You'd have to be pretty whiz-bang to write your own app to do call
    > setup & signalling, etc..
    > Better start reading the Encyclopaedia of H.323/Q.931.....
    >
    > Maybe there is an open-source app for doing it?


    Hi Arthur,

    Thanks very much for your reply. I just have a couple of questions...

    > Each interface is configured as a dot1q trunk with a sub-interface
    > configured as dot1q in VLAN 20 (for example)


    Do we have to use sub interfaces, or would the "switchport voice vlan
    xxx" command you mentioned, also do the job?

    I've been looking through the feature comparison tool on CCO, but they
    don't seem to list the exact permitted commands per se. Is there
    anything I should be looking out for to determine whether VLAN
    interfaces are supported?

    > You'd have to be pretty whiz-bang to write your own app to do call
    > setup & signalling, etc..
    > Better start reading the Encyclopaedia of H.323/Q.931..


    I think others have done the hard work for me thankfully ;-) I'll run
    a SIP image on the phone, then connect to one of the many sip proxies
    - here in the UK, voip.co.uk have written their own app and it's
    rumoured to be quite Cisco friendly. They support G729 or G711 with
    RTP carrying the voice. Otherwise, http://www.asterisk.org.

    The 79x1 phones are a special case because unlike the 79x0 series,
    they do not support NAT, hence my requirement for an outside IP.

    All the best

    James.
     
    James.Brown, Jul 23, 2007
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Oli
    Replies:
    3
    Views:
    908
  2. No Spam
    Replies:
    3
    Views:
    4,036
    No Spam
    Jun 7, 2004
  3. Replies:
    5
    Views:
    8,193
    news_user
    Nov 5, 2005
  4. Replies:
    5
    Views:
    576
  5. James.Brown
    Replies:
    7
    Views:
    1,466
    James.Brown
    Aug 20, 2007
Loading...

Share This Page