Need help with Storage USB Device

Discussion in 'Computer Support' started by Fred J, Jan 9, 2004.

  1. Fred J

    Fred J Guest

    I bought OTi UStorage USB Device (64MB) when I plug it in the USB port
    it visible on the system tray that it is plugged in, but when I click on the
    MyComputer Icon
    there it doesn't show as removable disc, under removable storage I have only
    3 1/2 Floppy - CD-RW Drive - CD-Rom but not the removable disc this happens
    in WindXP Pro, on the same computer I have Wind ME there is no problem it
    has assigned letter and is working fine, but when I am in Windows XP I can
    not see it,
    among the installed drives, in the Device manager under USB Mass Storage
    Device
    tells this device works properly but I don't have an icon to open it.
    Any help would be appreciated Fred
     
    Fred J, Jan 9, 2004
    #1
    1. Advertising

  2. Fred J

    Billh Guest

    I can offer what happened to me. I have a Canon A80 digital camera. I hate
    installing software I do not need so I had hoped to just plug it in and see
    it as a removeable drive. Oddly it worked as I wanted on my Dell Desktop
    with XP Home that I had done a clean install on. But my new Dell Laptop
    with XP Pro did not find a driver for it. I found a driver for it on
    Canon's website. They claimed I did not need it with XP as it should be all
    ready installed but offered a download for it anyways. It worked fine after
    the install. So my feeling is some how the driver was not install by Dell
    as it should have.

    It was a WIA Driver that I was missing.

    So look at the device web site and look for a driver.

    "Fred J" <> wrote in message
    news:abELb.137805$...
    > I bought OTi UStorage USB Device (64MB) when I plug it in the USB port
    > it visible on the system tray that it is plugged in, but when I click on

    the
    > MyComputer Icon
    > there it doesn't show as removable disc, under removable storage I have

    only
    > 3 1/2 Floppy - CD-RW Drive - CD-Rom but not the removable disc this

    happens
    > in WindXP Pro, on the same computer I have Wind ME there is no problem it
    > has assigned letter and is working fine, but when I am in Windows XP I can
    > not see it,
    > among the installed drives, in the Device manager under USB Mass Storage
    > Device
    > tells this device works properly but I don't have an icon to open it.
    > Any help would be appreciated Fred
    >
    >
    >
     
    Billh, Jan 10, 2004
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Arawak
    Replies:
    0
    Views:
    1,306
    Arawak
    Aug 20, 2003
  2. porkscratching

    USB data storage device.

    porkscratching, Oct 19, 2003, in forum: Computer Support
    Replies:
    2
    Views:
    432
    slumpy
    Oct 19, 2003
  3. Paul Burdett

    USB Storage device help please

    Paul Burdett, Aug 1, 2004, in forum: Computer Support
    Replies:
    1
    Views:
    548
    Paul Burdett
    Aug 1, 2004
  4. Fred J

    Need help with Storage USB Device

    Fred J, Jan 9, 2004, in forum: Computer Information
    Replies:
    2
    Views:
    719
    GT Grand Prix 00
    Jan 13, 2004
  5. reachnisarga
    Replies:
    0
    Views:
    1,220
    reachnisarga
    Nov 23, 2010
Loading...

Share This Page