Need help with Cisco 1605R

Discussion in 'Cisco' started by Michael Thomsen, Mar 16, 2005.

  1. Hi

    Ive bought a Cisco 1605R to replace my router (a cheap D-Link)

    I had problem with the router and got this new one cheap.

    The router is going to be connected to a cabel modem, that has dynamic IP.

    The router is running with IOS version 11.2(9)P (Image file:
    c1600-y-mz.112.9.P)

    Now that im going to setup the router, I might as well update the IOS,
    but where do I get the file from?

    Can someone help me with configuring it?

    Ive just completet CCNA, so I know the basic commands. :)

    Regards Michael
    Michael Thomsen, Mar 16, 2005
    #1
    1. Advertising

  2. Michael Thomsen wrote:

    > Ive bought a Cisco 1605R to replace my router (a cheap D-Link)
    > I had problem with the router and got this new one cheap.
    >
    > The router is going to be connected to a cabel modem, that has dynamic IP.
    >
    > The router is running with IOS version 11.2(9)P (Image file:
    > c1600-y-mz.112.9.P)
    >
    > Now that im going to setup the router, I might as well update the IOS,
    > but where do I get the file from?
    >
    > Can someone help me with configuring it?


    That's about the same situation as i have. You probably want to do
    many-to-1 NAT and run a dhcp server for your LAN and DHCP client for
    your cable modem.

    This is my 1605r config. It's using ip-plus with a 8M flash card and
    24MB (8+16) ram. Image name flash:c1600-k8osy-mz.123-9b.bin.
    My cable modem is a Docsys (UPC - Chello Netherlands).

    I'm not sure if you can find all these features in a standard IP image
    or in your rather old IOS version.

    !
    version 12.3
    service timestamps debug datetime localtime
    service timestamps log datetime localtime
    service password-encryption
    !
    hostname rtr
    !
    boot-start-marker
    boot-end-marker
    !
    logging buffered 8192 debugging
    enable secret 5 <deleted>
    enable password 7 <deleted>
    !
    username <deleted> password <deleted>
    no aaa new-model
    ip subnet-zero
    !
    ip dhcp pool pool01
    network 192.168.24.0 255.255.255.0
    default-router 192.168.24.2
    dns-server <deleted>
    !
    ip cef
    !
    interface Ethernet0
    ip address dhcp client-id Ethernet0
    ip access-group 100 in
    no ip unreachables
    ip nat outside
    load-interval 30
    no cdp enable
    !
    interface Ethernet1
    description local LAN shack
    ip address 192.168.24.2 255.255.255.0
    ip nat inside
    load-interval 30
    !
    ip nat inside source list 7 interface Ethernet0 overload
    !
    ! this is for bittorrent and winmx p2p programs used on the .26 host
    ip nat inside source static tcp 192.168.24.26 6699 interface Ethernet0 6699
    ip nat inside source static udp 192.168.24.26 6699 interface Ethernet0 6699
    ip nat inside source static tcp 192.168.24.26 6881 interface Ethernet0 6881
    ip nat inside source static tcp 192.168.24.26 6882 interface Ethernet0 6882
    ip nat inside source static tcp 192.168.24.26 6883 interface Ethernet0 6883
    ip nat inside source static tcp 192.168.24.26 6884 interface Ethernet0 6884
    ip nat inside source static tcp 192.168.24.26 6885 interface Ethernet0 6885
    ip nat inside source static tcp 192.168.24.26 6886 interface Ethernet0 6886
    ip nat inside source static tcp 192.168.24.26 6887 interface Ethernet0 6887
    ip nat inside source static tcp 192.168.24.26 6888 interface Ethernet0 6888
    ip classless
    no ip http server
    no ip http secure-server
    !
    access-list 7 permit 192.168.24.0 0.0.0.255
    access-list 100 deny tcp any any eq telnet
    access-list 100 permit ip any any
    !
    snmp-server community <deleted> RW
    snmp-server enable traps tty
    !
    line con 0
    exec-timeout 0 0
    login local
    transport preferred all
    transport output all
    line vty 0 4
    exec-timeout 0 0
    password 7 <deleted>
    login local
    transport preferred all
    transport input all
    transport output all
    !
    ntp server <deleted>
    end

    --
    Joop van der Velden
    Joop van der Velden, Mar 16, 2005
    #2
    1. Advertising

  3. Wow

    Thanks..

    Your the greatest.!

    Regards Michael


    > Michael Thomsen wrote:
    >
    >
    >>Ive bought a Cisco 1605R to replace my router (a cheap D-Link)
    >>I had problem with the router and got this new one cheap.
    >>
    >>The router is going to be connected to a cabel modem, that has dynamic IP.
    >>
    >>The router is running with IOS version 11.2(9)P (Image file:
    >>c1600-y-mz.112.9.P)
    >>
    >>Now that im going to setup the router, I might as well update the IOS,
    >>but where do I get the file from?
    >>
    >>Can someone help me with configuring it?

    >
    >
    > That's about the same situation as i have. You probably want to do
    > many-to-1 NAT and run a dhcp server for your LAN and DHCP client for
    > your cable modem.
    >
    > This is my 1605r config. It's using ip-plus with a 8M flash card and
    > 24MB (8+16) ram. Image name flash:c1600-k8osy-mz.123-9b.bin.
    > My cable modem is a Docsys (UPC - Chello Netherlands).
    >
    > I'm not sure if you can find all these features in a standard IP image
    > or in your rather old IOS version.
    >
    > !
    > version 12.3
    > service timestamps debug datetime localtime
    > service timestamps log datetime localtime
    > service password-encryption
    > !
    > hostname rtr
    > !
    > boot-start-marker
    > boot-end-marker
    > !
    > logging buffered 8192 debugging
    > enable secret 5 <deleted>
    > enable password 7 <deleted>
    > !
    > username <deleted> password <deleted>
    > no aaa new-model
    > ip subnet-zero
    > !
    > ip dhcp pool pool01
    > network 192.168.24.0 255.255.255.0
    > default-router 192.168.24.2
    > dns-server <deleted>
    > !
    > ip cef
    > !
    > interface Ethernet0
    > ip address dhcp client-id Ethernet0
    > ip access-group 100 in
    > no ip unreachables
    > ip nat outside
    > load-interval 30
    > no cdp enable
    > !
    > interface Ethernet1
    > description local LAN shack
    > ip address 192.168.24.2 255.255.255.0
    > ip nat inside
    > load-interval 30
    > !
    > ip nat inside source list 7 interface Ethernet0 overload
    > !
    > ! this is for bittorrent and winmx p2p programs used on the .26 host
    > ip nat inside source static tcp 192.168.24.26 6699 interface Ethernet0 6699
    > ip nat inside source static udp 192.168.24.26 6699 interface Ethernet0 6699
    > ip nat inside source static tcp 192.168.24.26 6881 interface Ethernet0 6881
    > ip nat inside source static tcp 192.168.24.26 6882 interface Ethernet0 6882
    > ip nat inside source static tcp 192.168.24.26 6883 interface Ethernet0 6883
    > ip nat inside source static tcp 192.168.24.26 6884 interface Ethernet0 6884
    > ip nat inside source static tcp 192.168.24.26 6885 interface Ethernet0 6885
    > ip nat inside source static tcp 192.168.24.26 6886 interface Ethernet0 6886
    > ip nat inside source static tcp 192.168.24.26 6887 interface Ethernet0 6887
    > ip nat inside source static tcp 192.168.24.26 6888 interface Ethernet0 6888
    > ip classless
    > no ip http server
    > no ip http secure-server
    > !
    > access-list 7 permit 192.168.24.0 0.0.0.255
    > access-list 100 deny tcp any any eq telnet
    > access-list 100 permit ip any any
    > !
    > snmp-server community <deleted> RW
    > snmp-server enable traps tty
    > !
    > line con 0
    > exec-timeout 0 0
    > login local
    > transport preferred all
    > transport output all
    > line vty 0 4
    > exec-timeout 0 0
    > password 7 <deleted>
    > login local
    > transport preferred all
    > transport input all
    > transport output all
    > !
    > ntp server <deleted>
    > end
    >
    michael thomsen, Mar 16, 2005
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Hugh William Collier-Byrd

    Cisco 1605R PPPoE ADSL Troubles

    Hugh William Collier-Byrd, Jul 17, 2003, in forum: Cisco
    Replies:
    3
    Views:
    3,019
    Hugh William Collier-Byrd
    Jul 21, 2003
  2. Jaap Hubert
    Replies:
    3
    Views:
    2,955
    Walter Roberson
    Jan 18, 2005
  3. Replies:
    2
    Views:
    643
    aservin
    Jul 4, 2005
  4. rob
    Replies:
    8
    Views:
    4,603
    Wayne
    Jul 9, 2005
  5. dan

    Cisco 1605r RS232 port

    dan, Oct 7, 2005, in forum: Cisco
    Replies:
    0
    Views:
    398
Loading...

Share This Page