need clarification on trunking and setting up port-channel

Discussion in 'Cisco' started by Adam Przestroga, May 21, 2009.

  1. Hi,

    I need some clarification on setting up trunks and port-channels. I have
    two Cisco switches connected via trunk ports:

    1st cable Switch A (port 1) <--> Switch B (port 1)
    2nd cable Switch A (port 2) <--> Switch B (port 2)

    This is where I need clarification now. Is there a point to configure
    port-channel on these switches? What will I gain by doing so, also are
    there any reasons why I would not want to do it?

    Thanks,
    AP
    Adam Przestroga, May 21, 2009
    #1
    1. Advertising

  2. Adam Przestroga

    flamer Guest

    config:
    interface GigabitEthernet0/1
    switchport trunk allowed vlan 2-4094
    switchport mode trunk
    channel-group 1 mode desirable

    interface GigabitEthernet0/2
    switchport trunk allowed vlan 2-4094
    switchport mode trunk
    channel-group 1 mode desirable


    a few points:
    * config must match exactly on the two ports
    * allowed vlans at either end must have the exact same range
    * channel-group number (port channel number) must match all on
    interfaces and be unique

    you should either configure port channel or spanning tree, you might
    as well double your bandwidth and use a port channel.

    traffic will still get across one link if the other goes down so you
    aren't losing out on diversity.

    Flamer.
    flamer , May 22, 2009
    #2
    1. Advertising

  3. flamer wrote:
    > config:
    > interface GigabitEthernet0/1
    > switchport trunk allowed vlan 2-4094
    > switchport mode trunk
    > channel-group 1 mode desirable
    >
    > interface GigabitEthernet0/2
    > switchport trunk allowed vlan 2-4094
    > switchport mode trunk
    > channel-group 1 mode desirable
    >
    >
    > a few points:
    > * config must match exactly on the two ports
    > * allowed vlans at either end must have the exact same range
    > * channel-group number (port channel number) must match all on
    > interfaces and be unique
    >
    > you should either configure port channel or spanning tree, you might
    > as well double your bandwidth and use a port channel.
    >
    > traffic will still get across one link if the other goes down so you
    > aren't losing out on diversity.


    Flamer,

    Thank you for the provided information. Please allow me to ask a few
    more follow up questions.
    1. I understand that the configuration on each port (within a switch)
    must match, but what about the other switch? Do I need to configure
    port channel on the other switch as well? If so, what are the
    requirements for it then?
    2. Is it required to use the "switchport trunk allowed vlan 2-4094"
    statement? I think, that skipping it will allow vlans.
    3. What does the "mode desirable" stand for? I googled it, but could not
    find anything that I could easily comprehend.
    4. If I understood it correctly, the "Port-channel1" interface will be
    created automatically when I add the first physical interface to the
    "channel-group 1"? Do I need to tweak the settings of the
    "Port-channel1" interface once it is created?
    5. Without creating the "channel-group" (etherchannel), and having 2
    wires connecting the two switches the throughput between the two
    switches will be equal to the speed of a single interface and only one
    of them will be active at a time? What happens when this link fails? Is
    there a downtime till the link is established over the other wire?

    Thank you in advance for additional clarification.

    Regards,
    AP

    Thanks,
    AP
    Adam Przestroga, May 22, 2009
    #3
  4. Adam Przestroga

    Trendkill Guest

    On May 22, 12:00 am, Adam Przestroga <> wrote:
    > flamer wrote:
    > > config:
    > > interface GigabitEthernet0/1
    > >  switchport trunk allowed vlan 2-4094
    > >  switchport mode trunk
    > >  channel-group 1 mode desirable

    >
    > > interface GigabitEthernet0/2
    > >  switchport trunk allowed vlan 2-4094
    > >  switchport mode trunk
    > >  channel-group 1 mode desirable

    >
    > > a few points:
    > > * config must match exactly on the two ports
    > > * allowed vlans at either end must have the exact same range
    > > * channel-group number (port channel number) must match all on
    > > interfaces and be unique

    >
    > > you should either configure port channel or spanning tree, you might
    > > as well double your bandwidth and use a port channel.

    >
    > > traffic will still get across one link if the other goes down so you
    > > aren't losing out on diversity.

    >
    > Flamer,
    >
    > Thank you for the provided information. Please allow me to ask a few
    > more follow up questions.
    > 1. I understand that the configuration on each port (within a switch)
    > must match, but what  about the other switch? Do I need to configure
    > port channel on the other switch as well? If so, what are the
    > requirements for it then?
    > 2. Is it required to use the "switchport trunk allowed vlan 2-4094"
    > statement? I think, that skipping it will allow vlans.
    > 3. What does the "mode desirable" stand for? I googled it, but could not
    > find anything that I could easily comprehend.
    > 4. If I understood it correctly, the "Port-channel1" interface will be
    > created automatically when I add the first physical interface to the
    > "channel-group 1"? Do I need to tweak the settings of the
    > "Port-channel1" interface once it is created?
    > 5. Without creating the "channel-group" (etherchannel), and having 2
    > wires connecting the two switches the throughput between the two
    > switches will be equal to the speed of a single interface and only one
    > of them will be active at a time? What happens when this link fails? Is
    > there a downtime till the link is established over the other wire?
    >
    > Thank you in advance for additional clarification.
    >
    > Regards,
    > AP
    >
    > Thanks,
    > AP


    http://www.cisco.com/en/US/products...figuration_guide_chapter09186a00800f0a17.html

    And yes, you need to configure the channel on both sides/switches. If
    you don't, it works as you say, and yes there will be downtime as
    spanning-tree runs since one of those links should be blocking. With
    the channel, it's only one logical link, so there really isn't any
    disadvantages to the channel in a small network (other than your
    switches may not be able to push the throughput).
    Trendkill, May 22, 2009
    #4
  5. Adam Przestroga

    Thrill5 Guest

    There is no advantage to using a 2-port channel group here because you can't
    have just one port in a channel-group. In case of failure of one of the
    links, the channel-group will go down, and the remaining link will then come
    up as just a trunk instead of a channel-group member. Spanning-tree will
    then reconverge on the VLANs and you will have an outage while spanning-tree
    reconverges. Since this a fixed port switch to another fixed port switch,
    there really isn't much reason to run a channel. The chance of a
    single-port failure on a fixed port switch is much lower than the who thing
    going up in smoke. The guiding principle in building reliable networks is
    KEEP IT SIMPLE. Since the channel offers no value, I wouldn't use one in
    this instance.

    "Trendkill" <> wrote in message
    news:...
    On May 22, 12:00 am, Adam Przestroga <> wrote:
    > flamer wrote:
    > > config:
    > > interface GigabitEthernet0/1
    > > switchport trunk allowed vlan 2-4094
    > > switchport mode trunk
    > > channel-group 1 mode desirable

    >
    > > interface GigabitEthernet0/2
    > > switchport trunk allowed vlan 2-4094
    > > switchport mode trunk
    > > channel-group 1 mode desirable

    >
    > > a few points:
    > > * config must match exactly on the two ports
    > > * allowed vlans at either end must have the exact same range
    > > * channel-group number (port channel number) must match all on
    > > interfaces and be unique

    >
    > > you should either configure port channel or spanning tree, you might
    > > as well double your bandwidth and use a port channel.

    >
    > > traffic will still get across one link if the other goes down so you
    > > aren't losing out on diversity.

    >
    > Flamer,
    >
    > Thank you for the provided information. Please allow me to ask a few
    > more follow up questions.
    > 1. I understand that the configuration on each port (within a switch)
    > must match, but what about the other switch? Do I need to configure
    > port channel on the other switch as well? If so, what are the
    > requirements for it then?
    > 2. Is it required to use the "switchport trunk allowed vlan 2-4094"
    > statement? I think, that skipping it will allow vlans.
    > 3. What does the "mode desirable" stand for? I googled it, but could not
    > find anything that I could easily comprehend.
    > 4. If I understood it correctly, the "Port-channel1" interface will be
    > created automatically when I add the first physical interface to the
    > "channel-group 1"? Do I need to tweak the settings of the
    > "Port-channel1" interface once it is created?
    > 5. Without creating the "channel-group" (etherchannel), and having 2
    > wires connecting the two switches the throughput between the two
    > switches will be equal to the speed of a single interface and only one
    > of them will be active at a time? What happens when this link fails? Is
    > there a downtime till the link is established over the other wire?
    >
    > Thank you in advance for additional clarification.
    >
    > Regards,
    > AP
    >
    > Thanks,
    > AP


    http://www.cisco.com/en/US/products...figuration_guide_chapter09186a00800f0a17.html

    And yes, you need to configure the channel on both sides/switches. If
    you don't, it works as you say, and yes there will be downtime as
    spanning-tree runs since one of those links should be blocking. With
    the channel, it's only one logical link, so there really isn't any
    disadvantages to the channel in a small network (other than your
    switches may not be able to push the throughput).
    Thrill5, May 23, 2009
    #5
  6. Thrill5 wrote:
    > There is no advantage to using a 2-port channel group here because you can't
    > have just one port in a channel-group. In case of failure of one of the
    > links, the channel-group will go down, and the remaining link will then come
    > up as just a trunk instead of a channel-group member. Spanning-tree will
    > then reconverge on the VLANs and you will have an outage while spanning-tree
    > reconverges. Since this a fixed port switch to another fixed port switch,
    > there really isn't much reason to run a channel. The chance of a
    > single-port failure on a fixed port switch is much lower than the who thing
    > going up in smoke. The guiding principle in building reliable networks is
    > KEEP IT SIMPLE. Since the channel offers no value, I wouldn't use one in
    > this instance.



    Thank you for taking time and explaining this.
    Regards,
    AP
    Adam Przestroga, May 23, 2009
    #6
  7. Adam Przestroga

    bod43 Guest

    On 23 May, 04:16, Adam Przestroga <> wrote:
    > Thrill5 wrote:
    > > There is no advantage to using a 2-port channel group here because you can't
    > > have just one port in a channel-group. In case of failure of one of the
    > > links, the channel-group will go down, and the remaining link will then come
    > > up as just a trunk instead of a channel-group member.  


    Hmm. I don't think that is the case. I can't test for the present
    but I have done a fair bit of work with EtherChannels in the
    past I am sure I would have noticed this.
    Maybe some platforms do this, but I would call it a bug.


    > > KEEP IT SIMPLE.  


    This is always a good plan.

    You can use RSTP to get fast convergence on reasonably
    recent kit. The one real disadvantage of using a channel
    for resilience is that it is more difficult to make changes to
    the port confiuration without risking an outage. This is due
    to the strict requirements regarding similarity of configuration
    of ports participating in a channel.

    Of course if you are well organised and practise change
    control that will never be necessary;-)
    bod43, May 24, 2009
    #7
  8. Adam Przestroga

    drum2000

    Joined:
    Mar 9, 2009
    Messages:
    1
    This is not correct. A channel-group can have only one active member. A two port channel-group will not go down if one member fails.

    One additional advantage is that the port channel increases the bandwidth between the two devices. However, connections across the port-channel can only use one path, so any two endpoint devices will be limited to the max available on one of the ports in the channel-group. Hosts don't get one 2 Gbps connection, but a choice of 2@1Gbps.
    drum2000, Sep 8, 2009
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. hari
    Replies:
    7
    Views:
    1,359
  2. Replies:
    1
    Views:
    511
    kaydigi
    Oct 10, 2005
  3. unknown
    Replies:
    6
    Views:
    12,326
    unknown
    May 25, 2006
  4. Replies:
    0
    Views:
    523
  5. Steven Carr
    Replies:
    3
    Views:
    2,957
    Steven Carr
    Oct 17, 2007
Loading...

Share This Page