NAT Setup

Discussion in 'Cisco' started by Brian Desmond, May 25, 2005.

  1. Hi,

    I'm struggling to get NAT working on a 2514 with my DSL link. I've
    gotten it such that I can ping the DSL gateway from the LAN and the
    router, but, I can't get any further than that. The LAN is pretty
    simple:

    192.168.12.0/24-[2514/e0]<>[2514/e1]-66.58.26.112/30

    ..113 is the DSL gateway and .114 is the IP I use

    I've pasted config & ver dumps are below.

    Thanks!
    --Brian Desmond

    Gnvw-2514-01#sh run
    Building configuration...

    Current configuration : 1739 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname Gnvw-2514-01
    !
    !
    clock timezone CST -6
    ip subnet-zero
    no ip domain-lookup
    ip domain-name greenview.local
    ip name-server 192.168.12.11
    ip dhcp excluded-address 192.168.12.1 192.168.12.20
    ip dhcp ping packets 4
    !
    ip dhcp pool 192.168.12.0/24
    network 192.168.12.0 255.255.255.0
    default-router 192.168.12.1
    dns-server 192.168.12.11 192.168.12.12
    domain-name greenview.local
    netbios-name-server 192.168.12.12
    lease 7
    !
    no ip bootp server
    !
    !
    !
    interface Ethernet0
    description 192.168.12.0/24 LAN
    ip address 192.168.12.1 255.255.255.0
    ip nat inside
    !
    interface Ethernet1
    description DSL Link
    ip address 66.58.26.114 255.255.255.252
    ip nat outside
    no cdp enable
    !
    interface Serial0
    description 192.168.4.1
    no ip address
    shutdown
    !
    interface Serial1
    description 192.168.3.1
    no ip address
    shutdown
    !
    ip default-gateway 66.58.26.113
    ip nat pool Internet 66.58.26.114 66.58.26.114 netmask 255.255.255.0
    ip nat inside source list 1 pool Internet overload
    ip nat inside source static tcp 192.168.12.11 80 66.58.26.114 80
    extendable
    ip nat inside source static tcp 192.168.12.11 53 66.58.26.114 53
    extendable
    ip nat inside source static udp 192.168.12.11 53 66.58.26.114 53
    extendable
    ip nat inside source static tcp 192.168.12.11 3389 66.58.26.114 3389
    extendable
    ip classless
    ip route 0.0.0.0 0.0.0.0 Ethernet1
    no ip http server
    !
    access-list 1 permit 192.168.12.0 0.0.0.255
    access-list 11 permit 192.168.12.11
    !
    !
    line con 0
    password 7 02010B550A1016
    logging synchronous
    login
    line aux 0
    line vty 0 4
    password 7 00031C08054D12
    logging synchronous
    login
    !
    end

    Gnvw-2514-01#
    Gnvw-2514-01#
    Gnvw-2514-01#sh ver
    Cisco Internetwork Operating System Software
    IOS (tm) 2500 Software (C2500-JS-L), Version 12.2(23), RELEASE SOFTWARE
    (fc2)
    Copyright (c) 1986-2004 by cisco Systems, Inc.
    Compiled Wed 28-Jan-04 16:35 by kellmill
    Image text-base: 0x0307D260, data-base: 0x00001000

    ROM: System Bootstrap, Version 5.2(5), RELEASE SOFTWARE
    BOOTLDR: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(5), RELEASE
    SOFTWARE (fc1)

    Gnvw-2514-01 uptime is 1 week, 1 day, 2 hours, 39 minutes
    System returned to ROM by reload
    System image file is "flash:c2500-js-l.122-23.bin"

    cisco 2500 (68030) processor (revision D) with 16384K/2048K bytes of
    memory.
    Processor board ID 01735578, with hardware revision 00000000
    Bridging software.
    X.25 software, Version 3.0.0.
    SuperLAT software (copyright 1990 by Meridian Technology Corp).
    TN3270 Emulation software.
    2 Ethernet/IEEE 802.3 interface(s)
    2 Serial network interface(s)
    32K bytes of non-volatile configuration memory.
    16384K bytes of processor board System flash (Read ONLY)

    Configuration register is 0x2102

    Gnvw-2514-01#
    Brian Desmond, May 25, 2005
    #1
    1. Advertising

  2. Brian Desmond

    Guest Guest

    Hello,

    Seems to me that your ISP is not advertising yet your network. When
    you ping the adsl GW from the lan, does the ip nat trans is filled? if so
    then the router is translating properly, it will be worthy to clear several
    times the translations pinging first the GW checking the trans and then
    pinging back internet to check again the trans. The previous will let you
    know how the translation is working.

    --
    2nd Law of Thermodynamics: Chaos will Reign.

    ///////////////////
    --Anthrax--
    //////////////////
    "Brian Desmond" <> wrote in message
    news:...
    > Hi,
    >
    > I'm struggling to get NAT working on a 2514 with my DSL link. I've
    > gotten it such that I can ping the DSL gateway from the LAN and the
    > router, but, I can't get any further than that. The LAN is pretty
    > simple:
    >
    > 192.168.12.0/24-[2514/e0]<>[2514/e1]-66.58.26.112/30
    >
    > .113 is the DSL gateway and .114 is the IP I use
    >
    > I've pasted config & ver dumps are below.
    >
    > Thanks!
    > --Brian Desmond
    >
    > Gnvw-2514-01#sh run
    > Building configuration...
    >
    > Current configuration : 1739 bytes
    > !
    > version 12.2
    > service timestamps debug uptime
    > service timestamps log uptime
    > service password-encryption
    > !
    > hostname Gnvw-2514-01
    > !
    > !
    > clock timezone CST -6
    > ip subnet-zero
    > no ip domain-lookup
    > ip domain-name greenview.local
    > ip name-server 192.168.12.11
    > ip dhcp excluded-address 192.168.12.1 192.168.12.20
    > ip dhcp ping packets 4
    > !
    > ip dhcp pool 192.168.12.0/24
    > network 192.168.12.0 255.255.255.0
    > default-router 192.168.12.1
    > dns-server 192.168.12.11 192.168.12.12
    > domain-name greenview.local
    > netbios-name-server 192.168.12.12
    > lease 7
    > !
    > no ip bootp server
    > !
    > !
    > !
    > interface Ethernet0
    > description 192.168.12.0/24 LAN
    > ip address 192.168.12.1 255.255.255.0
    > ip nat inside
    > !
    > interface Ethernet1
    > description DSL Link
    > ip address 66.58.26.114 255.255.255.252
    > ip nat outside
    > no cdp enable
    > !
    > interface Serial0
    > description 192.168.4.1
    > no ip address
    > shutdown
    > !
    > interface Serial1
    > description 192.168.3.1
    > no ip address
    > shutdown
    > !
    > ip default-gateway 66.58.26.113
    > ip nat pool Internet 66.58.26.114 66.58.26.114 netmask 255.255.255.0
    > ip nat inside source list 1 pool Internet overload
    > ip nat inside source static tcp 192.168.12.11 80 66.58.26.114 80
    > extendable
    > ip nat inside source static tcp 192.168.12.11 53 66.58.26.114 53
    > extendable
    > ip nat inside source static udp 192.168.12.11 53 66.58.26.114 53
    > extendable
    > ip nat inside source static tcp 192.168.12.11 3389 66.58.26.114 3389
    > extendable
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 Ethernet1
    > no ip http server
    > !
    > access-list 1 permit 192.168.12.0 0.0.0.255
    > access-list 11 permit 192.168.12.11
    > !
    > !
    > line con 0
    > password 7 02010B550A1016
    > logging synchronous
    > login
    > line aux 0
    > line vty 0 4
    > password 7 00031C08054D12
    > logging synchronous
    > login
    > !
    > end
    >
    > Gnvw-2514-01#
    > Gnvw-2514-01#
    > Gnvw-2514-01#sh ver
    > Cisco Internetwork Operating System Software
    > IOS (tm) 2500 Software (C2500-JS-L), Version 12.2(23), RELEASE SOFTWARE
    > (fc2)
    > Copyright (c) 1986-2004 by cisco Systems, Inc.
    > Compiled Wed 28-Jan-04 16:35 by kellmill
    > Image text-base: 0x0307D260, data-base: 0x00001000
    >
    > ROM: System Bootstrap, Version 5.2(5), RELEASE SOFTWARE
    > BOOTLDR: 3000 Bootstrap Software (IGS-RXBOOT), Version 10.2(5), RELEASE
    > SOFTWARE (fc1)
    >
    > Gnvw-2514-01 uptime is 1 week, 1 day, 2 hours, 39 minutes
    > System returned to ROM by reload
    > System image file is "flash:c2500-js-l.122-23.bin"
    >
    > cisco 2500 (68030) processor (revision D) with 16384K/2048K bytes of
    > memory.
    > Processor board ID 01735578, with hardware revision 00000000
    > Bridging software.
    > X.25 software, Version 3.0.0.
    > SuperLAT software (copyright 1990 by Meridian Technology Corp).
    > TN3270 Emulation software.
    > 2 Ethernet/IEEE 802.3 interface(s)
    > 2 Serial network interface(s)
    > 32K bytes of non-volatile configuration memory.
    > 16384K bytes of processor board System flash (Read ONLY)
    >
    > Configuration register is 0x2102
    >
    > Gnvw-2514-01#
    >




    Posted Via Usenet.com Premium Usenet Newsgroup Services
    ----------------------------------------------------------
    ** SPEED ** RETENTION ** COMPLETION ** ANONYMITY **
    ----------------------------------------------------------
    http://www.usenet.com
    Guest, May 25, 2005
    #2
    1. Advertising

  3. What do you mean not advertising my network? Everything's good with a
    linky in front of the dsl gateway...

    thx,
    brian
    Brian Desmond, May 25, 2005
    #3
  4. Your NAT syntax is incorrect, imho.

    Try something like this:

    interface Ethernet0
    ip address 192.168.12.1 255.255.255.0
    ip nat inside
    !
    interface Ethernet1
    ip address <your public ip address> 255.255.255.252
    ip nat outside
    !
    ip nat inside source list 7 interface Ethernet1 overload
    ip nat inside source static tcp 192.168.12.11 3389 int Ethernet1 3389
    ! put your other translations here

    ip classless
    !
    access-list 7 permit 192.168.12.0 0.0.0.255


    Plus all the other bells & whistles you want

    --
    Joop van der Velden -
    Joop van der Velden, May 25, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Rich

    Westell 327W (Verizon DSL) - NAT setup?

    Rich, Feb 26, 2006, in forum: Wireless Networking
    Replies:
    2
    Views:
    22,210
  2. Smokem

    Comment "setup" la Freebox en NAT...?

    Smokem, Dec 29, 2004, in forum: Computer Support
    Replies:
    1
    Views:
    424
    Rob K
    Dec 29, 2004
  3. =?Utf-8?B?UmFkYXIxNjU=?=

    Windows XP Setup Restarts the Setup Program

    =?Utf-8?B?UmFkYXIxNjU=?=, Dec 12, 2005, in forum: Windows 64bit
    Replies:
    21
    Views:
    3,052
    Colin Barnhorst
    Dec 14, 2005
  4. bthetford
    Replies:
    0
    Views:
    421
    bthetford
    May 30, 2007
  5. bthetford
    Replies:
    0
    Views:
    826
    bthetford
    May 30, 2007
Loading...

Share This Page