Nat-In-A-Stick Problem

Discussion in 'Cisco' started by Carlo, Sep 16, 2006.

  1. Carlo

    Carlo Guest

    Hy, I have some problem to configure LAB with NAT-IN-A-STICK
    This is my schema and configurations:

    Nat Router External Router
    +---------------+ +---------------+
    | | |Loop0 177.10.1.3
    | sec pri | | |
    +------+--------+ +------+--------+
    192.168.100.33 | 10.0.148.154 | 10.0.0148.153
    -----------+---+-----------------------+
    |
    +------+--------+
    | 192.168.100.2 |
    | gw .254 |
    | route add |
    +---------------+

    Nat Router
    ------------------------
    ip subnet-zero
    !
    interface Loopback0
    ip address 10.0.1.1 255.255.255.252
    ip nat outside
    !
    interface FastEthernet0
    ip address 192.168.100.33 255.255.255.0 secondary
    ip address 10.0.148.154 255.255.255.248
    ip nat inside
    ip policy route-map Nat-loop
    speed auto
    !
    ip nat pool MyExternal 10.0.148.155 10.0.148.156 prefix-length 29
    ip nat inside source list 11 pool MyExternal overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 10.0.148.153
    !
    access-list 11 remark "Usata per comunicare con ExternalRouter"
    access-list 11 permit 192.168.100.0 0.0.0.255
    access-list 102 remark "Usata dalla route-map Nat-loop"
    access-list 102 permit ip 192.168.100.0 0.0.0.255 any
    access-list 102 permit ip any 10.0.148.0 0.0.0.255
    access-list 177 remark "Per scopo debugging"
    access-list 177 permit icmp any any
    route-map Nat-loop permit 10
    match ip address 102
    set ip next-hop 10.0.1.2
    !
    ....end


    External Router
    ------------------------
    interface Loopback0
    ip address 177.10.1.3 255.255.255.0
    !
    interface Ethernet0
    ip address 10.0.148.153 255.255.255.0
    !
    interface ATM0
    ....
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 ATM0


    Route Statiche sul Pc
    ------------------------------------

    Route attive:
    Indirizzo rete Mask Gateway Interfaccia
    Metrica
    0.0.0.0 0.0.0.0 192.168.100.254 192.168.100.3
    20
    10.0.1.0 255.255.255.0 192.168.100.33 192.168.100.3
    1
    10.0.148.0 255.255.255.0 192.168.100.33 192.168.100.3
    1
    177.10.1.3 255.255.255.255 192.168.100.33 192.168.100.3
    1
    Gateway predef.: 192.168.100.254
    ===========================================================================
    Route permanenti:
    Nessuna



    ***************************

    Dal PC:
    C:\Documents and Settings\Administrator\Desktop>ping 177.10.1.3

    Esecuzione di Ping 177.10.1.3 con 32 byte di dati:

    Richiesta scaduta.

    Statistiche Ping per 177.10.1.3:
    Pacchetti: Trasmessi = 1, Ricevuti = 0,
    Persi = 1 (100% persi),
    Control-C
    ^C
    C:\Documents and Settings\Administrator\Desktop>


    Sul Nat Router:
    ----------------
    1w6d: IP: route map Nat-loop, item 10, permit
    1w6d: IP: FastEthernet0 to Loopback0 10.0.1.2
    1w6d: IP: route map Nat-loop, item 10, permit
    1w6d: IP: FastEthernet0 to Loopback0 10.0.1.2
    1w6d: IP: s=10.0.148.156 (FastEthernet0), d=177.10.1.3 (Loopback0),
    g=10.0.1.2,len 60, forward
    1w6d: ICMP type=8, code=0
    1w6d: IP: tableid=0, s=10.0.148.156 (Loopback0), d=177.10.1.3
    (FastEthernet0), routed via RIB
    1w6d: IP: s=10.0.148.156 (Loopback0), d=177.10.1.3 (FastEthernet0),
    g=10.0.148.153, len 60, forward
    1w6d: ICMP type=8, code=0
    1w6d: IP: route map Nat-loop, item 10, permit
    1w6d: IP: FastEthernet0 to Loopback0 10.0.1.2
    1w6d: IP: s=10.0.148.156 (FastEthernet0), d=177.10.1.3 (Loopback0),
    g=10.0.1.2,len 60, forward
    1w6d: ICMP type=8, code=0
    1w6d: IP: tableid=0, s=10.0.148.156 (Loopback0), d=177.10.1.3
    (FastEthernet0), routed via RIB
    1w6d: IP: s=10.0.148.156 (Loopback0), d=177.10.1.3 (FastEthernet0),
    g=10.0.148.153, len 60, forward
    1w6d: ICMP type=8, code=0
    1w6d: IP: tableid=0, s=177.10.1.3 (FastEthernet0), d=10.0.148.156
    (FastEthernet0), routed via RIB
    1w6d: IP: s=177.10.1.3 (FastEthernet0), d=10.0.148.156 (FastEthernet0),
    len 60,rcvd 3
    1w6d: ICMP type=0, code=0
    1w6d: ICMP: echo reply rcvd, src 177.10.1.3, dst 10.0.148.156


    NatRouter#sh ip nat trans
    Pro Inside global Inside local Outside local Outside
    global
    icmp 10.0.148.156:512 192.168.100.3:512 177.10.1.3:512
    177.10.1.3:512
    NatRouter#


    Sull'External Router:
    ---------------------------------
    ExternalRouter#
    *Mar 14 11:38:33.247: ICMP: echo reply sent, src 177.10.1.3, dst
    10.0.148.156
    *Mar 14 11:38:38.627: ICMP: echo reply sent, src 177.10.1.3, dst
    10.0.148.156


    It seems good the packets from PC to External Router between NAT router
    but the answer is seems not working fine.
    Why this?

    Thanks Carlo
     
    Carlo, Sep 16, 2006
    #1
    1. Advertising

  2. Carlo

    swapnendu

    Joined:
    Sep 13, 2006
    Messages:
    57
    swapnendu, Sep 16, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. jwv

    Sony Memory Stick Pro vs Standard Memory Stick

    jwv, Jul 17, 2003, in forum: Digital Photography
    Replies:
    13
    Views:
    1,067
    Godfrey DiGiorgi
    Jul 19, 2003
  2. Barry Lovelace

    Sony DSC-U30 Memory Stick vs. Memory Stick Pro

    Barry Lovelace, Feb 11, 2004, in forum: Digital Photography
    Replies:
    1
    Views:
    938
  3. fanfaron

    Memory stick pro is cheaper than normal memory stick

    fanfaron, Jun 6, 2004, in forum: Digital Photography
    Replies:
    2
    Views:
    552
    fanfaron
    Jun 7, 2004
  4. zxcvar
    Replies:
    3
    Views:
    933
    Joe Hotchkiss
    Nov 28, 2004
  5. eb7g
    Replies:
    3
    Views:
    606
    Larry
    Dec 9, 2004
Loading...

Share This Page