NAT for backup...

Discussion in 'Cisco' started by gkontos, Sep 29, 2006.

  1. gkontos

    gkontos

    Joined:
    Sep 29, 2006
    Messages:
    1
    Hi everybody,

    I’m experiencing a NAT problem here with my dynamic DSL. Here is the issue. I’ve configured a Cisco 836 router in front of a pix to use the ISDN backup interface when the DSL is down. So far so good the backup interface works fine. But I can’t seem to find any solution for NAT to the ISDN interface. Here is the config of the router:

    Code:
    version 12.3
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname cisco
    !
    no logging buffered
    enable secret ********************
    !
    username admin password ************
    no aaa new-model
    ip subnet-zero
    no ip source-route
    no ip domain lookup
    !
    !
    ip audit notify log
    ip audit po max-events 100
    no ftp-server write-enable
    isdn switch-type basic-net3
    isdn voice-call-failure 0
    !
    !
    !
    !
    !
    !
    !
    interface Ethernet0
     ip address 192.168.0.1 255.255.255.0
     ip nat inside
     no ip mroute-cache
     no cdp enable
    !
    interface Virtual-Template1
     no ip address
    !
    interface BRI0
     no ip address
     encapsulation ppp
     dialer pool-member 1
     isdn switch-type basic-net3
     no cdp enable
    !
    interface ATM0
     no ip address
     no ip mroute-cache
     no atm ilmi-keepalive
     pvc 8/35
      encapsulation aal5mux ppp dialer
      dialer pool-member 2
     !
     dsl operating-mode auto
     hold-queue 224 in
    !
    interface FastEthernet1
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet2
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet3
     no ip address
     duplex auto
     speed auto
    !
    interface FastEthernet4
     no ip address
     duplex auto
     speed auto
    !
    interface Dialer1
     ip address negotiated
     ip nat outside
     encapsulation ppp
     shutdown
     dialer pool 1
     dialer idle-timeout 30
     dialer string 8962545555
     dialer watch-group 1
     dialer-group 1
     no cdp enable
     ppp authentication pap chap callin
     ppp chap hostname username
     ppp chap password **************
     ppp pap sent-username usename password ******************
    !
    interface Dialer2
     ip address negotiated
     ip mtu 1492
     ip nat outside
     encapsulation ppp
     ip tcp adjust-mss 1452
     dialer pool 2
     dialer-group 2
     no cdp enable
     ppp authentication chap pap callin
     ppp chap hostname user@isp.tld
     ppp chap password ******************
     ppp pap sent-username user@isp.tld  password **************
    !
    ip nat inside source static 192.168.0.2 interface Dialer2
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer2
    ip route 0.0.0.0 0.0.0.0 Dialer1 80
    no ip http server
    no ip http secure-server
    !
    access-list 1 permit 192.168.0.0 0.0.0.255
    dialer-list 1 protocol ip permit
    no cdp run
    !
    line con 0
     exec-timeout 120 0
     no modem enable
     stopbits 1
    line aux 0
    line vty 0 4
     access-class 1 in
     exec-timeout 120 0
     login local
     length 0
    !
    scheduler max-task-time 5000
    no rcapi server
    !
    !
    !
    end
    
    
    I need the : ip nat inside source static 192.168.0.2 interface Dialer2
    Because this is the outside interface of my PIX which accepts some services. However, I can’t seem to find a way to NAT to interface Dialer1. (the backup)
    Any ideas will be much appreciated.

    George
     
    gkontos, Sep 29, 2006
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Silverstrand
    Replies:
    0
    Views:
    911
    Silverstrand
    Nov 24, 2005
  2. Christian Falch
    Replies:
    1
    Views:
    5,915
    Toolman Tim
    Jun 23, 2004
  3. The Babaloughesian

    How to backup registry without backup utility

    The Babaloughesian, Feb 27, 2005, in forum: Computer Support
    Replies:
    8
    Views:
    2,208
    Jim Byrd
    Feb 27, 2005
  4. skweetis
    Replies:
    0
    Views:
    1,226
    skweetis
    Dec 11, 2006
  5. Giuen
    Replies:
    0
    Views:
    1,241
    Giuen
    Sep 12, 2008
Loading...

Share This Page