Multiple IP's on Cisco 1750

Discussion in 'Cisco' started by JerryZ, Jun 18, 2006.

  1. JerryZ

    JerryZ Guest

    Hello,

    I have a Cisco 1750 with a WIC-1ENET connected to the Internet via an ISP
    provided DSL modem using PPPOE to do so.
    The ISP recently provided us with multiple IP's.
    The IP assigned for the PPPOE session is XXX.XXX.8.249 with a netmask of
    255.255.255.0, the IP's we have available are 8 but on a different subnet,
    XXX.XXX.3.16 to XXX.XXX.3.23 mask is 255.255.255.0 they state the gateway is
    XXX.XXX.8.1

    The Cisco Ethernet0 is connected via pppoe easy IP and correctly negotiates
    a session
    The FastEthernet0 has IP 192.168.0.1 assigned and using NAT option (Use WAN
    interface address for dynamic source address translation) all the hosts
    inside are able to surf the web. All the hosts inside have their IP fixed on
    the 192.168.0.x subnet.
    I also left a DHCP server running with addresses 192.168.0.100 - 150 so that
    roaming machines can connect with auto settings on their network cards.

    I need to create fixed routes between some of my inside machines and the
    fixed IP's I have available so that they can be accessed from the internet,
    Basically I need to be able to use DNS to be able to connect via the
    internet to the internal machines.
    one of them is a DVR server and being able to monitor it from the web is a
    necessity. also to be able to connect to some of the internal hosts to run
    VNC servers on them and be able for their users to connect to them is the
    other requirement.


    Here follows the current IOS configuration:

    Is there a way to acomplish this? please help.
    Thanks for your help

    Jerry


    !
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    no service tcp-small-servers
    no service udp-small-servers
    !
    hostname Cisco1750
    !
    enable password xxxxxxxxxxxxxxxxxxxxx
    !
    ip name-server yyy.yyy.yyy.yyy
    !
    ip subnet-zero
    ip domain-lookup
    ip routing
    vpdn enable
    no vpdn logging
    !
    vpdn-group pppoe
    request-dialin
    protocol pppoe
    !
    interface Dialer 1
    description connected to Internet
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    dialer-group 2
    dialer pool 1
    ppp authentication chap pap callin
    ppp chap hostname xxxxxxxxxxxxxxxxxxxxxxxxxx
    ppp chap password xxxxxxxxxxxxxxx
    ppp pap sent-username xxxxxxxxxxxxxxxx password xxxxxxxxxxxx
    !
    interface FastEthernet 0
    no shutdown
    description connected to EthernetLAN
    ip address 192.168.0.1 255.255.255.0
    ip nat inside
    keepalive 10
    ip tcp adjust-mss 1452
    !
    interface Ethernet 0
    no shutdown
    description connected to Internet
    no ip address
    no keepalive
    pppoe enable
    pppoe-client dial-pool-number 1
    !
    ! Access Control List 1
    !
    no access-list 1
    access-list 1 permit 192.168.0.0 0.0.0.255
    !
    ! Dialer Control List 2
    !
    no dialer-list 2
    dialer-list 2 protocol ip permit
    !
    ! Dynamic NAT
    !
    ip nat translation timeout 86400
    ip nat translation tcp-timeout 86400
    ip nat translation udp-timeout 300
    ip nat translation dns-timeout 60
    ip nat translation finrst-timeout 60
    ip nat inside source list 1 interface Dialer 1 overload
    !
    ! DHCP Server
    !
    service dhcp
    ip dhcp excluded-address 192.168.0.1 192.168.0.100
    ip dhcp excluded-address 192.168.0.151 192.168.0.254
    ip dhcp pool 1
    network 192.168.0.0 255.255.255.0
    default-router 192.168.0.1
    dns-server xxx.xxx.xxx.xxx yyy.yyy.yyy.yyy
    !
    router rip
    version 2
    network 192.168.0.0
    passive-interface Dialer 1
    no auto-summary
    !
    !
    ip classless
    !
    ! IP Static Routes
    ip route 0.0.0.0 0.0.0.0 Dialer 1
    no ip http server
    snmp-server community public RO
    snmp-server location xxxxxxxxxxxxxxxxxxxxxxxxxxx
    snmp-server contact xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.com
    !
    line console 0
    exec-timeout 0 0
    password xxxxxxxxxxxxxxxxxxxxx
    login
    !
    line vty 0 4
    password xxxxxxxxxxxxxxxxxxx
    login
    !
    end
    JerryZ, Jun 18, 2006
    #1
    1. Advertising

  2. I am glaid that I am not the only one who is wondering how to do
    this!!!!!!!!!


    :)


    JerryZ wrote:
    > Hello,
    >
    > I have a Cisco 1750 with a WIC-1ENET connected to the Internet via an ISP
    > provided DSL modem using PPPOE to do so.
    > The ISP recently provided us with multiple IP's.
    > The IP assigned for the PPPOE session is XXX.XXX.8.249 with a netmask of
    > 255.255.255.0, the IP's we have available are 8 but on a different subnet,
    > XXX.XXX.3.16 to XXX.XXX.3.23 mask is 255.255.255.0 they state the gateway is
    > XXX.XXX.8.1
    >
    > The Cisco Ethernet0 is connected via pppoe easy IP and correctly negotiates
    > a session
    > The FastEthernet0 has IP 192.168.0.1 assigned and using NAT option (Use WAN
    > interface address for dynamic source address translation) all the hosts
    > inside are able to surf the web. All the hosts inside have their IP fixed on
    > the 192.168.0.x subnet.
    > I also left a DHCP server running with addresses 192.168.0.100 - 150 so that
    > roaming machines can connect with auto settings on their network cards.
    >
    > I need to create fixed routes between some of my inside machines and the
    > fixed IP's I have available so that they can be accessed from the internet,
    > Basically I need to be able to use DNS to be able to connect via the
    > internet to the internal machines.
    > one of them is a DVR server and being able to monitor it from the web is a
    > necessity. also to be able to connect to some of the internal hosts to run
    > VNC servers on them and be able for their users to connect to them is the
    > other requirement.
    >
    >
    > Here follows the current IOS configuration:
    >
    > Is there a way to acomplish this? please help.
    > Thanks for your help
    >
    > Jerry
    >
    >
    > !
    > service timestamps debug uptime
    > service timestamps log uptime
    > service password-encryption
    > no service tcp-small-servers
    > no service udp-small-servers
    > !
    > hostname Cisco1750
    > !
    > enable password xxxxxxxxxxxxxxxxxxxxx
    > !
    > ip name-server yyy.yyy.yyy.yyy
    > !
    > ip subnet-zero
    > ip domain-lookup
    > ip routing
    > vpdn enable
    > no vpdn logging
    > !
    > vpdn-group pppoe
    > request-dialin
    > protocol pppoe
    > !
    > interface Dialer 1
    > description connected to Internet
    > ip address negotiated
    > ip mtu 1492
    > ip nat outside
    > encapsulation ppp
    > dialer-group 2
    > dialer pool 1
    > ppp authentication chap pap callin
    > ppp chap hostname xxxxxxxxxxxxxxxxxxxxxxxxxx
    > ppp chap password xxxxxxxxxxxxxxx
    > ppp pap sent-username xxxxxxxxxxxxxxxx password xxxxxxxxxxxx
    > !
    > interface FastEthernet 0
    > no shutdown
    > description connected to EthernetLAN
    > ip address 192.168.0.1 255.255.255.0
    > ip nat inside
    > keepalive 10
    > ip tcp adjust-mss 1452
    > !
    > interface Ethernet 0
    > no shutdown
    > description connected to Internet
    > no ip address
    > no keepalive
    > pppoe enable
    > pppoe-client dial-pool-number 1
    > !
    > ! Access Control List 1
    > !
    > no access-list 1
    > access-list 1 permit 192.168.0.0 0.0.0.255
    > !
    > ! Dialer Control List 2
    > !
    > no dialer-list 2
    > dialer-list 2 protocol ip permit
    > !
    > ! Dynamic NAT
    > !
    > ip nat translation timeout 86400
    > ip nat translation tcp-timeout 86400
    > ip nat translation udp-timeout 300
    > ip nat translation dns-timeout 60
    > ip nat translation finrst-timeout 60
    > ip nat inside source list 1 interface Dialer 1 overload
    > !
    > ! DHCP Server
    > !
    > service dhcp
    > ip dhcp excluded-address 192.168.0.1 192.168.0.100
    > ip dhcp excluded-address 192.168.0.151 192.168.0.254
    > ip dhcp pool 1
    > network 192.168.0.0 255.255.255.0
    > default-router 192.168.0.1
    > dns-server xxx.xxx.xxx.xxx yyy.yyy.yyy.yyy
    > !
    > router rip
    > version 2
    > network 192.168.0.0
    > passive-interface Dialer 1
    > no auto-summary
    > !
    > !
    > ip classless
    > !
    > ! IP Static Routes
    > ip route 0.0.0.0 0.0.0.0 Dialer 1
    > no ip http server
    > snmp-server community public RO
    > snmp-server location xxxxxxxxxxxxxxxxxxxxxxxxxxx
    > snmp-server contact xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.com
    > !
    > line console 0
    > exec-timeout 0 0
    > password xxxxxxxxxxxxxxxxxxxxx
    > login
    > !
    > line vty 0 4
    > password xxxxxxxxxxxxxxxxxxx
    > login
    > !
    > end
    Christopher W., Jun 22, 2006
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Alex
    Replies:
    4
    Views:
    3,302
    James
    May 8, 2004
  2. Sairam

    Problem with Cisco 1750

    Sairam, Jan 19, 2005, in forum: Cisco
    Replies:
    2
    Views:
    711
    Anthony
    Jan 19, 2005
  3. Amit Kaushal

    Copying configuration from Cisco 1750

    Amit Kaushal, Apr 11, 2005, in forum: Cisco
    Replies:
    2
    Views:
    2,560
    Amit Kaushal
    Apr 26, 2005
  4. william

    get log in Cisco 1750

    william, Jun 1, 2005, in forum: Cisco
    Replies:
    1
    Views:
    548
    Spencer Teran
    Jun 1, 2005
  5. Rene Kuhn
    Replies:
    0
    Views:
    851
    Rene Kuhn
    Dec 28, 2005
Loading...

Share This Page