Multilink with two T1s -- need sample config

Discussion in 'Cisco' started by Bob Wilson, Jul 16, 2004.

  1. Bob Wilson

    Bob Wilson Guest

    I haven't been out to this site yet. They say they have a Cisco 2560
    (another time they said 2561) with a T1, and are adding a second T1
    and want me to do the router part and multilink them.

    I can't find any info on 2560 series and don't think I've seen one,
    don't even know if they have T1 cards or CSU/DSU via the serial ports.
    I haven't talked to their technical person yet, so all that will get
    straightened out. Since one T1 is working right now, I"ll be able to
    set the second one up to match it.

    What I am unsure about is -- once I've got the two T1s firing okay and
    -- I think -- I configure ppp multilink on the interfaces, I don't
    know where or how to set the IP address they'll use, or maybe to use
    ip-unnumbered.

    I did RTFM, but the multilinking is discussed a lot more under BRI
    setups and didn't look like it would quite fit the same with PRI and I
    don't know how different PRI is going to be.

    Thanks in advance if someone can post me a piece of a working config
    with two T1s multilinked.

    Bob W.
     
    Bob Wilson, Jul 16, 2004
    #1
    1. Advertising

  2. On 15 Jul 2004 21:19:04 -0700, (Bob Wilson) wrote:

    >I haven't been out to this site yet. They say they have a Cisco 2560
    >(another time they said 2561) with a T1, and are adding a second T1
    >and want me to do the router part and multilink them.


    Could be a 2650 or 2651. I'm not familiar with a 2560 (though that
    doesn't mean it doesn't exist.

    >I can't find any info on 2560 series and don't think I've seen one,
    >don't even know if they have T1 cards or CSU/DSU via the serial ports.
    > I haven't talked to their technical person yet, so all that will get
    >straightened out. Since one T1 is working right now, I"ll be able to
    >set the second one up to match it.
    >
    >What I am unsure about is -- once I've got the two T1s firing okay and
    >-- I think -- I configure ppp multilink on the interfaces, I don't
    >know where or how to set the IP address they'll use, or maybe to use
    >ip-unnumbered.


    Well, what's on the other end? That will affect things...but in
    theory you should be able to bond them with ppp multilink. I've never
    bonded T1s though.

    >I did RTFM, but the multilinking is discussed a lot more under BRI
    >setups and didn't look like it would quite fit the same with PRI and I
    >don't know how different PRI is going to be.


    Are they PRIs or just standard T1s?

    --me
     
    Prince By-Tor, Jul 16, 2004
    #2
    1. Advertising

  3. Bob Wilson

    Bob Wilson Guest

    Prince,

    Thank you for responding -- I talked again to the non-technical person
    just now and learned that the router is a 2621. Makes me a lot more
    comfortable, as two T1s on a 2500 sounds like too much of a load. I
    still haven't gotten the number of the engineer so I don't know how it
    interfaces with the T1s -- if it's a 2600 series it could either have
    CSU/DSU module(s) or serial ones. And I THINK it connects to a single
    router at the provider end.

    I did search some more on past threads and now question whether these
    T1s even need to be multilinked, or if I just put the ideal parameters
    and same metric on both interfaces and let Cisco load-balance. Any
    thoughts? In either case I don't know how to assign the IP
    address(es). That's why it would help a lot to see a working ru.

    These guys are so non-technical that they want to set it up during
    business hours. I told them they would have Solitaire and that's
    about it. Battleship is out.

    Thanks again,

    Bob
     
    Bob Wilson, Jul 16, 2004
    #3
  4. On 16 Jul 2004 14:35:15 -0700, (Bob Wilson) wrote:

    >Prince,
    >
    >Thank you for responding -- I talked again to the non-technical person
    >just now and learned that the router is a 2621. Makes me a lot more
    >comfortable, as two T1s on a 2500 sounds like too much of a load.


    Me too...a 2621 should handle that no problem.

    >I
    >still haven't gotten the number of the engineer so I don't know how it
    >interfaces with the T1s -- if it's a 2600 series it could either have
    >CSU/DSU module(s) or serial ones. And I THINK it connects to a single
    >router at the provider end.
    >
    >I did search some more on past threads and now question whether these
    >T1s even need to be multilinked, or if I just put the ideal parameters
    >and same metric on both interfaces and let Cisco load-balance. Any
    >thoughts? In either case I don't know how to assign the IP
    >address(es). That's why it would help a lot to see a working ru.


    OK.

    If it's a single router at the other end, best to just weight both
    interfaces the same. Presumably you're using a routing protocol like
    BGP or something that will do load balancing...if BGP, be sure to add
    "maximum-paths 2" to your router bgp section.

    For IPs, just use a pair of /30 subnets...I would think the provider
    would give those but you never know. Assuming serial interfaces,
    then, you'd have something like:

    interface s0/0
    ip address 192.168.1.2 255.255.255.252

    interface s0/1
    ip address 192.168.1.6 255.255.255.252

    And the provider would have .1 and .5, respectively. Then, let's
    pretend you're using BGP, and your internal AS is 64000 and the
    provider's is 64500:

    router bgp 64000
    neighbor 192.168.1.1 remote-as 64500
    neighbor 192.168.1.1 soft-reconfiguration inbound
    neighbor 192.168.1.5 remote-as 64500
    neighbor 192.168.1.5 soft-reconfiguration inbound
    no auto-summary
    maximum-paths 2

    I'm oversimplifying...you probably want route-maps or prefix-lists
    blocking certain routes both ways but without knowing the exact
    topology I can't tell you for sure.

    Alternatively, you can just static it:

    ip route 0.0.0.0 0.0.0.0 s0/0
    ip route 0.0.0.0 0.0.0.0 s0/1

    (By pointing the routes at an interface, if one of the circuits goes
    down that particular static will drop out of the routing table so you
    don't lose 50% of your packets.)

    Again, replace the default with whatever specifics you might need if
    this is not an Internet connection.

    Let me know if you have further questions.

    >These guys are so non-technical that they want to set it up during
    >business hours. I told them they would have Solitaire and that's
    >about it. Battleship is out.


    That's not always so bad...the worst are the ones who THINK they are
    technical, insist that things be done a certain way, and then ask you
    to put a static route in...when you ask, "What's the next hop?" they
    say, "Next hop? What's that?"

    --me
     
    Prince By-Tor, Jul 18, 2004
    #4
  5. Bob Wilson

    AnyBody43 Guest

    Prince By-Tor <> wrote
    > On 16 Jul 2004 14:35:15 -0700, (Bob Wilson) wrote:


    > > And I THINK it connects to a single
    > >router at the provider end.
    > >
    > >I did search some more on past threads and now question whether these
    > >T1s even need to be multilinked, or if I just put the ideal parameters
    > >and same metric on both interfaces and let Cisco load-balance. Any
    > >thoughts? In either case I don't know how to assign the IP
    > >address(es). That's why it would help a lot to see a working ru.


    > If it's a single router at the other end, best to just weight both
    > interfaces the same. Presumably you're using a routing protocol like
    > BGP or something that will do load balancing...if BGP, be sure to add
    > "maximum-paths 2" to your router bgp section.


    MPPP and packet level load sharing have different behaviours.

    MPPP is VERY like a single higher speed link. The others are not.
    MPPP will have a lower 'hop latency' and does perfect load sharing.
    'Hop latency' is my term. It is the time taken to transmit
    all of the bits comprising the packet under consideration
    on to the wire. (Someone may know of a generally accepted term,
    Vincent?) It excludes the time taken for a bit to transit the wire.
    e.g. for a 1Mbps line and a 1,000 bit packet the hop latency
    will be 1ms.

    MPPP will use more CPU than CEF per packet or any of the
    'fast switching' per flow methods, however a 2621 would
    I guess be OK with 2 x T1 and MPPP.

    IIRC MPPP can be configured to bring down a link in the event that
    the error rate is over some threshold (or maybe I just made it up?).

    A search of CCO on [multilink ppp serial], 2nd hit is
    "Multilink PPP on Back-to-Back Routers with Multiple Serial Interfaces"
    I would guess that the configuration details there might help:)

    I suggest that you follow whatever recommendations your provider
    makes since you will most likely depend on them for support and
    there is no point in insisting on them doing something out
    of the ordinary unless you have very good reason.
     
    AnyBody43, Jul 18, 2004
    #5
  6. AnyBody43 wrote:

    > 'Hop latency' is my term. It is the time taken to transmit
    > all of the bits comprising the packet under consideration
    > on to the wire. (Someone may know of a generally accepted term,
    > Vincent?)


    That's 'transmission delay', IIRC.

    Regards,

    Marco.
     
    M.C. van den Bovenkamp, Jul 18, 2004
    #6
  7. Bob Wilson

    Bob Wilson Guest

    Marco, Prince,

    Thank you guys very much for the insights, info and references. I'll
    put all this together and look at that piece in CCO, and I think I"ll
    have a critical mass to do a good job with the situation I encounter
    when I go over there Tuesday nite.

    Best to all,

    Bob W.
     
    Bob Wilson, Jul 19, 2004
    #7
  8. Bob Wilson

    Bob Wilson Guest

    A last message to say thanks one more time -- I showed up at the
    facility today with way too many people watching over my shoulder.
    Company #1 hired me to do the job for Company #2 which was taking care
    of the client Company #3, God knows what they were charging for my
    time with all those markups... and long story short, I used the
    knowledge I've gained from you guys and especially AnyBody43 this past
    two days and bonded the two T1s and it worked without a hitch. When I
    rode away, they asked "Who WAS that masked man?"
     
    Bob Wilson, Jul 21, 2004
    #8
  9. Bob Wilson

    smoove Guest

    Here is the easy way

    create a multilink interface

    interface Multilink2
    description XXXXXXXX
    ip address XXXXXXXX 255.255.255.252
    ppp multilink
    no ppp multilink fragmentation
    multilink-group 2



    And then setup the interfaces


    interface Serial2/0
    no ip address
    encapsulation ppp
    service-module t1 timeslots 1-24
    service-module t1 remote-alarm-enable
    service-module t1 fdl ansi
    ppp multilink
    multilink-group 2
    !
    interface Serial2/1
    no ip address
    encapsulation ppp
    service-module t1 timeslots 1-24
    service-module t1 remote-alarm-enable
    service-module t1 fdl ansi
    ppp multilink
    multilink-group 2




    "Bob Wilson" <> wrote in message
    news:...
    >I haven't been out to this site yet. They say they have a Cisco 2560
    > (another time they said 2561) with a T1, and are adding a second T1
    > and want me to do the router part and multilink them.
    >
    > I can't find any info on 2560 series and don't think I've seen one,
    > don't even know if they have T1 cards or CSU/DSU via the serial ports.
    > I haven't talked to their technical person yet, so all that will get
    > straightened out. Since one T1 is working right now, I"ll be able to
    > set the second one up to match it.
    >
    > What I am unsure about is -- once I've got the two T1s firing okay and
    > -- I think -- I configure ppp multilink on the interfaces, I don't
    > know where or how to set the IP address they'll use, or maybe to use
    > ip-unnumbered.
    >
    > I did RTFM, but the multilinking is discussed a lot more under BRI
    > setups and didn't look like it would quite fit the same with PRI and I
    > don't know how different PRI is going to be.
    >
    > Thanks in advance if someone can post me a piece of a working config
    > with two T1s multilinked.
    >
    > Bob W.
     
    smoove, Aug 3, 2004
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. al

    two T1s

    al, Oct 23, 2003, in forum: Cisco
    Replies:
    2
    Views:
    547
    e-dub
    Oct 25, 2003
  2. Karnov
    Replies:
    1
    Views:
    8,690
    CCIE8122
    May 24, 2004
  3. Bonding two T1s

    , May 18, 2005, in forum: Cisco
    Replies:
    15
    Views:
    5,376
    zsazsa2011
    May 9, 2011
  4. Chris
    Replies:
    3
    Views:
    566
    Chris
    Jun 14, 2006
  5. Replies:
    6
    Views:
    7,641
    Hansang Bae
    Aug 30, 2006
Loading...

Share This Page