Multicast over a GRE tunnel

Discussion in 'Cisco' started by mamcb, Jun 26, 2007.

  1. mamcb

    mamcb

    Joined:
    Jun 26, 2007
    Messages:
    1
    I setup a GRE tunnel between two cisco 3725 routers following
    http://www.cisco.com/en/US/tech/tk828/technologies_configuration_example09186a00801a5aa2.shtml

    They are both running IOS c3725-ipbase-mz.123-9e.bin. When I do a show ip int brief they both show up/down! So I seem to have a problem with the protocol! I cannot ping the tunnel address at the far end. I have checked both of the tunnel interfaces and they seem fine.

    My IP cloud consists of some Nortel 7440 multiservice switches.

    I have looked all over the cisco site trying to find some troubleshooting
    information but, I don't see anything that applies.

    Here is a copy of my configs:

    ///////////////////////////////////////////////////
    MCast 1:

    ip multicast-routing
    frame-relay switching
    no ftp-server write-enable
    !
    !
    !
    !
    interface Loopback0
    ip address 2.2.2.2 255.255.255.255
    !
    interface Tunnel0
    ip address 192.168.0.1 255.255.255.0
    ip pim sparse-dense-mode
    tunnel source Loopback0
    tunnel destination 4.4.4.4
    !
    interface FastEthernet0/0
    ip address 10.120.255.1 255.255.255.0
    ip pim sparse-dense-mode
    speed 100
    full-duplex
    !
    interface Serial0/1
    ip address 10.120.254.1 255.255.255.0
    encapsulation frame-relay IETF
    ip ospf network point-to-point
    no fair-queue
    frame-relay interface-dlci 16
    frame-relay lmi-type q933a
    frame-relay intf-type dce
    !
    router ospf 1
    log-adjacency-changes
    network 2.2.2.2 0.0.0.0 area 0
    network 10.120.0.0 0.0.255.255 area 0
    network 192.168.0.0 0.0.0.255 area 0
    !
    ip classless
    no ip http server
    ip pim bidir-enable

    ////////////////////////////////////////////////////////

    MCast 4:

    no ip domain lookup
    ip multicast-routing
    frame-relay switching
    no ftp-server write-enable
    !
    !
    !
    !
    interface Loopback0
    ip address 4.4.4.4 255.255.255.255
    !
    interface Tunnel0
    ip address 192.168.0.2 255.255.255.0
    ip pim sparse-dense-mode
    tunnel source Loopback0
    tunnel destination 2.2.2.2
    !
    interface FastEthernet0/0
    ip address 10.120.244.1 255.255.255.0
    ip pim sparse-dense-mode
    duplex auto
    speed auto
    !
    interface Serial0/1
    ip address 10.120.245.1 255.255.255.0
    encapsulation frame-relay IETF
    ip ospf network point-to-point
    frame-relay interface-dlci 16
    frame-relay lmi-type q933a
    frame-relay intf-type dce
    !
    router ospf 1
    log-adjacency-changes
    network 4.4.4.4 0.0.0.0 area 0
    network 10.120.0.0 0.0.255.255 area 0
    network 192.168.0.0 0.0.0.255 area 0
    !
    ip classless
    no ip http server
    ip pim bidir-enable
    ip mroute 10.120.255.0 255.255.255.0 Tunnel0
    !

    ///////////////////////////////////////////////////////////


    Any help would be much appreciated. Thanks.

    Mark
     
    mamcb, Jun 26, 2007
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Derek Konigsberg
    Replies:
    1
    Views:
    3,130
    baktash
    Jul 27, 2009
  2. John Ireland
    Replies:
    1
    Views:
    1,137
    Claude LeFort
    Nov 11, 2003
  3. casatirider

    GRE tunnel over IPSEC

    casatirider, Jan 11, 2005, in forum: Cisco
    Replies:
    1
    Views:
    19,490
  4. parislubis@yahoo.com

    DECnet over GRE tunnel with serial interface

    parislubis@yahoo.com, Oct 5, 2005, in forum: Cisco
    Replies:
    1
    Views:
    874
    Steve
    Oct 6, 2005
  5. tsvanduyn@yahoo.com

    GRE Tunnel up/up Cannot ping tunnel interface

    tsvanduyn@yahoo.com, Mar 6, 2006, in forum: Cisco
    Replies:
    6
    Views:
    30,124
    tsvanduyn@yahoo.com
    Mar 9, 2006
Loading...

Share This Page