multi-(v)lan/protocols via etherchannel?

Discussion in 'Cisco' started by Kay Martinen, Dec 23, 2012.

  1. Kay Martinen

    Kay Martinen Guest

    Hello

    I am not shure if my english is good enough to describe my problem and to
    understand the answer(s) but i will do my best and hope someone can help me
    out.

    I have two cisco switches Model WS-C2924-XL-EN (one has two module slots,
    one not) both with IOS 12.0 Enterprise Software.

    I want to expand my home network down in the cellar where i have an emtpy
    rack. But i don't have any Cable down there and no way to have one. So i
    must use other techniques like powerline or wlan.

    One switch should stay in my rooms, one down in the rack. As interconnection
    i want a powerline and probably additional a wlan-connection (2 Accesspoints
    with Special antennas). I like to have this as bonded connection or maybe as
    failover.

    So far i know Cisco named it Etherchannel and this should be possible.

    But additionally i will use separete network segments with different
    protocols (one IP-Net, one Netbios, and probably an IPX Segment) which shall
    not be mixed.

    I believe a Switch in general is protocol-transparent. But there are some
    helpers for IP Networks, so i am not really shure if the switch don't care
    the protocols or if (and how) i can set it up so it can identify the
    protocol-types on a port. Thats why i believe i shall do it port-based and
    probably i need some VLANs for it.

    But i don't know if that is the best way and if vlans (binded to a group of
    ports) will do the job.

    I know i have to set it up so each vlan will go through the etherchannel to
    the other switch and there it should land on another group of ports.

    I know, its a lot of questions. Maybe i am totally wrong but i hope it is
    not.

    Below a quick drawing to help you understand what i mean.

    IP NB IPX <- Network-Segments
    ! ! !
    ============== Switch A
    |
    |
    | Etherchannel
    |
    |
    ============== Switch B
    ! ! !
    IP NB IPX <- Network-Segments


    Can one Help me out to find the right CLI Commands or similar to work this
    out. Thanks for any Answers.

    Kay
    (from Germany)
     
    Kay Martinen, Dec 23, 2012
    #1
    1. Advertising

  2. Kay Martinen

    tpheuk

    Joined:
    Jan 16, 2013
    Messages:
    11
    sample here

    !
    interface Port-channel1
    description BB-CSW-A02
    switchport trunk encapsulation dot1q
    switchport mode trunk
    ip arp inspection trust
    ip dhcp snooping trust
    !
    interface Port-channel2
    description BB-ASW-A01
    switchport trunk encapsulation dot1q
    switchport mode trunk
    ip arp inspection trust
    ip dhcp snooping trust
    !
    !
    interface GigabitEthernet0/45
    description ASW-A01
    switchport trunk encapsulation dot1q
    switchport mode trunk
    ip arp inspection trust
    channel-group 2 mode active
    ip dhcp snooping trust
    !
    interface GigabitEthernet0/46
    description ASW-A01
    switchport trunk encapsulation dot1q
    switchport mode trunk
    channel-group 2 mode active
    ip dhcp snooping trust
    !
    interface GigabitEthernet0/47
    description CSW-A02
    switchport trunk encapsulation dot1q
    switchport mode trunk
    ip arp inspection trust
    channel-group 1 mode active
    ip dhcp snooping trust
    !
    interface GigabitEthernet0/48
    description CSW-A02
    switchport trunk encapsulation dot1q
    switchport mode trunk
    ip arp inspection trust
    channel-group 1 mode active
    ip dhcp snooping trust
    !
    interface GigabitEthernet0/49

    more information http://cisconetworkingcenter.blogspot.com/2012/03/hot-standby-router-protocol-hsrp.html
     
    tpheuk, Jan 19, 2013
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. keithb

    Multi-vrf to Multi-vrf

    keithb, May 10, 2004, in forum: Cisco
    Replies:
    1
    Views:
    2,408
    Christophe Fillot
    May 10, 2004
  2. Tung Las Ying

    Using multi-media from multi-source

    Tung Las Ying, Nov 12, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    501
    Tung Las Ying
    Nov 12, 2004
  3. Replies:
    3
    Views:
    870
    Mike S.
    Jul 6, 2006
  4. Elia Spadoni

    VPN Lan-to-lan via Wireless Link

    Elia Spadoni, Mar 23, 2008, in forum: Cisco
    Replies:
    10
    Views:
    1,924
    News Reader
    Mar 23, 2008
  5. Thanatos

    Multi VPN / Multi Users

    Thanatos, Apr 6, 2010, in forum: Cisco
    Replies:
    0
    Views:
    873
    Thanatos
    Apr 6, 2010
Loading...

Share This Page