Mozilla & Firefox ignoring my Hosts file

Discussion in 'Firefox' started by Captain Infinity, Aug 10, 2004.

  1. I'm baffled. I'm running a Win XP Pro machine. IE used my hosts file very
    well. I've switched to Mozilla and then to Firefox and both ignore my
    hosts file.

    I've tried renaming it, as "hosts", "Hosts", and "HOSTS". I've tried
    placing it in
    c:\windows\system32\drivers\etc
    as well as
    c:\windows\system32
    and
    c:\windows

    No good. I still get connections to all the domains supposedly blocked.
    My system at home is Win XP Home edition and Mozilla accesses the hosts
    file just fine, and I get the annoying but soon-to-be fixed "connection
    refused" popup. So I know it's working there. But here at work, pffft!

    Any idea what might be going on?


    **
    Captain Infinity
     
    Captain Infinity, Aug 10, 2004
    #1
    1. Advertising

  2. Captain Infinity

    .BRIAN. Guest

    Captain Infinity wrote:
    > I'm baffled. I'm running a Win XP Pro machine. IE used my hosts file very
    > well. I've switched to Mozilla and then to Firefox and both ignore my
    > hosts file.
    >
    > I've tried renaming it, as "hosts", "Hosts", and "HOSTS". I've tried
    > placing it in
    > c:\windows\system32\drivers\etc
    > as well as
    > c:\windows\system32
    > and
    > c:\windows
    >
    > No good. I still get connections to all the domains supposedly blocked.
    > My system at home is Win XP Home edition and Mozilla accesses the hosts
    > file just fine, and I get the annoying but soon-to-be fixed "connection
    > refused" popup. So I know it's working there. But here at work, pffft!
    >
    > Any idea what might be going on?
    >
    >
    > **
    > Captain Infinity
    >


    Hmm... that's interesting, because the last time I checked, the host
    file is part of Windows -- not the browser. It's Windows (TCP/IP
    specifically) using the file, not the browser. But if I'm wrong,
    someone please let me know.

    Maybe you have extensions hidden and notepad (or whatever text editor
    you were using) saved it as a .txt file instead of just "hosts". Just a
    thought.

    Or maybe your work is using a proxy server which would bypass the
    "hosts" file.

    I don't understand why your configuration works with IE, but not
    Mozilla. Makes no sense to me at all. Please let us know when you
    figure out the solution.

    BTW, you can stop that "connection refused" popup by typing about:config
    in the address bar, then changing the following line from "false" to "true":

    _browser.xul.error_pages.enabled_

    --
    Brian

    Email Info -
    http://68.1.17.8/p0nykiller/email.htm
     
    .BRIAN., Aug 11, 2004
    #2
    1. Advertising

  3. Captain Infinity

    Andreas Guest

    ..BRIAN. wrote:

    > Captain Infinity wrote:
    >
    >> I'm baffled. I'm running a Win XP Pro machine. IE used my hosts file
    >> very
    >> well. I've switched to Mozilla and then to Firefox and both ignore my
    >> hosts file.
    >>
    >> I've tried renaming it, as "hosts", "Hosts", and "HOSTS". I've tried
    >> placing it in c:\windows\system32\drivers\etc
    >> as well as
    >> c:\windows\system32
    >> and
    >> c:\windows
    >>
    >> No good. I still get connections to all the domains supposedly blocked.
    >> My system at home is Win XP Home edition and Mozilla accesses the hosts
    >> file just fine, and I get the annoying but soon-to-be fixed "connection
    >> refused" popup. So I know it's working there. But here at work, pffft!
    >>
    >> Any idea what might be going on?
    >>
    >>
    >> ** Captain Infinity
    >>

    >
    > Hmm... that's interesting, because the last time I checked, the host
    > file is part of Windows -- not the browser. It's Windows (TCP/IP
    > specifically) using the file, not the browser. But if I'm wrong,
    > someone please let me know.
    >
    > Maybe you have extensions hidden and notepad (or whatever text editor
    > you were using) saved it as a .txt file instead of just "hosts". Just a
    > thought.
    >
    > Or maybe your work is using a proxy server which would bypass the
    > "hosts" file.
    >
    > I don't understand why your configuration works with IE, but not
    > Mozilla. Makes no sense to me at all. Please let us know when you
    > figure out the solution.
    >
    > BTW, you can stop that "connection refused" popup by typing about:config
    > in the address bar, then changing the following line from "false" to
    > "true":
    >
    > _browser.xul.error_pages.enabled_
    >

    I use my Hosts file all the time with no problems, and I have about
    10,000 entries. However, I do use it in conjunction with Spyblocker and
    it blocks 99% of the adds. Its now a shareware file, but you can still
    find the FREE version out there,
    http://www.freewarefiles.com/programs.php?categoryid=5&subcategoryid=180&ProgramID=1381

    It works great with my Mozilla.

    Andreas
    --
    Information wanted: http://www.ltinc.net/sass/
     
    Andreas, Aug 15, 2004
    #3
  4. Captain Infinity

    nlsteffens

    Joined:
    Aug 17, 2006
    Messages:
    2
    firefox ignoring hosts file

    If the hosts file is not working with mozilla firefox, clear the cache file by clicking tools->clear private data. Clear all fields except for 'cache' and then click on 'clear private data now'. Restart firefox. The hosts file should now work as expected.

    Regards,
    Nick
     
    nlsteffens, Aug 21, 2006
    #4
  5. Captain Infinity

    Mikha

    Joined:
    Sep 3, 2009
    Messages:
    1
    Tried on FireFox 3.5.2:

    1. Save updated Hosts file.
    2. Go to the file menu, mark 'work offline'
    3. Again go to the file menu, UNmark 'work offline'
    4. Refresh site - it should work now.
     
    Mikha, Sep 3, 2009
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Stig Ove Voll

    Ignoring multiple threads

    Stig Ove Voll, Mar 8, 2005, in forum: Firefox
    Replies:
    0
    Views:
    440
    Stig Ove Voll
    Mar 8, 2005
  2. Michael Orr

    IE ignoring Hosts File ?

    Michael Orr, Jun 28, 2004, in forum: Computer Support
    Replies:
    10
    Views:
    10,901
    Blinky the Shark
    Jun 30, 2004
  3. Joel Rubin

    Firefox ignoring don't allow right click pages?

    Joel Rubin, Oct 31, 2004, in forum: Computer Support
    Replies:
    0
    Views:
    810
    Joel Rubin
    Oct 31, 2004
  4. desoto

    Zone alarm ignoring settings

    desoto, Nov 12, 2004, in forum: Computer Support
    Replies:
    2
    Views:
    548
    mhicaoidh
    Nov 15, 2004
  5. spec
    Replies:
    7
    Views:
    1,335
    Peter
    Jun 5, 2006
Loading...

Share This Page