Mapping Problem

Discussion in 'Hardware' started by rangaprasad, Dec 4, 2008.

  1. rangaprasad

    rangaprasad

    Joined:
    Aug 8, 2008
    Messages:
    1
    Hello All,
    I have a substitute block in my design where 128 bit data is replaced by other 128 bit data. I have implemented a simple look up table with case statement to just assign output to the new value to be substituted. When I implement the design alone, the MAP process is assigning the block to 4 256 * 8 bit ROMs and both behavioral and place and route simulation are working fine. But when I implement the same design in a project where I have instantiated the substitute block, the MAP process is assigning the same to BLOCK RAM of 256 * 8 which has clock input (I did not send the clock to this module at all) and enable input. It is taking the enable pin from some other module which is no way in connection with this block.
    Can I somehow say MAPPER that to assign this block to ROMs instead of RAMs? or any other solution? I am using XILINX 10.1.3 and device family is XC3S1500-4FG456.
     
    rangaprasad, Dec 4, 2008
    #1
    1. Advertising

  2. rangaprasad

    bigal

    Joined:
    Jul 1, 2005
    Messages:
    1,483
    Location:
    Northern Virginia, USA
    Good luck with this question. Even I don't understand what you are doing and I'm an MSEE. How about some more background on the tools you are using? Do you have some links?
     
    bigal, Dec 6, 2008
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?QXN5bHVt?=

    Problem mapping some folders?

    =?Utf-8?B?QXN5bHVt?=, Mar 26, 2005, in forum: Wireless Networking
    Replies:
    1
    Views:
    433
  2. Jo Christian Buvarp

    Pix to pix vpn problem, mapping windows drive

    Jo Christian Buvarp, Jun 16, 2004, in forum: Cisco
    Replies:
    1
    Views:
    537
    Bill F
    Jun 21, 2004
  3. =?Utf-8?B?THVkcw==?=

    Mapping a network drive problem

    =?Utf-8?B?THVkcw==?=, Feb 26, 2007, in forum: Wireless Networking
    Replies:
    2
    Views:
    514
    =?Utf-8?B?THVkcw==?=
    Feb 26, 2007
  4. marv
    Replies:
    0
    Views:
    342
  5. =?Utf-8?B?QmFuYW5uYQ==?=

    Dell NAS Windows 2003 r2 NFS mapping problem

    =?Utf-8?B?QmFuYW5uYQ==?=, Aug 31, 2006, in forum: Windows 64bit
    Replies:
    0
    Views:
    411
    =?Utf-8?B?QmFuYW5uYQ==?=
    Aug 31, 2006
Loading...

Share This Page