Major problems roaming between access points

Discussion in 'Wireless Networking' started by =?Utf-8?B?ZmlsYnVydDE=?=, Sep 8, 2004.

  1. I have a problem similar to the KB article
    http://support.microsoft.com/default.aspx?scid=kb;en-us;828940 ; when I go to
    my campus and connect to one access point, the connection usually sticks.
    But, if I put my laptop to sleep and go to another access point, I am unable
    to connect to the network at all (although I am assigned an IP through DHCP
    successfully, no hostnames resolve).

    Often, rebooting does not help the problem, and in the rare event the
    connection is successful, I am usually kicked off a few seconds or minutes
    later. While I'm not sure, I believe this may have started after I installed
    SP2 (this is a clean installation of Windows XP Professional).

    When I try disabling the internal wireless connection, I am denied access so
    I cannot even attempt the listed workaround in the KB article.
    =?Utf-8?B?ZmlsYnVydDE=?=, Sep 8, 2004
    #1
    1. Advertising

  2. Filburt,
    This strongly seems like a driver issue. A great percentage of the problems
    that we find in troubleshooting wireless networking problems is the fact
    that there are less-than-fantastic network card drivers out there.

    In your scenario, you are most likely not getting a _new_ DHCP address after
    roaming to a different WiFi network, but rather holding on to the old one
    that you were given, because the card is not telling the OS that is has lost
    connectivity with the previous network. I would highly recommend that you:

    1) Update to the lastest version of the manufacturer's driver via their web
    site.
    2) Update your Windows installation to SP2. SP2 improves the visual and
    connection information presented to the user and works around various
    wireless networking problems found in SP1. There is much better security
    features in SP2 as well, which makes it worth your time.

    As to the problem of not being able to disable your network card, are you
    certain that you are using an administrator account? I am not sure if
    normal users can enable/disable interfaces.

    Please let me know if this works for you. I hope I can resolve your problem.

    Brian Wehrle

    Software Test Engineer/Wireless Networking
    Microsoft Corp.

    "filburt1" <> wrote in message
    news:...
    >I have a problem similar to the KB article
    > http://support.microsoft.com/default.aspx?scid=kb;en-us;828940 ; when I go
    > to
    > my campus and connect to one access point, the connection usually sticks.
    > But, if I put my laptop to sleep and go to another access point, I am
    > unable
    > to connect to the network at all (although I am assigned an IP through
    > DHCP
    > successfully, no hostnames resolve).
    >
    > Often, rebooting does not help the problem, and in the rare event the
    > connection is successful, I am usually kicked off a few seconds or minutes
    > later. While I'm not sure, I believe this may have started after I
    > installed
    > SP2 (this is a clean installation of Windows XP Professional).
    >
    > When I try disabling the internal wireless connection, I am denied access
    > so
    > I cannot even attempt the listed workaround in the KB article.
    Brian Wehrle [MSFT], Sep 8, 2004
    #2
    1. Advertising

  3. Filburt,

    I think that your idea of trying a different network card is an excellent
    one; when you do roam, open up the View Available Networks window for your
    adapter and check to make sure that the adapter doesn't still think that it
    is connected to the previous network. When you roam, or wake-up the system,
    this Window should show that you are no longer connected, and the Wifi
    network that was in range before should not appear on the Available Networks
    list.

    I understand what you are saying about the type of WLAN you are connecting
    to. It does DNS spoofing in order to take advantage of web page login.
    This should not affect the situation after you have disconnected from that
    network. I believe, and check this out with a different card, that the card
    is lying to Windows and hanging on to that last network for too long.

    As for the enable/disable problem, this appears to be a driver issue. You
    will also be able to test this when you use a different Wifi card.

    Please let me know what you learn from these small tests,
    Brian
    Brian Wehrle [MSFT], Sep 9, 2004
    #3
  4. Filburt,

    I have inquired about the "goodness" of this card. There are some cards
    that are not very good. I have not had trouble personally, but the way
    things work now the cards have a lot of control over what is going on. If
    the card stays connected and refuses to disconnect from a SSID, then there
    is a real problem. (I assume that this was the screen shot that you send me
    in which the card reports staying connected for over 1 day. Or was that
    screen shot showing the fact that the USB nic works exceptionally better?)
    What you are describing is a special case where the SSID is the same, but
    the network is different (or not), but essentially the card needs to handle
    these funny situations and notify Windows that things have changed. If
    windows is not being notified, the rest of your network functionality will
    start to not behave correctly.

    If the USB NIC appears to work much better, I would reccomend that you go
    with that one. For a lower power solution, spend $20 and get a good PCMCIA
    card that is reliable and does not have the power problems of the USB card.

    --
    Brian Wehrle

    Software Test Engineer/Wireless Networking
    Microsoft Corp.



    "filburt1" <> wrote in message
    news:...
    > The USB adapter is definitely more stable than the internal. I haven't
    > been
    > dropped off the network once except for signal dropoffs, at which point I
    > was
    > able to automatically reconnect without problems.
    >
    > Here are two screenshots for the internal wireless:
    > http://www.turtletips.com/status.bmp and
    > http://www.turtletips.com/error.bmp .
    Brian Wehrle [MSFT], Sep 16, 2004
    #4
  5. The screenshots were for the internal wireless (after the screenshot, I
    renamed the connections so they are more intuitive now). So, the SSID is the
    same but the AP is not. Obviously I was not sitting there on my laptop for
    over a day, so I suppose the drivers are at fault.

    My USB WLAN was free after rebate (the only reason I got it) so I'll just
    stick with it for now, but I may also soon be replacing this laptop with a
    Toshiba Portege M200 tablet (Centrino) which would certainly fix the problem.
    ;)

    Thanks very much for all the help.
    =?Utf-8?B?ZmlsYnVydDE=?=, Sep 16, 2004
    #5
  6. Filburt,

    If you would be willing, it would be a great favor to me if you would run a
    simple test and mail me some information. We here are working on a list of
    bad hardware. We also have someone from Interstil to whom we can forward
    these problems. So, if you don't mind here are the steps:

    1. Open command window
    2. type: netsh ras set tr* enable
    3. Go to the first cyber cafe and connect to the SSID.
    4. Make sure you can use the same command window and type: ping
    www.microsoft.com
    5. Now close the laptop
    6. Go to the second cybercafe (same SSID, like you said) and open up the
    laptop
    7. Now, try to sign-in, etc.
    8. Try doing the same ping command again
    9. Mail me the c:\windows\tracing\wzctrace.log file.

    That would be very helpful. I'm glad that your problem was finally
    resolved, but unfortunately it was not the best experience for you, because
    the OS could have helped you out a little more. If you have future
    problems, please post again. You can also try the "Repair" option on your
    wireless network connection, as there are more repair capabilities in SP2
    than before.

    Brian

    P.S.
    Regarding enabling/disabling a driver, you can sometimes do this better by
    using Device Manager. Run "devmgmt.msc", find the device and disable it
    from there.

    -
    Brian Wehrle

    Software Test Engineer/Wireless Networking
    Microsoft Corp.



    "filburt1" <> wrote in message
    news:...
    >I also forgot to note in my previous post that while DHCP may not be giving
    > me a new IP (which is actually understandable on many DHCP networks), the
    > lease time and lease expiration time are both updated--the lease is the
    > exact
    > date and time I attempted a connection to the WLAN and the expiration is
    > exactly one hour ahead of that as the web login page states ("You will
    > need
    > to login again in one hour...").
    >
    > Also, the new Wireless window in SP2 that displays wireless networks and
    > their statuses occasionally locks up when I disconnect from or reconnect
    > to
    > the WLAN, and when it does, it brings explorer (the Taskbar and desktop)
    > down
    > with it, although explorer restarts on its own.
    Brian Wehrle [MSFT], Sep 17, 2004
    #6
  7. It's possible that I won't have the laptop that long, but if I do, I will
    follow your procedure.
    =?Utf-8?B?ZmlsYnVydDE=?=, Sep 18, 2004
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jim Saunders

    Mobile Roaming Between GPRS and 802.11b

    Jim Saunders, Oct 17, 2003, in forum: Cisco
    Replies:
    0
    Views:
    407
    Jim Saunders
    Oct 17, 2003
  2. Replies:
    2
    Views:
    5,473
    Uli Link
    Jan 10, 2006
  3. Replies:
    1
    Views:
    1,959
    Aaron Leonard
    Jun 27, 2006
  4. Replies:
    1
    Views:
    810
    Aaron Leonard
    Jun 22, 2007
  5. Davidi
    Replies:
    0
    Views:
    1,125
    Davidi
    Jul 30, 2009
Loading...

Share This Page