Lots of frame errors

Discussion in 'Cisco' started by 808.mark.lee@gmail.com, Dec 27, 2005.

  1. Guest

    Hi:

    I have a 7204 VXR router. FA0/0 is internal net, fa0/1 is wan backup
    to dsl, s1 to frame relay isp and s2 load balanced over 2 t1s to
    co-location servers. Whenever we have a lot of traffic to the co-lo
    site (either running an app or downloading a large file using Windows
    XP to 2000/2003 server, I begin to see a lot of frame errors. If I
    plug in a fluke, I will see 20 - 30% jabber errors (spread evenly among
    FA0/0 and local machines trying to download data). I have taken
    ethereal traces and have found a lot of the following errors:

    nbss - tcp previous segment lost
    tcp - tcp dup ack

    I seem to be real slow over the load balanced t1's but my internet
    connection over frame relay seems to be okay.

    I have attached my router config. In addition to the slowness, I was
    wondering about a couple of things.

    1. Does packet load balancing work well in Windows environments where
    there is a lot of SMB type of traffic and file copies and pastes.

    2. I remember seeing somewhere that on Frame Relay when using
    subinterfaces, you should not have a IP address on the physical
    interface. We do have an IP address on the physical serial1 interface.
    Does this cause a problem?

    Router was setup by a consultant and I just started working here. Any
    help you can provide will be greatly appreciated.

    Thank you.

    Mark Lee

    version 12.1
    no service single-slot-reload-enable
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    no service dhcp
    !
    hostname xxxxx
    !
    logging rate-limit console 10 except errors
    enable secret xxxxx
    enable password xxxxx
    !
    clock timezone HST -10
    ip subnet-zero
    ip cef
    !
    !
    no ip finger
    ip host WORD 198.185.227.1
    ip name-server 10.1.1.1
    !
    call rsvp-sync
    !
    controller T1 2/0
    channel-group 0 timeslots 1-24
    !
    controller T1 2/1
    channel-group 0 timeslots 1-24
    !
    controller T1 2/2
    !
    controller T1 2/3
    !
    controller T1 2/4
    !
    controller T1 2/5
    !
    controller T1 2/6
    !
    controller T1 2/7
    !
    interface Loopback0
    ip address 192.168.252.1 255.255.255.255
    !
    interface FastEthernet0/0
    ip address 192.168.1.1 255.255.255.0
    duplex auto
    speed 100
    no mop enabled
    !
    interface FastEthernet0/1
    ip address 10.2.0.50 255.255.255.252
    ip ospf cost 100
    duplex auto
    speed auto
    !
    interface Serial1/0
    ip address 198.185.227.1 255.255.255.0
    encapsulation frame-relay
    no ip mroute-cache
    frame-relay map ip 198.185.227.2 18 broadcast
    frame-relay map ip 198.185.227.5 19 broadcast
    frame-relay map ip 198.185.227.6 17 broadcast
    frame-relay map ip 198.185.227.7 21 broadcast
    frame-relay map ip 198.185.227.8 23 broadcast
    frame-relay map ip 198.185.227.9 22 broadcast
    frame-relay map ip 198.185.227.10 24 broadcast
    frame-relay lmi-type ansi
    !
    interface Serial1/0.1 point-to-point
    ip address 10.2.0.30 255.255.255.252
    shutdown
    frame-relay interface-dlci 25 IETF
    !
    interface Serial1/0.2 point-to-point
    ip address 10.2.0.46 255.255.255.252
    ip ospf cost 90
    frame-relay interface-dlci 26 IETF
    !
    interface Serial1/1
    no ip address
    shutdown
    !
    interface Serial1/2
    no ip address
    shutdown
    !
    interface Serial1/3
    no ip address
    shutdown
    !
    interface Serial2/0:0
    ip address 192.168.250.2 255.255.255.0
    ip load-sharing per-packet
    !
    interface Serial2/1:0
    ip address 192.168.251.2 255.255.255.0
    ip load-sharing per-packet
    !
    interface FastEthernet4/0
    no ip address
    shutdown
    duplex full
    !
    router ospf 10
    log-adjacency-changes
    redistribute connected subnets
    redistribute rip subnets
    network 10.2.0.44 0.0.0.3 area 1
    network 10.2.0.48 0.0.0.3 area 1
    network 192.168.250.0 0.0.0.255 area 1
    network 192.168.251.0 0.0.0.255 area 1
    network 192.168.252.1 0.0.0.0 area 1
    distribute-list 10 out
    distribute-list 11 in
    distance 90
    !
    router rip
    version 1
    redistribute connected
    redistribute static
    network 192.168.1.0
    network 198.185.227.0
    distance 100
    no auto-summary
    !
    ip classless
    ip route 10.15.23.11 255.255.255.255 10.2.0.45
    no ip http server
    !
    access-list 10 permit 192.168.0.0 0.0.255.255
    access-list 11 permit 0.0.0.0
    access-list 11 permit 10.1.0.0 0.0.255.255
    access-list 11 permit 10.15.23.0 0.0.0.255
    access-list 11 permit 192.168.0.0 0.0.255.255
    snmp-server community xxxxx RW
    snmp-server host 192.168.1.234 xxxxx
    !
    !
    gatekeeper
    shutdown
    !
    !
    line con 0
    transport input none
    line aux 0
    line vty 0 4
    password xxxxx
    login
    line vty 5 15
    password xxxxx
    login
    !
    ntp clock-period 17179955
    ntp update-calendar
    ntp server 131.107.1.10
    end
     
    , Dec 27, 2005
    #1
    1. Advertising

  2. Hardcode speed and duplex on the router, all switch ports, and all relevant
    machines.


    <> wrote in message
    news:...
    > Hi:
    >
    > I have a 7204 VXR router. FA0/0 is internal net, fa0/1 is wan backup
    > to dsl, s1 to frame relay isp and s2 load balanced over 2 t1s to
    > co-location servers. Whenever we have a lot of traffic to the co-lo
    > site (either running an app or downloading a large file using Windows
    > XP to 2000/2003 server, I begin to see a lot of frame errors. If I
    > plug in a fluke, I will see 20 - 30% jabber errors (spread evenly among
    > FA0/0 and local machines trying to download data). I have taken
    > ethereal traces and have found a lot of the following errors:
    >
    > nbss - tcp previous segment lost
    > tcp - tcp dup ack
    >
    > I seem to be real slow over the load balanced t1's but my internet
    > connection over frame relay seems to be okay.
    >
    > I have attached my router config. In addition to the slowness, I was
    > wondering about a couple of things.
    >
    > 1. Does packet load balancing work well in Windows environments where
    > there is a lot of SMB type of traffic and file copies and pastes.
    >
    > 2. I remember seeing somewhere that on Frame Relay when using
    > subinterfaces, you should not have a IP address on the physical
    > interface. We do have an IP address on the physical serial1 interface.
    > Does this cause a problem?
    >
    > Router was setup by a consultant and I just started working here. Any
    > help you can provide will be greatly appreciated.
    >
    > Thank you.
    >
    > Mark Lee
    >
    > version 12.1
    > no service single-slot-reload-enable
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > no service dhcp
    > !
    > hostname xxxxx
    > !
    > logging rate-limit console 10 except errors
    > enable secret xxxxx
    > enable password xxxxx
    > !
    > clock timezone HST -10
    > ip subnet-zero
    > ip cef
    > !
    > !
    > no ip finger
    > ip host WORD 198.185.227.1
    > ip name-server 10.1.1.1
    > !
    > call rsvp-sync
    > !
    > controller T1 2/0
    > channel-group 0 timeslots 1-24
    > !
    > controller T1 2/1
    > channel-group 0 timeslots 1-24
    > !
    > controller T1 2/2
    > !
    > controller T1 2/3
    > !
    > controller T1 2/4
    > !
    > controller T1 2/5
    > !
    > controller T1 2/6
    > !
    > controller T1 2/7
    > !
    > interface Loopback0
    > ip address 192.168.252.1 255.255.255.255
    > !
    > interface FastEthernet0/0
    > ip address 192.168.1.1 255.255.255.0
    > duplex auto
    > speed 100
    > no mop enabled
    > !
    > interface FastEthernet0/1
    > ip address 10.2.0.50 255.255.255.252
    > ip ospf cost 100
    > duplex auto
    > speed auto
    > !
    > interface Serial1/0
    > ip address 198.185.227.1 255.255.255.0
    > encapsulation frame-relay
    > no ip mroute-cache
    > frame-relay map ip 198.185.227.2 18 broadcast
    > frame-relay map ip 198.185.227.5 19 broadcast
    > frame-relay map ip 198.185.227.6 17 broadcast
    > frame-relay map ip 198.185.227.7 21 broadcast
    > frame-relay map ip 198.185.227.8 23 broadcast
    > frame-relay map ip 198.185.227.9 22 broadcast
    > frame-relay map ip 198.185.227.10 24 broadcast
    > frame-relay lmi-type ansi
    > !
    > interface Serial1/0.1 point-to-point
    > ip address 10.2.0.30 255.255.255.252
    > shutdown
    > frame-relay interface-dlci 25 IETF
    > !
    > interface Serial1/0.2 point-to-point
    > ip address 10.2.0.46 255.255.255.252
    > ip ospf cost 90
    > frame-relay interface-dlci 26 IETF
    > !
    > interface Serial1/1
    > no ip address
    > shutdown
    > !
    > interface Serial1/2
    > no ip address
    > shutdown
    > !
    > interface Serial1/3
    > no ip address
    > shutdown
    > !
    > interface Serial2/0:0
    > ip address 192.168.250.2 255.255.255.0
    > ip load-sharing per-packet
    > !
    > interface Serial2/1:0
    > ip address 192.168.251.2 255.255.255.0
    > ip load-sharing per-packet
    > !
    > interface FastEthernet4/0
    > no ip address
    > shutdown
    > duplex full
    > !
    > router ospf 10
    > log-adjacency-changes
    > redistribute connected subnets
    > redistribute rip subnets
    > network 10.2.0.44 0.0.0.3 area 1
    > network 10.2.0.48 0.0.0.3 area 1
    > network 192.168.250.0 0.0.0.255 area 1
    > network 192.168.251.0 0.0.0.255 area 1
    > network 192.168.252.1 0.0.0.0 area 1
    > distribute-list 10 out
    > distribute-list 11 in
    > distance 90
    > !
    > router rip
    > version 1
    > redistribute connected
    > redistribute static
    > network 192.168.1.0
    > network 198.185.227.0
    > distance 100
    > no auto-summary
    > !
    > ip classless
    > ip route 10.15.23.11 255.255.255.255 10.2.0.45
    > no ip http server
    > !
    > access-list 10 permit 192.168.0.0 0.0.255.255
    > access-list 11 permit 0.0.0.0
    > access-list 11 permit 10.1.0.0 0.0.255.255
    > access-list 11 permit 10.15.23.0 0.0.0.255
    > access-list 11 permit 192.168.0.0 0.0.255.255
    > snmp-server community xxxxx RW
    > snmp-server host 192.168.1.234 xxxxx
    > !
    > !
    > gatekeeper
    > shutdown
    > !
    > !
    > line con 0
    > transport input none
    > line aux 0
    > line vty 0 4
    > password xxxxx
    > login
    > line vty 5 15
    > password xxxxx
    > login
    > !
    > ntp clock-period 17179955
    > ntp update-calendar
    > ntp server 131.107.1.10
    > end
    >
     
    DERICK WINKWORTH, Dec 28, 2005
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Lots of frame errors

    , Dec 27, 2005, in forum: Cisco
    Replies:
    0
    Views:
    515
  2. wylbur37
    Replies:
    1
    Views:
    1,110
    Jukka Aho
    Nov 6, 2006
  3. Don and Liz Campbell

    1 Frame per second frame capture rate

    Don and Liz Campbell, Mar 24, 2005, in forum: Digital Photography
    Replies:
    4
    Views:
    368
  4. asprigoftrig

    view loaded clip frame-by-frame on PC?

    asprigoftrig, Dec 14, 2005, in forum: Digital Photography
    Replies:
    3
    Views:
    697
    asprigoftrig
    Dec 14, 2005
  5. Komrade Klark

    Lots of errors in new DVD disk pack...

    Komrade Klark, Jul 11, 2006, in forum: NZ Computing
    Replies:
    30
    Views:
    863
    Invisible
    Jul 21, 2006
Loading...

Share This Page