"Lost" USB ports for Printer

Discussion in 'NZ Computing' started by Chris, Dec 17, 2003.

  1. Chris

    Chris Guest

    Hi

    Running win98SE and trying to print to an Epson 760 via a USB port.

    Looking in the printer properties box there is no USB port listed (just
    LPT1, print to file, serial ports, and a PDF print driver). I know that
    the USB port works as I attached something else to it with out problem. I
    have just noticed this since I reinstalled win 98 a few days ago.

    Looking in the System Properties box there is a ? where the printer is
    listed with error code 28 and advising to reinstall the driver (which I
    have tried to do). The USB properties are listed as "working correctly"

    Anybody got any ideas where to start looking for the problem ?

    TIA

    Chris
    Chris, Dec 17, 2003
    #1
    1. Advertising

  2. Chris

    Steve Guest

    Chris wrote
    > Hi
    >
    > Running win98SE and trying to print to an Epson 760 via a USB port.
    >
    > Looking in the printer properties box there is no USB port listed (just
    > LPT1, print to file, serial ports, and a PDF print driver). I know that
    > the USB port works as I attached something else to it with out problem. I
    > have just noticed this since I reinstalled win 98 a few days ago.
    >
    > Looking in the System Properties box there is a ? where the printer is
    > listed with error code 28 and advising to reinstall the driver (which I
    > have tried to do). The USB properties are listed as "working correctly"
    >
    > Anybody got any ideas where to start looking for the problem ?


    You will need to reinstall the printer for it to work after reinstalling Win98.
    If you cannot do that then try deleting the USB items in the System group
    from the Control Panel then restart your computer before reinstalling the
    printer. ... and do not plug the printer in until you have it installed - that
    can help.

    Steve.
    Steve, Dec 17, 2003
    #2
    1. Advertising

  3. "Chris" <> wrote in message
    news:QTQDb.13361$...
    > Hi
    >
    > Running win98SE and trying to print to an Epson 760 via a USB port.
    >
    > Looking in the printer properties box there is no USB port listed (just
    > LPT1, print to file, serial ports, and a PDF print driver). I know that
    > the USB port works as I attached something else to it with out problem. I
    > have just noticed this since I reinstalled win 98 a few days ago.
    >
    > Looking in the System Properties box there is a ? where the printer is
    > listed with error code 28 and advising to reinstall the driver (which I
    > have tried to do). The USB properties are listed as "working correctly"
    >
    > Anybody got any ideas where to start looking for the problem ?
    >
    > TIA
    >
    > Chris


    That USB printer port is actually a software port installed by the printer
    drivers. Try removing the device from the device list, unplugging the
    printer then plugging it back in. Do a manual search through the folders on
    the CD if the correct inf file isn't in the root directory of the CD.

    Basically: Problem with drivers, no problem with USB.

    Steve
    Stephen Williams, Dec 17, 2003
    #3
  4. Chris

    Chris Guest

    "Steve" <> wrote in news::

    > Chris wrote
    >> Hi
    >>
    >> Running win98SE and trying to print to an Epson 760 via a USB port.
    >>
    >> Looking in the printer properties box there is no USB port listed
    >> (just LPT1, print to file, serial ports, and a PDF print driver). I
    >> know that the USB port works as I attached something else to it with
    >> out problem. I have just noticed this since I reinstalled win 98 a
    >> few days ago.
    >>
    >> Looking in the System Properties box there is a ? where the printer
    >> is listed with error code 28 and advising to reinstall the driver
    >> (which I have tried to do). The USB properties are listed as
    >> "working correctly"
    >>
    >> Anybody got any ideas where to start looking for the problem ?

    >
    > You will need to reinstall the printer for it to work after
    > reinstalling Win98. If you cannot do that then try deleting the USB
    > items in the System group from the Control Panel then restart your
    > computer before reinstalling the printer. ... and do not plug the
    > printer in until you have it installed - that can help.
    >
    > Steve.
    >
    >
    >


    OK, tried NOT pluging the printer in and that worked. Thanks for your
    help.

    Chris
    Chris, Dec 17, 2003
    #4
  5. Chris

    Chris Guest

    "Stephen Williams" <> wrote in
    news::

    >
    > "Chris" <> wrote in message
    > news:QTQDb.13361$...
    >> Hi
    >>
    >> Running win98SE and trying to print to an Epson 760 via a USB port.
    >>
    >> Looking in the printer properties box there is no USB port listed
    >> (just LPT1, print to file, serial ports, and a PDF print driver). I
    >> know that the USB port works as I attached something else to it with
    >> out problem. I have just noticed this since I reinstalled win 98 a
    >> few days ago.
    >>
    >> Looking in the System Properties box there is a ? where the printer
    >> is listed with error code 28 and advising to reinstall the driver
    >> (which I have tried to do). The USB properties are listed as
    >> "working correctly"
    >>
    >> Anybody got any ideas where to start looking for the problem ?
    >>
    >> TIA
    >>
    >> Chris

    >
    > That USB printer port is actually a software port installed by the
    > printer drivers. Try removing the device from the device list,
    > unplugging the printer then plugging it back in. Do a manual search
    > through the folders on the CD if the correct inf file isn't in the
    > root directory of the CD.
    >
    > Basically: Problem with drivers, no problem with USB.
    >
    > Steve
    >
    >


    You were right it was the drivers, I though it must have been as the other
    USB devices were working. As I mentioned above I must have had the printer
    pluged in when I originally re-installed it.

    Thanks for your help

    Chris
    Chris, Dec 17, 2003
    #5
  6. > OK, tried NOT pluging the printer in and that worked. Thanks for your
    > help.
    >
    > Chris


    Struth! My Olympus camera USB driver needs to see a working camera when
    reinstalling.

    Henry
    Henry Falkner, Dec 17, 2003
    #6
  7. Chris

    Chris Guest

    "Henry Falkner" <> wrote in
    news::

    >> OK, tried NOT pluging the printer in and that worked. Thanks for your
    >> help.
    >>
    >> Chris

    >
    > Struth! My Olympus camera USB driver needs to see a working camera when
    > reinstalling.
    >
    > Henry
    >
    >
    >


    Actually what happened was after I installed the software, rebooted the PC
    and pluged the printer in, windows detected the new hardware and all was OK
    after that. I don't ever remember having to NOT have the printer pluged in
    to install it - not that I reinstall windows very offten as I use Ghost to
    make an image but this time round I had some new hardware and I wanted to
    get ride of the drivers of the old hardware as I believed they were causing
    some problems of their own so I started from fresh and made a new image.
    Chris, Dec 17, 2003
    #7
  8. Chris

    Steve Guest

    Henry Falkner wrote
    > > OK, tried NOT pluging the printer in and that worked. Thanks for your
    > > help.
    > >
    > > Chris

    >
    > Struth! My Olympus camera USB driver needs to see a working camera when
    > reinstalling.


    I have installed some flash drives recently and on 98 you MUST NOT HAVE
    the device plugged in before installing the drivers but on other systems you just
    plug them in and they are updated automatically.

    I think that the issue is with 98 not having USB support until after you install
    a USB device. I have not checked this out but I think you only need to install
    a single USB device before plugging in any USB device in 98.

    Steve.
    Steve, Dec 17, 2003
    #8
  9. "Steve" <> wrote in message
    news:...
    > Henry Falkner wrote
    > > > OK, tried NOT pluging the printer in and that worked. Thanks for your
    > > > help.
    > > >
    > > > Chris

    > >
    > > Struth! My Olympus camera USB driver needs to see a working camera when
    > > reinstalling.

    >
    > I think that the issue is with 98 not having USB support until after you

    install
    > a USB device. I have not checked this out but I think you only need to

    install
    > a single USB device before plugging in any USB device in 98.
    >
    > Steve.
    >


    My old Toshiba Satellite 2750DVD came with Win98SE and a USB port, so the
    generic USB driver was already there. It detected my camera (switched on,
    Olympus C-40ZOOM) when installing the Camedia software.

    Henry
    Henry Falkner, Dec 19, 2003
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mike
    Replies:
    27
    Views:
    1,344
  2. jmcgovern

    USB ports reporting all installs as Generic USB Hubs

    jmcgovern, Mar 4, 2007, in forum: Computer Support
    Replies:
    3
    Views:
    878
    Mike S.
    Mar 5, 2007
  3. =?Utf-8?B?ZHdlZWJvbQ==?=

    USB printer support lost

    =?Utf-8?B?ZHdlZWJvbQ==?=, Jul 25, 2005, in forum: Windows 64bit
    Replies:
    0
    Views:
    374
    =?Utf-8?B?ZHdlZWJvbQ==?=
    Jul 25, 2005
  4. Giuen
    Replies:
    0
    Views:
    736
    Giuen
    Sep 12, 2008
  5. Replies:
    0
    Views:
    1,114
Loading...

Share This Page