Loop back error and time issues...

Discussion in 'Cisco' started by Tim Fischer, Oct 16, 2003.

  1. Tim Fischer

    Tim Fischer Guest

    Today, for the first time since beginning our project to move to Cisco
    equipment - we had a massive failure. Actually it was dealing with a single
    port on our 3550.

    Here is what I have on the problem:
    At 11:10am no one on our Ethernet network (we have Token-ring as well
    until conversion is complete), could talk to our mainframe. So I looked
    into the logs of our 3550 switch. Checking the time on the switch - the
    time was correct (11:15am).

    The logs state though that on Oct 16th at "16:47:09
    %ETHCNTR-3-LOOP_BACK_DETECTED: keepalice packet loop-back detected on
    GigabitEthernet 0/11" occured. I tried relocating the cable and every port
    shutdown the same way. Port 11 has the cable coming from another switch
    which is connected to the Token-Ring router. This has been working for
    quite some time without issue.

    Anyone have any ideas? I searched Cisco and they say something about a
    balun cable, but this cable is the same cable that has been plugged in for a
    couple months.

    Any ideas on the Time difference? What would cause logging to be off so
    much?

    Thanks in advance!

    -Tim
     
    Tim Fischer, Oct 16, 2003
    #1
    1. Advertising

  2. Tim Fischer

    Steinar Haug Guest

    ["Tim Fischer"]

    | Here is what I have on the problem:
    | At 11:10am no one on our Ethernet network (we have Token-ring as well
    | until conversion is complete), could talk to our mainframe. So I looked
    | into the logs of our 3550 switch. Checking the time on the switch - the
    | time was correct (11:15am).
    |
    | The logs state though that on Oct 16th at "16:47:09
    | %ETHCNTR-3-LOOP_BACK_DETECTED: keepalice packet loop-back detected on
    | GigabitEthernet 0/11" occured. I tried relocating the cable and every port
    | shutdown the same way. Port 11 has the cable coming from another switch
    | which is connected to the Token-Ring router. This has been working for
    | quite some time without issue.
    |
    | Anyone have any ideas? I searched Cisco and they say something about a
    | balun cable, but this cable is the same cable that has been plugged in for a
    | couple months.

    Cisco's explanation here is utterly useless.

    The error message is caused by the keepalive packets that Cisco switches
    send, by default at 10 second intervals. Here is what tcpdump shows for
    such a keepalive packet (tcpdump -n 'ether[12:2]==0x9000'):

    22:56:54.497159 0:b0:c2:89:60:4a 0:b0:c2:89:60:4a 9000 60:
    0000 0100 0000 0000 0000 0000 0000 0000
    0000 0000 0000 0000 0000 0000 0000 0000
    0000 0000 0000 0000 0000 0000 0000

    The packet has the same MAC address as source and desstination (this is
    the MAC address of the switch port).

    If this keepalive packet is seen on *input* to the same switchport that
    sent it, the port shuts down, with the ETHCNTR-3-LOOP_BACK_DETECTED
    message that you saw.

    We haven't yet been able to determine the exact circumstances which
    cause this to happen - but we have seen it enough times that we have
    had to turn off loopback detection on all our 3550 switches. It is,
    however, easy to imagine that this could be caused by spanning tree
    problems. You can trigger it easily enough by connecting both ends
    of a fiber to the same GBIC, creating en explicit loopback.

    You can turn off the port shutdown with

    no errdisable detect cause loopback

    If you don't want to turn off loopback detection/shutdown, you should
    definitely enable loopback recovery (off by default, requiring manual
    reset, an *awful* default!):

    errdisable recovery cause loopback
    errdisable recovery interval 60

    Note that this is only available in 12.1(13)EA1a and newer.

    Steinar Haug, Nethelp consulting,
     
    Steinar Haug, Oct 16, 2003
    #2
    1. Advertising

  3. In article <>,
    Tim Fischer <> wrote:
    : At 11:10am no one on our Ethernet network (we have Token-ring as well
    :until conversion is complete), could talk to our mainframe. So I looked
    :into the logs of our 3550 switch. Checking the time on the switch - the
    :time was correct (11:15am).

    :The logs state though that on Oct 16th at "16:47:09
    :%ETHCNTR-3-LOOP_BACK_DETECTED: keepalice packet loop-back detected on
    :GigabitEthernet 0/11" occured.

    Is it possible that 16:47:09 was the time since reboot, rather
    than the absolute time? Do you have
    service timestamps datetime localtime show-timezone
    configured?
    --
    We don't need no side effect-ing
    We don't need no scope control
    No global variables for execution
    Hey! Did you leave those args alone? -- decvax!utzoo!utcsrgv!roderick
     
    Walter Roberson, Oct 16, 2003
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. T.B.

    BSOD loop; can't read error message

    T.B., Mar 7, 2005, in forum: Computer Support
    Replies:
    19
    Views:
    9,351
    Ron Martell
    Mar 9, 2005
  2. scilent-project

    Loop back

    scilent-project, Jun 6, 2006, in forum: Cisco
    Replies:
    3
    Views:
    6,164
  3. Wizard

    Re: BSOD loop; can't read error message

    Wizard, Mar 8, 2005, in forum: Computer Information
    Replies:
    0
    Views:
    401
    Wizard
    Mar 8, 2005
  4. GNY
    Replies:
    0
    Views:
    766
  5. Replies:
    2
    Views:
    792
Loading...

Share This Page