Logging on a Samba PDC over Cisco Router

Discussion in 'Cisco' started by Raffi, Feb 5, 2004.

  1. Raffi

    Raffi Guest

    Hi all,

    I'm setting up a test segment on my LAN. I have the following setup:

    Win2K host ---- Cisco 2621 ---- rest of the network routed by an RT314

    The RT314 segment contains the main network which has my Samba PDC.
    When I connect the Win2k host to the RT314 segment, it logs onto the
    Samba PDC just fine. When I connect through the 2621 the broadcasts
    don't make it to the PDC even when I attempt to configure the 2621 to
    do so. I have tried different configuration options on the Cisco
    router to try and forward the netbios UDP broadcasts, but they keep
    getting stuck on the LAN side of the router interface and don't make
    it to the PDC (confirmed through debug ip udp on the LAN side
    interface of the 2621). As expected, I can't browse shares on the
    RT314 network either. The configuration options I have tried are
    setting a ip helper-address on the LAN side interface on the 2621
    pointing to both the PDC ip address and the broadcast address of the
    RT314 network (x.x.100.255). I have also tried configuring a netbios
    name server with the ip address of the PDC. Neither of these have
    worked. I'm sure I'm dropping the ball somewhere but can't figure out
    where. Here are the relevant portions of the 2621 configuration. The
    Samba PDC is configured for WINS. I have tried the Win2k host both
    with and without WINS over TCP/IP. Any help would be greatly
    appreciated.
    -----------------------------------------------------------------------------
    ip subnet-zero
    ip name-server x.x.100.6
    ip dhcp excluded-address x.x.200.1
    !
    ip dhcp pool 1
    network x.x.200.0 255.255.255.0
    default-router x.x.200.1
    dns-server x.x.100.6
    !
    interface FastEthernet0/0
    description connected to RT 314
    ip address x.x.100.7 255.255.255.0
    duplex auto
    speed auto
    !
    interface FastEthernet0/1
    description connected to EthernetLAN
    ip address x.x.200.1 255.255.255.0
    duplex auto
    speed auto
    !
    router rip
    version 2
    network x.x.100.0
    network x.x.200.0
    no auto-summary
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 x.x.100.1
    no ip http server
    !
    Raffi, Feb 5, 2004
    #1
    1. Advertising

  2. Try this:

    interface FastEthernet0/0
    ip directed-broadcast
    interface FastEthernet0/1
    ip helper-address x.x.100.255


    Raffi schrieb:

    > Hi all,
    >
    > I'm setting up a test segment on my LAN. I have the following setup:
    >
    > Win2K host ---- Cisco 2621 ---- rest of the network routed by an RT314
    >
    > The RT314 segment contains the main network which has my Samba PDC.
    > When I connect the Win2k host to the RT314 segment, it logs onto the
    > Samba PDC just fine. When I connect through the 2621 the broadcasts
    > don't make it to the PDC even when I attempt to configure the 2621 to
    > do so. I have tried different configuration options on the Cisco
    > router to try and forward the netbios UDP broadcasts, but they keep
    > getting stuck on the LAN side of the router interface and don't make
    > it to the PDC (confirmed through debug ip udp on the LAN side
    > interface of the 2621). As expected, I can't browse shares on the
    > RT314 network either. The configuration options I have tried are
    > setting a ip helper-address on the LAN side interface on the 2621
    > pointing to both the PDC ip address and the broadcast address of the
    > RT314 network (x.x.100.255). I have also tried configuring a netbios
    > name server with the ip address of the PDC. Neither of these have
    > worked. I'm sure I'm dropping the ball somewhere but can't figure out
    > where. Here are the relevant portions of the 2621 configuration. The
    > Samba PDC is configured for WINS. I have tried the Win2k host both
    > with and without WINS over TCP/IP. Any help would be greatly
    > appreciated.
    > -----------------------------------------------------------------------------
    > ip subnet-zero
    > ip name-server x.x.100.6
    > ip dhcp excluded-address x.x.200.1
    > !
    > ip dhcp pool 1
    > network x.x.200.0 255.255.255.0
    > default-router x.x.200.1
    > dns-server x.x.100.6
    > !
    > interface FastEthernet0/0
    > description connected to RT 314
    > ip address x.x.100.7 255.255.255.0
    > duplex auto
    > speed auto
    > !
    > interface FastEthernet0/1
    > description connected to EthernetLAN
    > ip address x.x.200.1 255.255.255.0
    > duplex auto
    > speed auto
    > !
    > router rip
    > version 2
    > network x.x.100.0
    > network x.x.200.0
    > no auto-summary
    > !
    > ip classless
    > ip route 0.0.0.0 0.0.0.0 x.x.100.1
    > no ip http server
    > !
    Helmut Ulrich, Feb 5, 2004
    #2
    1. Advertising

  3. Raffi

    Raffi Guest

    Helmut,

    Thanks for the suggestion. I tried it but it didn't help the
    situation. I still couldn't log onto the domain or browse any of the
    shares on the x.x.100.0 segment.

    Is there a way to make this work without placing a WINS server or a
    BDC on every segment of the network, or without enabling bridging
    across the router?

    One interesting thing I noticed in my Samba nmbd.log file is that the
    PDC is losing local master browser election to the Win2k host. I
    thought "os level = 65" would have made sure Samba wins all LMB
    elections.

    Here is the pertinent portion of my smb.conf if it helps:

    [global]
    ; Network information
    netbios name = bsdbox
    workgroup = WORKGROUP
    keepalive = 3600

    ; Logging
    log level = 1
    log file = /var/log/samba/log.%m
    # passwd chat debug = yes

    ; Domain parameters
    domain logons = yes
    domain master = yes
    local master = yes
    preferred master = yes
    wins support = Yes
    os level = 65
    remote announce = 192.168.10.255


    Helmut Ulrich <> wrote in message news:<>...
    > Try this:
    >
    > interface FastEthernet0/0
    > ip directed-broadcast
    > interface FastEthernet0/1
    > ip helper-address x.x.100.255
    >
    >
    > Raffi schrieb:
    >
    > > Hi all,
    > >
    > > I'm setting up a test segment on my LAN. I have the following setup:
    > >
    > > Win2K host ---- Cisco 2621 ---- rest of the network routed by an RT314
    > >
    > > The RT314 segment contains the main network which has my Samba PDC.
    > > When I connect the Win2k host to the RT314 segment, it logs onto the
    > > Samba PDC just fine. When I connect through the 2621 the broadcasts
    > > don't make it to the PDC even when I attempt to configure the 2621 to
    > > do so. I have tried different configuration options on the Cisco
    > > router to try and forward the netbios UDP broadcasts, but they keep
    > > getting stuck on the LAN side of the router interface and don't make
    > > it to the PDC (confirmed through debug ip udp on the LAN side
    > > interface of the 2621). As expected, I can't browse shares on the
    > > RT314 network either. The configuration options I have tried are
    > > setting a ip helper-address on the LAN side interface on the 2621
    > > pointing to both the PDC ip address and the broadcast address of the
    > > RT314 network (x.x.100.255). I have also tried configuring a netbios
    > > name server with the ip address of the PDC. Neither of these have
    > > worked. I'm sure I'm dropping the ball somewhere but can't figure out
    > > where. Here are the relevant portions of the 2621 configuration. The
    > > Samba PDC is configured for WINS. I have tried the Win2k host both
    > > with and without WINS over TCP/IP. Any help would be greatly
    > > appreciated.
    > > -----------------------------------------------------------------------------
    > > ip subnet-zero
    > > ip name-server x.x.100.6
    > > ip dhcp excluded-address x.x.200.1
    > > !
    > > ip dhcp pool 1
    > > network x.x.200.0 255.255.255.0
    > > default-router x.x.200.1
    > > dns-server x.x.100.6
    > > !
    > > interface FastEthernet0/0
    > > description connected to RT 314
    > > ip address x.x.100.7 255.255.255.0
    > > duplex auto
    > > speed auto
    > > !
    > > interface FastEthernet0/1
    > > description connected to EthernetLAN
    > > ip address x.x.200.1 255.255.255.0
    > > duplex auto
    > > speed auto
    > > !
    > > router rip
    > > version 2
    > > network x.x.100.0
    > > network x.x.200.0
    > > no auto-summary
    > > !
    > > ip classless
    > > ip route 0.0.0.0 0.0.0.0 x.x.100.1
    > > no ip http server
    > > !
    Raffi, Feb 6, 2004
    #3
  4. Raffi wrote:

    > Helmut,
    >
    > Thanks for the suggestion. I tried it but it didn't help the
    > situation. I still couldn't log onto the domain or browse any of the
    > shares on the x.x.100.0 segment.
    >
    > Is there a way to make this work without placing a WINS server or a
    > BDC on every segment of the network, or without enabling bridging
    > across the router?
    >
    > One interesting thing I noticed in my Samba nmbd.log file is that the
    > PDC is losing local master browser election to the Win2k host. I
    > thought "os level = 65" would have made sure Samba wins all LMB
    > elections.


    Sigh, another top poster.

    Leave the "os level" at its default.

    Ensure each w/s is a member of the the workgroup "WORKGROUP"
    under My Computer/Properties.

    Ensure that each w/s is configured to use the Samba system
    as a WINS server under control panel/network interfaces/TCP/IP etc.

    I would probably configure the DHCP server on the same host
    as Samba, configure the router as appropriate, and check out
    "option netbios-node-type" on dhcp-options.



    B

    --
    http://www.mailtrap.org.uk/
    Bob { Goddard }, Feb 6, 2004
    #4
  5. Raffi

    Raffi Guest

    Bob { Goddard } <> wrote in message news:<bvvve5$11cnqe$-berlin.de>...
    > Raffi wrote:
    >
    > > Helmut,
    > >
    > > Thanks for the suggestion. I tried it but it didn't help the
    > > situation. I still couldn't log onto the domain or browse any of the
    > > shares on the x.x.100.0 segment.
    > >
    > > Is there a way to make this work without placing a WINS server or a
    > > BDC on every segment of the network, or without enabling bridging
    > > across the router?
    > >
    > > One interesting thing I noticed in my Samba nmbd.log file is that the
    > > PDC is losing local master browser election to the Win2k host. I
    > > thought "os level = 65" would have made sure Samba wins all LMB
    > > elections.

    >
    > Sigh, another top poster.
    >
    > Leave the "os level" at its default.
    >
    > Ensure each w/s is a member of the the workgroup "WORKGROUP"
    > under My Computer/Properties.
    >
    > Ensure that each w/s is configured to use the Samba system
    > as a WINS server under control panel/network interfaces/TCP/IP etc.
    >
    > I would probably configure the DHCP server on the same host
    > as Samba, configure the router as appropriate, and check out
    > "option netbios-node-type" on dhcp-options.
    >
    >
    >
    > B


    Bob,

    Sorry about top posting :)

    The problem turned out to be related to server access. Although I had
    made the necessary changes to the server firewall rules to allow the
    new network access, i hadn't done the same to hosts.allow. Once I
    fixed that, both logging on and browsing started working.

    As for the WINS server to be added under the network interface
    properties, this is indeed necessary for browsing shares using netbios
    names.

    Anyway, I'm glad this was a simple oversight on my part. Thanks for
    reading my posts and for making helpful suggestions.

    Raffi
    Raffi, Feb 6, 2004
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Mirek

    Samba PDC and PIX Firewall

    Mirek, Feb 19, 2004, in forum: Cisco
    Replies:
    0
    Views:
    437
    Mirek
    Feb 19, 2004
  2. DaveT
    Replies:
    8
    Views:
    522
  3. Dany P. Wu

    Samba PDC question

    Dany P. Wu, Sep 10, 2003, in forum: NZ Computing
    Replies:
    5
    Views:
    339
    Dany P. Wu
    Sep 12, 2003
  4. Theo Markettos

    VOIP over VPN over TCP over WAP over 3G

    Theo Markettos, Feb 3, 2008, in forum: UK VOIP
    Replies:
    2
    Views:
    808
    Theo Markettos
    Feb 14, 2008
  5. chary
    Replies:
    0
    Views:
    364
    chary
    Aug 29, 2008
Loading...

Share This Page