Load Sharing / Balancing two ISPs with NAT in C18XX

Discussion in 'Cisco' started by nmilford, Nov 21, 2007.

  1. nmilford

    nmilford

    Joined:
    Nov 8, 2007
    Messages:
    1
    Hi,

    I'm preparing to configure my 1800 series to share two DSL lines. Does anyone foresee any terrible issues with the following config?

    It seems, to my relatively inexperienced eyes as a workable way to do this... any input would be appreciated.



    interface FastEthernet0
    description Uplink to ISP1
    ip address X.X.X.1 255.255.255.0
    ip nat outside

    interface FastEthernet1
    description Uplink to ISP2
    ip address Y.Y.Y.1 255.255.255.0
    ip nat outside

    interface BVI1
    description Internal Network
    ip address 192.168.1.1
    ip nat inside

    ip route 0.0.0.0 0.0.0.0 X.X.1.1 5
    ip route 0.0.0.0 0.0.0.0 Y.Y.1.1 5

    ip nat pool POOL_ISP1 X.X.X.2 X.X.X.10 prefix-length 24
    ip nat pool POOL_ISP2 Y.Y.Y.2 Y.Y.Y.10 prefix-length 24
    ip nat inside source route-map ISP1 pool POOL_ISP1 overload
    ip nat inside source route-map ISP2 pool POOL_ISP2 overload
    ip nat inside source static 192.168.1.11 X.X.X.11 route-map ISP1
    ip nat inside source static 192.168.1.11 Y.Y.Y.11 route-map ISP2

    route-map ISP1 permit 10
    match ip address 10
    match interface FastEthernet0
    route-map ISP2 permit 10
    match ip address 10
    match interface FastEthernet1

    access-list 10 permit 192.168.1.0 255.255.255.0
    access-list 10 deny any

    Thanks,
    Nathan
     
    nmilford, Nov 21, 2007
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. marek

    Load Balancing with two ISPs

    marek, Apr 22, 2005, in forum: Cisco
    Replies:
    7
    Views:
    1,022
    dt1649651@yahoo.com
    Apr 24, 2005
  2. ciscortp@hotmail.com

    Load Balancing / Load Sharing over parallel paths

    ciscortp@hotmail.com, Nov 21, 2005, in forum: Cisco
    Replies:
    1
    Views:
    2,350
    Vincent C Jones
    Nov 21, 2005
  3. jimmie
    Replies:
    1
    Views:
    776
    The-Wisest-One
    Feb 26, 2006
  4. okrus
    Replies:
    0
    Views:
    1,547
    okrus
    Jun 3, 2008
  5. palas_123
    Replies:
    1
    Views:
    2,112
    donjohnston
    Dec 28, 2009
Loading...

Share This Page