link type is force-up

Discussion in 'Cisco' started by Erik Tamminga, May 5, 2005.

  1. Hi,

    On a Catalyst 4500 with SX-GBICs what does "link type is force-up" mean
    (show interface gi1/2, sx-gbic)?
    We're having troubles bringing up a link between a Cat4500 and Cat2950-sx24.
    Link light on 2950 doesn't light up. Link light on 4500-side does light up.
    We already exchanged ports / gbics / ... .

    Cisco.com doesn't have an explanation of the "force-up" state (or I can't
    find it).

    Erik
     
    Erik Tamminga, May 5, 2005
    #1
    1. Advertising

  2. Erik Tamminga

    Guest

    Please post the configs for the relevant ports.

    I have had a look too and can't find anything much.


    There is a thread in:

    de.comp.hardware.netzwerke.misc

    "E1000 bekommt keinen Link zum Catalyst-Switch"

    Altavista babelfish helped slightly.

    One of the 4500's that I look after says:

    interface GigabitEthernet2/1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,201-204
    switchport mode trunk
    udld port
    flowcontrol send on
    channel-group 1 mode desirable
    !
    interface GigabitEthernet2/2
    !
    interface GigabitEthernet3/1
    spanning-tree portfast
    !
    interface GigabitEthernet3/2
    spanning-tree portfast
    !
    interface GigabitEthernet3/3
    spanning-tree portfast
    !
    interface GigabitEthernet3/4
    spanning-tree portfast
    ......

    bcm-sw1#sh int | inc duplex
    Full-duplex, 1000Mb/s, link type is auto, media type is SX
    Auto-duplex, Auto-speed
    Full-duplex, 1000Mb/s, link type is auto, media type is SX
    Auto-duplex, Auto-speed
    Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
    Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
    Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
    Auto-duplex, Auto-speed
    Auto-duplex, Auto-speed
    Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
    Full-duplex, 100Mb/s
    Auto-duplex, Auto-speed


    bcm-sw1#sh ip int br
    Interface IP-Address OK? Method Status
    Protocol
    Vlan1 192.168.20.248 YES NVRAM up
    up
    Vlan201 10.20.1.248 YES NVRAM up
    up
    Vlan202 10.20.2.248 YES NVRAM up
    up
    Vlan203 10.20.3.248 YES NVRAM up
    up
    Vlan204 10.20.4.248 YES manual up
    up
    GigabitEthernet1/1 unassigned YES unset up
    up
    GigabitEthernet1/2 unassigned YES unset down
    down
    GigabitEthernet2/1 unassigned YES unset up
    up
    GigabitEthernet2/2 unassigned YES unset down
    down
    GigabitEthernet3/1 unassigned YES unset up
    up
    GigabitEthernet3/2 unassigned YES unset up
    up
    GigabitEthernet3/3 unassigned YES unset up
    up
    GigabitEthernet3/4 unassigned YES unset down
    down
    GigabitEthernet3/5 unassigned YES unset down
    down
    GigabitEthernet3/6 unassigned YES unset up
    up
    GigabitEthernet3/7 unassigned YES unset up
    up
     
    , May 5, 2005
    #2
    1. Advertising

  3. Erik Tamminga

    Guest

    Please post the configs for the relevant ports.

    I have had a look too and can't find anything much.


    There is a thread in:

    de.comp.hardware.netzwerke.misc

    "E1000 bekommt keinen Link zum Catalyst-Switch"

    Altavista babelfish helped slightly.

    One of the 4500's that I look after says:

    interface GigabitEthernet2/1
    switchport trunk encapsulation dot1q
    switchport trunk allowed vlan 1,201-204
    switchport mode trunk
    udld port
    flowcontrol send on
    channel-group 1 mode desirable
    !
    interface GigabitEthernet2/2
    !
    interface GigabitEthernet3/1
    spanning-tree portfast
    !
    interface GigabitEthernet3/2
    spanning-tree portfast
    !
    interface GigabitEthernet3/3
    spanning-tree portfast
    !
    interface GigabitEthernet3/4
    spanning-tree portfast
    ......

    bcm-sw1#sh int | inc duplex
    Full-duplex, 1000Mb/s, link type is auto, media type is SX
    Auto-duplex, Auto-speed
    Full-duplex, 1000Mb/s, link type is auto, media type is SX
    Auto-duplex, Auto-speed
    Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
    Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
    Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
    Auto-duplex, Auto-speed
    Auto-duplex, Auto-speed
    Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
    Full-duplex, 100Mb/s
    Auto-duplex, Auto-speed


    bcm-sw1#sh ip int br
    Interface IP-Address OK? Method Status
    Protocol
    Vlan1 192.168.20.248 YES NVRAM up
    up
    Vlan201 10.20.1.248 YES NVRAM up
    up
    Vlan202 10.20.2.248 YES NVRAM up
    up
    Vlan203 10.20.3.248 YES NVRAM up
    up
    Vlan204 10.20.4.248 YES manual up
    up
    GigabitEthernet1/1 unassigned YES unset up
    up
    GigabitEthernet1/2 unassigned YES unset down
    down
    GigabitEthernet2/1 unassigned YES unset up
    up
    GigabitEthernet2/2 unassigned YES unset down
    down
    GigabitEthernet3/1 unassigned YES unset up
    up
    GigabitEthernet3/2 unassigned YES unset up
    up
    GigabitEthernet3/3 unassigned YES unset up
    up
    GigabitEthernet3/4 unassigned YES unset down
    down
    GigabitEthernet3/5 unassigned YES unset down
    down
    GigabitEthernet3/6 unassigned YES unset up
    up
    GigabitEthernet3/7 unassigned YES unset up
    up
     
    , May 5, 2005
    #3
  4. Hi,

    The config on both switches is actually quite easy:

    interface GigabitEthernetX/Y
    switchport mode access
    !

    In order to rule out any mis-configuration we stripped the config to the
    bare minimum. My first goal is to see an up/up state on both sides of the
    link.
    Cat4500 says in show interface output "link type is force-up" and
    administrative- and operational status "up".
    Cat2950 says in show interface output operational status "down". Interface
    is not in shutdown state.

    I do not have physical access to the switches right now so I can't give you
    more details.

    Erik


    <> wrote in message
    news:...
    > Please post the configs for the relevant ports.
    >
    > I have had a look too and can't find anything much.
    >
    >
    > There is a thread in:
    >
    > de.comp.hardware.netzwerke.misc
    >
    > "E1000 bekommt keinen Link zum Catalyst-Switch"
    >
    > Altavista babelfish helped slightly.
    >
    > One of the 4500's that I look after says:
    >
    > interface GigabitEthernet2/1
    > switchport trunk encapsulation dot1q
    > switchport trunk allowed vlan 1,201-204
    > switchport mode trunk
    > udld port
    > flowcontrol send on
    > channel-group 1 mode desirable
    > !
    > interface GigabitEthernet2/2
    > !
    > interface GigabitEthernet3/1
    > spanning-tree portfast
    > !
    > interface GigabitEthernet3/2
    > spanning-tree portfast
    > !
    > interface GigabitEthernet3/3
    > spanning-tree portfast
    > !
    > interface GigabitEthernet3/4
    > spanning-tree portfast
    > .....
    >
    > bcm-sw1#sh int | inc duplex
    > Full-duplex, 1000Mb/s, link type is auto, media type is SX
    > Auto-duplex, Auto-speed
    > Full-duplex, 1000Mb/s, link type is auto, media type is SX
    > Auto-duplex, Auto-speed
    > Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
    > Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
    > Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
    > Auto-duplex, Auto-speed
    > Auto-duplex, Auto-speed
    > Full-duplex, 1000Mb/s, link type is auto, media type is RJ45
    > Full-duplex, 100Mb/s
    > Auto-duplex, Auto-speed
    >
    >
    > bcm-sw1#sh ip int br
    > Interface IP-Address OK? Method Status
    > Protocol
    > Vlan1 192.168.20.248 YES NVRAM up
    > up
    > Vlan201 10.20.1.248 YES NVRAM up
    > up
    > Vlan202 10.20.2.248 YES NVRAM up
    > up
    > Vlan203 10.20.3.248 YES NVRAM up
    > up
    > Vlan204 10.20.4.248 YES manual up
    > up
    > GigabitEthernet1/1 unassigned YES unset up
    > up
    > GigabitEthernet1/2 unassigned YES unset down
    > down
    > GigabitEthernet2/1 unassigned YES unset up
    > up
    > GigabitEthernet2/2 unassigned YES unset down
    > down
    > GigabitEthernet3/1 unassigned YES unset up
    > up
    > GigabitEthernet3/2 unassigned YES unset up
    > up
    > GigabitEthernet3/3 unassigned YES unset up
    > up
    > GigabitEthernet3/4 unassigned YES unset down
    > down
    > GigabitEthernet3/5 unassigned YES unset down
    > down
    > GigabitEthernet3/6 unassigned YES unset up
    > up
    > GigabitEthernet3/7 unassigned YES unset up
    > up
    >
     
    Erik Tamminga, May 6, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Sokre
    Replies:
    4
    Views:
    2,659
  2. Replies:
    0
    Views:
    1,672
  3. Replies:
    0
    Views:
    2,138
  4. Replies:
    0
    Views:
    2,201
  5. Replies:
    2
    Views:
    1,245
    Bert Hyman
    Dec 31, 2008
Loading...

Share This Page