limiting http bandwidth usage

Discussion in 'Cisco' started by Didier, Jan 23, 2004.

  1. Didier

    Didier Guest

    Hi,
    cisco ios Version 12.2(13)T10 on cisco1721

    I was wondering if it is possible to limit http bandwidth to a % of
    available bandwidth on an external interface.
    For example if it is 10mb interface limit http traffic to 60% .

    If it is possible, how?

    Thanks a lot
    Didier, Jan 23, 2004
    #1
    1. Advertising

  2. Didier

    Ivan Ostres Guest

    In article <40110a6e$>, says...
    > Hi,
    > cisco ios Version 12.2(13)T10 on cisco1721
    >
    > I was wondering if it is possible to limit http bandwidth to a % of
    > available bandwidth on an external interface.
    > For example if it is 10mb interface limit http traffic to 60% .
    >
    > If it is possible, how?
    >


    It's possible, but it makes sense just for outgoing traffic, not
    incoming.

    Search www.cisco.com for 'Custom queuing' and/or CBWFQ.


    --
    Ivan
    Ivan Ostres, Jan 23, 2004
    #2
    1. Advertising

  3. Hi.

    Well I think there are a few ways of doing it.

    Check out this link for more details.
    http://www.cisco.com/cgi-bin/Suppor...echnologies:Policing_and_Shaping&viewall=true



    This config uses CAR

    interface ethernet0
    ip address 192.168.1.1 255.255.255.0
    rate-limit input access-group 160 5000000 5000000 5000000
    conform-action transmit exceed-action drop
    !
    access-list 160 permit tcp any any eq www
    access-list 160 permit tcp any eq www any




    This config uses CB policing

    interface ethernet0
    ip address 192.168.1.1 255.255.255.0
    service-policy input HTTP
    !
    class-map match-all HTTP
    match access-group 160
    !
    policy-map HTTP
    class HTTP
    police 5000000 5000000 5000000 conform-action transmit
    exceed-action drop
    !
    access-list 160 permit tcp any any eq www
    access-list 160 permit tcp any eq www any
    Simon Tibbitts, Jan 23, 2004
    #3
  4. "Ivan Ostres" <> wrote in message
    news:burc72$kq6k4$-berlin.de...
    > It's possible, but it makes sense just for outgoing traffic, not
    > incoming.


    It makes most sence for outgoing traffic. That's where it is
    intended for.

    However, if you receive a stream and shape the outgoing
    interface (or rate-limit the input) some packets will be
    delayed or even dropped (always dropped with rate-limit).

    The delay and the lost packets cause usually a slow-start
    at the tcp stack of the sending end. This means the
    rate is dropped by the remote end. This really works
    in the real life too.

    keyword commands are
    traffic-shape ....
    rate-limit ...

    Oh, there is no aggregate shaping so it is not possible
    if you have more than one outgoing interface.

    This kind of simple solution will also set an absolute limit,
    weather you have unused capasity or not. The perfect
    solution is possible only at the next router upstream.
    There you can make desititions based on if there is
    unused capasity or not.
    --
    Harri
    Harri Suomalainen, Jan 26, 2004
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jon Jonsson
    Replies:
    0
    Views:
    1,348
    Jon Jonsson
    Dec 29, 2003
  2. Alex
    Replies:
    2
    Views:
    5,125
    Walter Roberson
    Feb 23, 2004
  3. Mohan Khurana

    Bandwidth limiting based on IP on PIX?

    Mohan Khurana, May 23, 2004, in forum: Cisco
    Replies:
    1
    Views:
    626
    Walter Roberson
    May 23, 2004
  4. Patrick Cervicek
    Replies:
    0
    Views:
    797
    Patrick Cervicek
    Aug 7, 2007
  5. milan_9211

    HTTP SOAP/HTTP GET/HTTP POST

    milan_9211, Jan 10, 2011, in forum: Software
    Replies:
    0
    Views:
    3,084
    milan_9211
    Jan 10, 2011
Loading...

Share This Page