Leased line configuration help with 2 1721's

Discussion in 'Cisco' started by James Philpot, Dec 27, 2003.

  1. Hi there,

    I have no experience of Cisco devices at all, but in the new year I will
    have to setup a leased line between 2 Cisco 1721 routers both with a WIC-1T.

    Here is the setup. At our head office we have about 20 pc's running Windows
    2k, 1 server running SBS 2k3 and a 512 ADSL connection to the 'Net. At the
    branch office we have 5 pc's working in a workgroup again with a 512 ADSL
    connection. At the moment the 2 networks are connected using a VPN using 2
    Draytek Vigor 2600's.

    The VPN is not fast enough so British Telecom are laying a 1 meg each way
    leased line. Does anyone know if the leased line BT call Megastream is PPP?
    The cabling will be X.21 inside the building.

    I will continue to use the ADSL routers for connection to the 'Net at both
    sites. Would I need to setup a static route on each ADSL router to point to
    the Cisco router for the clients to access the network the other side of the
    leased line?

    Does anyone know how difficult it will be to setup the 2 1721's to use the
    leased line? Is there a standard config? Do Telecom companies usually
    provide settings?

    Any help, advice, or pitfalls would be appreciated.

    Thank you,

    James.
     
    James Philpot, Dec 27, 2003
    #1
    1. Advertising

  2. On Sat, 27 Dec 2003 13:06:30 -0000, the infinite monkeys with infinite
    typewriters employed by "James Philpot" <>
    spewed forth:

    >Hi there,
    >
    >I have no experience of Cisco devices at all, but in the new year I will
    >have to setup a leased line between 2 Cisco 1721 routers both with a WIC-1T.
    >
    >Here is the setup. At our head office we have about 20 pc's running Windows
    >2k, 1 server running SBS 2k3 and a 512 ADSL connection to the 'Net. At the
    >branch office we have 5 pc's working in a workgroup again with a 512 ADSL
    >connection. At the moment the 2 networks are connected using a VPN using 2
    >Draytek Vigor 2600's.
    >
    >The VPN is not fast enough so British Telecom are laying a 1 meg each way
    >leased line. Does anyone know if the leased line BT call Megastream is PPP?


    The link will run whichever protocol you configure on the routers.

    >The cabling will be X.21 inside the building.
    >
    >I will continue to use the ADSL routers for connection to the 'Net at both
    >sites. Would I need to setup a static route on each ADSL router to point to
    >the Cisco router for the clients to access the network the other side of the
    >leased line?


    That would work, leaving the configuration on the PCs unchanged,
    minimising the risk of an "Oops" moment.

    >
    >Does anyone know how difficult it will be to setup the 2 1721's to use the
    >leased line? Is there a standard config? Do Telecom companies usually
    >provide settings?


    In order, very straight forward. There's a configuration on CCO that
    includes IPX and dynamic routing using RIP, but should give you an
    idea of what is required:
    http://www.cisco.com/en/US/products...figuration_guide_chapter09186a008007cd3d.html.

    Lastly, all BT are providing is the end to end connectivity; it is
    your decision as to what you do with the link.

    >
    >Any help, advice, or pitfalls would be appreciated.
    >
    >Thank you,
    >
    >James.
    >

    --
    Chris Ames
    --
    Statto - Stan Stannard's evil twin
    ZRX1200S GT750
    BOTAFOT#91 FTB#5 OSOS#32
    I'm not fat, I just need extra pre-load
     
    Chris Ames-Farrow, Dec 27, 2003
    #2
    1. Advertising

  3. "Chris Ames-Farrow" <> wrote in message
    news:...
    > On Sat, 27 Dec 2003 13:06:30 -0000, the infinite monkeys with infinite
    > typewriters employed by "James Philpot" <>
    > spewed forth:
    >
    > >Hi there,
    > >
    > >I have no experience of Cisco devices at all, but in the new year I will
    > >have to setup a leased line between 2 Cisco 1721 routers both with a

    WIC-1T.
    > >
    > >Here is the setup. At our head office we have about 20 pc's running

    Windows
    > >2k, 1 server running SBS 2k3 and a 512 ADSL connection to the 'Net. At

    the
    > >branch office we have 5 pc's working in a workgroup again with a 512 ADSL
    > >connection. At the moment the 2 networks are connected using a VPN using

    2
    > >Draytek Vigor 2600's.
    > >
    > >The VPN is not fast enough so British Telecom are laying a 1 meg each way
    > >leased line. Does anyone know if the leased line BT call Megastream is

    PPP?
    >
    > The link will run whichever protocol you configure on the routers.
    >
    > >The cabling will be X.21 inside the building.
    > >
    > >I will continue to use the ADSL routers for connection to the 'Net at

    both
    > >sites. Would I need to setup a static route on each ADSL router to point

    to
    > >the Cisco router for the clients to access the network the other side of

    the
    > >leased line?

    >
    > That would work, leaving the configuration on the PCs unchanged,
    > minimising the risk of an "Oops" moment.
    >
    > >
    > >Does anyone know how difficult it will be to setup the 2 1721's to use

    the
    > >leased line? Is there a standard config? Do Telecom companies usually
    > >provide settings?

    >
    > In order, very straight forward. There's a configuration on CCO that
    > includes IPX and dynamic routing using RIP, but should give you an
    > idea of what is required:
    >

    http://www.cisco.com/en/US/products...figuration_guide_chapter09186a008007cd3d.html.
    >
    > Lastly, all BT are providing is the end to end connectivity; it is
    > your decision as to what you do with the link.
    >
    > >
    > >Any help, advice, or pitfalls would be appreciated.
    > >
    > >Thank you,
    > >
    > >James.
    > >

    > --
    > Chris Ames
    > --
    > Statto - Stan Stannard's evil twin
    > ZRX1200S GT750
    > BOTAFOT#91 FTB#5 OSOS#32
    > I'm not fat, I just need extra pre-load


    Hi Chris, and thanks for your reply.

    I have a config which I would like someone with knowledge of Cisco devices
    to clarify will work for my situation. I can't test it myself as BT havn't
    installed the line yet. I can't believe BT get away with charging £900 per
    site to setup each router!

    I am planning to setup the routers with the config below and setup up a
    static route on each ADSL modem to say when a client on the 192.168.0.0
    network wants to view a computer on network 192.168.3.0 then use 192.168.0.1
    as the gateway, and vice versa - is this right??? Also would it be wise to
    setup either a WINS server of hosts file to help speed up network browsing?

    At the head office the computers are on the 192.168.0.0 network, and the
    computers at the branch office are on the 192.168.3.0 network.

    The router at the head office is called 1721_HEAD and the router at the
    branch office is called 1721_BRANCH.

    1721_HEAD#conf t
    1721_HEAD(config)#interface serial0
    1721_HEAD(config-if)#encapsulation ppp
    1721_HEAD(config-if)#ip address 192.168.0.1 255.255.255.0
    1721_HEAD(config-if)#no shut
    1721_HEAD(config-if)#end


    1721_BRANCH#conf t
    1721_BRANCH(config)#interface serial0
    1721_BRANCH(config-if)#encapsulation ppp
    1721_BRANCH(config-if)#ip address 192.168.3.1 255.255.255.0
    1721_BRANCH(config-if)#no shut
    1721_BRANCH(config-if)#end

    Once again thanks for any advice,

    James.
     
    James Philpot, Dec 28, 2003
    #3
  4. "James Philpot" <> wrote in message
    news:...
    >
    > "Chris Ames-Farrow" <> wrote in message
    > news:...
    > > On Sat, 27 Dec 2003 13:06:30 -0000, the infinite monkeys with infinite
    > > typewriters employed by "James Philpot" <>
    > > spewed forth:
    > >
    > > >Hi there,
    > > >
    > > >I have no experience of Cisco devices at all, but in the new year I

    will
    > > >have to setup a leased line between 2 Cisco 1721 routers both with a

    > WIC-1T.
    > > >
    > > >Here is the setup. At our head office we have about 20 pc's running

    > Windows
    > > >2k, 1 server running SBS 2k3 and a 512 ADSL connection to the 'Net. At

    > the
    > > >branch office we have 5 pc's working in a workgroup again with a 512

    ADSL
    > > >connection. At the moment the 2 networks are connected using a VPN

    using
    > 2
    > > >Draytek Vigor 2600's.
    > > >
    > > >The VPN is not fast enough so British Telecom are laying a 1 meg each

    way
    > > >leased line. Does anyone know if the leased line BT call Megastream is

    > PPP?
    > >
    > > The link will run whichever protocol you configure on the routers.
    > >
    > > >The cabling will be X.21 inside the building.
    > > >
    > > >I will continue to use the ADSL routers for connection to the 'Net at

    > both
    > > >sites. Would I need to setup a static route on each ADSL router to

    point
    > to
    > > >the Cisco router for the clients to access the network the other side

    of
    > the
    > > >leased line?

    > >
    > > That would work, leaving the configuration on the PCs unchanged,
    > > minimising the risk of an "Oops" moment.
    > >
    > > >
    > > >Does anyone know how difficult it will be to setup the 2 1721's to use

    > the
    > > >leased line? Is there a standard config? Do Telecom companies usually
    > > >provide settings?

    > >
    > > In order, very straight forward. There's a configuration on CCO that
    > > includes IPX and dynamic routing using RIP, but should give you an
    > > idea of what is required:
    > >

    >

    http://www.cisco.com/en/US/products...figuration_guide_chapter09186a008007cd3d.html.
    > >
    > > Lastly, all BT are providing is the end to end connectivity; it is
    > > your decision as to what you do with the link.
    > >
    > > >
    > > >Any help, advice, or pitfalls would be appreciated.
    > > >
    > > >Thank you,
    > > >
    > > >James.
    > > >

    > > --
    > > Chris Ames
    > > --
    > > Statto - Stan Stannard's evil twin
    > > ZRX1200S GT750
    > > BOTAFOT#91 FTB#5 OSOS#32
    > > I'm not fat, I just need extra pre-load

    >
    > Hi Chris, and thanks for your reply.
    >
    > I have a config which I would like someone with knowledge of Cisco devices
    > to clarify will work for my situation. I can't test it myself as BT havn't
    > installed the line yet. I can't believe BT get away with charging £900 per
    > site to setup each router!
    >
    > I am planning to setup the routers with the config below and setup up a
    > static route on each ADSL modem to say when a client on the 192.168.0.0
    > network wants to view a computer on network 192.168.3.0 then use

    192.168.0.1
    > as the gateway, and vice versa - is this right??? Also would it be wise to
    > setup either a WINS server of hosts file to help speed up network

    browsing?

    OK I spotted an error with my config. I need to setup a seperate IP for the
    ethernet side of each router don't I? So the static route would point to the
    ethernet IP instead. Say 192.168.3.2 and 192.168.0.2, right??


    >
    > At the head office the computers are on the 192.168.0.0 network, and the
    > computers at the branch office are on the 192.168.3.0 network.
    >
    > The router at the head office is called 1721_HEAD and the router at the
    > branch office is called 1721_BRANCH.
    >
    > 1721_HEAD#conf t
    > 1721_HEAD(config)#interface serial0
    > 1721_HEAD(config-if)#encapsulation ppp
    > 1721_HEAD(config-if)#ip address 192.168.0.1 255.255.255.0
    > 1721_HEAD(config-if)#no shut
    > 1721_HEAD(config-if)#end
    >
    >
    > 1721_BRANCH#conf t
    > 1721_BRANCH(config)#interface serial0
    > 1721_BRANCH(config-if)#encapsulation ppp
    > 1721_BRANCH(config-if)#ip address 192.168.3.1 255.255.255.0
    > 1721_BRANCH(config-if)#no shut
    > 1721_BRANCH(config-if)#end
    >
    > Once again thanks for any advice,
    >
    > James.
    >
    >
     
    James Philpot, Dec 28, 2003
    #4
  5. On Sun, 28 Dec 2003 11:23:37 -0000, the infinite monkeys with infinite
    typewriters employed by "James Philpot" <>
    spewed forth:

    >
    >"James Philpot" <> wrote in message
    >news:...
    >>
    >>
    >> Hi Chris, and thanks for your reply.
    >>
    >> I have a config which I would like someone with knowledge of Cisco devices
    >> to clarify will work for my situation. I can't test it myself as BT havn't
    >> installed the line yet. I can't believe BT get away with charging £900 per
    >> site to setup each router!


    A touch high.

    >>
    >> I am planning to setup the routers with the config below and setup up a
    >> static route on each ADSL modem to say when a client on the 192.168.0.0
    >> network wants to view a computer on network 192.168.3.0 then use

    >192.168.0.1
    >> as the gateway, and vice versa - is this right??? Also would it be wise to
    >> setup either a WINS server of hosts file to help speed up network

    >browsing?
    >
    >> At the head office the computers are on the 192.168.0.0 network, and the
    >> computers at the branch office are on the 192.168.3.0 network.
    >>
    >> The router at the head office is called 1721_HEAD and the router at the
    >> branch office is called 1721_BRANCH.
    >>
    >> 1721_HEAD#conf t
    >> 1721_HEAD(config)#interface serial0
    >> 1721_HEAD(config-if)#encapsulation ppp
    >> 1721_HEAD(config-if)#ip address 192.168.0.1 255.255.255.0
    >> 1721_HEAD(config-if)#no shut
    >> 1721_HEAD(config-if)#end
    >>
    >>
    >> 1721_BRANCH#conf t
    >> 1721_BRANCH(config)#interface serial0
    >> 1721_BRANCH(config-if)#encapsulation ppp
    >> 1721_BRANCH(config-if)#ip address 192.168.3.1 255.255.255.0
    >> 1721_BRANCH(config-if)#no shut
    >> 1721_BRANCH(config-if)#end


    O.K., first off, the serial links need to be on the same network. I'm
    guessing that you're using the lower end of the 192.168.x.0 networks
    for the LANs at each site, so to keep things simple, you could either
    use something like 192.168.254.0 for the WAN link:

    on 1721_HEAD:
    ip address 192.168.254.1 255.255.255.252

    on 1721_BRANCH:
    ip address 192.168.254.2 255.255.255.252

    I've used a network mask of 255.255.255.252 in order to minimise
    address usage on the WAN links.

    >
    >OK I spotted an error with my config. I need to setup a seperate IP for the
    >ethernet side of each router don't I? So the static route would point to the
    >ethernet IP instead. Say 192.168.3.2 and 192.168.0.2, right??


    Yes, you will need to assign an IP address from the networks at each
    location and point the ADSL routers at the ethernet interface on the
    1721s for the remote links

    On 1721_HEAD:
    ip route 192.168.x.0 255.255.255.0 192.168.254.2

    On 1721_BRANCH
    ip route 192.168.y.0 255.255.255.0 192.168.254.1

    As for the Windows networking side of things... I'm a bit rusty on
    that sort of thing, but from memory, if you want to avoid using an
    LMHOSTS file on each of the branch machines, then WINS/DNS would help
    - you should be able to run a single server at the head office and
    point the branch machines at them.

    --
    Chris Ames-Farrow
     
    Chris Ames-Farrow, Dec 28, 2003
    #5
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. James Philpot
    Replies:
    3
    Views:
    3,699
    Chris Ames-Farrow
    Jan 8, 2004
  2. norsyam
    Replies:
    6
    Views:
    3,216
    Vincent C Jones
    Sep 28, 2004
  3. ZP
    Replies:
    1
    Views:
    510
  4. Replies:
    0
    Views:
    616
  5. Master of Public Administration

    Leased Line configuration on Serial Port (Cisco 1841)

    Master of Public Administration, Mar 11, 2008, in forum: Cisco
    Replies:
    2
    Views:
    11,403
Loading...

Share This Page