learning destination MAC if default route uses interface and not next-hop IP

Discussion in 'Cisco' started by Brad, Sep 20, 2005.

  1. Brad

    Brad Guest

    I have a router with the following configuration:

    service password-encryption
    !
    hostname suse_class
    !
    ip subnet-zero
    !
    no ip domain-lookup
    !
    interface FastEthernet0/0
    ip address 192.168.100.254 255.255.255.0
    no shutdown
    no ip proxy-arp
    ip nat inside
    duplex auto
    speed auto
    !
    interface FastEthernet1/0
    ip address 10.0.0.1 255.255.255.128
    ip access-group inboundfilters in
    ip access-group outboundfilters out
    no ip proxy-arp
    ip nat outside
    no shutdown
    duplex auto
    speed auto
    !
    !
    ip nat pool suseclass 10.0.0.1 10.0.0.1prefix-length 29
    ip nat inside source list 1 pool suseclass overload
    no ip classless
    no ip forward-protocol udp tftp
    no ip forward-protocol udp domain
    no ip forward-protocol udp time
    no ip forward-protocol udp tacacs
    ip route 0.0.0.0 0.0.0.0 FastEthernet1/0
    no ip http server
    !
    !
    ip access-list extended inboundfilters
    evaluate traffic
    ip access-list extended outboundfilters
    permit tcp any any reflect traffic
    permit udp any any reflect traffic
    permit icmp any any reflect traffic
    access-list 1 permit 192.168.100.0 0.0.0.255
    !
    line con 0
    exec-timeout 0 0
    logging synchronous
    line aux 0
    line vty 0 4
    login

    The question I have is since I used the interface (fa1/0) in my default
    route statement instead of the next-hop IP address how does this router
    find out the MAC address for the router on the 10.0.0.0/25 network that
    my router is forwarding traffic to out of fa1/0?
     
    Brad, Sep 20, 2005
    #1
    1. Advertising

  2. Brad

    Merv Guest

    > how does this router find out the MAC address for the router on the 10.0.0.0/25 > network that > my router is forwarding traffic to out of fa1/0?

    It doesn't. It arps for the destination IP address in the outbount
    packet and the upstream router responds it it is configured for
    proxy-arp.

    pointing a static to an interface is a BAD idea; you will want to chane
    it to the next hop IP address ( and clear the routers ARP cache (use
    shut/no shut if necessary).
     
    Merv, Sep 20, 2005
    #2
    1. Advertising

  3. Brad

    Brad Guest

    Thanks for the reply. That makes sense. If the other router had proxy
    arp disabled I guess my router would be unable to communicate to the
    outside world?

    I did notice that the arp cache was huge, but besides that why is it
    such a bad idea?
     
    Brad, Sep 20, 2005
    #3
  4. Brad

    Merv Guest

    That is why it is abad idea, that ARP cache has to be scanned
    continually by the router. Change to use the next IP hop and it you
    control the next hop router disable proxy arp on it also.
     
    Merv, Sep 20, 2005
    #4
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Ben Low
    Replies:
    0
    Views:
    513
    Ben Low
    Feb 28, 2004
  2. Brad
    Replies:
    14
    Views:
    7,699
    Ivan OstreŇ°
    Mar 3, 2005
  3. Replies:
    4
    Views:
    1,503
  4. Eric
    Replies:
    15
    Views:
    10,440
  5. David Sudjiman

    Re: BGP + Route-map + Next-hop addr

    David Sudjiman, Jan 23, 2007, in forum: Cisco
    Replies:
    3
    Views:
    514
    David Sudjiman
    Jan 23, 2007
Loading...

Share This Page