Laptop Question

Discussion in 'NZ Computing' started by Rastus, Apr 16, 2005.

  1. Rastus

    Rastus Guest

    Greetings all,

    I have an Acer 512T laptop which is about 5½ years old.
    It's been going fine until the other day. I went to turn it on, it
    made the usual startup noises which I assume are the fan and the hard
    drive, nothing camp up on screen, then a few seconds later it just
    turned off again. Battery is fully charged. Every time I turn the
    power switch on, it does the same thing, winds up for a few seconds
    then dies with the screen remaining blank. Can't even get far enough
    to look at the bios settings. It just seems dead.

    I realise this is a really long shot, but is there anyone technically
    minded enough out there that is able to give some constructive
    thoughts as to what sorts of things it could be.

    Cheers and many thanks.
    Rastus, Apr 16, 2005
    #1
    1. Advertising

  2. Rastus

    Me Guest

    On Sat, 16 Apr 2005 17:06:21 +1200, Rastus <>
    wrote:

    Does it attempt to mount the hard drive?
    any does the HD LED show activity
    can it boot to a floppy boot disk?

    hmm, does sound rather terminal
    Me, Apr 16, 2005
    #2
    1. Advertising

  3. Rastus

    EMB Guest

    Rastus wrote:
    > Greetings all,
    >
    > I have an Acer 512T laptop which is about 5½ years old.
    > It's been going fine until the other day. I went to turn it on, it
    > made the usual startup noises which I assume are the fan and the hard
    > drive, nothing camp up on screen, then a few seconds later it just
    > turned off again. Battery is fully charged. Every time I turn the
    > power switch on, it does the same thing, winds up for a few seconds
    > then dies with the screen remaining blank. Can't even get far enough
    > to look at the bios settings. It just seems dead.
    >
    > I realise this is a really long shot, but is there anyone technically
    > minded enough out there that is able to give some constructive
    > thoughts as to what sorts of things it could be.
    >
    > Cheers and many thanks.


    Try taking the battery out and doing it all again. If that doesn't work
    have a google about getting into it's bios and see if anything's amiss
    there.

    --
    EMB
    EMB, Apr 16, 2005
    #3
  4. Rastus

    AlexT Guest

    I am guessing here.



    Sound like your external power source not function anymore.

    So the battery try to power up but die again.
    AlexT, Apr 16, 2005
    #4
  5. Rastus wrote:
    > Greetings all,
    >
    > I have an Acer 512T laptop which is about 5½ years old.
    > It's been going fine until the other day. I went to turn it on, it
    > made the usual startup noises which I assume are the fan and the hard
    > drive, nothing camp up on screen, then a few seconds later it just
    > turned off again. Battery is fully charged. Every time I turn the
    > power switch on, it does the same thing, winds up for a few seconds
    > then dies with the screen remaining blank. Can't even get far enough
    > to look at the bios settings. It just seems dead.
    >
    > I realise this is a really long shot, but is there anyone technically
    > minded enough out there that is able to give some constructive
    > thoughts as to what sorts of things it could be.
    >
    > Cheers and many thanks.


    I once had a similar problem with an Acer 507T. It turned out to be the
    power supply. In my case I could sometimes run the computer for half an
    hour before it died out of the blue. So I don't know whether you've got
    the same issue.

    Cheers,

    Martin
    Martin Kaufmann, Apr 17, 2005
    #5
  6. Rastus

    Jerry Guest

    Rastus wrote:
    > Greetings all,
    >
    > I have an Acer 512T laptop which is about 5½ years old.
    > It's been going fine until the other day. I went to turn it on, it
    > made the usual startup noises which I assume are the fan and the hard
    > drive, nothing camp up on screen, then a few seconds later it just
    > turned off again. Battery is fully charged. Every time I turn the
    > power switch on, it does the same thing, winds up for a few seconds
    > then dies with the screen remaining blank. Can't even get far enough
    > to look at the bios settings. It just seems dead.
    >
    > I realise this is a really long shot, but is there anyone technically
    > minded enough out there that is able to give some constructive
    > thoughts as to what sorts of things it could be.
    >
    > Cheers and many thanks.


    I have a customer Compaq in with a similar problem, except that the
    Windows start screen comes up before it quits. It is the power supply,
    he replaced the original with a brand X with a lower amp rating than the
    original.

    If the battery is really charged, try it on just battery, no charger.
    Then take the battery out and try it on just the charger. Try to borow
    a charger somewhere to see if that fixes it. Good luck

    Jerry
    Jerry, Apr 17, 2005
    #6
  7. Rastus wrote:
    > I have an Acer 512T laptop which is about 5½ years old.
    > It's been going fine until the other day. I went to turn it on, it
    > made the usual startup noises which I assume are the fan and the hard
    > drive, nothing camp up on screen, then a few seconds later it just
    > turned off again. Battery is fully charged. Every time I turn the
    > power switch on, it does the same thing, winds up for a few seconds
    > then dies with the screen remaining blank. Can't even get far enough
    > to look at the bios settings. It just seems dead.


    I have two suggestions for you.

    first, take out all batteries(it might have more than one, you'll know
    whether it does or not), and see if it powers up from mains alone... if
    it does, wait until its finished loading the OS, and then biff the
    batteries back in.

    not sure what causes this, or even whats wrong, but it happens to some
    of the dells and toshibashere at work.

    The other potential problem is capacitor damage. a fried had this same
    sort of problem happen to his laptop, and it turned out to be dead
    capacitors on the motherboard, and because it was well out of warranty,
    no way to fix it.
    Dave - Dave.net.nz, Apr 17, 2005
    #7
  8. Rastus

    Rastus Guest

    On Mon, 18 Apr 2005 08:06:34 +1200, "Dave - Dave.net.nz"
    <> wrote:

    >Rastus wrote:
    >> I have an Acer 512T laptop which is about 5½ years old.
    >> It's been going fine until the other day. I went to turn it on, it
    >> made the usual startup noises which I assume are the fan and the hard
    >> drive, nothing camp up on screen, then a few seconds later it just
    >> turned off again. Battery is fully charged. Every time I turn the
    >> power switch on, it does the same thing, winds up for a few seconds
    >> then dies with the screen remaining blank. Can't even get far enough
    >> to look at the bios settings. It just seems dead.

    >
    >I have two suggestions for you.
    >
    >first, take out all batteries(it might have more than one, you'll know
    >whether it does or not), and see if it powers up from mains alone... if
    >it does, wait until its finished loading the OS, and then biff the
    >batteries back in.
    >
    >not sure what causes this, or even whats wrong, but it happens to some
    >of the dells and toshibashere at work.
    >
    >The other potential problem is capacitor damage. a fried had this same
    >sort of problem happen to his laptop, and it turned out to be dead
    >capacitors on the motherboard, and because it was well out of warranty,
    >no way to fix it.



    I've tried it several ways. With the battery in and mains connected,
    using the battery only and with the battery out and on mains. In all
    cases the results are just the same.
    Rastus, Apr 19, 2005
    #8
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. =?Utf-8?B?UGV0ZXIgQy4=?=

    Work Laptop (XP Pro in Domain) to Home Laptop (XPH WorkGroup)

    =?Utf-8?B?UGV0ZXIgQy4=?=, Oct 19, 2004, in forum: Wireless Networking
    Replies:
    1
    Views:
    2,871
    Chris Gual [MSFT]
    Oct 22, 2004
  2. =?Utf-8?B?Qmx1Y2FkZHk3MQ==?=

    Desktop can't access Laptop but Laptop can access desktop

    =?Utf-8?B?Qmx1Y2FkZHk3MQ==?=, Nov 22, 2004, in forum: Wireless Networking
    Replies:
    2
    Views:
    789
    Chuck
    Nov 23, 2004
  3. =?Utf-8?B?VGF6?=

    WLAN: from Laptop to Laptop to router ...???

    =?Utf-8?B?VGF6?=, Oct 14, 2005, in forum: Wireless Networking
    Replies:
    2
    Views:
    5,451
    =?Utf-8?B?VGF6?=
    Oct 14, 2005
  4. Plomaris

    Desktop can see Laptop, but Laptop can't see Desktop!

    Plomaris, Feb 16, 2006, in forum: Wireless Networking
    Replies:
    3
    Views:
    3,954
    Plomaris
    Feb 17, 2006
  5. rafael
    Replies:
    7
    Views:
    1,811
    Jack \(MVP-Networking\).
    Jan 21, 2008
Loading...

Share This Page