Laptop Only Uses WiFi, Refuses to Use Wired LAN When Connected

Discussion in 'Wireless Networking' started by M.H., Jul 23, 2005.

  1. M.H.

    M.H. Guest

    I have an IBM ThinkPad T42 running Windows XP SP2, and I have two
    network adapters:

    1. Intel PRO/1000 MT
    2. Intel PRO/Wireless 2200BG

    I have the adapters set to IP xxx.xxx.x.3 and xxx.xxx.x.4, respectively.
    For network bindings, I have the LAN set first, then WiFi. The
    problem is, when the laptop is in its dock, where it should have a wired
    connection, it uses WiFi instead. If I set both adapters to the same
    IP, such as IP xxx.xxx.x.3, and the laptop is in its dock, it uses the
    wired network, as the WiFi connection cannot setup its IP. How can I
    get Windows XP to use the wired connection when present, and only the
    WiFi as a fallback? Thanks.
     
    M.H., Jul 23, 2005
    #1
    1. Advertising

  2. M.H.

    * * Chas Guest

    "M.H." <> wrote in message
    news:...
    | I have an IBM ThinkPad T42 running Windows XP SP2, and I have two
    | network adapters:
    |
    | 1. Intel PRO/1000 MT
    | 2. Intel PRO/Wireless 2200BG
    |
    | I have the adapters set to IP xxx.xxx.x.3 and xxx.xxx.x.4,
    respectively.
    | For network bindings, I have the LAN set first, then WiFi. The
    | problem is, when the laptop is in its dock, where it should have a
    wired
    | connection, it uses WiFi instead. If I set both adapters to the same
    | IP, such as IP xxx.xxx.x.3, and the laptop is in its dock, it uses the
    | wired network, as the WiFi connection cannot setup its IP. How can I
    | get Windows XP to use the wired connection when present, and only the
    | WiFi as a fallback? Thanks.

    You can manually enable and disable both adapters. Also, there is a
    bridge feature that should control the adapters. Right click on My
    Networks (or whatever the fools in Redmond call it) desktop icon and
    choose Properties. Look for the Wired, Wireless and Bridge icons and
    right click on them to check their status.

    Chas.
     
    * * Chas, Jul 23, 2005
    #2
    1. Advertising

  3. M.H.

    eM eL Guest

    "M.H." <> wrote in message news:...
    >I have an IBM ThinkPad T42 running Windows XP SP2, and I have two network adapters:
    > How can I get Windows XP to use the wired connection when present, and only the
    > WiFi as a fallback? Thanks.


    Use IBM Access Connections to configure your connections instead of using windows
    network setup (and uncheck the "connect automatically" property for the wireless
    connection.)

    --
    ><<>><eM eL><
     
    eM eL, Jul 23, 2005
    #3
  4. M.H.

    Clark Guest

    Have you tried Network Connections-Advanced-Advanced Settings . I don't
    know is that will do it, but it looks promising.

    Clark

    "* * Chas" <> wrote in message
    news:...
    >
    > "M.H." <> wrote in message
    > news:...
    > | I have an IBM ThinkPad T42 running Windows XP SP2, and I have two
    > | network adapters:
    > |
    > | 1. Intel PRO/1000 MT
    > | 2. Intel PRO/Wireless 2200BG
    > |
    > | I have the adapters set to IP xxx.xxx.x.3 and xxx.xxx.x.4,
    > respectively.
    > | For network bindings, I have the LAN set first, then WiFi. The
    > | problem is, when the laptop is in its dock, where it should have a
    > wired
    > | connection, it uses WiFi instead. If I set both adapters to the same
    > | IP, such as IP xxx.xxx.x.3, and the laptop is in its dock, it uses the
    > | wired network, as the WiFi connection cannot setup its IP. How can I
    > | get Windows XP to use the wired connection when present, and only the
    > | WiFi as a fallback? Thanks.
    >
    > You can manually enable and disable both adapters. Also, there is a
    > bridge feature that should control the adapters. Right click on My
    > Networks (or whatever the fools in Redmond call it) desktop icon and
    > choose Properties. Look for the Wired, Wireless and Bridge icons and
    > right click on them to check their status.
    >
    > Chas.
    >
    >
     
    Clark, Jul 23, 2005
    #4
  5. M.H.

    M.H. Guest

    eM eL wrote:
    > "M.H." <> wrote in message news:...
    >
    >>I have an IBM ThinkPad T42 running Windows XP SP2, and I have two network adapters:
    >>How can I get Windows XP to use the wired connection when present, and only the
    >>WiFi as a fallback? Thanks.

    >
    >
    > Use IBM Access Connections to configure your connections instead of using windows
    > network setup (and uncheck the "connect automatically" property for the wireless
    > connection.)
    >


    Ok, I think using IBM Access Connections is the best solution, and what
    I was using previously. However, I switched over to letting Windows
    handle my connections, and I can't figure out how to re-enable IBM
    Access Connections. If I double-click on the "Wireless Connection
    Status" (I think this is a part of IBM Access Connections) in my system
    tray, I only have three buttons, "Find WLAN," "Modify WLAN Settings"
    (grayed out), and "Close." How do I wrench control of my connections
    from Windows and give them back to IBM Access Connections? Thanks!
     
    M.H., Jul 23, 2005
    #5
  6. M.H.

    eM eL Guest

    "M.H." <> wrote in message news:...
    > How do I wrench control of my connections from Windows and give them back to IBM
    > Access Connections? Thanks!




    Go to Start | Network Connections
    Click on the Wireless Connection and choose Properties
    Go to the Advanced tab and uncheck the "Use Windows to configure my wireless network
    setting" box. Click on OK.
    Click once on the IBM Access Connections icon in the tray and choose Launch IBM
    Access Connections.
    Click on Manage profiles and go from there.
    Good luck!
    --
    ><eM eL><
     
    eM eL, Jul 23, 2005
    #6
  7. M.H.

    M.H. Guest

    eM eL wrote:
    > "M.H." <> wrote in message news:...
    >
    >> How do I wrench control of my connections from Windows and give them back to IBM
    >>Access Connections? Thanks!

    >
    >
    >
    >
    > Go to Start | Network Connections
    > Click on the Wireless Connection and choose Properties
    > Go to the Advanced tab and uncheck the "Use Windows to configure my wireless network
    > setting" box. Click on OK.
    > Click once on the IBM Access Connections icon in the tray and choose Launch IBM
    > Access Connections.
    > Click on Manage profiles and go from there.
    > Good luck!


    Thanks, that worked! Although the "Use Windows to configure my wireless
    setting box" was under the "Wireless Networks" tab, not "Advanced."
    Since IBM Access Connections was handling my WiFi previously, all I had
    to do was disable Windows from handling it and IBM AC took over from there.
     
    M.H., Jul 24, 2005
    #7
  8. M.H.

    M.H. Guest

    eM eL wrote:
    > "M.H." <> wrote in message news:...
    >
    >> How do I wrench control of my connections from Windows and give them back to IBM
    >>Access Connections? Thanks!

    >
    >
    >
    >
    > Go to Start | Network Connections
    > Click on the Wireless Connection and choose Properties
    > Go to the Advanced tab and uncheck the "Use Windows to configure my wireless network
    > setting" box. Click on OK.
    > Click once on the IBM Access Connections icon in the tray and choose Launch IBM
    > Access Connections.
    > Click on Manage profiles and go from there.
    > Good luck!


    Actually, that didn't work. Also, IBM Access Connections seems to be
    for manual switching only. So I've gone back to Windows, but now I
    think I have the same issue...grr...
     
    M.H., Jul 24, 2005
    #8
  9. M.H.

    M.H. Guest

    eM eL wrote:
    > "M.H." <> wrote in message news:...
    >
    >> How do I wrench control of my connections from Windows and give them back to IBM
    >>Access Connections? Thanks!

    >
    >
    >
    >
    > Go to Start | Network Connections
    > Click on the Wireless Connection and choose Properties
    > Go to the Advanced tab and uncheck the "Use Windows to configure my wireless network
    > setting" box. Click on OK.
    > Click once on the IBM Access Connections icon in the tray and choose Launch IBM
    > Access Connections.
    > Click on Manage profiles and go from there.
    > Good luck!


    I figured out a Windows snafu. If you have a wired and WiFi connection,
    disconnect from the wired, it switches over to WiFi. Then when you
    redock the laptop, it still uses the WiFi.
     
    M.H., Jul 24, 2005
    #9
  10. M.H.

    Guest Guest

    Pop a cmd box. Run

    c:\>route /?

    Play with the IF (interface), and possibly metric.
    When you get it switching the way you want, write
    it up in a pair of .cmd scripts, one to switch to
    wifi, one to switch to ethernet. IFs may not be
    simply 1 for wired, 2 for wifi, ... it may be 1 for
    wired, 10003 for wifi, or whatever. There may be
    other, easier ways.

    MH- [Sun, 24 Jul 2005 17:26:29 -0400]:
    >I figured out a Windows snafu. If you have a wired and WiFi connection,
    >disconnect from the wired, it switches over to WiFi. Then when you
    >redock the laptop, it still uses the WiFi.


    --
    40th Floor - Software @ http://40th.com/
    iPlay : the ultimate audio player for mobiles
    parametric eq, xfeed, reverb; all on a mobile
     
    Guest, Jul 24, 2005
    #10
  11. M.H.

    eM eL Guest

    "M.H." <> wrote in message news:...


    > I figured out a Windows snafu. If you have a wired and WiFi connection, disconnect
    > from the wired, it switches over to WiFi. Then when you redock the laptop, it
    > still uses the WiFi.



    I switch between a variety of wired and wireless connections several times a day and
    don't have this problem.
    There are many other settings in IBM Connection Manager, for instance:
    Automatically Use the adapter with the fastest available network
    connection/Automatically use the adapter with the highest defined priority level.
    Pick one.
    And
    Disconnect from the wireless network and turn off any wireless radios associated with
    this profile when I switch to a different location profile.

    (all on the Adapter tab.)

    Investigate also the settings on the Wireless tab .
    Perhaps you need to upgrade your Connection Manager..?

    Good luck!

    --
    ><eM eL><
     
    eM eL, Jul 24, 2005
    #11
  12. M.H.

    M.H. Guest

    * * Chas wrote:
    > "M.H." <> wrote in message
    > news:...
    > | I have an IBM ThinkPad T42 running Windows XP SP2, and I have two
    > | network adapters:
    > |
    > | 1. Intel PRO/1000 MT
    > | 2. Intel PRO/Wireless 2200BG
    > |
    > | I have the adapters set to IP xxx.xxx.x.3 and xxx.xxx.x.4,
    > respectively.
    > | For network bindings, I have the LAN set first, then WiFi. The
    > | problem is, when the laptop is in its dock, where it should have a
    > wired
    > | connection, it uses WiFi instead. If I set both adapters to the same
    > | IP, such as IP xxx.xxx.x.3, and the laptop is in its dock, it uses the
    > | wired network, as the WiFi connection cannot setup its IP. How can I
    > | get Windows XP to use the wired connection when present, and only the
    > | WiFi as a fallback? Thanks.
    >
    > You can manually enable and disable both adapters. Also, there is a
    > bridge feature that should control the adapters. Right click on My
    > Networks (or whatever the fools in Redmond call it) desktop icon and
    > choose Properties. Look for the Wired, Wireless and Bridge icons and
    > right click on them to check their status.
    >
    > Chas.
    >
    >


    Can you go into the Bridge feature in more detail? I was told by IBM to
    set both adapters to dynamic IP, set the bridge to static IP (my network
    is static), and that should work. When I rebooted the PC though, I
    couldn't connect to the network, as it stated that the static IP for the
    bridge was already in use by the network. Could have been each network
    adapter fighting over the single IP address. Should I have an IP
    address set for each network adapter as well as the bridge? Thanks.
     
    M.H., Jul 24, 2005
    #12
  13. M.H.

    M.H. Guest

    eM eL wrote:
    > "M.H." <> wrote in message news:...
    >
    >
    >
    >>I figured out a Windows snafu. If you have a wired and WiFi connection, disconnect
    >>from the wired, it switches over to WiFi. Then when you redock the laptop, it
    >>still uses the WiFi.

    >
    >
    >
    > I switch between a variety of wired and wireless connections several times a day and
    > don't have this problem.
    > There are many other settings in IBM Connection Manager, for instance:
    > Automatically Use the adapter with the fastest available network
    > connection/Automatically use the adapter with the highest defined priority level.
    > Pick one.
    > And
    > Disconnect from the wireless network and turn off any wireless radios associated with
    > this profile when I switch to a different location profile.
    >
    > (all on the Adapter tab.)
    >
    > Investigate also the settings on the Wireless tab .
    > Perhaps you need to upgrade your Connection Manager..?
    >
    > Good luck!
    >


    I'm not currently using IBM Access Connections. My understanding, from
    what I was told by IBM tech support, is that you must manually switch
    between wired and WiFI when using IBM Access Connections. In any case,
    IBM Access Connections is fiendishly difficult to configure properly,
    and the Indian or whatever he was wasn't any help. IBM Access
    Connections is the latest release, 3.71. Although the only way I can
    figure to get into the thing is to use the "Access IBM" button, do a
    keyword search, and open it from the Help Page. So it's not what you'd
    call user-friendly at all.
     
    M.H., Jul 25, 2005
    #13
  14. M.H.

    Gary L. Guest

    M.H. wrote:

    > I'm not currently using IBM Access Connections. My understanding, from
    > what I was told by IBM tech support, is that you must manually switch
    > between wired and WiFI when using IBM Access Connections. In any case,
    > IBM Access Connections is fiendishly difficult to configure properly,
    > and the Indian or whatever he was wasn't any help. IBM Access
    > Connections is the latest release, 3.71. Although the only way I can
    > figure to get into the thing is to use the "Access IBM" button, do a
    > keyword search, and open it from the Help Page. So it's not what you'd
    > call user-friendly at all.


    Actually, you can have Access Connections automatically switch between
    network adapters under the conditions you define, if you set it up
    correctly. My system will turn off the wireless radio and switch to
    Ethernet if it detects an Ethernet connection. If I disconnect the
    Ethernet it will then turn on the wireless and connect to my 802.11g
    network (and prompts me for permission to do so). If I boot it without
    an Ethernet connection, it will automatically try to connect to the
    wireless networks I have configured, according to the criteria I have
    defined. It will also switch default printers, change your browser home
    page, run applications, etc. according to the location detected. A few
    minutes of experimentation was all that was required to figure out the
    set-up. All in all, I think it is a pretty nice piece of work and I have
    had a pretty good experience with it.

    --
    Gary L.
    Reply to the newsgroup only
     
    Gary L., Jul 25, 2005
    #14
  15. M.H.

    eM eL Guest

    "M.H." <> wrote in message news:...
    > I'm not currently using IBM Access Connections. My understanding, from what I was
    > told by IBM tech support, is that you must manually switch between wired and WiFI
    > when using IBM Access Connections. In any case, IBM Access Connections is
    > fiendishly difficult to configure properly, and the Indian or whatever he was
    > wasn't any help. IBM Access Connections is the latest release, 3.71. Although the
    > only way I can figure to get into the thing is to use the "Access IBM" button, do a
    > keyword search, and open it from the Help Page. So it's not what you'd call
    > user-friendly at all.


    If so, your ThinkPad seems to have big configuration problems. Normally, Access
    Connections loads on startup. Edit your registry (or use msconfig) to add
    C:\Program Files\ThinkPad\ConnectUtilities\QCTRAY.EXE
    and
    C:\Program Files\ThinkPad\ConnectUtilities\QCWLICON.EXE
    to
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run
    (assuming, that your programs are in default locations)

    Or - better - use the IBM software installer to reinstall/update all your IBM
    utilities and drivers.

    I used to manage 1000 + of very mobile ThinkPad users and Access Connections worked
    fine for us to manage a multitude wired and wireless connections without any problems
    you've described.

    --
    ><eM eL><
     
    eM eL, Jul 25, 2005
    #15
  16. M.H.

    GomJabbar Guest

    M.H. wrote:

    > I'm not currently using IBM Access Connections. My understanding,
    > from what I was told by IBM tech support, is that you must manually
    > switch between wired and WiFI when using IBM Access Connections.
    > In any case, IBM Access Connections is fiendishly difficult to configure
    > properly, and the Indian or whatever he was wasn't any help. IBM
    > Access Connections is the latest release, 3.71. Although the only way
    > I can figure to get into the thing is to use the "Access IBM" button, do a
    > keyword search, and open it from the Help Page. So it's not what
    > you'd call user-friendly at all.


    (1) IBM Access Connections is not fiendishly difficult to configure.
    There is a profile wizard for creating as many location profiles as you
    want, whether wired (ethernet) or wireless (WiFi).

    (2) You do not need to manually switch between wired and WiFi when
    using Access Connections. Simply click on "Location Switching" on the
    top menu bar and click on "Switch Ethernet and Wireless Location
    Profiles Automatically"

    (3) To get into "the thing", go to Start > All Programs > Access IBM >
    IBM Access Connections. On the top menu bar, click on "Options" then
    on "Global Settings", and check the box for "Show wireless status icon
    in task tray". (Note: you must be logged on as Administrator to change
    some of the settings.) Now you will have an icon in the task tray at
    the lower right of the screen. Just click on the icon to open the
    program.
     
    GomJabbar, Jul 26, 2005
    #16
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Chris Burson

    WiFi router connected to a wired router?

    Chris Burson, Nov 17, 2005, in forum: Wireless Networking
    Replies:
    3
    Views:
    5,079
  2. =?Utf-8?B?Q2lhY2NpaG9tZQ==?=

    Connection between a lan-connected pc and a wireless connected

    =?Utf-8?B?Q2lhY2NpaG9tZQ==?=, Aug 17, 2006, in forum: Wireless Networking
    Replies:
    1
    Views:
    1,504
    Malke
    Aug 17, 2006
  3. Travis M.
    Replies:
    0
    Views:
    555
    Travis M.
    Dec 28, 2005
  4. Replies:
    6
    Views:
    1,063
    Duane Arnold
    Jun 11, 2006
  5. (PeteCresswell)
    Replies:
    2
    Views:
    662
    Jack \(MVP-Networking\).
    Dec 29, 2008
Loading...

Share This Page