lan-to-lan vpn over adsl

Discussion in 'Cisco' started by blaj, Nov 19, 2003.

  1. blaj

    blaj Guest

    Hi,

    I'm a beginner with vpns trying to follow
    Cisco's guides but now i am stucked with this
    lan-to-lan vpn over adsl config between 806 routers.
    I made the following so far but it works not.
    Could you please take a look on it.
    What's wrong with it?

    ROUTER_A:
    ....
    vpdn enable
    !
    vpdn-group pppoe
    accept-dialin
    protocol pppoe
    !
    crypto isakmp policy 5
    hash md5
    authentication pre-share
    crypto isakmp key PASSWORD address xx.yy.zzz.96
    !
    crypto isakmp peer address xx.yy.zzz.96
    !
    crypto ipsec transform-set vpnbol esp-des esp-md5-hmac
    !
    crypto map vpn 5 ipsec-isakmp
    set peer xx.yy.zzz.96
    set transform-set vpnbol
    match address 120
    ....
    interface Ethernet1
    description --- Connected to ADSL ---
    no ip address
    ip tcp adjust-mss 1452
    pppoe enable
    pppoe-client dial-pool-number 1
    no cdp enable
    crypto map vpn
    ....
    interface Dialer1
    ip address negotiated
    ip mtu 1492
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no keepalive
    no cdp enable
    ppp authentication pap callin
    ppp pap sent-username password 7 PASSWORD
    crypto map vpn
    ....
    ip nat inside source list 1 interface Dialer1 overload
    ....
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ....
    access-list 1 permit 192.168.1.0 0.0.0.255
    access-list 10 permit 213.163.0.0 0.0.0.255
    access-list 120 permit ip 192.168.1.0 0.0.0.15 10.0.0.0 0.0.0.15
    dialer-list 1 protocol ip permit


    ROUTER_B's config is the same except:
    hostname, peer name, e0 config,


    TIA,
    Balazs
     
    blaj, Nov 19, 2003
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. igor
    Replies:
    2
    Views:
    2,215
    Walter Roberson
    Oct 29, 2003
  2. Jason
    Replies:
    5
    Views:
    8,313
    Jason
    Nov 8, 2003
  3. -pau.fr
    Replies:
    0
    Views:
    722
    -pau.fr
    Oct 29, 2006
  4. pasatealinux
    Replies:
    1
    Views:
    2,067
    pasatealinux
    Dec 17, 2007
  5. Theo Markettos

    VOIP over VPN over TCP over WAP over 3G

    Theo Markettos, Feb 3, 2008, in forum: UK VOIP
    Replies:
    2
    Views:
    941
    Theo Markettos
    Feb 14, 2008
Loading...

Share This Page