L2TP tunnel problem

Discussion in 'Cisco' started by gzerphey, Jul 9, 2007.

  1. gzerphey

    gzerphey Guest

    I am having trouble with an L2TP tunnel. I have set up the manual
    handshake configuration and the tunnel is up and active, but no data
    seems to be traversing the network. If you guys have any ideas they
    would be appreciated. Attached is the configurations for the routers
    in question.

    I am trying to switch 172.20.48.x over the link. Oh yeah, please
    ignore the hostname on the routers, this was originally going to be
    GRE tunnels.

    Thank you,

    George

    JFK_GRE Router
    --------------------------
    Current configuration : 1141 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname JFK_GRE
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$tZ3g$vojTFXEobkFOMeJhb/eNy.
    !
    no aaa new-model
    !
    resource policy
    !
    ip subnet-zero
    ip cef
    !
    !
    l2tp-class class1
    !
    l2tp-class l2tp-defaults
    retransmit initial retries 30
    cookie size 8
    !
    !
    pseudowire-class ether-tunnel
    encapsulation l2tpv3
    protocol none
    ip local interface FastEthernet4
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0
    no cdp enable
    xconnect 172.20.16.250 123 encapsulation l2tpv3 manual pw-class ether-
    tunnel
    l2tp id 222 111
    l2tp cookie local 4 12345
    l2tp hello l2tp-defaults
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface FastEthernet4
    ip address 172.20.32.250 255.255.240.0
    duplex auto
    speed auto
    !
    interface Vlan1
    no ip address
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 172.20.32.1
    !
    no ip http server
    no ip http secure-server
    !
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    password cisco
    login
    !
    scheduler max-task-time 5000
    end



    Elkneck_GRE
    ---------------------
    Current configuration : 1154 bytes
    !
    version 12.4
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    no service password-encryption
    !
    hostname Elkneck_GRE
    !
    boot-start-marker
    boot-end-marker
    !
    enable secret 5 $1$9eXt$ne3V6bdt/MaUDXnkAYRkJ0
    !
    no aaa new-model
    !
    resource policy
    !
    ip subnet-zero
    ip cef
    !
    !
    l2tp-class l2tp-defaults
    retransmit initial retries 30
    cookie size 8
    !
    !
    pseudowire-class ether-tunnel
    encapsulation l2tpv3
    protocol none
    ip local interface FastEthernet4
    !
    !
    !
    !
    !
    !
    !
    !
    interface FastEthernet0
    no cdp enable
    xconnect 172.20.32.250 123 encapsulation l2tpv3 manual pw-class ether-
    tunnel
    l2tp id 111 222
    l2tp cookie local 4 12345
    l2tp cookie remote 4 54321
    l2tp hello l2tp-defaults
    !
    interface FastEthernet1
    !
    interface FastEthernet2
    !
    interface FastEthernet3
    !
    interface FastEthernet4
    ip address 172.20.16.250 255.255.240.0
    duplex auto
    speed auto
    !
    interface Vlan1
    no ip address
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 172.20.16.1
    !
    no ip http server
    no ip http secure-server
    !
    !
    control-plane
    !
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    password cisco
    login
    !
    scheduler max-task-time 5000
    end
     
    gzerphey, Jul 9, 2007
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. a.nonny mouse
    Replies:
    2
    Views:
    1,166
  2. Gary
    Replies:
    2
    Views:
    2,114
  3. AM
    Replies:
    1
    Views:
    593
  4. AM
    Replies:
    0
    Views:
    476
  5. davidls
    Replies:
    0
    Views:
    1,107
    davidls
    Mar 31, 2009
Loading...

Share This Page