JVC Camcorder

Discussion in 'DVD Video' started by jackperry5@gmail.com, Oct 22, 2005.

  1. Guest

    I have a strange problem with my JVC GR-AXM70 VHS-C Camcorder. When it
    is powered up it comes on but within a second or two after hitting
    record or play it dies as if the battery is dead. The batteries still
    show a full charge after the machine dies! I can turn it off and leave
    it a few minutes and it will do the same thing again. Or I can remove
    and reinstall the battery and it will power back up and do the same
    thing again. The strange thing is that it works great on AC power. I
    have tried several different batteries even new ones with no luck. Any
    ideas out there?

    Thanks,

    JP
     
    , Oct 22, 2005
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. tigercat

    JVC Camcorder

    tigercat, Jun 13, 2004, in forum: Computer Support
    Replies:
    14
    Views:
    1,206
    pablo fuentes
    Jun 15, 2004
  2. DG
    Replies:
    0
    Views:
    2,963
  3. John \O\

    JVC GR-DX100EK DV camcorder

    John \O\, Dec 19, 2003, in forum: Digital Photography
    Replies:
    0
    Views:
    1,264
    John \O\
    Dec 19, 2003
  4. Robert Kim

    JVC digital camcorder questions

    Robert Kim, Feb 7, 2004, in forum: Digital Photography
    Replies:
    0
    Views:
    397
    Robert Kim
    Feb 7, 2004
  5. Juan Carrera

    JVC camcorder UNIT IN SAFEGUARD MODE error

    Juan Carrera, Apr 28, 2004, in forum: DVD Video
    Replies:
    0
    Views:
    5,659
    Juan Carrera
    Apr 28, 2004
Loading...

Share This Page