ISIS and EIGRP mutual redistribution --Help!

Discussion in 'Cisco' started by phillip, Dec 20, 2004.

  1. phillip

    phillip Guest

    This does not work-->

    interface Serial0
    description connection to router3 EIGRP net
    ip address 192.168.1.1 255.255.255.0

    !
    interface Serial1
    description connection to router2 ISIS net
    ip address 10.1.1.1 255.255.255.0
    ip router isis
    !

    router eigrp 1
    redistribute isis level-1 metric 64 100 255 1 1500
    network 192.168.1.0
    no auto-summary

    !
    router isis
    redistribute eigrp 1 metric 10 metric-type external level-1
    net 02.0010.7b36.027e.00


    This does, why?--->

    Here is what I had to do to get ISIS and EIGRP to do mutual redistribution

    interface Serial0
    description connection to router3 EIGRP net
    ip address 192.168.1.1 255.255.255.0

    !
    interface Serial1
    description connection to router2 ISIS net
    ip address 10.1.1.1 255.255.255.0
    ip router isis
    !

    router eigrp 1
    redistribute isis level-1 metric 64 100 255 1 1500
    network 10.1.1.0 0.0.0.255
    network 192.168.1.0
    no auto-summary

    !
    router isis
    redistribute eigrp 1 metric 10 metric-type external level-1


    Here is the part that is confusing me. The only way I could get it to work
    is to
    redistribute connected or tell EIGRP about the 10.1.1.0 network which is
    basically the same thing.

    Usually when you redistribute you don't have to tell the protocol about both
    networks.

    I didn't have to enable ISIS on interface Serial0 (eigrp side)

    Why do I have to enable EIGRP on interface Serial1 (isis side)


    I tried it the other way around, I removed the 10.1.1.0 network From EIGRP
    and enabled ISIS on the 192.168.1.0 side but it didn't work, why?
     
    phillip, Dec 20, 2004
    #1
    1. Advertising

  2. phillip

    Ivan Ostreš Guest

    In article <41c6cdee$>,
    says...
    >
    > I didn't have to enable ISIS on interface Serial0 (eigrp side)
    >
    > Why do I have to enable EIGRP on interface Serial1 (isis side)
    >
    >


    Usually you don't need to do that. ISIS is a special case. When you have
    a redistribution ISIS to anything else, you have to redistribute
    connected interfaces which are under ISIS process manualy by
    'redistribute connected' or 'network' statement in destination routing
    protocol.

    I've never find out why this happens, but it does. I tried it on the
    Juniper router and there wasn't such situation (if I remember
    correctly). So, it's probably due cisco implementation of ISIS.

    If anyone know this in some more depth and find some time to write it
    here, that would be great...


    --
    -Ivan.

    *** Use Rot13 to see my eMail address ***
     
    Ivan Ostreš, Dec 20, 2004
    #2
    1. Advertising

  3. phillip

    mos33

    Joined:
    Aug 15, 2008
    Messages:
    8
    what the meaning of redistribution level 1 routes inside EIGRP??
     
    mos33, Sep 19, 2008
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Sam Soh
    Replies:
    5
    Views:
    8,016
    Sam Soh
    Aug 15, 2003
  2. slipstream_242

    route redistribution RIP and EIGRP

    slipstream_242, Jul 15, 2004, in forum: Cisco
    Replies:
    1
    Views:
    10,645
  3. phillip
    Replies:
    5
    Views:
    3,642
    Bob by the Bay
    Dec 7, 2004
  4. ciscohelp
    Replies:
    0
    Views:
    653
    ciscohelp
    Sep 5, 2006
  5. Scrif
    Replies:
    1
    Views:
    941
    Thrill5
    Feb 23, 2007
Loading...

Share This Page