isdn callback

Discussion in 'Cisco' started by Andree Toonk, Nov 12, 2003.

  1. Andree Toonk

    Andree Toonk Guest

    Hello everyone,

    I want to make a ISDN dialback connection with my Cisco 803.
    I use a windows 2000 workstation as dialback client, so the win2000 hosts
    dials to the cisco803,
    the cisco 803 then does a dialback to the win2000 host.

    Unfortunatly, this doesn't work as I would suspect.
    This was my initial (relevant) config, this is without dialback.

    <>
    username test password 7 xxxxxx

    interface Ethernet0
    description connected to InternalLAN
    ip address 192.168.1.252 255.255.254.0
    !
    interface BRI0
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type basic-net3
    ppp callback accept
    ppp authentication chap
    ppp multilink
    !
    interface Dialer1
    description connected to dialback
    ip unnumbered Ethernet0
    encapsulation ppp
    no ip split-horizon
    ip tcp header-compression passive
    no ip mroute-cache
    dialer pool 1
    dialer remote-name test
    dialer-group 1
    peer default ip address dhcp
    no cdp enable
    ppp authentication chap pap

    </>

    This works fine, the next step was to add the dialback option.
    unfortunatly this doesn't work...
    the new (dialback) config is this one:

    <>
    username test password 7 xxxxxx

    interface Ethernet0
    description connected to InternalLAN
    ip address 192.168.1.252 255.255.254.0
    !
    interface BRI0
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type basic-net3
    ppp callback accept
    ppp authentication chap
    ppp multilink
    !
    interface Dialer1
    description connected to dialback
    ip unnumbered Ethernet0
    encapsulation ppp
    no ip split-horizon
    ip tcp header-compression passive
    no ip mroute-cache
    dialer pool 1
    dialer remote-name test
    dialer string 0123456789
    dialer caller 0123456789 callback
    dialer-group 1
    peer default ip address dhcp
    no cdp enable
    ppp authentication chap pap
    </>


    I added the 2 commands (for dialer1):
    dialer string 0123456789
    dialer caller 0123456789 callback
    the telephone number 0123456789 is the number of the win2000 isdn line.


    should I add any aditional config?
    does anyone know how i should configure the win2000 client?
    I played around with the callback option in the advaced > dialup preferences
    menu in "network and dial-up connections",
    but it didn't seem te make diference.

    at the end of the message you'll find some debug info:


    any advise?

    thanks in advance,
    Andree


    debug:
    sh debugging
    Dial on demand:
    Dial on demand events debugging is on
    PPP:
    PPP protocol negotiation debugging is on
    PPP Callback Control Protocol debugging is on

    The following ISDN debugs are enabled on all DSLs:

    debug isdn error is ON.
    debug isdn event is ON.
    debug isdn q921 is ON.
    debug isdn q931 is ON.


    00:08:07: ISDN BR0 EVENT: service_queue_from_physical_layer: Recvd L1 prim 1
    state is 3
    00:08:07: ISDN BR0 EVENT: isdn_sw_cstate: State = 4, Old State = 4
    00:08:07: ISDN BR0 Q921: User TX -> IDREQ ri=65279 ai=127
    00:08:07: ISDN BR0 Q921: User RX <- IDASSN ri=65279 ai=70
    00:08:07: ISDN BR0 Q921: User TX -> SABMEp sapi=0 tei=70
    00:08:07: ISDN BR0 Q921: User RX <- UI sapi=0 tei=127
    00:08:07: ISDN BR0 Q931: SETUP pd = 8 callref = 0x7C
    Sending Complete
    Bearer Capability i = 0x8890
    Standard = CCITT
    Transer Capability = Unrestricted Digital
    Transfer Mode = Circuit
    Transfer Rate = 64 kbit/s
    Channel ID i = 0x89
    Calling Party Number i = 0x2183, '0123456789'
    Plan:ISDN, Type:National
    Called Party Number i = 0xA1, 'router isdn-telephone-number'
    Plan:ISDN, Type:National
    00:08:07: ISDN BR0 Q921: User RX <- UAf sapi=0 tei=70
    00:08:07: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 70 changed to up
    00:08:30064771072: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0xF
    calltype 1 HOST_INCOMING_CALL
    00:08:30064771072: BR0:1 DDR: Caller id 0123456789 matched to profile test
    00:08:30064771072: Di1 DDR: Caller id: Callback server starting to test
    0123456789
    00:08:30077190116: ISDN BR0 **ERROR**: host_incoming_call: DIALER ERROR 0x1:
    b channel 0, call id 0xF
    00:08:30064771072: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0xF
    calltype 1 HOST_DISCONNECT_ACK
    00:08:07: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=70, ns=0 nr=0
    00:08:07: ISDN BR0 Q931: RELEASE_COMP pd = 8 callref = 0xFC
    Cause i = 0x8095 - Call rejected
    00:08:07: ISDN BR0 Q921: User RX <- RR sapi=0 tei=70 nr=1
    00:08:17: ISDN BR0 Q921: User TX -> RRp sapi=0 tei=70 nr=0
    00:08:17: ISDN BR0 Q921: User RX <- RRf sapi=0 tei=70 nr=1
    00:08:17: ISDN BR0 Q921: User RX <- DISCp sapi=0 tei=70
    00:08:17: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 70 changed to
    down
    00:08:17: ISDN BR0 Q921: User TX -> UAf sapi=0 tei=70
    00:08:22: DDR: Callback timer expired
    00:08:22: Di1 DDR: beginning callback to test 0123456789
    00:08:22: BR0 DDR: rotor dialout [best] least recent failure is also most
    recent failure
    00:08:22: BR0 DDR: rotor dialout [best] also has most recent failure
    00:08:22: BR0 DDR: rotor dialout [best]
    00:08:22: BR0 DDR: Dialing cause Callback return call
    00:08:22: BR0 DDR: Attempting to dial 0123456789
    00:08:22: ISDN BR0 EVENT: UserIdle: callid 0x8006 received ISDN_CALL (0x0)
    00:08:22: ISDN BR0 Q921: User TX -> SABMEp sapi=0 tei=70
    00:08:22: ISDN BR0 Q921: User RX <- UAf sapi=0 tei=70
    00:08:22: %ISDN-6-LAYER2UP: Layer 2 for Interface BR0, TEI 70 changed to up
    00:08:22: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=70, ns=0 nr=0
    00:08:22: ISDN BR0 Q931: SETUP pd = 8 callref = 0x06
    Bearer Capability i = 0x8890
    Standard = CCITT
    Transer Capability = Unrestricted Digital
    Transfer Mode = Circuit
    Transfer Rate = 64 kbit/s
    Channel ID i = 0x83
    Called Party Number i = 0x80, '0123456789'
    Plan:Unknown, Type:Unknown
    00:08:22: ISDN BR0 Q921: User RX <- RR sapi=0 tei=70 nr=1
    00:08:22: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=70, ns=0 nr=1
    00:08:22: ISDN BR0 Q931: CALL_PROC pd = 8 callref = 0x86
    Channel ID i = 0x8A
    00:08:22: ISDN BR0 Q921: User TX -> RR sapi=0 tei=70 nr=1
    00:08:94489280512: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0x8006
    calltype 1 HOST_PROCEEDING
    00:08:27: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=70, ns=1 nr=1
    00:08:27: ISDN BR0 Q931: DISCONNECT pd = 8 callref = 0x86
    Cause i = 0x8095 - Call rejected
    00:08:27: ISDN BR0 Q921: User TX -> RR sapi=0 tei=70 nr=2
    00:08:115964116992: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0x8006
    calltype 1 HOST_DISCONNECT
    00:08:115976536572: BRI0: wait for isdn carrier timeout, call id=0x8006
    00:08:120259084287: DDR: Freeing callback to test 0123456789
    00:08:27: ISDN BR0 Q921: User TX -> INFO sapi=0 tei=70, ns=1 nr=2
    00:08:27: ISDN BR0 Q931: RELEASE pd = 8 callref = 0x06
    Cause i = 0x8095 - Call rejected
    00:08:27: ISDN BR0 Q921: User RX <- RR sapi=0 tei=70 nr=2
    00:08:27: ISDN BR0 Q921: User RX <- INFO sapi=0 tei=70, ns=2 nr=2
    00:08:27: ISDN BR0 Q931: RELEASE_COMP pd = 8 callref = 0x86
    Cause i = 0x8095 - Call rejected
    00:08:27: ISDN BR0 Q921: User TX -> RR sapi=0 tei=70 nr=3
    00:08:115964116992: ISDN BR0 EVENT: process_rxstate: ces/callid 1/0x8006
    calltype 1 HOST_DISCONNECT_ACK
    00:08:37: ISDN BR0 Q921: User TX -> RRp sapi=0 tei=70 nr=3
    00:08:37: ISDN BR0 Q921: User RX <- RRf sapi=0 tei=70 nr=2
    00:08:38: ISDN BR0 Q921: User RX <- DISCp sapi=0 tei=70
    00:08:38: %ISDN-6-LAYER2DOWN: Layer 2 for Interface BR0, TEI 70 changed to
    down
    00:08:38: ISDN BR0 Q921: User TX -> UAf sapi=0 tei=70
    00:08:48: ISDN BR0 Q921: User RX <- IDCKRQ ri=0 ai=70
    00:08:48: ISDN BR0 Q921: User TX -> IDCKRP ri=61168 ai=70
    00:08:58: ISDN BR0 EVENT: service_queue_from_physical_layer: Recvd L1 prim 5
    state is 1
    00:09:00: ISDN BR0 EVENT: service_queue_from_physical_layer: Recvd L1 prim 3
    state is 2
    00:09:00: ISDN BR0 EVENT: isdn_sw_cstate: State = 0, Old State = 4
    00:09:00: ISDN BR0 Q931: L3_ShutDown: Shutting down ISDN Layer 3
     
    Andree Toonk, Nov 12, 2003
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. jt
    Replies:
    0
    Views:
    523
  2. Phil
    Replies:
    0
    Views:
    440
  3. SS
    Replies:
    0
    Views:
    777
  4. sync
    Replies:
    0
    Views:
    592
  5. Fritz Schoeler
    Replies:
    7
    Views:
    440
    Dan Lanciani
    Jun 25, 2008
Loading...

Share This Page