ISDN call

Discussion in 'Cisco' started by Ned, Mar 12, 2009.

  1. Ned

    Ned Guest

    My remote router is configured to initiate a ISDNdialup to my local
    router in event of data cct failure.This works as expected. I need to
    be able to use ISDN to dial INTO the remote router on some occasions
    even when the data cct is up. I know my authentication is correct but
    I can't get it working. Would the remote router use their dialer
    string even if the call is being placed from the other side?
    ******************************
    local router
    !
    interface Dialer4
    ip address 10.10.40.1 255.255.255.252
    ip nat outside
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    dialer pool 1
    dialer remote-name Remote_rtr
    dialer string 011223344
    dialer wait-for-carrier-time 10
    dialer redial interval 12 attempts 3
    dialer string 0123456
    dialer load-threshold 26 either
    dialer-group 1
    no fair-queue
    no cdp enable
    ppp authentication chap
    ppp multilink
    !
    ****************************
    ! Remote router
    !
    !
    interface Serial1/0:15
    no ip address
    encapsulation ppp
    dialer pool-member 1
    isdn switch-type primary-net5
    isdn caller 0188776600
    isdn caller 0188776500
    no cdp enable
    ppp authentication chap
    !
    !
    interface Dialer1
    ip address 10.10.40.2 255.255.255.252
    encapsulation ppp
    no ip route-cache
    no ip mroute-cache
    dialer pool 1
    dialer remote-name Local_router
    dialer idle-timeout 300
    dialer string 018484848
    dialer caller 0188776600
    dialer caller 0188776500
    dialer load-threshold 1 either
    dialer-group 1
    no fair-queue
    no cdp enable
    ppp authentication chap
    ppp multilink
    !
    **************************************
    Local_router#
    00:22:08: Di4 DDR: Redial: Timeout. Redial on Se1/0:15 for ip
    (s=10.10.28.14,
    d=10.10.18.198) (attempt 2)
    00:22:08: Se1/0:15 DDR: Attempting to dial 011223344
    00:22:08: ISDN Se1/0:15: Outgoing call id = 0x8010, dsl 0
    00:22:34359738368: ISDN Se1/0:15: Event: Call to 011223344 at 64 Kb/s
    00:22:34359738368: ISDN Se1/0:15: process_pri_call(): call id 0x8010,
    number 091
    386700, speed 64, call type DATA, redialed? f, csm call? f, pdata? f
    00:22:34359738432: callED type/plan overridden by call_decode
    00:22:34359738432: did't copy oct3a reason: not CALLER_NUMBER_IE
    00:22:08: building outgoing channel id for call nfas_int is 0 len is
    0
    00:22:08: ISDN Se1/0:15: TX ->
    Local_router#SETUP pd = 8 callref = 0x0010
    00:22:08: Bearer Capability i = 0x8890
    00:22:08: Channel ID i = 0xA9839F
    00:22:08: Called Party Number i = 0x81, '011223344',
    Plan:ISDN, Type:Unknown
    00:22:08: ISDN Se1/0:15: RX <- SETUP_ACK pd = 8 callref = 0x8010
    00:22:08: Channel ID i = 0xA9839F
    00:22:08: ISDN Se1/0:15: LIF_EVENT: ces/callid 1/0x8010 CALL_SETUP_ACK
    00:22:08: ISDN Se1/0:15: PRI Event: 16, bchan = 30, call type = DATA
    00:22:08: ISDN Se1/0:15: RX <- CALL_PROC pd = 8 callref = 0x8010
    00:22:08: ISDN Se1/0:15: LIF_EVENT: ces/callid 1/0x8010
    CALL_PROCEEDING
    Local_router#
    00:22:17: ISDN Se1/0:15: RX <- DISCONNECT pd = 8 callref = 0x8010
    00:22:17: Cause i = 0x8592 - No user responding
    00:22:17: ISDN Se1/0:15: LIF_EVENT: ces/callid 1/0x8010 CALL_DISC
    00:22:17: ISDN Se1/0:15: process_disc_ack(): call id 0x8010, ces 1,
    call type DATA cause 0x12
    00:22:17: ISDN Se1/0:15: TX -> RELEASE pd = 8 callref = 0x0010
    00:22:18: Serial1/0:15: wait for isdn carrier timeout, call id=0x8010
    00:22:77309411328: ISDN Se1/0:15: Event: Hangup call to call id 0x8010
    00:22:79484283164: ISDN Se1/0:15: process_disconnect(): call id
    0x8010, call type
    is DATA, b_idb 0x820F0D2C, ces 1, cause Normal call clearing(0x10)
    00:22:18: ISDN Se1/0:15: RX <-
    Local_router#RELEASE_COMP pd = 8 callref = 0x8010
    00:22:18: ISDN Se1/0:15: CCPRI_ReleaseCall(): bchan 31, call id
    0x8010, call type DATA
    00:22:18: CCPRI_ReleaseChan released b_dsl 0 B_Chan 31
    00:22:18: ISDN Se1/0:15: LIF_EVENT: ces/callid 1/0x8010 CALL_CLEARED
    00:22:18: ISDN Se1/0:15: received CALL_CLEARED call_id 0x8010
    00:22:18: no resend setup, no redial
    00:22:18: no resend setup, no redial
    Local_router#
    00:22:28: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0/0,
    changed
    state to down
    00:22:30: Di4 DDR: Redial: Timeout. Redial on Se1/0:15 for ip
    (s=10.10.28.14,
    d=10.10.18.198) (attempt 3)
    00:22:30: Se1/0:15 DDR: Attempting to dial 011223344
    00:22:30: ISDN Se1/0:15: Outgoing call id = 0x8011, dsl 0
    00:22:128849018880: ISDN Se1/0:15: Event: Call to 011223344 at 64 Kb/s
    00:22:128849018880: ISDN Se1/0:15: process_pri_call(): call id 0x8011,
    number 09
    1386700, speed 64, call type DATA, redialed? f, csm call? f, pdata? f
    00:22:128849018944: callED type/plan overridden by call_decode
    00:22:128849018944: did't copy oct3a reason: not CALLER_NUMBER_IE
    00:22:30: building outgoing channel id for call nfas_int is 0 len is
    0
    00:22:30: ISDN Se1/0:15: TX ->
    Local_router#SETUP pd = 8 callref = 0x0011
    00:22:30: Bearer Capability i = 0x8890
    00:22:30: Channel ID i = 0xA9839F
    00:22:30: Called Party Number i = 0x81, '011223344',
    Plan:ISDN, Type:Unk
    nown
    00:22:30: ISDN Se1/0:15: RX <- SETUP_ACK pd = 8 callref = 0x8011
    00:22:30: Channel ID i = 0xA9839F
    00:22:30: ISDN Se1/0:15: LIF_EVENT: ces/callid 1/0x8011 CALL_SETUP_ACK
    00:22:30: ISDN Se1/0:15: PRI Event: 16, bchan = 30, call type = DATA
    00:22:30: ISDN Se1/0:15: RX <- CALL_PROC pd = 8 callref = 0x8011
    00:22:30: ISDN Se1/0:15: LIF_EVENT: ces/callid 1/0x8011
    CALL_PROCEEDING
    Local_router#
    00:22:39: ISDN Se1/0:15: RX <- DISCONNECT pd = 8 callref = 0x8011
    00:22:39: Cause i = 0x8592 - No user responding
    00:22:39: ISDN Se1/0:15: LIF_EVENT: ces/callid 1/0x8011 CALL_DISC
    00:22:39: ISDN Se1/0:15: process_disc_ack(): call id 0x8011, ces 1,
    call type DATA cause 0x12

    **************************************************************************************
    Ned, Mar 12, 2009
    #1
    1. Advertising

  2. Ned wrote:

    > My remote router is configured to initiate a ISDNdialup to my local
    > router in event of data cct failure.This works as expected. I need to
    > be able to use ISDN to dial INTO the remote router on some occasions
    > even when the data cct is up. I know my authentication is correct but
    > I can't get it working. Would the remote router use their dialer
    > string even if the call is being placed from the other side?
    > **************************************
    > Local_router#
    > 00:22:17: ISDN Se1/0:15: RX <- DISCONNECT pd = 8 callref = 0x8010
    > 00:22:17: Cause i = 0x8592 - No user responding

    *************************************************************************

    Acts like the remote is configured to use "backup interface" to trigger the
    call, in which case as long as the primary link is active, the dialer is
    down and cannot be used to answer (or place) any calls. You could change
    the backup mode to "dial on demand" or "dialer watch" or try defining a
    separate, independent dialer for dial in. Depending upon how many systems
    may be dialing in, you may want to consider a virtual template rather than
    a dialer per caller.

    Good luck and have fun!
    --
    Dr. Vincent C. Jones, PE
    Computer Network Consultant
    Networking Unlimited, Inc.
    http://www.networkingunlimited.com
    Vincent C Jones, Mar 16, 2009
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. BobCov
    Replies:
    3
    Views:
    587
    Andre Beck
    Nov 21, 2003
  2. SkY
    Replies:
    0
    Views:
    942
  3. Martin Maurer
    Replies:
    5
    Views:
    14,571
    moc.hooha
    Nov 7, 2008
  4. sync
    Replies:
    0
    Views:
    557
  5. BE749309
    Replies:
    0
    Views:
    1,195
    BE749309
    Jun 9, 2010
Loading...

Share This Page