IS-IS Routers not establishing adjacency

Discussion in 'Cisco' started by alex_edwards2000@hotmail.com, Mar 27, 2006.

  1. Guest

    Hi,

    I am working through an IS-IS configuration in the SYBEX BSCI book. I
    followed the example configs exactly but my routers can not establish
    adjacency. Any IS-IS gurus with any ideas?

    I don't want to post configs yet as the config from the sample chapter
    is very straightforward. I'm probably missing a trick.

    Thanks
     
    , Mar 27, 2006
    #1
    1. Advertising

  2. chris Guest

    <> wrote in message
    news:...
    > Hi,
    >
    > I am working through an IS-IS configuration in the SYBEX BSCI book. I
    > followed the example configs exactly but my routers can not establish
    > adjacency. Any IS-IS gurus with any ideas?
    >
    > I don't want to post configs yet as the config from the sample chapter
    > is very straightforward. I'm probably missing a trick.
    >
    > Thanks
    >


    You're not giving any information to go on. How are we supposed to know what
    you have configured?
     
    chris, Mar 27, 2006
    #2
    1. Advertising

  3. Charlie Root Guest

    <> wrote in message
    news:...
    > Hi,
    >
    > I am working through an IS-IS configuration in the SYBEX BSCI book. I
    > followed the example configs exactly but my routers can not establish
    > adjacency. Any IS-IS gurus with any ideas?
    >

    MTU mismatch comes first to my mind.I don't know what is in BSCI book, so
    without seeing what have you configured there are many guesses. Did you
    configure clns routing? did you configure 'clns routing', is-is routing
    process with NET, and 'ip router isis' on the interfaces?

    'debug isis adj' should give you some idea what might be wrong

    Kind regards,
    iLya
     
    Charlie Root, Mar 27, 2006
    #3
  4. Guest

    I thought it may be a problem with MTU sizes but the mtu size used by
    RouterA and RouterB are the same.

    OK, here is the scenario and config:

    Two routers - RouterA and RouterB connected across a serial interface.

    Config for Router A - level 1
    ----------------------------
    RouterA#show run
    Building configuration...

    Current configuration : 640 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname RouterA
    !
    !
    ip subnet-zero
    !
    clns routing
    !
    !
    !
    interface Ethernet0
    ip address 192.168.50.1 255.255.255.0
    ip router isis
    clns router isis
    no shutdown
    !
    interface Ethernet1
    no ip address
    shutdown
    !
    interface Serial0
    no ip address
    !
    interface Serial0.1
    ip address 192.168.40.1 255.255.255.0
    ip router isis
    clns router isis
    !
    interface Serial1
    no ip address
    !
    router isis
    net 01.0000.0000.0001.00
    is-type level-1
    !
    ip classless
    no ip http server
    !
    !
    !
    line con 0
    exec-timeout 0 0
    line aux 0
    line vty 0 4
    login
    !
    end

    Config for RouterB - level-1-2
    --------------------------
    RouterB#show run
    Building configuration...

    Current configuration : 1043 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname RouterB
    !
    !
    ip subnet-zero
    !
    clns routing
    !
    !
    !
    interface Serial0
    no ip address
    shutdown
    !
    interface Serial1
    no ip address
    clockrate 64000
    !
    interface Serial1.1
    ip address 192.168.30.1 255.255.255.0
    ip router isis
    !
    interface Serial2
    no ip address
    clockrate 64000
    !
    interface Serial2.1
    ip address 192.168.40.2 255.255.255.0
    ip router isis
    clns router isis
    !
    router isis
    net 01.0000.0000.0002.00
    !
    ip classless
    no ip http server
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
    login
    !
    end

    On RouterA, here is the output of show clns neighbor and debug isis
    adj:
    RouterA#show clns neighbor

    RouterA#
    01:29:09: ISIS-Adj: Sending L1 LAN IIH on Ethernet0, length 1497
    01:29:16: ISIS-Adj: Sending serial IIH on Serial0.1, length 1499
    01:29:18: ISIS-Adj: Sending L1 LAN IIH on Ethernet0, length 1497
    01:29:25: ISIS-Adj: Sending serial IIH on Serial0.1, length 1499
    01:29:25: ISIS-Adj: Sending L1 LAN IIH on Ethernet0, length 1497
    01:29:33: ISIS-Adj: Sending serial IIH on Serial0.1, length 1499
    01:29:35: ISIS-Adj: Sending L1 LAN IIH on Ethernet0, length 1497
    01:29:41: ISIS-Adj: Sending serial IIH on Serial0.1, length 1499show
    clns neighb
    or
    01:29:43: ISIS-Adj: Sending L1 LAN IIH on Ethernet0, length 1497

    RouterA#
    RouterA#
    RouterA#
    RouterA#show clns int e
    01:29:51: ISIS-Adj: Sending serial IIH on Serial0.1, length 1499 0
    Ethernet0 is up, line protocol is up
    Checksums enabled, MTU 1497, Encapsulation SAP
    ERPDUs enabled, min. interval 10 msec.
    RDPDUs enabled, min. interval 100 msec., Addr Mask enabled
    Congestion Experienced bit set at 4 packets
    CLNS fast switching enabled
    CLNS SSE switching disabled
    DEC compatibility mode OFF for this interface
    Next ESH/ISH in 0 seconds
    Routing Protocol: IS-IS
    Circuit Type: level-1-2
    Interface number 0x0, local circuit ID 0x1
    Level-1 Metric: 10, Priority: 64, Circuit ID: RouterA.01
    Number of active level-1 adjacencies: 0
    Next IS-IS LAN Level-1 Hello in 7 seconds
    RouterA#

    Some debug on RouterB:
    01:36:46: ISIS-Adj: Sending serial IIH on Serial2.1, length 1499ug isis
    a
    01:36:49: ISIS-Adj: Sending serial IIH on Serial1.1, length 1499dj
    IS-IS Adjacency related packets debugging is off
    RouterB#
    RouterB#show clns int s2.1
    Serial2.1 is up, line protocol is up
    Checksums enabled, MTU 1500, Encapsulation HDLC
    ERPDUs enabled, min. interval 10 msec.
    RDPDUs enabled, min. interval 100 msec., Addr Mask enabled
    Congestion Experienced bit set at 4 packets
    CLNS fast switching enabled
    CLNS SSE switching disabled
    DEC compatibility mode OFF for this interface
    Next ESH/ISH in 16 seconds
    Routing Protocol: IS-IS
    Circuit Type: level-1-2
    Interface number 0x0, local circuit ID 0x100
    Level-1 Metric: 10, Priority: 64, Circuit ID: RouterB.00
    Number of active level-1 adjacencies: 0
    Level-2 Metric: 10, Priority: 64, Circuit ID: RouterB.00
    Number of active level-2 adjacencies: 0
    Next IS-IS Hello in 2 seconds


    chris wrote:
    > <> wrote in message
    > news:...
    > > Hi,
    > >
    > > I am working through an IS-IS configuration in the SYBEX BSCI book. I
    > > followed the example configs exactly but my routers can not establish
    > > adjacency. Any IS-IS gurus with any ideas?
    > >
    > > I don't want to post configs yet as the config from the sample chapter
    > > is very straightforward. I'm probably missing a trick.
    > >
    > > Thanks
    > >

    >
    > You're not giving any information to go on. How are we supposed to know what
    > you have configured?
     
    , Mar 27, 2006
    #4
  5. Charlie Root Guest

    <> wrote in message
    news:...
    >I thought it may be a problem with MTU sizes but the mtu size used by
    > RouterA and RouterB are the same.
    >


    That won't work with sub-interfaces when main serial interface uses HDLC -
    the router doesn't know where to deliver packets once they reach the
    router's main interface. Configure IP directly on the main interface.

    Kind regards,
    iLya
     
    Charlie Root, Mar 27, 2006
    #5
  6. Guest

    This worked. The example in the book was configured for FRAME-RELAY.

    Many Thanks

    Charlie Root wrote:
    > <> wrote in message
    > news:...
    > >I thought it may be a problem with MTU sizes but the mtu size used by
    > > RouterA and RouterB are the same.
    > >

    >
    > That won't work with sub-interfaces when main serial interface uses HDLC -
    > the router doesn't know where to deliver packets once they reach the
    > router's main interface. Configure IP directly on the main interface.
    >
    > Kind regards,
    > iLya
     
    , Mar 28, 2006
    #6
  7. Charlie Root Guest

    <> wrote in message
    news:...
    > This worked. The example in the book was configured for FRAME-RELAY.
    >

    with Frame-relay sub-interfaces surely will work because there is DLCI to
    distinguish between sub-interfaces.

    Kind regards,
    iLya
     
    Charlie Root, Mar 28, 2006
    #7
  8. Guest

    wrote:
    > This worked. The example in the book was configured for FRAME-RELAY.


    When using IS-IS with frame relay, you will also have to add a frame
    relay map for the CLNS protocol for IS-IS to work.

    Cisco da Gama
    http://ciscostudy.blogspot.com
     
    , Mar 29, 2006
    #8
  9. Xangadib Guest

    Have you solved it yet?

    Xangadib

    <> wrote in message
    news:...
    >I thought it may be a problem with MTU sizes but the mtu size used by
    > RouterA and RouterB are the same.
    >
    > OK, here is the scenario and config:
    >
    > Two routers - RouterA and RouterB connected across a serial interface.
    >
    > Config for Router A - level 1
    > ----------------------------
    > RouterA#show run
    > Building configuration...
    >
    > Current configuration : 640 bytes
    > !
    > version 12.2
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname RouterA
    > !
    > !
    > ip subnet-zero
    > !
    > clns routing
    > !
    > !
    > !
    > interface Ethernet0
    > ip address 192.168.50.1 255.255.255.0
    > ip router isis
    > clns router isis
    > no shutdown
    > !
    > interface Ethernet1
    > no ip address
    > shutdown
    > !
    > interface Serial0
    > no ip address
    > !
    > interface Serial0.1
    > ip address 192.168.40.1 255.255.255.0
    > ip router isis
    > clns router isis
    > !
    > interface Serial1
    > no ip address
    > !
    > router isis
    > net 01.0000.0000.0001.00
    > is-type level-1
    > !
    > ip classless
    > no ip http server
    > !
    > !
    > !
    > line con 0
    > exec-timeout 0 0
    > line aux 0
    > line vty 0 4
    > login
    > !
    > end
    >
    > Config for RouterB - level-1-2
    > --------------------------
    > RouterB#show run
    > Building configuration...
    >
    > Current configuration : 1043 bytes
    > !
    > version 12.2
    > service timestamps debug uptime
    > service timestamps log uptime
    > no service password-encryption
    > !
    > hostname RouterB
    > !
    > !
    > ip subnet-zero
    > !
    > clns routing
    > !
    > !
    > !
    > interface Serial0
    > no ip address
    > shutdown
    > !
    > interface Serial1
    > no ip address
    > clockrate 64000
    > !
    > interface Serial1.1
    > ip address 192.168.30.1 255.255.255.0
    > ip router isis
    > !
    > interface Serial2
    > no ip address
    > clockrate 64000
    > !
    > interface Serial2.1
    > ip address 192.168.40.2 255.255.255.0
    > ip router isis
    > clns router isis
    > !
    > router isis
    > net 01.0000.0000.0002.00
    > !
    > ip classless
    > no ip http server
    > !
    > !
    > !
    > line con 0
    > line aux 0
    > line vty 0 4
    > login
    > !
    > end
    >
    > On RouterA, here is the output of show clns neighbor and debug isis
    > adj:
    > RouterA#show clns neighbor
    >
    > RouterA#
    > 01:29:09: ISIS-Adj: Sending L1 LAN IIH on Ethernet0, length 1497
    > 01:29:16: ISIS-Adj: Sending serial IIH on Serial0.1, length 1499
    > 01:29:18: ISIS-Adj: Sending L1 LAN IIH on Ethernet0, length 1497
    > 01:29:25: ISIS-Adj: Sending serial IIH on Serial0.1, length 1499
    > 01:29:25: ISIS-Adj: Sending L1 LAN IIH on Ethernet0, length 1497
    > 01:29:33: ISIS-Adj: Sending serial IIH on Serial0.1, length 1499
    > 01:29:35: ISIS-Adj: Sending L1 LAN IIH on Ethernet0, length 1497
    > 01:29:41: ISIS-Adj: Sending serial IIH on Serial0.1, length 1499show
    > clns neighb
    > or
    > 01:29:43: ISIS-Adj: Sending L1 LAN IIH on Ethernet0, length 1497
    >
    > RouterA#
    > RouterA#
    > RouterA#
    > RouterA#show clns int e
    > 01:29:51: ISIS-Adj: Sending serial IIH on Serial0.1, length 1499 0
    > Ethernet0 is up, line protocol is up
    > Checksums enabled, MTU 1497, Encapsulation SAP
    > ERPDUs enabled, min. interval 10 msec.
    > RDPDUs enabled, min. interval 100 msec., Addr Mask enabled
    > Congestion Experienced bit set at 4 packets
    > CLNS fast switching enabled
    > CLNS SSE switching disabled
    > DEC compatibility mode OFF for this interface
    > Next ESH/ISH in 0 seconds
    > Routing Protocol: IS-IS
    > Circuit Type: level-1-2
    > Interface number 0x0, local circuit ID 0x1
    > Level-1 Metric: 10, Priority: 64, Circuit ID: RouterA.01
    > Number of active level-1 adjacencies: 0
    > Next IS-IS LAN Level-1 Hello in 7 seconds
    > RouterA#
    >
    > Some debug on RouterB:
    > 01:36:46: ISIS-Adj: Sending serial IIH on Serial2.1, length 1499ug isis
    > a
    > 01:36:49: ISIS-Adj: Sending serial IIH on Serial1.1, length 1499dj
    > IS-IS Adjacency related packets debugging is off
    > RouterB#
    > RouterB#show clns int s2.1
    > Serial2.1 is up, line protocol is up
    > Checksums enabled, MTU 1500, Encapsulation HDLC
    > ERPDUs enabled, min. interval 10 msec.
    > RDPDUs enabled, min. interval 100 msec., Addr Mask enabled
    > Congestion Experienced bit set at 4 packets
    > CLNS fast switching enabled
    > CLNS SSE switching disabled
    > DEC compatibility mode OFF for this interface
    > Next ESH/ISH in 16 seconds
    > Routing Protocol: IS-IS
    > Circuit Type: level-1-2
    > Interface number 0x0, local circuit ID 0x100
    > Level-1 Metric: 10, Priority: 64, Circuit ID: RouterB.00
    > Number of active level-1 adjacencies: 0
    > Level-2 Metric: 10, Priority: 64, Circuit ID: RouterB.00
    > Number of active level-2 adjacencies: 0
    > Next IS-IS Hello in 2 seconds
    >
    >
    > chris wrote:
    >> <> wrote in message
    >> news:...
    >> > Hi,
    >> >
    >> > I am working through an IS-IS configuration in the SYBEX BSCI book. I
    >> > followed the example configs exactly but my routers can not establish
    >> > adjacency. Any IS-IS gurus with any ideas?
    >> >
    >> > I don't want to post configs yet as the config from the sample chapter
    >> > is very straightforward. I'm probably missing a trick.
    >> >
    >> > Thanks
    >> >

    >>
    >> You're not giving any information to go on. How are we supposed to know
    >> what
    >> you have configured?

    >
     
    Xangadib, Apr 12, 2006
    #9
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jed Renton
    Replies:
    0
    Views:
    1,146
    Jed Renton
    Nov 5, 2003
  2. Replies:
    0
    Views:
    416
  3. dennis

    ISIS Adjacency Problem

    dennis, Jun 8, 2007, in forum: Cisco
    Replies:
    1
    Views:
    692
    Trendkill
    Jun 8, 2007
  4. Replies:
    3
    Views:
    3,189
  5. Dan Lanciani
    Replies:
    14
    Views:
    1,600
    Dan Lanciani
    Jan 26, 2009
Loading...

Share This Page