IP Tunnel Debug

Discussion in 'Cisco' started by gooogooo, Sep 10, 2004.

  1. gooogooo

    gooogooo Guest

    Im trying to tunnel IP between these networks, making it transparent to the
    public IPs when traffic is routed across the WAN internally. Is it okay
    to apply the Tunnels like I have below, without a IP assigned to them.

    G.


    Cisco 828 Router (Local network 192.168.100.0/24)
    ~~~~~~~~~~~~

    Current configuration : 2402 bytes
    !
    version 12.2
    no service single-slot-reload-enable
    no service pad
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname xxxxxxxxxxxxxxxxxx
    !
    logging rate-limit console 10 except errors
    enable secret 5 xxxxxxxxxxxxxxxxxxxx
    enable password 7 xxxxxxxxxxxxxxxxxx
    !
    ip subnet-zero
    no ip source-route
    no ip domain-lookup
    !
    no ip dhcp-client network-discovery
    lcp max-session-starts 0
    !
    !
    !
    interface Tunnel0
    ip unnumbered Dialer1
    tunnel source Dialer1
    tunnel destination 203.x.x.x.1
    !
    interface Ethernet0
    ip address 192.168.100.1 255.255.255.0
    ip access-group 105 in
    ip access-group 105 out
    ip nat inside
    hold-queue 32 in
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl equipment-type CPE
    dsl operating-mode GSHDSL symmetric annex B
    dsl linerate AUTO
    !
    interface ATM0.1 point-to-point
    description Internet Network
    pvc 1/34
    ubr 2048
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface Dialer1
    description Internet Network
    ip address negotiated
    ip access-group 100 in
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    ppp authentication chap callin
    ppp chap hostname xxxxxxxxxxxxxxxxx
    ppp chap password 7 xxxxxxxxxxxxxxxxxx
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 192.168.1.0 255.255.255.0 Tunnel0
    no ip http server
    no ip http server
    !
    ip nat inside source list 11 interface Dialer1 overload
    access-list 1 permit 192.168.100.0 0.0.0.255
    access-list 11 remark permit local network for nat
    access-list 11 permit 192.168.100.0 0.0.0.255
    access-list 70 permit 192.168.100.2
    access-list 100 permit ip any any
    access-list 100 permit icmp any any
    access-list 100 permit tcp any any
    access-list 100 permit gre any any
    access-list 105 permit ip any any
    access-list 105 permit tcp any any
    access-list 105 permit icmp any any
    dialer-list 1 protocol ip permit
    !
    line con 0
    transport input none
    stopbits 1
    line vty 0 4
    access-class 70 in
    exec-timeout 15 0
    password 7 xxxxxxxxxxxxxxxxx
    login
    !
    scheduler max-task-time 5000
    end

    ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~`
    Cisco 837 Router (Local network 192.168.1.0/24)

    Current configuration : 2805 bytes
    !
    version 12.3
    no service pad
    service timestamps debug datetime msec
    service timestamps log datetime msec
    service password-encryption
    !
    hostname xxxxxxxxxxxxxx
    !
    enable secret 5 xxxxxxxxxxxxxxxxxxxx
    enable password 7 xxxxxxxxxxxxxxxxxxxxxxxx
    !
    no aaa new-model
    ip subnet-zero
    no ip source-route
    no ip domain lookup
    !
    !
    ip audit notify log
    ip audit po max-events 100
    vpdn enable
    !
    vpdn-group pppoe
    request-dialin
    protocol pppoe
    !
    no ftp-server write-enable
    !

    interface Tunnel0
    ip unnumbered Dialer1
    tunnel source Dialer1
    tunnel destination 203.x.x.2
    !
    interface Ethernet0
    ip address 192.168.1.254 255.255.255.0
    ip access-group 105 in
    ip access-group 105 out
    ip nat inside
    hold-queue 100 out
    !
    interface ATM0
    no ip address
    no atm ilmi-keepalive
    dsl operating-mode itu-dmt
    !
    interface ATM0.1 point-to-point
    description internet network
    pvc 1/34
    ubr 384
    encapsulation aal5mux ppp dialer
    dialer pool-member 1
    !
    !
    interface FastEthernet1
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet2
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet3
    no ip address
    duplex auto
    speed auto
    !
    interface FastEthernet4
    no ip address
    duplex auto
    speed auto
    !
    interface Dialer1
    description internet network
    ip address negotiated
    ip access-group 100 in
    ip nat outside
    encapsulation ppp
    dialer pool 1
    dialer-group 1
    no cdp enable
    ppp authentication chap callin
    ppp chap hostname xxxxxxxxxxxxxxxxx
    ppp chap password 7 xxxxxxxxxxxxxxxxxxxxxxxx
    !
    ip nat inside source list 11 interface Dialer1 overload
    ip classless
    ip route 0.0.0.0 0.0.0.0 Dialer1
    ip route 192.168.100.0 255.255.255.0 Tunnel0
    no ip http server
    no ip http secure-server
    !
    access-list 1 permit 192.168.0.0 0.0.255.255
    access-list 11 remark permit local network for nat
    access-list 11 permit 192.168.1.0 0.0.0.255
    access-list 70 permit 192.168.0.0 0.0.255.255
    access-list 100 permit ip any any
    access-list 100 permit icmp any any
    access-list 100 permit tcp any any
    access-list 100 permit gre any any
    access-list 105 permit ip any any
    access-list 105 permit icmp any any
    access-list 105 permit tcp any any
    dialer-list 1 protocol ip permit
    !
    line con 0
    no modem enable
    line aux 0
    line vty 0 4
    access-class 70 in
    exec-timeout 15 0
    password 7 xxxxxxxxxxxxxxxxxxxxxxx
    login
    !
    scheduler max-task-time 5000
    !
    end
    gooogooo, Sep 10, 2004
    #1
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. John Ireland
    Replies:
    1
    Views:
    1,070
    Claude LeFort
    Nov 11, 2003
  2. a.nonny mouse
    Replies:
    2
    Views:
    1,094
  3. AM
    Replies:
    7
    Views:
    4,419
    kh_alex81
    Jul 19, 2007
  4. Replies:
    6
    Views:
    29,416
  5. Trouble
    Replies:
    0
    Views:
    618
    Trouble
    Aug 4, 2006
Loading...

Share This Page