IP Routing Help

Discussion in 'Cisco' started by Matthew, Jun 27, 2005.

  1. Matthew

    Matthew Guest

    Hello,
    I am having trouble getting these routes working as expected. I have 3
    computers hooked to a Catalyst. I also have a 7206 into that Catalyst. I
    also have 4 seperate T1s into a 7206. 2 of the T1s are bandwidth from
    our upstream. The other 2 are for direct connect customers.

    We have two class C networks: 22.22.22.* 22.22.23.*

    If I traceroute from one of the 3 computers (in the .22.* network) to
    one of the T1s (in the .23.* network), the 7206 will send the route out
    one of the provider T1s. They will simply send it back and then the 7206
    will send the packet to the customers T1.

    This is bad. This is a waste. How come the 7206 won't recognize that the
    packet is destined for an IP/network that is directly connected to it?

    Here is a good example:

    "show ip route" shows this:

    S 22.22.23.150/32 is directly connected, Serial1/6:6

    So if I traceroute from one of the macines in the .22.* it should only
    be 1 hop to the 7206 then onto 6:6 right? Well it doesn't. I hit the
    7206 then upstream then back to 7206 then on to 6:6.

    Can someone give some examples of what our routing "should" look like?

    If you need more, I can provide some configs.

    Thanks,
    Matthew
    Matthew, Jun 27, 2005
    #1
    1. Advertising

  2. Matthew

    Ivan Ostres Guest

    In article <d9pk0e$1qf$>,
    says...
    > Here is a good example:
    >
    > "show ip route" shows this:
    >
    > S 22.22.23.150/32 is directly connected, Serial1/6:6
    >


    This really *is* a good example if you understand what you read from it.
    It shows that router "knows" that is has just one address from the range
    22.22.23.y connected to it and not the whole C class network.

    I would expect that if you traceroute from .22.* to 22.22.23.150, hops
    would go as expected....


    --
    Ivan

    *** User rot13 to see my eMail address ***
    Ivan Ostres, Jun 27, 2005
    #2
    1. Advertising

  3. Matthew

    Matthew Guest

    Ivan Ostres wrote:
    > In article <d9pk0e$1qf$>,
    > says...
    >
    >>Here is a good example:
    >>
    >>"show ip route" shows this:
    >>
    >>S 22.22.23.150/32 is directly connected, Serial1/6:6
    >>

    >
    >
    > This really *is* a good example if you understand what you read from it.
    > It shows that router "knows" that is has just one address from the range
    > 22.22.23.y connected to it and not the whole C class network.
    >
    > I would expect that if you traceroute from .22.* to 22.22.23.150, hops
    > would go as expected....
    >
    >


    No they don't. Tracerouting from .22.* to 22.22.23.150 still results in
    the packets going out provider bandwidth #1 then back to us on #2 then
    on to .150

    -Matthew
    Matthew, Jun 27, 2005
    #3
  4. Matthew

    Ivan Ostres Guest

    In article <d9pl5l$2bb$>,
    says...
    > Ivan Ostres wrote:
    > > In article <d9pk0e$1qf$>,
    > > says...
    > >
    > >>Here is a good example:
    > >>
    > >>"show ip route" shows this:
    > >>
    > >>S 22.22.23.150/32 is directly connected, Serial1/6:6
    > >>

    > >
    > >
    > > This really *is* a good example if you understand what you read from it.
    > > It shows that router "knows" that is has just one address from the range
    > > 22.22.23.y connected to it and not the whole C class network.
    > >
    > > I would expect that if you traceroute from .22.* to 22.22.23.150, hops
    > > would go as expected....
    > >
    > >

    >
    > No they don't. Tracerouting from .22.* to 22.22.23.150 still results in
    > the packets going out provider bandwidth #1 then back to us on #2 then
    > on to .150
    >


    Strange...post your config and 'show ip route' output.

    --
    Ivan

    *** User rot13 to see my eMail address ***
    Ivan Ostres, Jun 27, 2005
    #4
  5. Matthew

    Matthew Guest

    Ivan Ostres wrote:
    > Strange...post your config and 'show ip route' output.


    Here is what you requested. IP addresses and passwords have been changed
    to protect the innocent.

    173.45.143.* is the network with client computers on the switch.
    173.45.144.* is the network with some direct connect T1s

    163.209.175.22 these two are our outgoing bandwidth to upstream.
    163.209.175.18

    Thanks for your help,
    Matthew

    GW#show run
    Building configuration...

    Current configuration : 12279 bytes
    !
    ! Last configuration change at 14:33:40 GMT Tue Jun 28 2005 by keith
    ! NVRAM config last updated at 15:51:48 GMT Tue Jun 7 2005 by keith
    !
    version 12.3
    service timestamps debug datetime localtime
    service timestamps log datetime msec localtime
    service password-encryption
    service compress-config
    !
    hostname GW
    !
    boot-start-marker
    boot system slot0:c7200-is-mz.123-13.bin
    boot-end-marker
    !
    card type t1 2
    logging buffered 10000 debugging
    enable secret 5 $4%Copp$C.Hlj7cqN*&je88ESf.K70
    !
    clock timezone GMT 0
    clock calendar-valid
    dspint DSPfarm2/0
    !
    aaa new-model
    !
    !
    aaa authentication password-prompt Password:
    aaa authentication username-prompt Login:
    aaa authentication login default group radius local
    aaa authentication login localauth local
    aaa authentication login noauthen none
    aaa authentication ppp default none
    aaa authentication ppp network none
    aaa authorization console
    aaa authorization exec noauthor none
    aaa authorization commands 15 noauthor none
    aaa accounting delay-start
    aaa session-id common
    ip subnet-zero
    !
    !
    ip cef table consistency-check type lc-detect
    ip cef table consistency-check type scan-lc
    ip cef table consistency-check type scan-rp
    ip cef table consistency-check type scan-rib
    ip cef
    no ip domain lookup
    !
    isdn switch-type primary-5ess
    !
    !
    !
    voice service voip
    fax protocol t38 ls-redundancy 0 hs-redundancy 0
    fallback pass-through g711ulaw
    sip
    !
    voice class codec 1
    codec preference 1 g729r8
    codec preference 2 g711alaw
    codec preference 3 g711ulaw
    !
    !
    !
    voice class h323 1
    call start slow
    !
    !
    !
    !
    !
    !
    !
    username myuser password 7 0204080B080D2F251F
    !
    !
    controller T1 1/0
    framing esf
    linecode b8zs
    channel-group 0 timeslots 1-24
    !
    controller T1 1/1
    framing esf
    linecode b8zs
    channel-group 1 timeslots 1-24
    !
    controller T1 1/2
    framing esf
    linecode b8zs
    channel-group 2 timeslots 1-24
    !
    controller T1 1/3
    framing esf
    linecode b8zs
    channel-group 3 timeslots 1-24
    !
    controller T1 1/4
    framing esf
    linecode b8zs
    channel-group 4 timeslots 20-24
    !
    controller T1 1/5
    framing esf
    linecode b8zs
    channel-group 5 timeslots 1-24
    !
    controller T1 1/6
    framing esf
    linecode b8zs
    channel-group 6 timeslots 1-24
    !
    controller T1 1/7
    framing esf
    linecode b8zs
    channel-group 7 timeslots 1-24
    !
    controller T1 2/0
    framing esf
    linecode b8zs
    cablelength long 0db
    pri-group timeslots 1-24
    !
    controller T1 2/1
    framing esf
    linecode b8zs
    cablelength long 0db
    pri-group timeslots 1-24
    !
    class-map match-any AutoQoS-Stream-Video-Se1/2:2
    match protocol netshow
    match protocol rtspplayer
    match protocol vdolive
    class-map match-any AutoQoS-Transactional-Se1/2:2
    match protocol ssh
    match protocol notes
    class-map match-any AutoQoS-VoIP-Remark
    match ip dscp ef
    match ip dscp cs3
    match ip dscp af31
    class-map match-any AutoQoS-Bulk-Se1/2:2
    match protocol smtp
    match protocol pop3
    match protocol exchange
    match protocol secure-pop3
    match protocol nntp
    match protocol ftp
    class-map match-any AutoQoS-Management-Se1/2:2
    match protocol imap
    match protocol dns
    match protocol secure-imap
    class-map match-any AutoQoS-VoIP-Control-UnTrust
    match access-group name AutoQoS-VoIP-Control
    class-map match-any AutoQoS-VoIP-RTP-UnTrust
    match protocol rtp audio
    match access-group name AutoQoS-VoIP-RTCP
    !
    !
    policy-map AutoQoS-Policy-UnTrust
    class AutoQoS-VoIP-RTP-UnTrust
    priority percent 70
    set dscp ef
    class AutoQoS-VoIP-Control-UnTrust
    bandwidth percent 5
    set dscp af31
    class AutoQoS-VoIP-Remark
    set dscp default
    class class-default
    fair-queue
    policy-map AutoQoS-Policy-Se1/2:2
    class AutoQoS-Stream-Video-Se1/2:2
    bandwidth remaining percent 1
    set dscp cs4
    class AutoQoS-Transactional-Se1/2:2
    bandwidth remaining percent 1
    random-detect dscp-based
    set dscp af21
    class AutoQoS-Bulk-Se1/2:2
    bandwidth remaining percent 15
    random-detect dscp-based
    set dscp af11
    class AutoQoS-Management-Se1/2:2
    bandwidth remaining percent 1
    set dscp cs2
    class class-default
    fair-queue
    !
    gw-accounting aaa
    acct-template callhistory-detail
    !
    !
    translation-rule 3
    Rule 1 ^695211 1
    Rule 2 ^695212 2
    Rule 3 ^695213 3
    Rule 4 ^695214 4
    Rule 5 ^695215 5
    Rule 6 ^695216 6
    Rule 7 ^695217 7
    Rule 8 ^695218 8
    Rule 9 ^695219 9
    !
    !
    !
    !
    interface Loopback0
    ip address 116.86.24.98 255.255.255.255
    !
    interface FastEthernet0/0
    description External-Access
    ip address 173.45.143.1 255.255.255.0
    ip route-cache same-interface
    no ip mroute-cache
    ip policy route-map cnw
    duplex full
    !
    interface FastEthernet0/0.1
    !
    interface Serial1/0:0
    description Peacock
    ip address 192.168.0.1 255.255.255.252
    encapsulation ppp
    ip mroute-cache
    autodetect encapsulation ppp
    !
    interface Serial1/1:1
    description Marks&Salley
    ip address 173.45.144.141 255.255.255.252
    encapsulation ppp
    ip mroute-cache
    no fair-queue
    !
    interface Serial1/2:2
    description TimeWarner Bandwidth
    ip address 163.209.175.18 255.255.255.252
    encapsulation ppp
    h323-gateway voip interface
    h323-gateway voip id key-dmx1 ipaddr 67.107.77.35 1719
    h323-gateway voip h323-id 2091631751
    h323-gateway voip tech-prefix 2977#
    service-policy output AutoQoS-Policy-Se1/2:2
    !
    interface Serial1/3:3
    description TimeWarner Bandwidth
    ip address 163.209.175.22 255.255.255.252
    encapsulation ppp
    no ip route-cache same-interface
    ip mroute-cache
    !
    interface Serial1/4:4
    description vacant
    no ip address
    encapsulation ppp
    ip mroute-cache
    shutdown
    !
    interface Serial1/5:5
    no ip address
    ip mroute-cache
    shutdown
    auto qos voip
    service-policy output AutoQoS-Policy-UnTrust
    !
    interface Serial1/6:6
    description TEI - Staffing
    bandwidth 1540
    ip address 192.168.2.5 255.255.255.252
    encapsulation ppp
    ip mroute-cache
    autodetect encapsulation ppp
    auto qos voip
    service-policy output AutoQoS-Policy-UnTrust
    !
    interface Serial1/7:7
    ip address 192.168.0.9 255.255.255.252
    encapsulation ppp
    ip mroute-cache
    !
    interface Serial2/0:23
    no ip address
    encapsulation ppp
    no logging event link-status
    isdn switch-type primary-5ess
    isdn incoming-voice voice
    isdn map address 011* plan isdn type international
    isdn map address 1* plan isdn type national
    isdn map address 832* plan isdn type national
    isdn map address 713* plan isdn type national
    isdn map address 281* plan isdn type national
    !
    interface Serial2/1:23
    no ip address
    encapsulation ppp
    no logging event link-status
    isdn switch-type primary-5ess
    isdn incoming-voice voice
    isdn map address 011* plan isdn type international
    isdn map address 1* plan isdn type national
    isdn map address 832* plan isdn type national
    isdn map address 713* plan isdn type national
    isdn map address 281* plan isdn type national
    !
    router bgp 85712
    no synchronization
    bgp log-neighbor-changes
    network 64.72.107.0 mask 255.255.255.0
    network 64.72.108.0 mask 255.255.255.0
    network 173.45.143.0
    network 173.45.144.0
    network 216.136.24.192 mask 255.255.255.240
    neighbor 64.72.96.2 remote-as 19750
    neighbor 64.72.96.2 version 4
    neighbor 64.72.96.2 soft-reconfiguration inbound
    neighbor 64.72.96.2 route-map BGPWeight in
    neighbor 207.67.76.24 remote-as 4323
    neighbor 207.67.76.24 description Time Warner Telecom
    neighbor 207.67.76.24 ebgp-multihop 2
    neighbor 207.67.76.24 update-source Loopback0
    neighbor 207.67.76.24 version 4
    neighbor 207.67.76.24 soft-reconfiguration inbound
    no auto-summary
    !
    ip classless
    ip route 0.0.0.0 0.0.0.0 163.209.175.21
    ip route 64.72.107.0 255.255.255.0 Null0 254
    ip route 64.72.108.0 255.255.255.0 Null0 254
    ip route 205.215.29.3 255.255.255.255 Serial1/3:3
    ip route 207.67.76.24 255.255.255.255 163.209.175.17
    ip route 207.67.76.24 255.255.255.255 163.209.175.21
    ip route 208.186.228.44 255.255.255.255 Serial1/3:3
    ip route 209.244.0.3 255.255.255.255 163.209.175.17
    ip route 173.45.143.0 255.255.255.0 Null0 254
    ip route 173.45.144.0 255.255.255.0 Null0 254
    ip route 173.45.144.0 255.255.255.128 173.45.143.4
    ip route 173.45.144.128 255.255.255.252 192.168.0.2
    ip route 173.45.144.144 255.255.255.248 Serial1/6:6
    ip route 173.45.144.150 255.255.255.255 Serial1/6:6
    ip route 173.45.144.152 255.255.255.248 Serial1/7:7
    ip route 173.45.144.192 255.255.255.240 173.45.144.222
    ip route 173.45.144.248 255.255.255.248 173.45.143.4
    ip route 216.136.24.98 255.255.255.255 Null0 254
    ip route 216.136.24.192 255.255.255.240 Null0 254
    no ip http server
    !
    ip as-path access-list 10 permit ^$
    !
    !
    ip access-list extended AutoQoS-VoIP-Control
    permit tcp any any eq 1720
    permit tcp any any range 11000 11999
    permit udp any any eq 2427
    permit tcp any any eq 2428
    permit tcp any any range 2000 2002
    permit udp any any eq 1719
    permit udp any any eq 5060
    ip access-list extended AutoQoS-VoIP-RTCP
    permit udp any any range 16384 32767
    logging history size 190
    access-list 100 permit ip any any
    access-list 101 deny ip 207.51.254.0 0.0.0.255 any
    access-list 102 permit ip any any
    access-list 190 permit udp any any range 16384 33000
    access-list 199 permit udp any any eq 1720
    access-list 199 permit udp any any eq 1719
    access-list 199 permit udp any any eq 1718
    access-list 199 permit tcp any any eq 1720
    access-list 199 permit tcp any any eq 1719
    access-list 199 permit tcp any any eq 1718
    priority-list 1 protocol ip high list 199
    priority-list 1 protocol ip high fragments
    !
    route-map BGPPrepend permit 10
    match ip address 60
    match as-path 2
    set as-path prepend 31802 31802 31802 31802 31802 31802
    !
    route-map BGPWeight permit 10
    set weight 150
    !
    route-map localonly permit 10
    match as-path 2
    !
    route-map cnw permit 20
    match ip address 103
    set ip next-hop 163.209.175.17 163.209.175.21
    !
    snmp-server community cytel RO
    snmp-server contact Matthew Boehm, Cypress Telecommunications
    snmp-server enable traps tty
    !
    radius-server host 173.45.143.7 auth-port 1812 acct-port 1813
    radius-server key 7 05255624086D1F5B
    !
    rmon event 33333 log trap AutoQoS description "AutoQoS SNMP traps for
    Voice Drops" owner AutoQoS
    rmon alarm 33333 cbQosCMDropBitRate.1263.1265 30 absolute
    rising-threshold 1 33333 falling-threshold 0 owner AutoQoS
    rmon alarm 33334 cbQosCMDropBitRate.1319.1321 30 absolute
    rising-threshold 1 33333 falling-threshold 0 owner AutoQoS
    !
    voice-port 2/0:23
    playout-delay maximum 250
    playout-delay nominal 80
    bearer-cap Speech
    !
    voice-port 2/1:23
    playout-delay maximum 250
    playout-delay nominal 80
    bearer-cap Speech
    !
    !
    dial-peer cor custom
    !
    !
    !
    dial-peer voice 1 pots
    description CSX
    preference 1
    application session
    destination-pattern [0-9]T
    no digit-strip
    direct-inward-dial
    port 2/0:23
    no register e164
    !
    dial-peer voice 2 pots
    description CSX
    preference 1
    application session
    destination-pattern [0-9]T
    no digit-strip
    direct-inward-dial
    port 2/1:23
    no register e164
    !
    dial-peer voice 10 voip
    description asterisk
    preference 1
    destination-pattern [0-9]T
    progress_ind setup enable 3
    progress_ind progress enable 8
    translate-outgoing called 3
    voice-class codec 1
    session protocol sipv2
    session target ipv4:173.45.143.6
    dtmf-relay rtp-nte
    playout-delay minimum low
    no vad
    !
    dial-peer voice 11 voip
    description asterisk
    preference 1
    destination-pattern 69521T
    progress_ind setup enable 3
    progress_ind progress enable 8
    translate-outgoing called 3
    voice-class codec 1
    session protocol sipv2
    session target ipv4:173.45.143.6
    dtmf-relay rtp-nte
    playout-delay minimum low
    no vad
    !
    gateway
    !
    sip-ua
    nat symmetric check-media-src
    timers trying 1000
    timers disconnect 1000
    sip-server ipv4:64.72.107.121
    !
    !
    gatekeeper
    shutdown
    !
    !
    line con 0
    authorization commands 15 noauthor
    authorization exec noauthor
    login authentication noauthen
    transport preferred all
    transport output all
    stopbits 1
    line aux 0
    no exec
    transport preferred all
    transport input telnet
    transport output all
    stopbits 1
    line vty 0 4
    session-timeout 60
    exec-timeout 60 0
    password 7 001707560A081C26032D
    transport preferred all
    transport input all
    transport output all
    !
    !
    end

    ##################################################################

    GW#show ip route
    Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
    D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
    N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
    E1 - OSPF external type 1, E2 - OSPF external type 2
    i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS
    level-2
    ia - IS-IS inter area, * - candidate default, U - per-user
    static route
    o - ODR, P - periodic downloaded static route

    Gateway of last resort is 163.209.175.21 to network 0.0.0.0

    C 173.45.143.0/24 is directly connected, FastEthernet0/0
    64.0.0.0/24 is subnetted, 2 subnets
    C 64.72.107.0 is directly connected, FastEthernet0/0
    S 64.72.108.0 is directly connected, Null0
    208.186.228.0/32 is subnetted, 1 subnets
    S 208.186.228.44 is directly connected, Serial1/3:3
    163.209.175.0/24 is variably subnetted, 4 subnets, 2 masks
    C 163.209.175.21/32 is directly connected, Serial1/2:2
    C 163.209.175.20/30 is directly connected, Serial1/3:3
    C 163.209.175.17/32 is directly connected, Serial1/3:3
    C 163.209.175.16/30 is directly connected, Serial1/2:2
    207.67.76.0/32 is subnetted, 1 subnets
    S 207.67.76.24 [1/0] via 163.209.175.17
    [1/0] via 163.209.175.21
    216.136.24.0/24 is variably subnetted, 2 subnets, 2 masks
    C 216.136.24.98/32 is directly connected, Loopback0
    S 216.136.24.192/28 is directly connected, Null0
    192.168.0.0/24 is variably subnetted, 4 subnets, 2 masks
    C 192.168.0.8/30 is directly connected, Serial1/7:7
    C 192.168.0.10/32 is directly connected, Serial1/7:7
    C 192.168.0.0/30 is directly connected, Serial1/0:0
    C 192.168.0.2/32 is directly connected, Serial1/0:0
    173.45.144.0/24 is variably subnetted, 10 subnets, 6 masks
    S 173.45.144.0/25 [1/0] via 173.45.143.4
    S 173.45.144.0/24 is directly connected, Null0
    S 173.45.144.248/29 [1/0] via 173.45.143.4
    S 173.45.144.192/28 [1/0] via 173.45.144.222
    S 173.45.144.152/29 is directly connected, Serial1/7:7
    S 173.45.144.150/32 is directly connected, Serial1/6:6
    S 173.45.144.144/29 is directly connected, Serial1/6:6
    C 173.45.144.140/30 is directly connected, Serial1/1:1
    C 173.45.144.138/32 is directly connected, Serial1/1:1
    S 173.45.144.128/30 [1/0] via 192.168.0.2
    209.244.0.0/32 is subnetted, 1 subnets
    S 209.244.0.3 [1/0] via 163.209.175.17
    205.215.29.0/32 is subnetted, 1 subnets
    S 205.215.29.3 is directly connected, Serial1/3:3
    192.168.2.0/24 is variably subnetted, 2 subnets, 2 masks
    C 192.168.2.6/32 is directly connected, Serial1/6:6
    C 192.168.2.4/30 is directly connected, Serial1/6:6
    S* 0.0.0.0/0 [1/0] via 163.209.175.21
    Matthew, Jun 28, 2005
    #5
  6. Matthew

    Katty

    Joined:
    Jan 5, 2010
    Messages:
    1
    Hi Matthew,

    remove the below mentioned routes and place them at the bottom of the list as shown below.

    ip route 173.45.143.0 255.255.255.0 Null0 254
    ip route 173.45.144.0 255.255.255.0 Null0 254
    ip route 0.0.0.0 0.0.0.0 163.209.175.21

    --
    Katty
    Katty, Jan 5, 2010
    #6
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Jeff Mao

    ISO AppleTalk Routing basics help

    Jeff Mao, Oct 21, 2003, in forum: Cisco
    Replies:
    1
    Views:
    441
    Sam Wilson
    Oct 22, 2003
  2. Guest

    Help with dynamic routing

    Guest, Oct 26, 2003, in forum: Cisco
    Replies:
    0
    Views:
    556
    Guest
    Oct 26, 2003
  3. zher
    Replies:
    2
    Views:
    8,859
  4. joeblow
    Replies:
    3
    Views:
    1,205
    Philip D'Ath
    Mar 14, 2005
  5. Sied@r
    Replies:
    3
    Views:
    8,389
    Sied@r
    Oct 20, 2005
Loading...

Share This Page