IP NAT in 2621XM

Discussion in 'Cisco' started by omidi, Oct 16, 2006.

  1. omidi

    omidi

    Joined:
    Jul 17, 2006
    Messages:
    4
    hi freinds

    we have a 2621XM that connect a remote lan via HDSL modem to our lan.
    i want to users in remote lan can see 2 server in our lan and connect to it.
    remote user can ping nat ip (217.16.2.18 - 19) but cant access http or remote desktop.

    tanx for ur help

    Our Lan

    [​IMG]

    this is my 2621 config

    Code:
    Current configuration : 949 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    service password-encryption
    !
    hostname Mali-2600
    !
    enable secret 5 *****
    enable password 7 *****
    !
    ip subnet-zero
    !
    !
    !
    !
    !
    !
    interface Loopback0
     ip address 172.16.2.17 255.255.255.255
    !
    interface FastEthernet0/0
     no ip address
     shutdown
     duplex auto
     speed auto
    !
    interface Serial0/0
     ip unnumbered FastEthernet0/1
     ip nat outside
     encapsulation ppp
     no fair-queue
    !
    interface FastEthernet0/1
     ip address 10.1.4.81 255.255.255.248
     ip nat inside
     duplex auto
     speed auto
    !
    ip nat outside source static 172.16.2.18 10.1.4.82 extendable
    ip nat outside source static 172.16.2.19 10.1.4.84 extendable
    ip classless
    ip route 172.16.1.0 255.255.255.0 Serial0/0
    ip route 172.16.2.0 255.255.255.0 FastEthernet0/1
    ip http server
    ip pim bidir-enable
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     password 7 *****
     autobaud
     login
     length 50
    !
    !
    end
    
    Mali-2600#
    
     
    Last edited: Oct 19, 2006
    omidi, Oct 16, 2006
    #1
    1. Advertising

  2. omidi

    omidi

    Joined:
    Jul 17, 2006
    Messages:
    4
    no body can help me? :(
     
    omidi, Oct 18, 2006
    #2
    1. Advertising

  3. omidi

    sk1lledsupp0rt

    Joined:
    Oct 18, 2006
    Messages:
    4
    The 2621 is located at the remote site? Are the remote users trying to connect to the PUBLIC IP 217.16.2.18,19 through the internet?
     
    sk1lledsupp0rt, Oct 19, 2006
    #3
  4. omidi

    omidi

    Joined:
    Jul 17, 2006
    Messages:
    4
    i think this can describe our situation

    [​IMG]

    a user in remote lan (172.16.1.0) want access to server (10.1.4.82)
     
    omidi, Oct 19, 2006
    #4
  5. omidi

    sk1lledsupp0rt

    Joined:
    Oct 18, 2006
    Messages:
    4
    If this is your situation, why do you need NAT? Simply place a static route on the default gateway of the remote LAN hosts that directs 10.1.1.0 255.255.255.0 to the Cisco 2621 (172.16.2.17). In addition, place a static route on the default gateway of the server that directs 172.16.1.0 255.255.255.0 to the Cisco 2621 (10.1.4.81).
     
    sk1lledsupp0rt, Oct 19, 2006
    #5
  6. omidi

    omidi

    Joined:
    Jul 17, 2006
    Messages:
    4
    because we have a complicated wan and remote lan connect to many lan that may be have same IP to us. i know this is not right but it is :(.
    help me sort this plllz
     
    omidi, Oct 21, 2006
    #6
  7. omidi

    tru5tn01

    Joined:
    Oct 29, 2006
    Messages:
    1
    I could be wrong but I think, you have unnumbered serial0/0, but the borrowed IP address from Fas0/1 is internal IP address, you should have this on your Fast0/1

    ip address 172.16.2.1 255.255.255.240 " or what ever block you have"
    ip address 10.1.4.81 255.255.255.248 secondary
     
    tru5tn01, Oct 29, 2006
    #7
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Aaron Leonard
    Replies:
    3
    Views:
    523
    Hansang Bae
    Oct 16, 2003
  2. Stephan Cohen
    Replies:
    0
    Views:
    606
    Stephan Cohen
    Oct 16, 2003
  3. Stephan Cohen

    Receving IDSN incoming calls on a 2621XM

    Stephan Cohen, Oct 23, 2003, in forum: Cisco
    Replies:
    0
    Views:
    1,292
    Stephan Cohen
    Oct 23, 2003
  4. Rocl LI
    Replies:
    0
    Views:
    389
    Rocl LI
    Jan 15, 2004
  5. A. Andrews

    2621xm with nm-16a and LOW speeds

    A. Andrews, Jan 15, 2004, in forum: Cisco
    Replies:
    3
    Views:
    610
    A. Andrews
    Jan 16, 2004
Loading...

Share This Page