IOS Working config for VPN Client

Discussion in 'Cisco' started by fedexarg, Dec 10, 2003.

  1. fedexarg

    fedexarg Guest

    Im trying to make a proof of concept for my company.

    Can anyone post a real life working config example using a cisco
    router as a hub for 5 to 10 clients using the Cisco VPN Client.

    Ive been trying to make it work without much success in my lab.

    I already used and tried the Cisco Web Site examples with even less
    success.

    Please state wich version of client you are using and which IOS
    version you are using and hardware.

    Thanks.
    fedexarg, Dec 10, 2003
    #1
    1. Advertising

  2. (fedexarg) wrote in message news:<>...
    > Im trying to make a proof of concept for my company.
    >
    > Can anyone post a real life working config example using a cisco
    > router as a hub for 5 to 10 clients using the Cisco VPN Client.
    >
    > Ive been trying to make it work without much success in my lab.
    >
    > I already used and tried the Cisco Web Site examples with even less
    > success.
    >
    > Please state wich version of client you are using and which IOS
    > version you are using and hardware.
    >
    > Thanks.



    This works fine with the Cisco VPN Client (with split tunnelling).

    -------------------------------------
    aaa new-model
    !
    aaa authorization network xxx-vpn-clientgroup local
    aaa session-id common
    !
    username user1 password xxxxxxxxxx
    !
    crypto isakmp policy 1
    encr 3des
    authentication pre-share
    group 2
    crypto isakmp client configuration address-pool local dynpool
    !
    crypto isakmp client configuration group xxx-vpn-clientgroup
    key vpnkey
    pool dynpool
    acl 111
    !
    crypto ipsec transform-set transform-1 esp-3des esp-sha-hmac
    !
    crypto dynamic-map dynmap 1
    set transform-set transform-1
    !
    crypto map dynmap isakmp authorization list xxx-vpn-clientgroup
    crypto map dynmap client configuration address respond
    crypto map dynmap 1 ipsec-isakmp dynamic dynmap
    !
    interface Ethernet0
    ip address nnn.nnn.nnn.nnn 255.255.255.240
    no cdp enable
    crypto map dynmap
    !
    interface FastEthernet0
    ip address nnn.nnn.nnn.nnn 255.255.255.0
    no cdp enable
    !
    ip local pool dynpool 10.96.55.129 10.96.55.190
    ip default-gateway nnn.nnn.nnn.nnn
    ip route 0.0.0.0 0.0.0.0 nnn.nnn.nnn.nnn
    !
    access-list 111 permit ip nnn.nnn.0.0 0.0.255.255 10.96.55.128
    0.0.0.63
    access-list 111 permit ip 10.0.0.0 0.255.255.255 10.96.55.128 0.0.0.63
    -------------------------------------

    IOS (tm) C1700 Software (C1710-K9O3SY-M), Version 12.2(4)YA2, EARLY
    DEPLOYMENT RELEASE SOFTWARE (fc1)
    System image file is "flash:c1710-k9o3sy-mz.122-4.YA2.bin"

    cisco 1710 (MPC855T) processor (revision 0x200) with 27853K/4915K
    bytes of memory.

    VPN Client is v4.0.2(D)

    Pete
    Pete Mainwaring, Dec 15, 2003
    #2
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. hk
    Replies:
    0
    Views:
    1,936
  2. GVB
    Replies:
    1
    Views:
    2,799
    Martin Bilgrav
    Feb 6, 2004
  3. Jaros³aw Skórka

    VPN - Cisco IOS <-> VPN Client - problem

    Jaros³aw Skórka, Feb 1, 2005, in forum: Cisco
    Replies:
    1
    Views:
    3,110
  4. Mike Rahl
    Replies:
    1
    Views:
    1,232
    Trendkill
    May 30, 2007
  5. Giuen
    Replies:
    0
    Views:
    864
    Giuen
    Sep 12, 2008
Loading...

Share This Page