ios : Source and destination nat on a single interface

Discussion in 'Cisco' started by Laurent, Mar 28, 2011.

  1. Laurent

    Laurent Guest

    Hi!
    nearly everything in the subject..

    s:any d:172.16.57.0/24
    ->
    s:136.156.12.1(overload) d:172.16.17.0/24(match-host)

    Is it possible to do ?

    (IOS (tm) C2600 Software (C2600-IS-M), Version 12.2(13)T8)

    The configuration lines about nat, and wich does not seem to work :(

    interface Loopback0
    ip address 192.168.251.1 255.255.255.252
    ip nat inside
    !
    interface FastEthernet0/0
    ip address 136.156.12.1 255.255.0.0
    ip nat outside
    ip policy route-map Nat
    !
    ip nat pool castellano 172.16.17.1 172.16.17.254 netmask 255.255.255.0
    type match-host
    ip nat inside source list 101 interface FastEthernet0/0 overload
    ip nat inside destination list 100 pool castellano
    !
    access-list 100 permit ip any 172.16.57.0 0.0.0.255
    access-list 101 permit ip 172.16.104.0 0.0.0.255 172.16.0.0 0.0.63.255
    !
    route-map Nat permit 10
    match ip address 100 101
    set ip next-hop 192.168.251.2

    thank you :)
     
    Laurent, Mar 28, 2011
    #1
    1. Advertising

  2. Laurent

    Laurent Guest

    Laurent, Mar 29, 2011
    #2
    1. Advertising

  3. Laurent

    vishal31369

    Joined:
    Mar 4, 2010
    Messages:
    4
    Not sure why you have ip nat inside the loopback interface (No data is running from the loopback interface)

    you can try

    ip nat inside/outside source list -acl interface Loopback0 overload
     
    vishal31369, Jun 24, 2011
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Dave
    Replies:
    0
    Views:
    1,638
  2. Replies:
    1
    Views:
    8,909
    Phillip Remaker
    May 11, 2005
  3. Klaus Zerwes

    IOS and destination NAT

    Klaus Zerwes, Sep 15, 2006, in forum: Cisco
    Replies:
    2
    Views:
    3,211
    Klaus Zerwes
    Sep 20, 2006
  4. 1388-2/HB

    Source and destination NAT

    1388-2/HB, Jun 26, 2007, in forum: Cisco
    Replies:
    4
    Views:
    1,051
    usenet
    Jul 4, 2007
  5. Xunzi
    Replies:
    0
    Views:
    1,002
    Xunzi
    Apr 10, 2009
Loading...

Share This Page