IOS NAT

Discussion in 'Cisco' started by Todd Bennett, Mar 31, 2009.

  1. Todd Bennett

    Todd Bennett Guest

    I need to NAT a range of ports from a public IP to a private IP. I
    typically use the form:

    ip nat inside source static tcp i1.i2.i3.i4 22 p1.p2.p3.p4 22 extendable


    I could make quite a few of these statements and have it work, but I want to
    specify a range of ports. Does anyone know the syntax to do this?

    _________________________________
    Todd Bennett
    BennTech
    Todd Bennett, Mar 31, 2009
    #1
    1. Advertising

  2. Todd Bennett

    bod43 Guest

    On 31 Mar, 19:12, "Todd Bennett" <tabennett(nospam)@benntech.net>
    wrote:
    > I need to NAT a range of ports from a public IP to a private IP.  I
    > typically use the form:
    >
    > ip nat inside source static tcp i1.i2.i3.i4 22 p1.p2.p3.p4 22 extendable
    >
    > I could make quite a few of these statements and have it work, but I want to
    > specify a range of ports.  Does anyone know the syntax to do this?


    I have not needed to do this and have not researched it
    however I don't believe that this is available.

    If your lists are complex perhaps you might manage them
    in Excel and copy paste into the router.

    Such a facility is available for address ranges but not
    as far as I know for port ranges.
    bod43, Apr 1, 2009
    #2
    1. Advertising

  3. Todd Bennett

    Todd Bennett Guest

    Thank you for your reply. I may have gotten a solution from another source.
    I'm not yet sure if this will work until I test it.

    To permit a range through the firewall:
    access-list 120 permit <tcp/udp> any any range 10000 20000
    int <outside interface>
    ip access-group 120 in

    To NAT the range of ports:
    ip nat inside source static 1.1.1.1 2.2.2.2 route-map NAME extendable
    access-list 130 permit tcp any any range 10000 20000
    route-map NAME permit 10
    match ip address 130

    _________________________________
    Todd Bennett
    BennTech

    "bod43" <> wrote in message
    news:...
    On 31 Mar, 19:12, "Todd Bennett" <tabennett(nospam)@benntech.net>
    wrote:
    > I need to NAT a range of ports from a public IP to a private IP. I
    > typically use the form:
    >
    > ip nat inside source static tcp i1.i2.i3.i4 22 p1.p2.p3.p4 22 extendable
    >
    > I could make quite a few of these statements and have it work, but I want
    > to
    > specify a range of ports. Does anyone know the syntax to do this?


    I have not needed to do this and have not researched it
    however I don't believe that this is available.

    If your lists are complex perhaps you might manage them
    in Excel and copy paste into the router.

    Such a facility is available for address ranges but not
    as far as I know for port ranges.
    Todd Bennett, Apr 2, 2009
    #3
    1. Advertising

Want to reply to this thread or ask your own question?

It takes just 2 minutes to sign up (and it's free!). Just click the sign up button to choose a username and then you can ask your own questions on the forum.
Similar Threads
  1. Evan Mann

    IOS to IOS VPN Problem

    Evan Mann, Feb 11, 2004, in forum: Cisco
    Replies:
    0
    Views:
    1,215
    Evan Mann
    Feb 11, 2004
  2. Ed Kideys, Tech-Train
    Replies:
    3
    Views:
    4,586
    Wence Van der Meersch
    Apr 30, 2004
  3. Mr Corbett
    Replies:
    5
    Views:
    3,141
    Aaron Leonard
    Aug 19, 2005
  4. spec
    Replies:
    2
    Views:
    1,423
    Walter Roberson
    May 25, 2006
  5. Mike Rahl
    Replies:
    1
    Views:
    1,198
    Trendkill
    May 30, 2007
Loading...

Share This Page